Ubuntu

[Sony Corporation VGN-NS130FE] hibernate/resume failure

Reported by Cristian Aravena Romero on 2010-04-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

~$ dpkg -l | grep linux-image
ii linux-image-2.6.32-21-generic 2.6.32-21.32 Linux kernel image for version 2.6.32 on x86
ii linux-image-2.6.34-rc5-20100421 2.6.34-rc5-20100421-10.00.Custom

[ 382.500096] ------------[ cut here ]------------
[ 382.500103] WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143 local_bh_enable_ip+0x61/0x90()
[ 382.500105] Hardware name: VGN-NS130FE
[ 382.500112] Modules linked in: nls_iso8859_1 nls_cp437 btrfs zlib_deflate crc32c libcrc32c ufs qnx4 hfsplus hfs minix ntfs vfat msdos fat jfs xfs exportfs reiserfs aes_i586 aes_generic joydev snd_hda_codec_realtek arc4 fbcon tileblit font bitblit softcursor vga16fb vgastate snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device ath9k snd mac80211 ath i915 drm_kms_helper soundcore sdhci_pci sony_laptop sdhci cfg80211 led_class psmouse serio_raw drm i2c_algo_bit video output uvcvideo snd_page_alloc videodev v4l1_compat intel_agp agpgart lp parport usbhid hid ohci1394 ieee1394 ahci sky2
[ 382.500179] Pid: 748, comm: phy0 Not tainted 2.6.32-21-generic #32-Ubuntu
[ 382.500182] Call Trace:
[ 382.500187] [<c014c3d2>] warn_slowpath_common+0x72/0xa0
[ 382.500190] [<c0153381>] ? local_bh_enable_ip+0x61/0x90
[ 382.500193] [<c0153381>] ? local_bh_enable_ip+0x61/0x90
[ 382.500197] [<c014c41a>] warn_slowpath_null+0x1a/0x20
[ 382.500200] [<c0153381>] local_bh_enable_ip+0x61/0x90
[ 382.500204] [<c058b826>] _spin_unlock_bh+0x16/0x20
[ 382.500215] [<f8ffa18f>] ath_tx_node_cleanup+0x14f/0x170 [ath9k]
[ 382.500223] [<f8ff4eee>] ath9k_sta_notify+0x4e/0xb0 [ath9k]
[ 382.500238] [<f8697647>] __sta_info_unlink+0x127/0x1b0 [mac80211]
[ 382.500246] [<f8ff4ea0>] ? ath9k_sta_notify+0x0/0xb0 [ath9k]
[ 382.500254] [<f8697703>] sta_info_unlink+0x33/0x50 [mac80211]
[ 382.500264] [<f869eeca>] ieee80211_set_disassoc+0x17a/0x1d0 [mac80211]
[ 382.500273] [<f86a0e27>] ieee80211_sta_work+0x427/0x460 [mac80211]
[ 382.500278] [<c013eff3>] ? finish_task_switch+0x43/0xc0
[ 382.500282] [<c016369e>] run_workqueue+0x8e/0x150
[ 382.500290] [<f86a0a00>] ? ieee80211_sta_work+0x0/0x460 [mac80211]
[ 382.500294] [<c01637e4>] worker_thread+0x84/0xe0
[ 382.500298] [<c0167740>] ? autoremove_wake_function+0x0/0x50
[ 382.500301] [<c0163760>] ? worker_thread+0x0/0xe0
[ 382.500304] [<c01674b4>] kthread+0x74/0x80
[ 382.500307] [<c0167440>] ? kthread+0x0/0x80
[ 382.500311] [<c0104087>] kernel_thread_helper+0x7/0x10
[ 382.500313] ---[ end trace ae9cfb68556162e7 ]---

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-21-generic 2.6.32-21.32
Regression: No
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: caravena 1384 F.... pulseaudio
CRDA: Error: [Errno 2] No existe el fichero ó directorio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd4200000 irq 22'
   Mixer name : 'Realtek ALC262'
   Components : 'HDA:10ec0262,104d3700,00100302 HDA:14f12c06,104d1700,00100000'
   Controls : 18
   Simple ctrls : 11
Date: Thu Apr 22 16:25:31 2010
Frequency: Once a day.
HibernationDevice: RESUME=UUID=61e37874-09f4-4e5f-85d9-2f588d2f19d6
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
MachineType: Sony Corporation VGN-NS130FE
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=7c374b03-1455-4547-80c4-d0b762953c15 ro quiet splash
ProcEnviron:
 LANG=es_CL.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
SourcePackage: linux
dmi.bios.date: 08/27/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0200Y3
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0200Y3:bd08/27/2009:svnSonyCorporation:pnVGN-NS130FE:pvrC6U0B23E:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VGN-NS130FE
dmi.product.version: C6U0B23E
dmi.sys.vendor: Sony Corporation

---
ApportVersion: 2.10-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2952 F.... pulseaudio
                      ubuntu 6755 F.... pulseaudio
CasperVersion: 1.332
DistroRelease: Ubuntu 13.10
LiveMediaBuild: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130513)
MachineType: Sony Corporation VGN-NS130FE
MarkForUpload: True
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 3.9.0-1.5-generic 3.9.1
RelatedPackageVersions:
 linux-restricted-modules-3.9.0-1-generic N/A
 linux-backports-modules-3.9.0-1-generic N/A
 linux-firmware 1.108
Tags: saucy
Uname: Linux 3.9.0-1-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 08/27/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0200Y3
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0200Y3:bd08/27/2009:svnSonyCorporation:pnVGN-NS130FE:pvrC6U0B23E:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VGN-NS130FE
dmi.product.version: C6U0B23E
dmi.sys.vendor: Sony Corporation

summary: - not work hibernate and suspend
+ Not work hibernate and suspend
summary: - Not work hibernate and suspend
+ Not work hibernate and suspend in Sony Vaio VGN-NS130FE
description: updated

Hi Cristian,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-suspend
tags: added: kernel-hibernate
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Not work hibernate and suspend in kernel:
linux-image-2.6.34-020634rc5-generic

tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Triaged
status: Triaged → Confirmed
importance: Undecided → Medium

Work fine suspend. Not work hibernate. My kernel:

$ dpkg -l | grep linux-image | grep rc6
ii linux-image-2.6.34-020634rc6-generic 2.6.34-020634rc6 Linux kernel image for version 2.6.34 on x86

summary: - Not work hibernate and suspend in Sony Vaio VGN-NS130FE
+ Not work hibernate in Sony Vaio VGN-NS130FE
Changed in linux:
status: Unknown → Fix Released
Changed in linux:
importance: Unknown → Medium

Cristian Aravena, could you please provide the information following https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume ?

As well, could you please confirm this issue exists with the latest development release of Ubuntu? ISO CD images are available from http://releases.ubuntu.com/quantal/ . Please note that one will need to install Ubuntu to test hibernate, as at this time, hibernate does not work in a live environment. If the issue remains, could you please run the following command from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Please let us know your results. Thank you for your understanding.

tags: added: needs-upstream-testing
removed: kernel-suspend
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Problem with my laptop.

summary: - Not work hibernate in Sony Vaio VGN-NS130FE
+ [Sony Corporation VGN-NS130FE] suspend/resume failure
Changed in linux:
status: Fix Released → Confirmed
Changed in linux:
status: Confirmed → Fix Released
summary: - [Sony Corporation VGN-NS130FE] suspend/resume failure
+ [Sony Corporation VGN-NS130FE] hibernate/resume failure
tags: added: latest-bios-r0200y3

Cristian Aravena, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the mainline kernels archive directory daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.10-rc1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: raring

apport information

tags: added: apport-collected saucy
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Random work suspend - Not work hibernate

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.