Sleep and Hibernate don't work any more in Ubuntu Lucid Beta 2

Bug #567314 reported by Josef Engelfrost on 2010-04-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Suspend doesn't work for me in Lucid Beta 2. It worked fine in Jaunty.
When I click on Sleep in the menu I get a message saying "Networking system disabled", and the network connection is broken. The mouse and keyboard freeze for a second, and then everything is functioning again as if nothing happened. I can reconnect to the network manually.

I'm not sure what package to assign this to, or what logs or other data to attach, but I'm happy to provide more information on request.

MikeN (mike-mtb) wrote :

I also cannot get Suspend or Hibernate to work on my Dell 9400, in both cases all I get is a blank screen (still powered on) but no response and the laptop is totally unresponsive.

Mind you, suspend and hibernate on this have never been good since 8.04 LTS, it's just got gradually worse over time with each release...
8.10 Worked intermittently
9.04 Suspend didn't work, Hibernate worked at first then stopped after a few months (wouldn't resume)
9.10 Didn't resume from hibernate
10.04 Zip, nada, nothing - both just hang.

I'm pretty disappointed that this has continued to plague Ubuntu, given that it is so difficult to change laptop components to ones that work.

I'm also happy to continue to provide logs or whatever if this can be made to work, I can't afford to replace my laptop ever couple of years but need working suspend and hibernate. Do I have to got back to 8.04 LTS!?!

exactt (giesbert) wrote :

could you please post the output of dmesg and perhaps the the last parts of /var/log/messages ? also have a look at https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume#Debugging%20Suspend

Josef Engelfrost (engelfrost) wrote :

output of dmesg

Josef Engelfrost (engelfrost) wrote :

Latest messages from /var/log/messages. Wasn't sure how many to include, these are from the last reboot.

Josef Engelfrost (engelfrost) wrote :

I'll test the wiki instructions as soon as I can get hold of a camera.

Victor Vargas (kamus) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in Linux Kernel package.

affects: ubuntu → linux (Ubuntu)
tags: added: kernel-hibernate
tags: added: kj-triage
Jeremy Foshee (jeremyfoshee) wrote :

Hi josef,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 567314

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: New → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers