Comment 2 for bug 567016

Rikki - Unfortunately your laptop contains an rtl8192se wifi adapter that is not supported by upstream. The kernel team chose to integrate the Realtek vendor driver which is still in a state of development. I've updated this driver to the latest version that I could find (0015.0127.2010 has substantial changes) in the hope that it may solve your problem. If not, then I may have to have actual hardware in order to figure it out.

Please try installing linux-2.6.32-22.33~lp567016 from my PPA at http://launchpad.net/~timg-tpi/+archive/ppa when it has completed building.