Ubuntu

Wireless won't work on Lenovo Thinkpad T510 - rtl8192se

Reported by Rikki Kite on 2010-04-20
412
This bug affects 146 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Lucid
Medium
Tim Gardner

Bug Description

I can see my network and the system says I'm connected, but I'm not actually online (using Lucid 10.4 beta [dual-booting with Windows] on my new Lenovo Thinkpad T510).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-21-generic 2.6.32-21.32
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rikki 1427 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf2620000 irq 17'
   Mixer name : 'Intel G45 DEVIBX'
   Components : 'HDA:14f15069,17aa218b,00100301 HDA:80862804,17aa21b5,00100000'
   Controls : 10
   Simple ctrls : 5
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6MHT33WW-1.08'
   Mixer name : 'ThinkPad EC 6MHT33WW-1.08'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Apr 19 21:06:13 2010
HibernationDevice: RESUME=UUID=205eb75a-89a7-417b-bb78-4232f4d8e0ab
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
Lsusb:
 Bus 002 Device 002: ID 8087:0020
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 17ef:480f Lenovo
 Bus 001 Device 002: ID 8087:0020
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 4313CTO
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=4edd78e3-1b91-452b-aa5c-9c932474055a ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:

SourcePackage: linux
dmi.bios.date: 02/22/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6MET49WW (1.12 )
dmi.board.name: 4313CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6MET49WW(1.12):bd02/22/2010:svnLENOVO:pn4313CTO:pvrThinkPadT510:rvnLENOVO:rn4313CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4313CTO
dmi.product.version: ThinkPad T510
dmi.sys.vendor: LENOVO

Rikki Kite (rkite) wrote :
Tim Gardner (timg-tpi) on 2010-04-23
Changed in linux (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → Medium
milestone: none → lucid-updates
status: New → In Progress
Tim Gardner (timg-tpi) wrote :

Rikki - Unfortunately your laptop contains an rtl8192se wifi adapter that is not supported by upstream. The kernel team chose to integrate the Realtek vendor driver which is still in a state of development. I've updated this driver to the latest version that I could find (0015.0127.2010 has substantial changes) in the hope that it may solve your problem. If not, then I may have to have actual hardware in order to figure it out.

Please try installing linux-2.6.32-22.33~lp567016 from my PPA at http://launchpad.net/~timg-tpi/+archive/ppa when it has completed building.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Rikki!
      Here is some further detail on what you need to do.

Go to https://edge.launchpad.net/~timg-tpi/+archive/ppa/+packages to get a good view of all the packages in Tim's PPA.

Click on the name for linux - 2.6.32-22.33~lp567016 which will open details about this particular package.

At the bottom of that expansion there should be 2 choices, amd64 and i386. Select the one that is appropriate for your hardware.

This will bring you to the specific information for your particular build of the package. At the bottom of the page are all the packages that were built by Tim for this test case. I suspect that the 2 you will need are:
linux-headers-2.6.32-22-generic_2.6.32-22.33~lp567016_<i386/amd64>.deb and
linux-image-2.6.32-22-generic_2.6.32-22.33~lp567016_<i386/amd64>.deb

you will need to save these to your machine (this will probably take a while to download depending on your connection)

Instructions for installing the packages is available at https://wiki.ubuntu.com/KernelTeam/MainlineBuilds in the section titled "Installing Mainline builds.

I'm available on IRC (as JFo) should you have any issues with the above information. :-)

Thanks!

~JFo

Jeremy Foshee (jeremyfoshee) wrote :

from Rikki's install:

(Reading database ... 156192 files and directories currently installed.) Preparing to replace linux-headers-2.6.32-22-generic 2.6.32-22.33~lp567016 (using linux-headers-2.6.32-22-generic_2.6.32-22.33~lp567016_amd64.deb) ... Unpacking replacement linux-headers-2.6.32-22-generic ... dpkg: dependency problems prevent configuration of linux-headers-2.6.32-22-generic: linux-headers-2.6.32-22-generic depends on linux-headers-2.6.32-22;

Rikki Kite (rkite) wrote :

Yay! I'm online!

I followed JFo's instructions above and thought it didn't work, but then I walked through it all again and rebooted & it's working (I'm really not sure what part I didn't do the first time, but whatever I skipped was important). So, I don't have anything to add to JFo's instructions above except to make sure you follow them closely and don't skip a step.

And a big huge THANKS! to everyone who worked on this!

Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: rtl8192se vendor driver does not work consistently. The vendor has made many improvements since the initial (not very robust) version.

Patch description: Update vendor driver to 0015.0127.2010. This version has much better integration with cfg80211.

Patch: https://lists.ubuntu.com/archives/kernel-team/2010-April/010295.html

Test results: It appears to have fixed at least one user's problems. See previous comment from Rikki.

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed

Hi Rikki,
     I just wanted to follow up with you and explain what Steve's comment above means. The patch to fix your issue has been accepted as an SRU to be included in the next update. What we need from you is to go to the EnableProposed in Steve's comment and enable it, update it and verify that you are still in a good state. Once you do that, you would report back here any issues or if the update was successful. Let me know if you need any help.

Thanks!

~JFo

Luca Ferretti (elle.uca) wrote :

Maybe I've found a potential regression to this change. Upgrading in 10.04 from kernel in -main to kernel in -proposed, my realtech based WiFi card (rt73usb driver) stopped working. I've added a small and quick description in latest comments for bug #362875 (initially I wasn't thinking about kernel from -proposed). I'll open a full bug report, just the time to restart, collect data and send to launchpad.

Luca Ferretti (elle.uca) wrote :

Unfortunately Launchpad doesn't like my report, timeout :( Here is the description of the bug and dmesg log attached

Several issues installing kernel from proposed emerged. My wifi is using rt73usb. It's a D-Link DWA-111 (I'll provide the exact chipset later)

 * on system startup, the card is unable to connect to router, filling the textual console with following error message "phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x30c4 with error -108."

 * unplugging the USB card, the related kernel module is not unloaded

 * re-plugging the USB card, it seems unable to "turn on": the activity led is off and the plugging is not reported in logs

 * removing and uploading the kernel module, the following messages are showed by dmesg

[ 4096.249323] phy2 -> rt2x00usb_vendor_request: Error - Vendor Request 0x09 failed for offset 0x0000 with error -108.
[ 4096.249340] phy2 -> rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x3000 with error -108.
[ 4096.249342] phy2 -> rt73usb_init_eeprom: Error - Invalid RT chipset detected.
[ 4096.249344] phy2 -> rt2x00lib_probe_dev: Error - Failed to allocate device.
[ 4096.249372] usbcore: registered new interface driver rt73usb

pablomme (pablomme) wrote :

@Luca: why should your problem be related to the change in the rtl8192se driver?

pablomme (pablomme) wrote :

@people on duplicates: please note that the fix for the rtl8192se problem is in lucid-proposed at the moment. Enable "Proposed" in Software Sources, upgrade your kernel and reboot to test.

Andrew Goodnough (agoodno) wrote :

Thanks, Tim. Just installed the new linux kernel from proposed and my wireless is now working on my Thinkpad T510.

greg n (gregnorc) wrote :

Just popping in to say I came here from a different bug that was marked as a duplicate of this one (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/530275)

I had been havign issues connection to aps... I could see APs, but when I entered the password it would just time out after ~30 seconds.

I followed the suggestion in there...

using this .deb solved all my wireless issues: https://launchpad.net/~matt-price/+archive/mattprice/+files/rtl8192se-dkms_2.6.0015.0127.2010_all.deb)

Porbably slightly off topic, so feel free to tell me to piss off:
Should I still upgrade my kernel? (I had to disable KMS to get 10.04 to boot on this Lenovo X201, because it uses the i5's integrated graphics card, which is very new and has some issues:
http://www.thinkwiki.org/wiki/Category:X201
http://www.thinkwiki.org/wiki/Intel_HD_Graphics)

greg n (gregnorc) wrote :

Oh I almost forgot: My wifi card was a Realtek 8191SE-VA2, thats kind of an important detail :)

Martin Pitt (pitti) on 2010-05-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-22.33

---------------
linux (2.6.32-22.33) lucid-proposed; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: ACPI: EC: Allow multibyte access to EC (v3)
    - LP: #526354

  [ Tim Gardner ]

  * ubuntu: rtl8192se -- update to version 0015.0127.2010
    - LP: #567016
 -- Andy Whitcroft <email address hidden> Mon, 19 Apr 2010 11:06:35 +0100

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
theUg (theug) wrote :

I have similar bug with the same 8192 chipset, but different model of the adapter: https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/574105. I installed 22.33 package to no avail.

Brad Philips (bradphilips) wrote :

Thanks guys! The kernel upgrade solved my issue. :) I'm on a Satellite L505-S5990 and after the kernel and removing the blacklist I put on the original with my hacked in module, wireless connects straight away with no problems.

Jonathan (pyrosphere0) wrote :

With the latest kernel update I can connect fine but the driver causes frequent crashes requiring a hard reboot. Please fix this problem.

Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
Changed in linux (Ubuntu Lucid):
status: Fix Released → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Lucid):
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Jonathan (pyrosphere0) wrote :

Sorry for changing the status, I didn't expect it to auto-apply. Should I report this as a new bug?

Bungeur (sanfton-0801) wrote :

0015.0127.2010 driver in the new Kernel for Kubuntu Lucid works fine on my RTL8192 equipped Fujitsu Amilo 3560. Previous driver 0014 connected for about 1 minute. Thank you very much!

Marek Stasiak (marecki) wrote :

I have Fujitsu Amilo 3560 too, it's great to hear that everything works fine!
Thank you devs :)

Jonathan [2010-05-06 3:35 -0000]:
> Should I report this as a new bug?

Please do. Thank you!

Version 0015 of Realtek's driver turned out to be what was needed for my Advent Verona; lucid didn't quite work out of the box, but since installing linux-image-2.6.32-22-generic it all seems to work.

Peter Funk (pf-artcom-gmbh) wrote :

I did a fresh install of a Lucid .iso on a HP Compaq 610 today.
This computer contains a Realtek 8171se WiFi chip. WiFi didn't work first.
The installation .iso still contained kernel image 2.6.32-21
Downloading the file http://de.archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.32-22-generic_2.6.32-22.33_i386.deb
manually on another computer with Internet Access and copying this single file using an USB-flash memory stick made it possible to upgrade the kernel on the new machine and after the reboot WiFi worked fine. I would like to thank everybody for their nice work!

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Xebec (xebec-yandex) wrote :

Lucid with the latest standard kernel + 0015.0127.2010 driver. Unfortunately back to square 1. :( Transmission signal strength is horrible again. My WIndows 7 has rock-solid connectivity, while Lucid takes minutes to connect and retains the signal for 1-2 minutes before dropping of into endless retries. I'd be glad if you fixed the issue.

Xebec (vkleban) wrote :

Karmic + 0014.0115.2010 driver used to work wonderfully. Now I have the same issues, just as with first driver versions in 2009:
Router's Tomato firmware reporting signal quality:
Windows 7: 10-12
Lucid: 3-5

Basically the signal is garbage once again. Could you fix the driver to work just as Windows driver works?

Vadim Chekan (kot-begemot) wrote :

I want report success too. My box is ASUS Eee-1201T with Realtek 8192se adapter (discussed in some duplicate threads).
Installing pristine 10.04 netbook remix did not work, but upgrading it to 2.6.32-22 made wireless alive to some degree. Scanning worked, I could see my neighbors routers, but I could not connect to mine.
After some experiments I figured out that I can connect when I set my router to WPA/WPA2 Personal & TKIP.
Setting router to AES or AES+TKIP makes connect attempt failing after long (minutes) trying.

Bear in mind, that I have a desktop ubuntu install of the same version, and it works with router in AES mode just fine (Zonet ZEW2500P usb adapter). So, OS is the same, router is the same, and only HW and drivers are different.

Also something unexplainable happen to open (unencrypted) router connections. They failed too ( I tried 2 of them). But after I managed to connect to my own router, I checked open connections and was able to connect to open ones. I rebooted severl times in between, so it hardly can be wireless card stuck in a strange state.

So if your symptoms are: scanning works but you can't connect, please report your *router* settings too. And give it a try WPA/TKIP.

Stefan Bader (smb) wrote :

This bug number seems to get referenced again by the next proposed upload. Note, that it is already released. The reference just is caused because git could not check for that.

CarpeNox (tiagosbatista) wrote :

Just a heads up:

Version 17 of the driver is up on the realtek site.

I had to patch the makefile as usual to remove the ENABLE??? option (I do not remember it now!) that was described on the earlier posts.

I did not yet look at the source differences, but the changelog is quite small...

Matt Price (matt-price) wrote :

At least some people are reporting kernel panics with the Realtek closed-source drivers (one here, 3 more on lp:585938).

1) can anyone subscribed to this bug test whether running powertop with the r8192se_pci module loaded causes a kernel panic (running in a VT at least lets you see the kernel panic message, so you know what's happening)?
2) anyone have any ideas how to report bugs to the Realtek upstream?
3) given that the crash is reliably caused by powertop, does anyone have workaround ideas (that is, what does powertop do to cause the crash, and can we stop whatever other processes are doing that same thing from performing that action? I bet it has something to do with probing the power-saving state. or something like that.

Thanks, Matt

Brian Candler (b-candler) wrote :

Oh thanks, now I know another way to crash my Thinkpad X100e :-(

In return you might want to see if you can crash yours according to bug #591699 (i.e. "xset s 1" to blank the screen while transferring a large file over the ethernet).

I haven't yet tried repeating the test with various kernel modules unloaded, but that might point to a problem with one of them.

elPraga (elpraga) wrote :

Hello all,
I ran into the same problem on Toshiba Satellite A 500-18Q. I found a solution that works quite well.

After installing the driver as noted here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/544485?comments=all

I created a script that changes to the directory of the driver and runs the wlan0up script provided there and I have put it in to
the rc.local script. It works even after upgrading kernels without modifications (so far :-) )

nano /usr/local/bin/wifi_workaround.sh

#!/bin/bash

cd /the_path_to_the_driver..../rtl8192se_linux_2.6.0017.0507.2010

./wlan0up

chmod a+x /usr/local/bin/wifi_workaround.sh

and add these lines to /etc/rc.local :

# The wifi error workaround..
/usr/local/bin/wifi_workaround.sh

I hope it helps someone..

Greetings.

Shane (kohlrak-kohlrak) wrote :

elPraga, thanks to you pointing that out, i managed to get my driver working a little better. I'm running the 2.6.32-23-generic kernel, but it seems to me that that kernel module is still semi-broken. (connection has issues after an hour with that annoying crash requiring startup. According to syslog and various other tools, i've kept a good stable connection for a whole 8 hours (impressive at this point) with only a silent disconnect that none of the networking programs i use (like irssi and such) even noticed. I'd post a syslog to go with it to show the difference, but apparently they're getting deleted every day (or hidden somewhere). I gotta find a way to keep those logs available for longer periods of time... But that's for another topic.

So yes, if you're reading this (thank god you found this one and not another one), simply (i'm putting the instructions here for completeness sake and for ease of those who don't know how to use all those fancy unix commands):

sudo su #yes, this is necessary
rmmod r8192se_pci #blacklist it, too in /etc/modprob.d/blacklist.conf
cd Downloads/rtl8192se_linux_2.6.0017.0507.2010 #if this line fails, change it accordingly to the one you downloaded from realtek's site
make
make install
mv HAL/rtl8192r8192se_pci.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless/r8192se.ko
depmod -a

I'm not sure if that truly solves the problem, though, because i'm still getting kernel messages once a minute after i do that (as opposed to none if i use the wlan0up script), and i haven't had time to test to see if it still disconnects or not after following those instructions. If it doesn't work, i'll work on finding a way to make it work (hopefully not the same solution to use a startup script obviously requiring a login script which would thus reqire password at login to startup the wlan) and post the complete instructions (or a fix to the current instructions).

Anakin Starkiller (sunrider) wrote :

Shane >> I was experiencing those frequent kernel messages too since 2.6.0017 version of Realtek Drivers.
So I decided to switch back to 2.6.0014... and everything seems to work fine until now.
I guess there recently has been some changes in rtl8192 in linux staging area...so there must have been some conflicts after the upgrade to 2.6.32-23.

Shane (kohlrak-kohlrak) wrote :

Well, i just started having trouble with the current drivers again. It seems the kernel driver is really crappy, and the current realtek driver is still crappy, but not as crappy. I used skype to help with this. No one can hear me on skype if i use the kernel driver (apparently my instructions above did not work, as it seems it still enables the kernel driver anyway), so if i disable that and use the wlan0up i am still heard, but after so much network usage, it'll eventually crash and burn again (and no, this wasn't just skype disconnecting, but everything) into an infinite loop of failed reconnect attempts inevitably reasking for my simple WEP key. I just got this new laptop (toshiba satellite L654D-S4025) after dealing with a crappy dell vostro 1000 that i swear was rigged to fall apart (and i took the thing apart and could put it back together again, but i still could not see the logic behind alot of component placements and so forth that just seem so counter intuitive), so i'm starting to ask myself whether or not i should even bother with laptops anymore. i'm seriously sick of companies not caring whether or not their product works.

Doing some research on this particular card here at launchpad, it seems to be a common assumption (and i agree with it) that Realtek just doesn't care about making their product work (understandable, they make too much money off of people simply buying new components rather than making old ones work). I also have another really weird issue (i don't even know how to report it let alone who to report it to) with this laptop that i can't solve.

Maybe i'm doing something wrong. I hope so: i hope i'm wrong. I want this to be a quick and simple issue to fix so that i don't have to constantly run some sort of wlan restart script every time the driver decides it wants to go nuts on me. I'm gonna keep testing until i can figure out what i'm doing wrong.

Shane (kohlrak-kohlrak) wrote :

Just to try to speed things up to make it go into that infinite loop of non-connectingness, i decided to transfer 2.9GB of data from my desktop computer to my laptop, and low and behold something so incredibly obvious appears. Right at about 1:50 is where i started the file transfer. Want to guess when it completed? I find it so strange that even outside of those "message repeated" errors, i could set my watch fairly accurately to these debug messages (well, here and there they seem to miss a minute, but still). Granted, i don't loose connection from services (my router, however, is complaining in it's logs) at those times (haven't had a chance to time "talking glitches" with skype yet, but at this point i doubt i have to). If only i knew my way around those drivers and wireless networking hardware, i'd fix the problem myself, however I don't.

While typing this, my connection went out again. I found that before finishing this, though, it inevitably reconnected. So i updated the file accordingly while typing. Anyway, if not all these messages correspond to a single issue, solving them so that they disappear would help the issues come into light more clearly. I originally had a theory written here on what the problem was, but once i got enough data, i realized that connecting all these error messages was a stretch. A new theory, though:

There's a 6 element queue of something called "TX." The driver gets "stuck" whenever it runs out of TX (slowly, but progressively), however it can't free TX because something (that it can't sacrifice because data would end up permanently lost, despite it supposedly not being lost) is using that 6th slot. Now, it'll have a little success, but inevitably because this queue's usage grows and can't be freed at the rate in which it gets used up, it inevitably gets truly stuck and connection is lost and cannot be re-established. Though, my guess is that i'm actually totally wrong, because i'm just making a wild guess on the data, but if all else fails, it's something to go on, because solving any of these messages could clear them up enough to see the real problem.

The only thing i really can't explain is that i did have one good night where nothing happened in syslog for about 8 hours or why these messages appear so consistently.

Brian Candler (b-candler) wrote :

> Right at about 1:50 is where i started the file transfer. Want to guess when it completed?

Not really, can you explain what you saw? How long did the transfer take, or before it got interrupted?

Possible side issue, but have you tried disabling screen blanking (xset s 0) and disabling all other power management which might kick in N minutes after you last touched the machine? Also, you could try removing the battery and running just on mains, so that you don't get any ACPI events like "battery fully charged". My Thinkpad X100e has strange lockups in these circumstances.

[Off-topic]
> it seems to be a common assumption (and i agree with it) that Realtek just doesn't care about making their product work (understandable, they make too much money off of people simply buying new components rather than making old ones work

More likely, they care about their Windows customers but not those who replace Windows with Linux, since the product was never advertised as working with Linux in the first place. This makes buying a laptop for Linux a risky business.

If you want a laptop with a Unix-based O/S which works out of the box, probably your best bet is a Macbook - but you pay a large premium for that.

I notice Dell still have an Ubuntu page:
http://www.dell.co.uk/ubuntu
but AFAICS that now links to a list of laptops with Windows and no mention of Ubuntu.

Otherwise, if the wireless is a miniPCI card, you can replace it with one with better driver support.

Shane (kohlrak-kohlrak) wrote :
Download full text (3.3 KiB)

>Not really, can you explain what you saw? How long did the transfer take, or before it got interrupted?

Aside from seemingly random freezes in the progress bar for a split second at a time, what you see in the log at that time is what i saw. The transfer completed successfully.

>Possible side issue, but have you tried disabling screen blanking (xset s 0) and disabling all other power management which might kick in N minutes after you last touched the machine?

The first thing i did was removed the default power manager (because it has always been a problem for me on my previous laptop where it'd go critically low battery on plugin) and installed kpowermanager and turned off all the power save stuff except "Prefer power savings over performance" on battery (option not available when plugged in, but i have had the issue come up while plugged in too, so i doubt that option is the culprit). I did this because this new laptop is like the old laptop in that it has an ati card. My last laptop would have major issues with power save functions and that ati card not returning from a power save mode (actually, it ended up freezing the computer because i could not ssh in).

>Also, you could try removing the battery and running just on mains, so that you don't get any ACPI events like "battery fully charged". My Thinkpad X100e has strange lockups in these circumstances.

Considering these never happen during those times and i've often since restarted the driver after plugging it in or unplugging it, i doubt this is the case, however later on i will try it just to be sure.

>More likely, they care about their Windows customers but not those who replace Windows with Linux, since the product was never advertised as working with Linux in the first place. This makes buying a laptop for Linux a risky business.

Yeah, when i bought the thing i called my girlfriend and had her do some serious google work while i was looking at them. She said that she found this particular laptop as one they managed to get working using ndis or they solved the driver issues. Turns out the laptop walmart gave me merely looks like the one i picked out (not complaining, as i paid 500usd for what i found out to be a 700usd laptop). Consequently, this lead to the problem I'm having right now.

>If you want a laptop with a Unix-based O/S which works out of the box, probably your best bet is a Macbook - but you pay a large premium for that.

I prefer an x86 laptop (because i like to do assembly development).

>I notice Dell still have an Ubuntu page:
>http://www.dell.co.uk/ubuntu
>but AFAICS that now links to a list of laptops with Windows and no mention of Ubuntu.

Worse yet, my last laptop was a Dell. That thing was a horror story, because the hardware was more compatable with ubuntu than it was with the world. The lid specifically was obviously designed to physically break with time (which it did, hence why i opened it up in the first place), but i'd rather not delve into the details here, as that would be counter productive.

>Otherwise, if the wireless is a miniPCI card, you can replace it with one with better driver support.

More investment. I don't know what it is for sure, b...

Read more...

Brian Candler (b-candler) wrote :

All current Macbooks are x86. You can even boot them into Windows if you buy a copy.

As for the mini PCI: Thinkpads do generally have very good hardware maintenance manuals that you can download from the Lenovo support site. You'll be able to check how easy it would be to open up and swap the miniPCI, and you can pick up a new Atheros one for $10-$20.

[BTW, my very old Thinkpad X30 was locked to a particular wireless card vendor: it wouldn't boot with a different one installed. The workaround was to bootup without the card, run a utility to flip a bit in the CMOS, and then reinstall the card. Hopefully they don't do that any more]

Shane (kohlrak-kohlrak) wrote :

I don't know if this is the same driver or not, but i was emailed this driver (when i emailed Realtek) with a slightly different version number (a more recent build or testing maybe?). By limiting my range (something i havn't tried to do) to about 5 meters or less, i am able to maintain a relatively stable connection for almost 24 hours. Normally my log complains twice a minute when i leave the safe range.

Log:

[Admin login] from source 192.168.1.3, Thursday, Jul 08,2010 12:30:03
[LAN access from remote] from 119.63.193.57:38246 to 192.168.1.2:80 Thursday, Jul 08,2010 11:55:46
[LAN access from remote] from 207.46.199.184:32271 to 192.168.1.2:80 Thursday, Jul 08,2010 11:49:38
[LAN access from remote] from 85.190.0.3:47786 to 192.168.1.2:80 Thursday, Jul 08,2010 10:52:40
[DHCP IP: (192.168.1.2)] to MAC address 00:07:E9:8F:FF:27, Thursday, Jul 08,2010 09:40:15
[DHCP IP: (192.168.1.3)] to MAC address 20:7C:8F:0D:44:B3, Thursday, Jul 08,2010 09:15:46
[LAN access from remote] from 123.172.6.214:2916 to 192.168.1.2:80 Thursday, Jul 08,2010 06:38:49
[LAN access from remote] from 91.149.144.16:13721 to 192.168.1.2:80 Thursday, Jul 08,2010 05:44:06
[LAN access from remote] from 66.116.101.120:61348 to 192.168.1.2:25 Thursday, Jul 08,2010 02:11:27
[LAN access from remote] from 112.198.79.23:25076 to 192.168.1.2:80 Thursday, Jul 08,2010 02:06:37
[LAN access from remote] from 112.198.79.23:22676 to 192.168.1.2:80 Thursday, Jul 08,2010 02:05:23
[LAN access from remote] from 112.198.79.23:20435 to 192.168.1.2:80 Thursday, Jul 08,2010 01:06:01
[LAN access from remote] from 112.198.79.23:20163 to 192.168.1.2:80 Thursday, Jul 08,2010 01:05:57
[LAN access from remote] from 112.198.79.23:26282 to 192.168.1.2:80 Thursday, Jul 08,2010 01:05:32
[LAN access from remote] from 208.80.193.121:36910 to 192.168.1.2:80 Thursday, Jul 08,2010 00:37:56
[WLAN access allowed] from MAC: 20:7C:8F:0D:44:B3, Wednesday, Jul 07,2010 23:39:18
[WLAN access allowed] from MAC: 20:7C:8F:0D:44:B3, Wednesday, Jul 07,2010 23:38:48
[DHCP IP: (192.168.1.2)] to MAC address 00:07:E9:8F:FF:27, Wednesday, Jul 07,2010 23:36:09
[LAN access from remote] from 121.72.195.86:51365 to 192.168.1.3:6510 Wednesday, Jul 07,2010 22:38:19
[Log Cleared] Wednesday, Jul 07,2010 22:09:30

This doesn't stop the syslog's ramblings, but the connection is seemingly stable. The syslog appears to complain more often, however, which makes me think there's alot of give and take with these drivers. I emailed them back with a mention of the huge range issue, so we'll see how things go from there.

Mancy (mancy) wrote :

it Works for me.
my station: Toshiba L510 Satellite Realtek 8172 with driver RTL8192SE

I've discovered my WIFI problem with Lucid 2.6.32-24-generic

my system was in dual-boot, i logged in to windows then i was using the LAN which led me to deactivate/disable the WLAN using the keyboard function keys.

then all solutions on Ubuntu doesn't work, until i booted to windows again and activated the WLAN driver then rebooted to Ubuntu and that made it WORK.

so my suggestion is to activate your WLAN using the keyboard function keys from Windows or other application because i cannot use the keyboard functions keys on Ubuntu to activate or deactivate the WLAN Driver.

hope it helps ;)

Tim Gardner (timg-tpi) wrote :

Mancy - you could also use 'rfkill unblock wifi' to achieve the same result under Linux.

This bug is DUPLICATED of a bug we are discussing in #215802

Please update your links

Ok so Launchpad didn´t let me add this bug as a DUPLICATE, so I managed to link our old bugs to this...

We were dealing with Realtek 8187b chipset, and the problems are mainly with the onboard usb chip.

Please see bug #215802 for a full discussion on the subject.

See also http://www.spinics.net/lists/linux-wireless/msg54219.html

as a discussion with linux-wireless kernel devs

Thanks all (will try the -proposed kernel to see if this is fixed - I´ll post results in 1-2 days)

Rogerio

Ok couldn´t put his as a DUPLICATE so I put the #215802 as a duplicat eof this one.

Please note that these other bugs are for the 8187b internal usb chipset, but I its my hope someone could help us :)

Rogerio

Jonas Schwabe (jonas-schwabe) wrote :

@Rogerio Luz Coelho: This is not a duplicate as we are dealing with different hardware...
The report you marked as duplicate deals with rtl8187b, this one does not.

tags: added: iso-testing
summary: - Wireless won't work on Lenovo Thinkpad T510
+ Wireless won't work on Lenovo Thinkpad T510 - rtl8192se
Download full text (3.4 KiB)

oooops can I undo this then ??

I was taken by my search of Realtek 8187 ... the first post has it , but I
didn´t read through

Rogerio

PS: to #215802 -- SORRY GUYS, dead end again...

2010/10/2 Ubuntu QA Website <email address hidden>

> ** Tags added: iso-testing
>
> --
> Wireless won't work on Lenovo Thinkpad T510
> https://bugs.launchpad.net/bugs/567016
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (293946).
>
> Status in “linux” package in Ubuntu: Fix Released
> Status in “linux” source package in Lucid: Fix Released
>
> Bug description:
> I can see my network and the system says I'm connected, but I'm not
> actually online (using Lucid 10.4 beta [dual-booting with Windows] on my new
> Lenovo Thinkpad T510).
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: linux-image-2.6.32-21-generic 2.6.32-21.32
> Regression: No
> Reproducible: Yes
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-21-generic x86_64
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: rikki 1427 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xf2620000 irq 17'
> Mixer name : 'Intel G45 DEVIBX'
> Components : 'HDA:14f15069,17aa218b,00100301
> HDA:80862804,17aa21b5,00100000'
> Controls : 10
> Simple ctrls : 5
> Card29.Amixer.info:
> Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw
> 6MHT33WW-1.08'
> Mixer name : 'ThinkPad EC 6MHT33WW-1.08'
> Components : ''
> Controls : 1
> Simple ctrls : 1
> Card29.Amixer.values:
> Simple mixer control 'Console',0
> Capabilities: pswitch pswitch-joined penum
> Playback channels: Mono
> Mono: Playback [on]
> Date: Mon Apr 19 21:06:13 2010
> HibernationDevice: RESUME=UUID=205eb75a-89a7-417b-bb78-4232f4d8e0ab
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
> Lsusb:
> Bus 002 Device 002: ID 8087:0020
> Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 001 Device 003: ID 17ef:480f Lenovo
> Bus 001 Device 002: ID 8087:0020
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: LENOVO 4313CTO
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic
> root=UUID=4edd78e3-1b91-452b-aa5c-9c932474055a ro quiet splash
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> RelatedPackageVersions: linux-firmware 1.34
> RfKill:
>
> SourcePackage: linux
> dmi.bios.date: 02/22/2010
> dmi.bios.vendor: LENOVO
> dmi.bios.version: 6MET49WW (1.12 )
> dmi.board.name: 4313CTO
> dmi.board.vendor: LENOVO
> dmi.board.version: Not Available
> dmi.chassis.asset.tag: No Asset Information
> dmi.chassis.type: 10
> dmi.chassis.vendor: LENOVO
> dmi.chassis.version: Not Available
> dmi.modalias:
> dmi:bvnLENOVO:bvr6MET49WW(1.12):bd02/22/2010:svnLE...

Read more...

Jobo (arkazon) wrote :

Just adding my two cents here because I don't think this bug has been fixed.

I have a Lenovo X201 (3249CTO) laptop with the Realtek 3172 (rev. 10) card. I am running Ubuntu 10.04 with the 2.6.32-25.45 generic kernel, and using the r8192se_pci kernel module and (per lspci) the rtl819xSE "kernel driver in use." The only thing possibly nonstandard is that I am using the latest version of the firmware from Realtek's web site rather than the one that came with Lucid.

I connect almost exclusively to G networks using WPA-PSK, but I connect manually as needed rather than having the computer set to connect automatically. On a good day, the computer will freeze on ~30% of connect attempts; on a bad day, it can be north of 50%. Additionally, once or twice a week it will freeze up out of the blue. In all of these cases, /var/log/syslog indicates that it froze while attempting to negotiate or renegotiate with the wireless network. Also, in all of these cases, it is a hard freeze requiring a power-off/power-on restart, but without a kernel panic.

I'm happy to post syslog excerpts or provide any other information that may be useful. Just wish I could actually DO something to help with this, as it's very frustrating.

Jobo

P.S. Apologies if I stepped on anyone's toes by changing the status back to confirmed. Please advise re etiquette if that was not the right thing to do.

Changed in linux (Ubuntu Lucid):
status: Fix Released → Confirmed
Jobo (arkazon) wrote :

One additional point: Once it connects, it works just fine, until/unless it eventually freezes out of the blue. I.e., I don't experience the poor reception, dropped connections, etc. that some other folks have reported. --Jobo

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
JL (vwyodapink) wrote :

The problem is still here for me running any version of this driver either from Ubuntu or Realtek themselves. I have even tried emailing their tech support for help and the drivers they sent me still cause the same problems, some even worse than before. For me even if I am not connected to anything just have the driver installed I get the hard lock up and have to do a hard reboot and then restart again to get everything going correctly again. I have to resort to using a USB dongle for wifi and leaving the driver out of the system. Funny thing is my USB adapter is a realtek as well just different chip version and it rocks no issues at all. I am on a toshiba x505-887 running Ubuntu 10.10 Kernel 2.6.35-23-generic, nvidia driver.

I have done every possible combination to confirm its this driver alone and for my system its only this that makes it unusable.

  my problems seem to have been solved but even so I would recommend to
ubuntu users that they replace any realtek wifi cards rather than deal
with this -- on many laptops this is not as hard as it sounds. It would
be nice if this chipset is also listed in a compatibility database
somewhere as linux-incompatible...

Shane (kohlrak-kohlrak) wrote :

The driver that comes with ubuntu works for a while, but i have no idea how to restart it when it breaks down (or how to identify when it breaks down as easily as identifying the realtek drivers breaking down). I've discovered that overall heat affects connectivity and even direction of the laptop in relation to the router (this tells me that there might be a physical issue as well). I've even caught it blocking access of one wireless device from connecting to the router when my laptop was placed between the two, while, interestingly enough, the laptop actually kept a stable connection. Restarting the drivers almost always works, however it is annoying. The default driver, while it now works to some degree, does not last forever (but it does work longer than the realtek driver). I've found that locking my router to a specific channel also helps (beware overlaps, though) in the range department. This card is livable, but it's rather annoying and i still can't rely on the connectivity to fulfill my needs. I'm sure, though, we could easily create a script to restart it for us automatically (even then it's not guaranteed to work). All i can say is, if you have it, consider direction and position until it connects, then move around as you see fit until it's time to reconnect again.

Also, make sure you recommend against realtek in the future, as their product clearly doesn't meet our needs.

Jobo (arkazon) wrote :

I've been continuing to try to find a workaround for this problem, and I thought I would share what I've tried, what hasn't worked, and what seems now to be working.

First, I tried installing the lastest Linux driver from Realtek's site (v. 2.6.0018.1025.2010) following the readme included with the download. This involves manual installation using "sudo make" and "sudo make install" from the command line. This did not work, and using "make uninstall" broke my wireless completely. (Easy to see why if you look at the makefile: Both install and uninstall go all over the place "rm -rf"ing things, and I consider myself lucky that all I broke was the wireless.) Finally got it "working" again, with the Lucid driver, by uninstalling and reinstalling the kernel in Synaptic, and manually copying the firmware files from the download to /lib/firmware/RTL8192SE. Random freezes, however, persisted.

Second, I tried installing the WinXP driver (v. 1092.1.0802.2010) using ndisgtk. By blacklisting the Lucid kernel module (rtl8192se_pci) in /etc/modprobe.d/blacklist.conf and including ndiswrapper in /etc/modules, I was able to get ndiswrapper to load and install the XP driver. But this didn't work at all, and "sudo lshw -C Network" showed that no driver was associated with the card. Searching /var/log/syslog for "ndiswrapper" showed that it was unable to load the XP driver because of a couple of "unknown symbol" errors. The Windows 7 driver produced a similar result. Basically, the Windows drivers appeared not to be compatible with ndiswrapper.

I subsequently discovered that the 32-bit XP drivers may in fact work with ndiswrapper, but the 64-bit drivers (which is what I use) are known not to work. So you 32-bitters may be able to go this route, if necessary.

Finally, I tried installing the Realtek Linux driver (version above) using the modified procedure of "sudo make" followed by "sudo checkinstall." (Checkinstall packages the installation such that it can be removed later using Synaptic, if needed.) This worked, in that it did indeed install the new driver and it does now connect. I would also note that the signal strength in my small apartment is now shown as three or four bars, instead of one or two before. What I don't yet know is whether it fixed the biggest problem, which was the random OS freezes. I will report back once I have enough connects under my belt to get a sense of that.

I still think, though, that this would benefit from a "real" solution. This card may be hated, but it is very common, and it is frequently installed on laptops (such as my Lenovo X201) with BIOS locks preventing the owner from installing other wireless cards. It is possible to hack the BIOS to get around this, but in doing so one runs the risk of bricking one's laptop, which I am not willing to do.

dmbfan2007 (dmbfan2007) wrote :

@Jobo
Thanks for your documentation. I have the rtl819xSE using a rtl8191SEvB and am seeing nearly the exact same thing. I'm not so great with moving drivers in and out, so I'm afraid to try half the stuff you have without breaking it all.

Shane (kohlrak-kohlrak) wrote :

@dmbfan2007
If you happen to have the source code, just follow the instructions provided by realtek to me:

>Dear Sir / Madam,
>
>Thanks for your mail.
>Please find the latest RTL8191SE Linux driver source in the attachment.
>You should clear previous drive or inbox driver first after you install this
>driver source.
>The previous driver will be stored within
>/lib/modules/2.6.XXX/kernel/driver/staging.
>Please remove "r8192se_pci.ko" files by following command.
>1. sudo su (you should input you root password after it)
>2. find /lib/modules/ -name "r8192se_*.ko" -exec ls -l {} \;
>3. find /lib/modules/ -name "r8192se_*.ko" -exec rm {} \;
>
>After, You could execute "find /lib/modules/ -name "r8192se_*.ko" -exec ls
>-l {} \;" to confirm it's clear properly.
>And then, install this driver source as below steps. Don't forget to extract
>this package before you install it.
>1. sudo su
>2. make
>3. make install
>4. reboot
>5. ./wlan0up or ./wlan1up

Then, to reset when needed, i simply made a button to shut it down and start it up again.

>./wlan0down
>./wlan0up

Put that in a file, chmod +x it, then put a shortcut wherever you want it and have the shortcut gksu the file that uses the down and up scripts. Then click, enter password, and it resets.

Jobo (arkazon) wrote :

Just reporting back: Only problem in nine days was one random disconnect, so I consider my problem fixed... phew!

@dmbfan2007: If you're still having problems, and you're using 32-bit, I would suggest trying the ndiswrapper route. It is fairly straightforward and easily reversible.

1. Download the Windows XP 32-bit drivers from Realtek's web site: <http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=21&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false>.
2. Install ndisgtk. At the command line, type "sudo apt-get install ndisgtk" (without the quotes, here and in what follows).
3. Add ndiswrapper to /etc/modules. At the command line, type "gksudo gedit /etc/modules". This will bring up /etc/modules in the text editor. Add a line at the end with the single word "ndiswrapper" (no quotes). Save and quit.
4. Figure out what Linux driver you're using. At the command line, type "lsmod | grep 819". You should see a line that says something like "r8192se_pci 512184 0", except in your case it will probably be "r8191se_pci" or something like that.
5. Blacklist the Linux driver in /etc/modprobe.d/blacklist.conf. At the command line, type "gksudo gedit /etc/modprobe.d/blacklist.conf". Add a line at the end that says "blacklist r8191se_pci" (no quotes), replacing r8191se_pci with whatever driver you are using.
6. Follow the instructions here <https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper> at 3.3 and 3.4.1 to extract the Windows driver from what you downloaded and install it using ndisgtk.
7. Restart, throwing salt over shoulder, knocking on wood, keeping fingers crossed, and the like.

If it doesn't work, you can undo everything step by step: Uninstall the driver in ndisgtk, unblacklist the Linux driver by deleting the line in blacklist.conf, remove ndiswrapper from modules, and if you like uninstall ndiswrapper. After restarting, you should be back exactly where you are now.

Jobo (arkazon) wrote :

A quick report on my experience with kernel 2.6.32-26:

First, installing this kernel version appeared to overwrite the Realtek-supplied driver (see #54 above, second-to-last paragraph), but the driver supplied with the kernel suffered from the same flaws as the driver supplied with 2.6.32-25. This was fixed by uninstalling and then reinstalling the package created with checkinstall, but the Realtek-supplied driver didn't work as well with kernel -26 as it did with -25: Didn't detect as many networks, signal not as strong, system freezes. I just set grub to boot to -25 by default, and this seems to fix the problems.

Tim Gardner (timg-tpi) wrote :

This bug has been fixed for the original reporter. Start your own bug if you continue to have issues.

Changed in linux (Ubuntu):
assignee: Tim Gardner (timg-tpi) → nobody
Changed in linux (Ubuntu Lucid):
assignee: Tim Gardner (timg-tpi) → nobody
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/567016

tags: added: laptop-testing
To post a comment you must log in.