comedi drivers are missing completley in the /lib/modules dir

Bug #563436 reported by Bernd Porr on 2010-04-14
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara
Lucid
Medium
Leann Ogasawara

Bug Description

SRU Justification/Impact:

It seems the comedi staging drivers were disabled in Lucid. This is a regression from Karmic. I'm not sure why these were disabled, so if someone has a good reason for them to remain disabled please speak up.

Per the request of the usbdux maintainer, I've re-enabled comedi by reverting the patch which disabled it. I recognize we are frozen for the upcoming release so please consider this for the first Lucid Stable Release Update.

TEST CASE:

I've built a test kernel which re-enables comedi and have received confirmation from the bug reporter (usbdux maintainer) that this indeed provides the comedi drivers.

=====

The kernel modules for comedi were available in karmic but have disappeared from lucid. In the original kernel package comedi exists:
bp1@bp1-lab:/usr/local/src$ ls -l linux-2.6.32.11/drivers/staging/
total 176
drwxrwxr-x 2 root root 4096 2010-04-01 23:59 altpciechdma
drwxrwxr-x 2 root root 4096 2010-04-01 23:59 android
drwxrwxr-x 2 root root 4096 2010-04-01 23:59 asus_oled
drwxrwxr-x 2 root root 4096 2010-04-01 23:59 b3dfg
drwxrwxr-x 4 root root 4096 2010-04-01 23:59 comedi
drwxrwxr-x 2 root root 4096 2010-04-01 23:59 cx25821
drwxrwxr-x 5 root root 4096 2010-04-01 23:59 dream
whereas in the precompiled modules comedi is missing:
bp1@bp1-lab:/usr/local/src$ ls -l /lib/modules/2.6.32-21-generic/kernel/drivers/staging/
total 128
drwxr-xr-x 2 root root 4096 2010-04-14 22:16 altpciechdma
drwxr-xr-x 2 root root 4096 2010-04-14 22:16 asus_oled
drwxr-xr-x 2 root root 4096 2010-04-14 22:16 b3dfg
drwxr-xr-x 2 root root 4096 2010-04-14 22:16 cx25821
drwxr-xr-x 2 root root 4096 2010-04-14 22:16 dst
drwxr-xr-x 2 root root 4096 2010-04-14 22:16 echo
drwxr-xr-x 2 root root 4096 2010-04-14 22:16 et131x

Note that I have reported a comedi related bug for karmic (Bug #483343) and it was promised that this would be fixed for lucid.

Can you guys include comedi in 2.6.32. That would be great if that could be fixed before the release of lucid because I (and the comedi community) was really looking forward to an ubuntu with all comedi drivers installed. We have spent quite a lot of effort to get comedi into the mainstream kernel and comedi is used by many users.

/Bernd

Linux bp1-lab 2.6.32-21-generic #31-Ubuntu SMP Tue Apr 13 20:34:00 UTC 2010 i686 GNU/Linux
bp1@bp1-lab:/usr/local/src$ cat /proc/version_signature
Ubuntu 2.6.32-21.31-generic 2.6.32.11+drm33.2

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-21-generic 2.6.32-21.31
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-21.31-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bp1 1389 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe024000 irq 23'
   Mixer name : 'SigmaTel STAC9227'
   Components : 'HDA:83847618,102801f4,00100201'
   Controls : 31
   Simple ctrls : 21
Date: Wed Apr 14 23:21:36 2010
HibernationDevice: RESUME=UUID=9371ee38-3399-4f29-b63b-2f270c1490b9
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb:
 Bus 002 Device 003: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse
 Bus 002 Device 002: ID 046a:0001 Cherry GmbH My3000 Keyboard
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 004: ID 13d8:0001
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc Dimension C521
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=92275eb7-4fa4-4422-818e-acd416b744b1 ro
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:

SourcePackage: linux
dmi.bios.date: 12/09/2006
dmi.bios.vendor: Dell Inc
dmi.bios.version: 1.1.4
dmi.board.name: 0HY175
dmi.board.vendor: Dell Inc
dmi.board.version: A03
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc
dmi.modalias: dmi:bvnDellInc:bvr1.1.4:bd12/09/2006:svnDellInc:pnDimensionC521:pvr:rvnDellInc:rn0HY175:rvrA03:cvnDellInc:ct3:cvr:
dmi.product.name: Dimension C521
dmi.sys.vendor: Dell Inc

Bernd Porr (berndporr) wrote :
Bernd Porr (berndporr) wrote :

I have compiled from source with the standard config file which actually contains the lines:
CONFIG_COMEDI=m
# CONFIG_COMEDI_DEBUG is not set
CONFIG_COMEDI_PCI_DRIVERS=m
CONFIG_COMEDI_PCMCIA_DRIVERS=m
CONFIG_COMEDI_USB_DRIVERS=m

and after manual compile I get the drivers and everything works fine. Seems so that the comedi subdirectory has been removed by hand?

Bernd Porr (berndporr) on 2010-04-15
tags: added: kernel-lucid
description: updated
Bernd Porr (berndporr) wrote :

I've just checked if the bugs from (Bug #483343) have been fixed in 2.6.32 but they haven't.

Hi Bernd,

It appears comedi was disabled on purpose. Not sure why. This might have to be re-enabled post release as a Stable Release Update as the entire distro is now frozen for release.

ogasawara@emiko:~/ubuntu-lucid$ git show 1db11be784cdb22018c240b40bbe869658b5534c
commit 1db11be784cdb22018c240b40bbe869658b5534c
Author: Andy Whitcroft <email address hidden>
Date: Tue Oct 6 10:01:38 2009 +0100

    UBUNTU: staging/comdi -- disable

    Signed-off-by: Andy Whitcroft <email address hidden>

As far as bug Bug #483343 is concerned, it seems the patches to resolved it went upstream in 2.6.33. As Lucid is 2.6.32 based it explains why the patches are missing and the bug still unresolved. But it seems this bug needs resolved prior to bug 483343 cherry-picking fixes from 2.6.33. Thanks.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Give me a bit and I'll revert the above noted patch and build you some test kernels to get the ball rolling on this.

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
status: Triaged → In Progress

I've placed a test kernel at the following:

http://people.canonical.com/~ogasawara/lp563436/i386/

If you could please give it a try and confirm it re-enables comedi drivers for you that'd be great. Once I get your confirmation I'll submit this for a Lucid Stable Release Update. Thanks in advance.

Bernd Porr (berndporr) wrote :

That's great. Thanks. Looking forward to some testing! ;)

Hi!

Tested and works so far. thanks. In the meantime I've made a patch for
the 2.6.32 ubuntu kernel which should fix the timeout issues. I've
uploaded it on launchpad.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/483343

/Bernd

Leann Ogasawara wrote:
> I've placed a test kernel at the following:
>
> http://people.canonical.com/~ogasawara/lp563436/i386/
>
> If you could please give it a try and confirm it re-enables comedi
> drivers for you that'd be great. Once I get your confirmation I'll
> submit this for a Lucid Stable Release Update. Thanks in advance.
>

--
www: http://www.berndporr.me.uk/
         http://www.linux-usb-daq.co.uk/
 http://www.imdb.com/name/nm3293421/
Mobile: +44 (0)7840 340069
Work: +44 (0)141 330 5237
         University of Glasgow
         Department of Electronics & Electrical Engineering
         Room 519, Rankine Building, Oakfield Avenue,
         Glasgow, G12 8LT

Awesome, thanks Bernd. I'll get this posted to the Ubuntu kernel team mailing list for consideration. I've subsequently also built and posted a test kernel for bug 483343 (see comment 9 in that bug report). Could you give that kernel a spin and let me know your results in that bug report? Thanks!

Bernd Porr (berndporr) wrote :

as written in the other bug report: everything is fine now. Comedi works perfectly.
thanks for the quick response!

description: updated
Changed in linux (Ubuntu Lucid):
milestone: none → lucid-updates
Andy Whitcroft (apw) on 2010-04-21
Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Committed
Bernd Porr (berndporr) wrote :

Hi Leann,
lucid had a kernel update a couple of days ago but comedi is still not in it. Do you know then these fixes appear in the lucid update.
/Bernd

Hi Bernd,

The most recent kernel update only contained security fixes. I'd anticipate the next kernel upload for Lucid containing the comedi driver fixes but it first needs to cycle through -proposed and then be moved to -updates. I unfortunately can't give you an exact ETA as it all is dependent on the kernel going through testing in -proposed. See https://wiki.ubuntu.com/Testing/EnableProposed

As the comedi drivers are already enabled in the actively developed Maverick kernel I'm marking the current linux task for this bug as Fix Released. The Lucid task still remains at Fix Committed. Thanks.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Bernd Porr (berndporr) wrote :

Hi Leann,

thanks for the info.

/Bernd

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Hi Martin Pitt,

I could verify that the comedi folder is present with this kernel version.

Bernd Porr (berndporr) wrote :

I've just tested it with the USBDUX board and ktimetrace and it's working fine. I've also compiled comedirecord with QT4 and that worked also without any problems.

Martin Pitt (pitti) on 2010-06-15
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (25.2 KiB)

This bug was fixed in the package linux - 2.6.32-23.37

---------------
linux (2.6.32-23.37) lucid-proposed; urgency=low

  [ Alex Deucher ]

  * SAUCE: drm/radeon/kms/atom: fix dual-link DVI on DCE3.2/4.0
    - LP: #564559

  [ Andy Whitcroft ]

  * [Config] ports -- build in dm-mod to enable LVM boot
    - LP: #560717
  * tools -- fix perf version extraction for multi-part flavours
    - LP: #555130
  * SAUCE: ACPI: EC: Allow multibyte access to EC (v3)
    - LP: #526354
  * [Config] enforce -- ensure dm_mod is built-in for LVM
    - LP: #560717
  * update to ubuntu-debian:7e708d33054c373faf41da23b73e8b48c342d958
    - LP: #570500, #576274

  [ Chase Douglas ]

  * Revert "(pre-stable): input: ALPS - Add signature for HP Pavilion dm3
    laptops"
    - LP: #550625
  * Enable ftrace function profiler
    - LP: #570389
  * enforce CONFIG_TMPFS_POSIX_ACL=y
    - LP: #575940

  [ Leann Ogasawara ]

  * Revert "staging/comdi -- disable"
    - LP: #563436
  * [Config] Enable multicast routing for sparc
    - LP: #416266
  * [Config] Add ahci.ko to virtual sub-flavour
    - LP: #570542

  [ Stefan Bader ]

  * Revert "SAUCE: drm/i915: Disable FBC on 915GM and 945GM"
    - LP: #588832

  [ Tim Gardner ]

  * ubuntu: rtl8192se -- update to version 0015.0127.2010
    - LP: #567016
  * [Config] Add atl1c to nic-modules udeb
    - LP: #557130

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) iwlwifi: fix nfreed--"
    - LP: #575853
  * Revert "backlight: mbp_nvidia_bl - add five more MacBook variants"
    - LP: #575853
  * Revert "(pre-stable) pata_via: Add VIA VX900 support"
    - LP: #575853
  * Revert "(pre-stable) x86-32, resume: do a global tlb flush in S4
    resume"
    - LP: #575853
  * Revert "x86: disable IOMMUs on kernel crash"
    - LP: #575853
  * Revert "sunrpc: fix peername failed on closed listener"
    - LP: #575853
  * Revert "sunrpc: move the close processing after do recvfrom method"
    - LP: #575853
  * Revert "(pre-stable) drm/edid: allow certain bogus edids to hit a fixup
    path rather than fail"
    - LP: #575853
  * Revert "drm/radeon/kms: don't print error on -ERESTARTSYS."
    - LP: #575853
  * Revert "ath9k: fix lockdep warning when unloading module" on stable
    kernels
    - LP: #588832
  * Staging: comedi: removed "depricated" from COMEDI_CB_BLOCK
    - LP: #483343
  * fat: fix buffer overflow in vfat_create_shortname()
    - LP: #575853
  * xfs: simplify inode teardown
    - LP: #575853
  * xfs: fix mmap_sem/iolock inversion in xfs_free_eofblocks
    - LP: #575853
  * xfs: I/O completion handlers must use NOFS allocations
    - LP: #575853
  * xfs: Wrapped journal record corruption on read at recovery
    - LP: #575853
  * xfs: Fix error return for fallocate() on XFS
    - LP: #575853
  * xfs: check for not fully initialized inodes in xfs_ireclaim
    - LP: #575853
  * xfs: fix timestamp handling in xfs_setattr
    - LP: #575853
  * xfs: Don't flush stale inodes
    - LP: #575853
  * xfs: Ensure we force all busy extents in range to disk
    - LP: #575853
  * xfs: reclaim inodes under a write lock
    - LP: #575853
  * xfs: Avoid inodes in reclaim when flushing from inode cache
    - LP: #575853
  * xfs: recla...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers