Please blacklist older 8xx cards from using KMS

Bug #563277 reported by Bryce Harrington
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Andy Whitcroft
Lucid
Critical
Andy Whitcroft

Bug Description

Please blacklist the following chipsets from using Kernel Mode-Setting:

i830 (8086:3577) -- lp #542208
i845 (8086:2562) -- lp #541492
i855 (8086:3582) -- lp #511001, #541511

A number of testers with these chips have reported X freezes which happen less frequently when KMS is disabled.

Bryce Harrington (bryce)
description: updated
Changed in linux (Ubuntu Lucid):
importance: Undecided → Critical
assignee: nobody → Andy Whitcroft (apw)
description: updated
Bryce Harrington (bryce)
description: updated
Revision history for this message
Rick Spencer (rick-rickspencer3) wrote :

This is an unfortunate situation. There is a non-trivial number of users with 845 and 855 chips who are impacted by a regressions in stability in the current x stack when running 3d and KMS.

We have opted for a "stability first" approach for these users. We will disable 3D and KMS for these chips in Lucid final release. This will have the unfortunate effect of disabling compiz. This will introduce a functional regression. So we will be sacrificing functionality for these users in favor of stability. This is a painful choice to make, but we feel that stability must trump functionality when we are forced to make such choices.

We will be pursuing functional fixes. However, we will do this outside the main release, for example in a PPA. If we are able to provide a fix that delivers stability and functionality, we will consider this a potential SRU in 10.04.1.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-21.32

---------------
linux (2.6.32-21.32) lucid; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: i915 KMS -- support disabling KMS for known broken devices
    - LP: #563277
  * SAUCE: i915 KMS -- blacklist i830
    - LP: #542208, #563277
  * SAUCE: i915 KMS -- blacklist i845g
    - LP: #541492, #563277
  * SAUCE: i915 KMS -- blacklist i855
    - LP: #511001, #541511, #563277
  * SAUCE: radeon KMS -- support disabling KMS for known broken devices
    - LP: #546743
  * SAUCE: radeon KMS -- blacklist ES1000
    - LP: #546743
 -- Andy Whitcroft <email address hidden> Thu, 15 Apr 2010 17:18:49 +0100

Changed in linux (Ubuntu Lucid):
status: New → Fix Released
Revision history for this message
Christiansen (happylinux) wrote :

If stability is an issue, I'm not sure if the latest approach taken in kernel 2.6.31-21.32 is right - at least for an ThinkPad Intel i855 GPU like this:

00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)
Subsystem: IBM Device [1014:0557]

Latest update to kernel 2.6.31-21.32 makes_X_completely_lock_up_the_box on bootup, while booting into an older kernel like 2.6.31-18.xx still works fine. All updates as of 2010.04.17 applied, and using X-server module from "xserver-xorg-video-intel_2.9.1-3ubuntu4_i386".
Booting -21.32 in rescue mode and manually starting X also locks up the box completely right away.

Downgrading to previus kernel -21.31 without the changes from comment #2, X startup works fine and stability is just perfect on the box too. Even running when compiz with a downgraded Intel X-server module from previous "xserver-xorg-video-intel_2.9.1-3ubuntu2_i386" works completely stable.

Changed in linux (Ubuntu Lucid):
status: Fix Released → Fix Committed
Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Kimble,
   Please don't change the status of bugs from fix Released without also providing a reason for the change. I have changed this back to Fix Released.

~JFo

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Chris Jones (cmsj) wrote :

I have a Thinkpad X40 (i855, PCI id 8086:3582) which only sees light use (1-2 hours a day), but has not displayed any kind of X crashing since it was upgraded to Lucid at beta2.
However, with this blacklisted kernel, it is unable to start X, I just get a black screen and no response to SysRq.

Revision history for this message
Chris Jones (cmsj) wrote :

(but dropping back to 2.6.32-20 boots fine)

Revision history for this message
Bryce Harrington (bryce) wrote : Re: [Bug 563277] Re: Please blacklist older 8xx cards from using KMS

On Mon, Apr 26, 2010 at 09:50:32PM -0000, Chris Jones wrote:
> I have a Thinkpad X40 (i855, PCI id 8086:3582) which only sees light use (1-2 hours a day), but has not displayed any kind of X crashing since it was upgraded to Lucid at beta2.
> However, with this blacklisted kernel, it is unable to start X, I just get a black screen and no response to SysRq.

We've seen several people reporting this, that KMS makes it work and UMS
doesn't.

This seems quite perplexing to me. AFAIK with UMS turned on, things
should work as they did in... Jaunty? Whenever we last had UMS on by
default.

I think we should doublecheck that this blacklist did in fact fix
reported issues for people as intended.

Revision history for this message
Christiansen (happylinux) wrote :

I have to support Bryce Harrington in comment #7, running kernel 2.6.31-21.32 with KMS black listed on a couple of different i855 based ThinkPads crashes X right away on X-startup and locks the box completely. Downgrading to kernel 2.6.31-21.31or using i915.modeset=1 in GRUB and the box runs fine for hours, even with the compiz enabled by the latest xserver-xorg-video-intel package.

This means that users are unable to boot LiveCD at all without knowing that you need to set the i915.modeset=1 as a kernel parameter. So may I suggest, that if this isn't changed, as a absolute minimum this is noted in the final Release notes ?.

Revision history for this message
Bryce Harrington (bryce) wrote :

On Thu, Apr 29, 2010 at 03:42:06PM -0000, Christiansen wrote:
> This means that users are unable to boot LiveCD at all without knowing
> that you need to set the i915.modeset=1 as a kernel parameter. So may I
> suggest, that if this isn't changed, as a absolute minimum this is noted
> in the final Release notes ?.

There is a mention in the release notes already, but please review and
suggest alterations to the text if you think it can be improved.

Revision history for this message
Nanachi Tang 420 (nanachitang420) wrote :

how to download?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers