Ubuntu

Comment 11 for bug 561802

@Radek - that works, i can confirm on a DELL e6410 with the NVIDIA 3100m, this works only with 9.10. When added to boot options in 10.04 system stays black/blank. (this was tested with install only environment and live environment). I have tried the last few versions of Ubuntu down to 8.x The system doesn't hang, but you cannot access any of the VT's by doing ALT+CTRL+F(x).

After installation of 9.10 with the boot parameters, GDM and Gnome load fine, but with poor graphics. Click "System" and click "Administration" Then "Drivers" and allow the computer to find the NVIDIA driver: 185.x Install it, by clicking "Activate" then reboot. The screen goes black once again. the NVIDIA drivers' installation will change the /etc/X11/xorg.conf to try to run "nv" drivers.

I ran nvidia-xconfig and the xorg.conf file changed, and rebooted, still black screen, and now no sound.

I noticed that X appears for a split second after i type "reboot" from the cli. I blacklisted i915 in /etc/modprobe.d/i915 and rebooted, which turned up a black/blank screen as well. If i hook up an external display to the VGA port, and hit Fn+F8 the screen shows up on the LCD, but the graphics are distorted like the GPU is bad??? After a few minutes of being plugged into the external display the computer halts completely.

I have tried many OS's, the only one that seemed to work out of the box was PCBSD with the 195.x NVIDIA drivers, so I reinstalled Ubuntu 9.10 with the blacklisted i915 and xforcevesa and did this, from a terminal:

wget ftp://download.nvidia.com/XFree86/Linux-x86/195.22/NVIDIA-Linux-x86-195.22-pkg1.run -O nvidia.sh && chmod +x nvidia.sh && ./nvidia.sh

and finally, it's fixed. This, once again, is for 3100m NVS nvidia E6410 Karmic.

@Tim your're right, it's most likely an out of date NVIDIA driver, not i915, and the xforcevesa simply bypasses the issue.

For Lucid, you can't even see the text at boot, so you may need to install the OS a different way and install the driver above in a chrooted environment from another machine possibly.