Ubuntu

168c:002b WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143 local_bh_enable_ip+0x61/0x90() [ath9k]

Reported by Sean Fitzpatrick on 2010-04-12
This bug affects 244 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by b.ny

Bug Description

Crash report appeared almost immediately after reboot after updating to 2.6.32 kernel.

ProblemType: KernelOops
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-20-generic 2.6.32-20.29
Regression: Yes
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.32-20.29-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Annotation: Your system might become unstable now and might need to be restarted.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sean 1157 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7db8000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,104383ce,00100004'
   Controls : 12
   Simple ctrls : 7
Date: Sun Apr 11 22:22:24 2010
Failure: oops
Frequency: This has only happened once.
HibernationDevice: RESUME=UUID=b7cfe575-2e89-459d-ae45-23dcbaa1f96a
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
MachineType: ASUSTeK Computer INC. 1005HA
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-20-generic root=UUID=79f3df8d-d615-4cd1-a8e6-ee6ab2e3ed2d ro quiet splash
RelatedPackageVersions: linux-firmware 1.33
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Title: WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143 local_bh_enable_ip+0x61/0x90()
dmi.bios.date: 10/16/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1102
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1005HA
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1102:bd10/16/2009:svnASUSTeKComputerINC.:pn1005HA:pvrx.x:rvnASUSTeKComputerINC.:rn1005HA:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1005HA
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Edit: I rebooted to see if the crash happens at reboot, or if it was caused by the first thing I did upon rebooting.
The answer appears to be: the first thing I did, which was click on Ubuntu One under preferences.
As the preferences dialog grabs my account information from the server, the crash/warning occurs, telling me that the system has encountered a serious kernel bug.

Steps to reproduce:
1. Update to 2.6.32 kernel
2. Reboot
3. Open ubuntuone-preferences

Things seem to be functioning normally despite the warning of stability, and reopening ubuntuone-preferences after the initial error report doesn't cause further problems.

Re-edit: I don't think Ubuntu One has anything to do with it - it just happened by coincidence as I was opening the program twice in a row! So in fact, this can be reproduced by rebooting, and waiting 60 seconds.

Update: the same problem is still present after the latest kernel upgrade made available today.

Joakim Gillebo (jokkers) wrote :

I started the computer and immediately after the system was ready i noticed the crash icon next to the wifi icon. I dont know what when or where, but when asked to report a bug report, i got 3-4 other bug report requests. System seems stable though but this is all that i did. I'm new to ubuntu so maby the chrash icon had been lying there for a day but not more. Did complete updat yesterday. One of the bug reports suggested i had an old something and needed to update ;) will try that after this.... quite time consuming but of course important but i'm maby not the beta tester guy sinsce this is my first linux ever! going on day three :D BTW i'm quite a microsoft tech guy but i started to hate windows more and more after vista and then win7 just broke my heart, my itsy bitsy heart!.... hrmf..... well so i love to be in controll of the computer again! - after i learn how to controll it! ..... sidetrack but who cares whouiiiiii

The problem persists upon updating to the latest kernel version released with today's updates.
@ Joakim: there's a good chance things will be resolved by the time the final release comes out at the end of the month. For now, play with the beta version, do a clean installation with the official release, and hope for the best!

Gabe Gorelick (gabegorelick) wrote :

Confirming since a lot of people are reporting this.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: metabug
Denis.K (dkorkut) wrote :

I have no idea how this happens, but it shows up at restart a few times. I'll post back if I can figure it out. (I haven't touched ubuntu one prefs, like Sean said)

Denis.K (dkorkut) wrote :

Edit: should of read your other post!.. atleast what you said can be confirmed, samething happens to me, and with newest update.

Gabe Gorelick (gabegorelick) wrote :

There are *a lot* of duplicates for this bug, and more being reported every day. It may be that not all of these are really duplicates, but they do all get the same warning and do have very similar kernel oopses. There are also a bunch of old bugs on the 2.6.31 kernel with the same warning that might be duplicates of this as well (for example, bug 401401). This link [1] gives good results for all the possible duplicates.

[1] https://bugs.launchpad.net/ubuntu/+source/linux?field.searchtext=local_bh_enable_ip

Gabe Gorelick (gabegorelick) wrote :

Well, bug 401401 is actually older than I thought (2.6.28). Bug 442329 is actually what I meant.

After installing the mainline kernel from here:
http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/
the problem still persists - 60 seconds after boot, the crash appears.

I'm not 100% sure but that probably means the needs-upstream-testing tag can be removed - maybe someone else should confirm first?
Are most people with the bug running the netbook edition? I know mine (eeePC 1005HA) has some hardware issues with the microphone and pulse audio - I'm using pavumeter and pavucontrol to shut off one of the microphone channels. I could try reverting to the default installation but at the moment I need the use of the microphone. (It seems like a sound problem from the bug description)

Well, I did manage to get one boot without the warning message showing up, but with the upstream kernel I get about 10 minutes or less before ending up in low graphics mode... so back to the drawing board!

Javier González (jvrgzlez) wrote :

I am using a acer aspire 5532

I am having the issue on a eee-1005ha, and not on a lenovo or hp

Em 15/04/2010 23:12, Javier González escreveu:
> I am using a acer aspire 5532
>
>

same problem for me. (well, not really a problem, as it doesn't seem to have any consequences on stability...) i also have an eee-1005ha. i believe it happened only on my second reboot after updating the kernel (which was just now). i'm not entirely sure, though.

b.ny (spacem-nkey) wrote :

Edit: I just nominated the bug for release.

...I've got no idea, if that's a good thing or not... sorry in advance if it's not :\

Download full text (3.5 KiB)

It's some kind of random behavior in my machine, the message appears
sometimes shortly after boot, 10 min later or does not show at all.
Also, a couple times, when using mozilla firefox, everything, yes,
everything freezes out.
Not keyboard response, mouse.
I need to find out that special set of keys to return control of keyboard.
Running lucid beta on a Sony Vaio VPCF11FX.
seba

2010/4/16 b.ny <email address hidden>

> Edit: I just nominated the bug for release.
>
> ...I've got no idea, if that's a good thing or not... sorry in advance
> if it's not :\
>
> --
> WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143
> local_bh_enable_ip+0x61/0x90()
> https://bugs.launchpad.net/bugs/561125
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “linux” package in Ubuntu: Confirmed
>
> Bug description:
> Crash report appeared almost immediately after reboot after updating to
> 2.6.32 kernel.
>
> ProblemType: KernelOops
> DistroRelease: Ubuntu 10.04
> Package: linux-image-2.6.32-20-generic 2.6.32-20.29
> Regression: Yes
> Reproducible: No
> ProcVersionSignature: Ubuntu 2.6.32-20.29-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-20-generic i686
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
> Annotation: Your system might become unstable now and might need to be
> restarted.
> AplayDevices:
> **** List of PLAYBACK Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: sean 1157 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xf7db8000 irq 22'
> Mixer name : 'Realtek ALC269'
> Components : 'HDA:10ec0269,104383ce,00100004'
> Controls : 12
> Simple ctrls : 7
> Date: Sun Apr 11 22:22:24 2010
> Failure: oops
> Frequency: This has only happened once.
> HibernationDevice: RESUME=UUID=b7cfe575-2e89-459d-ae45-23dcbaa1f96a
> InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Beta i386
> (20100406.1)
> MachineType: ASUSTeK Computer INC. 1005HA
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-20-generic
> root=UUID=79f3df8d-d615-4cd1-a8e6-ee6ab2e3ed2d ro quiet splash
> RelatedPackageVersions: linux-firmware 1.33
> RfKill:
> 0: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> SourcePackage: linux
> Title: WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143
> local_bh_enable_ip+0x61/0x90()
> dmi.bios.date: 10/16/2009
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 1102
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: 1005HA
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: x.xx
> dmi.chassis.asset.tag: 0x00000000
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK Computer INC.
> dmi.chassis.version: x.x
> dmi.modalias:
> dmi:bvnAme...

Read more...

Yantit (t-ehmer) wrote :

got this on a EeePC 1005PE, happed the first time for me with this kernel version, occured just after booting the OS. don't know if this is maybe an issue with the ath9k... :-/ I don't experience any stability issues, everything seems to run normal...

bacidath4011 (bacidath) wrote :

have had no stability isssues that i can see...

Ralf-Peter (rohbeck) wrote :

Same here. EeePC 1005HA. Kernel stack shows ath9k driver. No apparent problems otherwise; Wireless works.

Francisco Coloma (yopaco) wrote :

In my case I do not feel any instability problem at all, despite of the message, that as already stated pops out few seconds after rebooting.

Chad (chad-schellenger-gmail) wrote :

This happens to me when switching between gnome and netbook sessions in 10.04.

Rocky Stone (rstone-mail) wrote :

IMO the issue occurs for chipsets with Intel audio, at least that's what I observe in this one and several of the duplicate bugs.

AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sean 1157 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7db8000 irq 22'

I have the same issue with Kubuntu 10.04 beta and kernel 2.6.32 on Sony VAIO VPC EB1E1E.

For me the crash occurs right after I choose Reboot or Shut down from KDE Application launcher menu. It shows that plazma-desktop crashed with Segmentation fault and after few seconds reboots/shuts down.

Workaround that works for me: If I reboot/shutdown by running 'sudo reboot' / 'sudo halt' the crash doesn't occur.

Regards,
Rocky

summary: WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143
- local_bh_enable_ip+0x61/0x90()
+ local_bh_enable_ip+0x61/0x90() [Intel audio]

Yep, same log lines in 10+ bugs that I checked - all have "Intel [HDA Intel]" in the report log. Thus I've updated the bug title.

Gabe Gorelick (gabegorelick) wrote :

I think there's multiple bugs going on here. One may be intel audio related, but some definitely have to do with ath9k drivers, for example, bug 564432 has ath9k_sta_notify and some other related functions in its kernel call trace.

Gabe Gorelick (gabegorelick) wrote :

I just realized this bug has the same ath9k functions in its call trace, so why do we think it's an intel audio issue? The audio errors may be completely unrelated, and the intel drivers are very common, so it may just be random that a lot of people reporting this use intel audio. But the fact that all the bugs I checked have ath9k functions in the kernel call trace seems very suspicious.

Jhonattan (jhonattancastillo) wrote :

Im having problems to turn my wireless on :S
I think the bug is related to ath9k too and not precisely the audio.

I changed the title back until we come to a resolution of what this bug is related to.

summary: WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143
- local_bh_enable_ip+0x61/0x90() [Intel audio]
+ local_bh_enable_ip+0x61/0x90()
Gabe Gorelick (gabegorelick) wrote :

The 2.6.31 bugs seem unrelated, they don't have the ath9k functions in the call trace, but every bug I've checked with this warning on 2.6.32 has the ath9k functions.

Emanuel K (capslock286) wrote :

random behavior. The systems never becomes unstable. The exclamation mark showed up when the wifi dropped completely for a few seconds and reconnected.

Forceflow (baertman) wrote :

Seems to happen in the minutes after booting. System does not become unstable.

I'm running an asus eeepc 1005HA.

Andreas (andreas-weiden) wrote :

well, as for me, i don't see any stability problems after the bug appears. i have an asus ul50ag, it has both, an atheros wifi card but also the intel soundchip.

zen933k (jbarager) wrote :

This is affecting me as well, Acer Aspire One 532H. Only thing I can add is my sound was fine before the update. now this crashes after every boot. Main speakers no longer working, headphone jack has sound.

Gabe Gorelick (gabegorelick) wrote :

> Only thing I can add is my sound was fine before the update
That's probably completely unrelated to this bug, as no one else is reporting that. I would file a separate bug report for that issue.

tags: removed: ubuntu-une
summary: WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143
- local_bh_enable_ip+0x61/0x90()
+ local_bh_enable_ip+0x61/0x90() [ath9k]

I noticed with the sound issues being reported. My audio output gets routed to the headphones jack right after I get the defect. I can not confirm this is a part of this defect or another one, because this does not consistently happen.

I can consistently reproduce this bug. When I manually disconnect from a wireless access point and then connect to the the same access point I get the bug, the first time after a fresh boot. If I disconnect from one access point and connect to another I do not get the crash.

Upon reading this message, I went to the system and switched the Wi-fi
connection off then on. The warning occurred immediately. However, after
that I couldn't get it to occur again, until I rebooted. Then, the
warning came on once. I've been unable to reproduce. One thing I've
noticed in all the posts I've read, this problem is appears to be
related to Asus hardware. My machine, in particular, is an Asus EeeBox.

On 18/04/2010 20:15, leon wrote:
> I noticed with the sound issues being reported. My audio output gets
> routed to the headphones jack right after I get the defect. I can not
> confirm this is a part of this defect or another one, because this does
> not consistently happen.
>
> I can consistently reproduce this bug. When I manually disconnect from
> a wireless access point and then connect to the the same access point I
> get the bug, the first time after a fresh boot. If I disconnect from
> one access point and connect to another I do not get the crash.
>
>

> One thing I've noticed in all the posts I've read, this problem is appears to be
> related to Asus hardware

That would make sense if most Asus hardware uses Atheros chipsets. The problem probably extends to most users of the ath9k drivers, and not just ones on Asus hardware, but feel free to correct me if I'm wrong.

Brian Kerven (bkerven) wrote :

@ Gabe - I believe you're correct. Using an Aspire One D250, I get the error less frequently than I did when I first reported, but it still occurs, and is still not reproducible. I'm not sure whether it's a video glitch, but when the problem occurs, I always lose the Evolution/Empathy/et al icon on the panel.

Problem does not invite instability, as has been stated.

Download full text (3.5 KiB)

I am using an Acer 5732-z laptop. I would think it is more of the ath9k drivers.
Sent via BlackBerry from T-Mobile

-----Original Message-----
From: Gabe Gorelick <email address hidden>
Date: Sun, 18 Apr 2010 20:08:13
To: <email address hidden>
Subject: [Bug 561125] Re: WARNING: at
 /build/buildd/linux-2.6.32/kernel/softirq.c:143
 local_bh_enable_ip+0x61/0x90() [ath9k]

> One thing I've noticed in all the posts I've read, this problem is appears to be
> related to Asus hardware

That would make sense if most Asus hardware uses Atheros chipsets. The
problem probably extends to most users of the ath9k drivers, and not
just ones on Asus hardware, but feel free to correct me if I'm wrong.

--
WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143 local_bh_enable_ip+0x61/0x90() [ath9k]
https://bugs.launchpad.net/bugs/561125
You received this bug notification because you are a direct subscriber
of the bug.

Status in “linux” package in Ubuntu: Confirmed

Bug description:
Crash report appeared almost immediately after reboot after updating to 2.6.32 kernel.

ProblemType: KernelOops
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-20-generic 2.6.32-20.29
Regression: Yes
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.32-20.29-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Annotation: Your system might become unstable now and might need to be restarted.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sean 1157 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7db8000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,104383ce,00100004'
   Controls : 12
   Simple ctrls : 7
Date: Sun Apr 11 22:22:24 2010
Failure: oops
Frequency: This has only happened once.
HibernationDevice: RESUME=UUID=b7cfe575-2e89-459d-ae45-23dcbaa1f96a
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
MachineType: ASUSTeK Computer INC. 1005HA
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-20-generic root=UUID=79f3df8d-d615-4cd1-a8e6-ee6ab2e3ed2d ro quiet splash
RelatedPackageVersions: linux-firmware 1.33
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Title: WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143 local_bh_enable_ip+0x61/0x90()
dmi.bios.date: 10/16/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1102
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1005HA
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: A...

Read more...

Gabe Gorelick (gabegorelick) wrote :

Bug 566335 is an example of a user experiencing this issue with non-intel audio.

I haven't realize this before, my bad, but I also have no sound on my
asus eee1005ha main speaker

Yet, on an acerone250s it is just fine (not affected?)

Em 18-04-2010 15:24, x1n933k escreveu:
> This is affecting me as well, Acer Aspire One 532H. Only thing I can add
> is my sound was fine before the update. now this crashes after every
> boot. Main speakers no longer working, headphone jack has sound.
>
>

--
Fábio Leitão
..-. .- -... .. --- .-.. . .. - .- --- ...-.-

My duplicate of this appears linked to the network, not to sound, and in particular when the system goes into hibernation (when I close the lid), although it reconnects to wireless net when I reopen the lid. Only occurs once after each reboot (subsequent hibernations do not reproduce it without a reboot), and appears to have vanished (for now) when I changed to fixed IP instead of DHCP. Once, I saw it reconnect to wireless after unhibernate but not get an IP address (remained at 0.0.0.0), but I've not been able to reproduce that. HTH. Laptop is Acer Aspire 5740G.

Gabe Gorelick (gabegorelick) wrote :

@Vark
Thanks for your comments. Yes, this bug is caused by issues with the ath9k wireless drivers, and not anything sound related. But it *may* also cause sound issues for some users, though its likely that any audio issues users are reporting are unrelated to this bug.

I have a sound problem too, which i reported: my sound is very low, i can
hear it with in-ear headphones but not by speakers, even at the highest
volume settings in alsamixer. May these two bugs be related?

On Mon, Apr 19, 2010 at 9:07 PM, Gabe Gorelick <email address hidden>wrote:

> @Vark
> Thanks for your comments. Yes, this bug is caused by issues with the ath9k
> wireless drivers, and not anything sound related. But it *may* also cause
> sound issues for some users, though its likely that any audio issues users
> are reporting are unrelated to this bug.
>
> --
> WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143
> local_bh_enable_ip+0x61/0x90() [ath9k]
> https://bugs.launchpad.net/bugs/561125
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

sound problems too.... cannot choose external mic, speakers do not mute when headphone is plugged in...

Download full text (3.3 KiB)

I don't have speakers sound either.
The bug appeared once after disconnecting from an wifi access point.
No brightness key control.
On sony vaio VCPF111
seba

2010/4/19 Jhonattan <email address hidden>

> sound problems too.... cannot choose external mic, speakers do not mute
> when headphone is plugged in...
>
> --
> WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143
> local_bh_enable_ip+0x61/0x90() [ath9k]
> https://bugs.launchpad.net/bugs/561125
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “linux” package in Ubuntu: Confirmed
>
> Bug description:
> Crash report appeared almost immediately after reboot after updating to
> 2.6.32 kernel.
>
> ProblemType: KernelOops
> DistroRelease: Ubuntu 10.04
> Package: linux-image-2.6.32-20-generic 2.6.32-20.29
> Regression: Yes
> Reproducible: No
> ProcVersionSignature: Ubuntu 2.6.32-20.29-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-20-generic i686
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
> Annotation: Your system might become unstable now and might need to be
> restarted.
> AplayDevices:
> **** List of PLAYBACK Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: sean 1157 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xf7db8000 irq 22'
> Mixer name : 'Realtek ALC269'
> Components : 'HDA:10ec0269,104383ce,00100004'
> Controls : 12
> Simple ctrls : 7
> Date: Sun Apr 11 22:22:24 2010
> Failure: oops
> Frequency: This has only happened once.
> HibernationDevice: RESUME=UUID=b7cfe575-2e89-459d-ae45-23dcbaa1f96a
> InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Beta i386
> (20100406.1)
> MachineType: ASUSTeK Computer INC. 1005HA
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-20-generic
> root=UUID=79f3df8d-d615-4cd1-a8e6-ee6ab2e3ed2d ro quiet splash
> RelatedPackageVersions: linux-firmware 1.33
> RfKill:
> 0: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> SourcePackage: linux
> Title: WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143
> local_bh_enable_ip+0x61/0x90()
> dmi.bios.date: 10/16/2009
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 1102
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: 1005HA
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: x.xx
> dmi.chassis.asset.tag: 0x00000000
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK Computer INC.
> dmi.chassis.version: x.x
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvr1102:bd10/16/2009:svnASUSTeKComputerINC.:pn1005HA:pvrx.x:rvnASUSTeKComputerINC.:rn1005HA:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
> dmi.product.name: 1005HA
> dmi.product.version: x.x
> dmi.sys.vendor: ASUSTeK...

Read more...

I hit this bug when I switched my access point off.
I was running Thunderbird at the same time. TB was indexing and synchronizing e-mails over IMAP.
-----------
Toshiba Satellite A300D-18I
network Atheros AR928X (ath9k)
kernel 2.6.32-21-generic #32, x86_64

Nowres Rafed (nss-zpeedzter) wrote :

i have sound problem too.

i can hear sound only with headset.

i have intel audio hd and it's detected very well

cdunphy (rc-dunphy) wrote :

I noticed the ath9k in the stack dump as well. Sony VAIO VPCCW21FD here. I do notice that my wireless is having issues where the connection is intermittent. When downloading a large file for example, there are short periods of activity, followed by long periods of no network activity. I dual boot with Windows 7 on this machine and do not see the issue on the Windows instance.

Shaun Dennie (sdennie) wrote :

Looking through the ath9k driver changes, I have a feeling that this problem is related to the driver defaulting to powersave mode for chips where the driver isn't stable with powersave mode enabled. A potential workaround is:

sudo modprobe -r ath9k
sudo modprobe ath9k
sudo iwconfig wlan0 power off

Note: This will drop your connection because you are reloading the driver.

The card claims that power savings is not enabled even before doing this but, my connection has been stable for an abnormally long period of time since trying this. This potential workaround will not persist through a reboot or suspend/resume but, if it's found to help people, I can post pm-utils scripts that permanently disable the power savings.

galazka (jean-jacques-galazka) wrote :

the bugs don't persist with 2.6.33-020633-generic

Am 22.04.2010 07:57, schrieb galazka:
> the bugs don't persist with 2.6.33-020633-generic
>
> ** Attachment added: "Capture-1.png"
> http://launchpadlibrarian.net/45003290/Capture-1.png
>
>

.... but then, u probably won't have running "Lucid Lynx" any longer
.... ;-) )
Take it easy ;-)

Same problem here, also using ath9k
This happened to me after my connection to the AP was lost, while firefox was loading a website. I had no problems with my machine, it just kept running normally.
[OffTopic] BTW ath9k is a very bad driver, I've had many problems trying to do the same things I was doing with my old ralink rt73 (USB), and some of them don't even work.
Sorry for my bad english, it is not my native language.

Russell Nakamu (rhnakamu) wrote :

I had the same problem when it started (the 11th of April or so), on an Asus eee with an Atom 1.66 GHz processor, but it went away with the last update and hasn't returned since.

I got Asus Eee pc (1000HE) with Intel Atom 1.66 GHz too, and it also dual boots with Windows 7. I also get this bug report for nothing (it seems), when I'm starting Ubuntu.

Javier González (jvrgzlez) wrote :

Since the RC this problem is solve everything is working fine right now.

Zaleco (e-contact-zaleco-nl) wrote :

Since the last update, last Thursday or so, this error did not return. Everything is working fine now.

Vreixo Formoso (metalpain2002) wrote :

I'm having the same problem with a Lucid fresh install. It appears when I try to connect to a WPA-Enterprise wireless network. No issues with open, WEP or WPA-Personal networks for now.

DarkSide (darkside-ua) wrote :
Download full text (5.0 KiB)

Frequently got this error... :(

Trace:
May 6 03:10:01 gateway kernel: [44975.287831] ------------[ cut here ]------------
May 6 03:10:01 gateway kernel: [44975.287849] WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143 local_bh_enable_ip+0x61/0x90()
May 6 03:10:01 gateway kernel: [44975.287856] Hardware name:
May 6 03:10:01 gateway kernel: [44975.287859] Modules linked in: f71882fg nls_cp437 isofs aes_i586 aes_generic xt_DSCP iptable_mangle ipt_MASQUERADE iptable_nat nf_nat ipt_REJECT xt_recent xt_tcpudp nf_conntrack_ipv4 nf_defrag_ipv4 xt_state xt_conntrack nf_conntrack iptable_filter ip_tables x_tables nfsd exportfs nfs lockd nfs_acl arc4 auth_rpcgss fbcon tileblit font bitblit softcursor vga16fb vgastate sunrpc bridge stp i915 drm_kms_helper ath9k mac80211 drm ath i2c_algo_bit ppdev cfg80211 intel_agp video lp parport_pc led_class psmouse output agpgart serio_raw parport r8169 mii [last unloaded: f71882fg]
May 6 03:10:01 gateway kernel: [44975.287959] Pid: 1170, comm: hostapd Not tainted 2.6.32-22-generic #33-Ubuntu
May 6 03:10:01 gateway kernel: [44975.287965] Call Trace:
May 6 03:10:01 gateway kernel: [44975.287976] [<c014c3d2>] warn_slowpath_common+0x72/0xa0
May 6 03:10:01 gateway kernel: [44975.287985] [<c0153381>] ? local_bh_enable_ip+0x61/0x90
May 6 03:10:01 gateway kernel: [44975.287992] [<c0153381>] ? local_bh_enable_ip+0x61/0x90
May 6 03:10:01 gateway kernel: [44975.288000] [<c014c41a>] warn_slowpath_null+0x1a/0x20
May 6 03:10:01 gateway kernel: [44975.288007] [<c0153381>] local_bh_enable_ip+0x61/0x90
May 6 03:10:01 gateway kernel: [44975.288017] [<c058b866>] _spin_unlock_bh+0x16/0x20
May 6 03:10:01 gateway kernel: [44975.288045] [<f83f418f>] ath_tx_node_cleanup+0x14f/0x170 [ath9k]
May 6 03:10:01 gateway kernel: [44975.288068] [<f83eeeee>] ath9k_sta_notify+0x4e/0xb0 [ath9k]
May 6 03:10:01 gateway kernel: [44975.288092] [<f8348647>] __sta_info_unlink+0x127/0x1b0 [mac80211]
May 6 03:10:01 gateway kernel: [44975.288115] [<f83eeea0>] ? ath9k_sta_notify+0x0/0xb0 [ath9k]
May 6 03:10:01 gateway kernel: [44975.288138] [<f8348703>] sta_info_unlink+0x33/0x50 [mac80211]
May 6 03:10:01 gateway kernel: [44975.288165] [<f8355f60>] ? ieee80211_del_station+0x0/0x60 [mac80211]
May 6 03:10:01 gateway kernel: [44975.288191] [<f8355fa5>] ieee80211_del_station+0x45/0x60 [mac80211]
May 6 03:10:01 gateway kernel: [44975.288216] [<f80649ce>] nl80211_del_station+0x6e/0xc0 [cfg80211]
May 6 03:10:01 gateway kernel: [44975.288230] [<c04e2567>] genl_rcv_msg+0x227/0x250
May 6 03:10:01 gateway kernel: [44975.288243] [<c04e2340>] ? genl_rcv_msg+0x0/0x250
May 6 03:10:01 gateway kernel: [44975.288251] [<c04e14e6>] netlink_rcv_skb+0x86/0xb0
May 6 03:10:01 gateway kernel: [44975.288258] [<c04e2331>] genl_rcv+0x21/0x30
May 6 03:10:01 gateway kernel: [44975.288265] [<c04e11a9>] netlink_unicast+0x259/0x280
May 6 03:10:01 gateway kernel: [44975.288273] [<c04e1dca>] netlink_sendmsg+0x1ba/0x2a0
May 6 03:10:01 gateway kernel: [44975.288283] [<c03208b5>] ? apparmor_socket_sendmsg+0x15/0x20
May 6 03:10:01 gateway kernel: [44975.288292] [<c04b38a5>] sock_sendmsg+0xe5/0x110
May 6 03:10:...

Read more...

Vreixo Formoso (metalpain2002) wrote :

Hi,

this bug seems related with upstream bug in ath9k driver: https://bugzilla.kernel.org/show_bug.cgi?id=15761

Vreixo Formoso (metalpain2002) wrote :

Hi,

I have fixed my problem by downgrading to an old version of the module. I have explained my solution here: https://bugs.launchpad.net/ubuntu/+bug/578306/comments/1.

Now I can connect to WPA enterprise networks, and the error does not appear anymore.
Be free to try if that works for you.

Changed in linux:
status: Unknown → Fix Released
Changed in linux:
importance: Unknown → Medium
tags: removed: regression-potential
tags: added: bios-outdated-1601
summary: - WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143
+ 168c:002b WARNING: at /build/buildd/linux-2.6.32/kernel/softirq.c:143
local_bh_enable_ip+0x61/0x90() [ath9k]

Sean Fitzpatrick, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc4

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

Christopher - I haven't encountered any problems related to this in quite some time; I guess it got resolved at some point and I forgot about it - sorry! If there are any edits you'd like me to apply to the report, please let me know.

Sean Fitzpatrick, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/561125/comments/66 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.