ports kernel lacks device-mapper as built-in (causes LVM not to activate)

Bug #560717 reported by Emmet Hikory on 2010-04-11
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Medium
Unassigned
linux (Ubuntu)
Medium
Andy Whitcroft
Lucid
Medium
Andy Whitcroft
Maverick
Medium
Andy Whitcroft

Bug Description

When booting my powerpc server into lucid, it hangs in initramfs, unable to find /dev/mapper/vg00-root : the same disk configuration and fstab worked successfully under karmic. To complete the boot, I must run the following two commands manually:

modprobe dm_mod
lvm vgchange -a y

I do not encounter this issue on a similarly configured amd64 system. Further investigation shows that the dm_mod kernel module is built-in for amd64, and that the /dev/mapper/* nodes are populated correctly during startup with this configuration.

Please set the dm_mod module to be a built-in also for powerpc (or any other architectures where it may be missing).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-20-powerpc 2.6.32-20.29
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-20.29-powerpc 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-powerpc ppc
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices: Error: [Errno 2] No such file or directory
Architecture: powerpc
ArecordDevices: Error: [Errno 2] No such file or directory
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/controlC0', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info: Error: [Errno 2] No such file or directory
Card0.Amixer.values: Error: [Errno 2] No such file or directory
CurrentDmesg:
 [ 126.309570] input: Mouseemu virtual keyboard as /devices/virtual/input/input3
 [ 126.311333] input: Mouseemu virtual mouse as /devices/virtual/input/input4
 [ 127.947501] eth0: no IPv6 routers present
Date: Sun Apr 11 23:05:54 2010
HibernationDevice: RESUME=UUID=94943b87-8978-4bd5-a2fb-bc5421e1c791
PciMultimedia:

ProcCmdLine: root=/dev/mapper/vg00-root ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.33
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux

Emmet Hikory (persia) wrote :
Kees Cook (kees) on 2010-04-15
summary: - lucid sever fails to boot with LVM root
+ ports kernel lacks device-mapper as built-in (causes LVM not to
+ activate)
Kees Cook (kees) on 2010-04-15
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in linux (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Steve Langasek (vorlon) wrote :

Unfortunately this wasn't discovered before the kernel freeze was already in effect for final release. It can and should be fixed for the first post-release kernel upload, as well as being mentioned in the release notes.

Changed in linux (Ubuntu Lucid):
milestone: ubuntu-10.04 → lucid-updates
Changed in ubuntu-release-notes:
importance: Undecided → Medium
status: New → Triaged
Andy Whitcroft (apw) on 2010-04-22
Changed in linux (Ubuntu Lucid):
status: Triaged → In Progress
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

This is builtin for all distro flavours so it seems reasonable to harmonise them.

Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Documented at <https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#Boot%20failures%20with%20LVM%20on%20ia64,%20powerpc,%20sparc>:

The linux kernel packages for the ia64, powerpc, and sparc architectures builds device-mapper support as a module, where the packages for the other architectures have the driver built in, which leads to boot failures on ia64/powerpc/sparc when using LVM. To work around this, users must run these commands manually from the initramfs:

modprobe dm_mod
lvm vgchange -a y

This issue will be addressed in a post-release kernel update. (560717)

Changed in ubuntu-release-notes:
status: Triaged → Fix Released

when is it planned for release to updates repo?

Simon Déziel (sdeziel) wrote :

The 10.04.1 release date is July 29th which is 3 months after the initial release of Lucid.

Sometimes Ubuntu releases essential and critical fixes before .1 release.
I would consider this fix as essential for everybody who's using LVM on 'ports' platforms. Am I wrong?

Courtney Bane (cbane) wrote :

This bug doesn't just affect people using ports platforms. I'm using the i386 2.6.32-305-ec2 kernel in a Xen VM, and I ran in to this as well. I have a script that can be added to the initrd as a workaround, but I haven't actually tested it yet. Once I do so (hopefully tomorrow sometime) I'll post it for other people to use.

Courtney Bane (cbane) wrote :

OK, I've had a chance to test my workaround script, and it does work. I've attached it to this comment; drop it in /etc/intramfs-tools/scripts/local-top, and rebuild your initrds ("update-initrd -k all -u"). During boot, if the /dev/mapper directory isn't available, this script will load the dm_mod kernel module, wait a second, and then activate all LVM volumes.

Confirming - the workaround works. Thanks a bunch! I hate to do vgchange on every boot.

Steve Langasek (vorlon) on 2010-05-17
Changed in linux (Ubuntu):
milestone: lucid-updates → none

Steve, does that mean there will be no update for lucid?

Steve Langasek (vorlon) wrote :

no, just doing housekeeping on the bug state.

KVM is also affected but only when linux-image-virtual is used.
As a work-aroudn linux-image-sever can be used instead.

http://ubuntuforums.org/showthread.php?p=9426296

Martin Pitt (pitti) on 2010-06-11
Changed in linux (Ubuntu Maverick):
milestone: none → maverick-alpha-2

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (25.2 KiB)

This bug was fixed in the package linux - 2.6.32-23.37

---------------
linux (2.6.32-23.37) lucid-proposed; urgency=low

  [ Alex Deucher ]

  * SAUCE: drm/radeon/kms/atom: fix dual-link DVI on DCE3.2/4.0
    - LP: #564559

  [ Andy Whitcroft ]

  * [Config] ports -- build in dm-mod to enable LVM boot
    - LP: #560717
  * tools -- fix perf version extraction for multi-part flavours
    - LP: #555130
  * SAUCE: ACPI: EC: Allow multibyte access to EC (v3)
    - LP: #526354
  * [Config] enforce -- ensure dm_mod is built-in for LVM
    - LP: #560717
  * update to ubuntu-debian:7e708d33054c373faf41da23b73e8b48c342d958
    - LP: #570500, #576274

  [ Chase Douglas ]

  * Revert "(pre-stable): input: ALPS - Add signature for HP Pavilion dm3
    laptops"
    - LP: #550625
  * Enable ftrace function profiler
    - LP: #570389
  * enforce CONFIG_TMPFS_POSIX_ACL=y
    - LP: #575940

  [ Leann Ogasawara ]

  * Revert "staging/comdi -- disable"
    - LP: #563436
  * [Config] Enable multicast routing for sparc
    - LP: #416266
  * [Config] Add ahci.ko to virtual sub-flavour
    - LP: #570542

  [ Stefan Bader ]

  * Revert "SAUCE: drm/i915: Disable FBC on 915GM and 945GM"
    - LP: #588832

  [ Tim Gardner ]

  * ubuntu: rtl8192se -- update to version 0015.0127.2010
    - LP: #567016
  * [Config] Add atl1c to nic-modules udeb
    - LP: #557130

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) iwlwifi: fix nfreed--"
    - LP: #575853
  * Revert "backlight: mbp_nvidia_bl - add five more MacBook variants"
    - LP: #575853
  * Revert "(pre-stable) pata_via: Add VIA VX900 support"
    - LP: #575853
  * Revert "(pre-stable) x86-32, resume: do a global tlb flush in S4
    resume"
    - LP: #575853
  * Revert "x86: disable IOMMUs on kernel crash"
    - LP: #575853
  * Revert "sunrpc: fix peername failed on closed listener"
    - LP: #575853
  * Revert "sunrpc: move the close processing after do recvfrom method"
    - LP: #575853
  * Revert "(pre-stable) drm/edid: allow certain bogus edids to hit a fixup
    path rather than fail"
    - LP: #575853
  * Revert "drm/radeon/kms: don't print error on -ERESTARTSYS."
    - LP: #575853
  * Revert "ath9k: fix lockdep warning when unloading module" on stable
    kernels
    - LP: #588832
  * Staging: comedi: removed "depricated" from COMEDI_CB_BLOCK
    - LP: #483343
  * fat: fix buffer overflow in vfat_create_shortname()
    - LP: #575853
  * xfs: simplify inode teardown
    - LP: #575853
  * xfs: fix mmap_sem/iolock inversion in xfs_free_eofblocks
    - LP: #575853
  * xfs: I/O completion handlers must use NOFS allocations
    - LP: #575853
  * xfs: Wrapped journal record corruption on read at recovery
    - LP: #575853
  * xfs: Fix error return for fallocate() on XFS
    - LP: #575853
  * xfs: check for not fully initialized inodes in xfs_ireclaim
    - LP: #575853
  * xfs: fix timestamp handling in xfs_setattr
    - LP: #575853
  * xfs: Don't flush stale inodes
    - LP: #575853
  * xfs: Ensure we force all busy extents in range to disk
    - LP: #575853
  * xfs: reclaim inodes under a write lock
    - LP: #575853
  * xfs: Avoid inodes in reclaim when flushing from inode cache
    - LP: #575853
  * xfs: recla...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
emile (emileditomaso) on 2010-08-16
Changed in linux (Ubuntu Lucid):
status: Fix Released → Opinion
Changed in linux (Ubuntu Lucid):
status: Opinion → Fix Released
gigastress (a9711599) wrote :

Hey guys,

I just proceeded from 9.10 to 10.4 LTS lucid, after not upgrading for 2.5 years, I was about to proceed to the latest version.
I decided to keep the old grub, for I made a whole-disk-encryprtion and wanted to keep the settings. I dont know if this is the problem with lvm problem adressed in the lucid release notes. I think I installed the new kernel but Im not sure here.
Anyway the result of this installation is, that
When I boot, the display where Im supposed to put in the LVM/luks password is showing up, but when I put it in, it keeps saying - cryptsetup failed, bad password or options -
It is the correct pass, the release note said sth. about changing the UUID in the fstab with the actual name of the hd, but since the display where Im supposed to put in the LVM/luks password is showing up at boot, I dont know if this problem is related.
so it actually could be a kernel, fstab, or grub problem.
I got know idea how to handle this.
suggestions would be highly appreciated.
anyone, how can I proceed ???

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers