Ubuntu

[USB-Audio - USB AUDIO ] no volume control possible with Tenx USB audio adapter

Reported by Oliver Gerlich on 2010-04-10
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

When using a "Logilink USB2.0 to Audio Adapter" (which apparently uses a Tenx Technology TP6911 chip, judging from USB id 1130:f211) under Lucid Beta, the volume control does not work. Sound is always played at same volume.

The volume slider in panel can be used but doesn't have any effect on volume, except that going down near 0 suddenly mutes the sound. Also, when using the slider in Volume Settings dialog, moving the volume above the 100% mark actually increases playback volume - but I assume this is done by Pulseaudio in software?

Aside from the volume issue, the device seems to basically work - it is displayed in Audio Settings as additional input/output device, and it plays sound (didn't test recording, though).

According to http://www.tenx.com.tw/product_detail.aspx?ProductID=192 the chip is supposed to have "64-level volume control" - is that not true, or does the driver not make these 64 levels available?

This is with up-to-date Lucid Beta, on EeePc 701. The normal built-in sound card works fine, including volume control.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic-pae 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: oliver 1121 F.... pulseaudio
 /dev/snd/controlC0: oliver 1121 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7eb8000 irq 16'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,104382a1,00100101'
   Controls : 13
   Simple ctrls : 8
Card1.Amixer.info:
 Card hw:1 'default'/'USB AUDIO at usb-0000:00:1d.0-2, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB1130:f211'
   Controls : 4
   Simple ctrls : 2
Date: Sat Apr 10 12:11:03 2010
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100224.3)
PackageArchitecture: all
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
SelectedCard: 1 default USB-Audio - USB AUDIO
SourcePackage: alsa-driver
Symptom: audio
Title: [USB-Audio - USB AUDIO ] Playback problem
dmi.bios.date: 05/16/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1101
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 701
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1101:bd05/16/2008:svnASUSTeKComputerINC.:pn701:pvrx.x:rvnASUSTeKComputerINC.:rn701:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 701
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Oliver Gerlich (ogerlich) wrote :
Markus Birth (mbirth) wrote :

I also got the same device (http://www.dizeg.net/digit/photo/caplior7/rimg1555.jpg) ... and with it the same symptoms. Using alsamixer, going from 63.00 dB (max) gain volume down to 11.00dB only slightly changes the volume (it's still very loud at this point). Going one step down to 10.99dB completely mutes the output. Besides from that, it works fine. Activating "Analog Mono Input" in PulseAudio volume control (Hardware tab, "Profile"-setting) adds a digital noise the audio output, but from the VU-meter, input seems to work.

I just noticed: When setting the profile to "Digital Stereo Duplex (IEC958)" (didn't see this profile last time I checked), volume control seems to work. But lowering the volume adds noise to the output sound ... might be the poor audio processor. Can anybody confirm this?

Alfagulf (alfagulf) wrote :

I am having the same problem with the same USB sound adapter!
I am using ubuntu 11.04 and the bug description mentioned above applies to me as well.
Also, I can confirm the comment by Markus, ie. using IEC958 allows me to have control over the volume!

The Gnome Alsa Mixer does not show any controls at all!

The sound is distorted unless I turn down my external speakers (Amplified) in order to reduce the distortion!
It seems the sound level from this USB device is rather high for such active speakers.

I hope something could be done to make this device more useful.

sndfnsdfin (qawsnews) wrote :

Hi,
I encountered the same problem and fixed it with a tiny kernel patch. So give it a try! ( It basically disables the hardware volume control that seems to be broken on this device and frees the way for software mixing...)
Feedback is appreciated...

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Слава (slav-a1976) on 2011-09-12
Changed in alsa-driver (Ubuntu):
assignee: nobody → Слава (slav-a1976)

The attachment "A patch that applies to linux 3.1-rc1" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Øyvind Stegard (oyvinst) wrote :

The patch does work in the way intended. However, the hardware volume, now uncontrollable, seems pegged at max by default, and it is very high in output (sensitive headsets beware). This also causes significant noise at sane/lower software-mixer volume levels. I guess the hardware in question here is just cheap crap and not worth the hassle.

While going through Ubuntu bugs, I discovered this patch being
posted and a confirmation that the patch works as expected.

Finding out how the hw volume really works would be preferrable
to just disabling the broken one, but this would be better than
nothing.

Credit: sndfnsdfin (qawsnews)
BugLink: https://bugs.launchpad.net/bugs/559939
Signed-off-by: David Henningsson <email address hidden>
---
 sound/usb/mixer.c | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/sound/usb/mixer.c b/sound/usb/mixer.c
index 4f40ba8..fe56c9d 100644
--- a/sound/usb/mixer.c
+++ b/sound/usb/mixer.c
@@ -1267,6 +1267,13 @@ static int parse_audio_feature_unit(struct mixer_build *state, int unitid, void
   /* disable non-functional volume control */
   master_bits &= ~UAC_CONTROL_BIT(UAC_FU_VOLUME);
   break;
+ case USB_ID(0x1130, 0xf211):
+ snd_printk(KERN_INFO
+ "usbmixer: volume control quirk for Tenx TP6911 Audio Headset\n");
+ /* disable non-functional volume control */
+ channels = 0;
+ break;
+
  }
  if (channels > 0)
   first_ch_bits = snd_usb_combine_bytes(bmaControls + csize, csize);
--
1.7.9.5

Takashi Iwai (tiwai) wrote :

At Thu, 20 Sep 2012 10:20:41 +0200,
David Henningsson wrote:
>
> While going through Ubuntu bugs, I discovered this patch being
> posted and a confirmation that the patch works as expected.
>
> Finding out how the hw volume really works would be preferrable
> to just disabling the broken one, but this would be better than
> nothing.
>
> Credit: sndfnsdfin (qawsnews)
> BugLink: https://bugs.launchpad.net/bugs/559939
> Signed-off-by: David Henningsson <email address hidden>

Applied now. Thanks.

Takashi

> ---
> sound/usb/mixer.c | 7 +++++++
> 1 file changed, 7 insertions(+)
>
> diff --git a/sound/usb/mixer.c b/sound/usb/mixer.c
> index 4f40ba8..fe56c9d 100644
> --- a/sound/usb/mixer.c
> +++ b/sound/usb/mixer.c
> @@ -1267,6 +1267,13 @@ static int parse_audio_feature_unit(struct mixer_build *state, int unitid, void
> /* disable non-functional volume control */
> master_bits &= ~UAC_CONTROL_BIT(UAC_FU_VOLUME);
> break;
> + case USB_ID(0x1130, 0xf211):
> + snd_printk(KERN_INFO
> + "usbmixer: volume control quirk for Tenx TP6911 Audio Headset\n");
> + /* disable non-functional volume control */
> + channels = 0;
> + break;
> +
> }
> if (channels > 0)
> first_ch_bits = snd_usb_combine_bytes(bmaControls + csize, csize);
> --
> 1.7.9.5
>

David Henningsson (diwic) wrote :

The good: Upstream has accepted the patch!
The slow: It's probably scheduled for Linux 3.7 which means it won't reach Precise/Quantal by default.

Changed in alsa-driver (Ubuntu):
status: Confirmed → In Progress
assignee: Слава (slav-a1976) → nobody
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-18.29). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Luis Henriques (henrix) wrote :

The fix for this bug has hit Quantal through an upstream stable update (3.5.7). Thus, I'm tagging it as verified.

tags: added: verification-done-quantal
removed: verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (16.4 KiB)

This bug was fixed in the package linux - 3.5.0-18.29

---------------
linux (3.5.0-18.29) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1068224

  [ Andy Whitcroft ]

  * [packaging] do not fail secure copy on older kernels
  * SAUCE: efivarfs: efivarfs_file_read ensure we free data in error paths
    - LP: #1063061
  * SAUCE: efivars: efivarfs_create() ensure we drop our reference on inode
    on error
    - LP: #1063061
  * SAUCE: efivarfs: efivarfs_fill_super() fix inode reference counts
    - LP: #1063061
  * SAUCE: efivarfs: efivarfs_fill_super() ensure we free our temporary
    name
    - LP: #1063061
  * SAUCE: efivarfs: efivarfs_fill_super() ensure we clean up correctly on
    error
    - LP: #1063061
  * [Config] add fs/udf to linux-image to support DVD/CD formats in virtual
    instances
    - LP: #1066921

  [ Jeremy Kerr ]

  * SAUCE: efi: Handle deletions and size changes in efivarfs_write_file
    - LP: #1063061
  * SAUCE: efivarfs: Implement exclusive access for {get, set}_variable
    - LP: #1063061

  [ Kamal Mostafa ]

  * SAUCE: input: Cypress PS/2 Trackpad list additional contributors

  [ Kyle Fazzari ]

  * SAUCE: input: Cypress PS/2 Trackpad fix lost sync upon palm contact
    - LP: #1048258
  * SAUCE: input: Cypress PS/2 Trackpad fix taps turning into hardware
    clicks
    - LP: #1064086

  [ Leann Ogasawara ]

  * Revert "SAUCE: ext4: fix crash when accessing /proc/mounts
    concurrently"
    - LP: #1066176
  * Revert "SAUCE: ALSA: hda/realtek - Fix detection of ALC271X codec"
    - LP: #1066176

  [ Lee, Chun-Yi ]

  * SAUCE: efi: add efivars kobject to efi sysfs folder
    - LP: #1063061

  [ Matt Fleming ]

  * SAUCE: efivarfs: Add documentation for the EFI variable filesystem
    - LP: #1063061

  [ Matthew Garrett ]

  * SAUCE: efi: Add support for a UEFI variable filesystem
    - LP: #1063061

  [ Sarveshwar Bandi ]

  * SAUCE: bridge: Pull ip header into skb->data before looking into ip
    header.
    - LP: #1065150

  [ Upstream Kernel Changes ]

  * Revert "drm/i915: correctly order the ring init sequence"
    - LP: #1066176
  * vfs: dcache: fix deadlock in tree traversal
    - LP: #1063761
  * dm mpath: only retry ioctl when no paths if queue_if_no_path set
    - LP: #1063761
  * dm: handle requests beyond end of device instead of using BUG_ON
    - LP: #1063761
  * dm table: clear add_random unless all devices have it set
    - LP: #1063761
  * dm verity: fix overflow check
    - LP: #1063761
  * usb: gadget: make g_printer enumerate again
    - LP: #1063761
  * usb: gadget: initialize the strings in tcm_usb_gadget properly
    - LP: #1063761
  * USB: option: blacklist QMI interface on ZTE MF683
    - LP: #1063761
  * USB: ftdi_sio: add TIAO USB Multi-Protocol Adapter (TUMPA) support
    - LP: #1063761
  * USB: qcaux: add Pantech vendor class match
    - LP: #1063761
  * usb: host: xhci: Fix Null pointer dereferencing with 71c731a for
    non-x86 systems
    - LP: #1063761
  * USB: serial: fix up bug with missing {}
    - LP: #1063761
  * staging: speakup_soft: Fix reading of init string
    - LP: #1063761
  * tty: keyboard.c: Remove locking from vt_get_leds.
  ...

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Herton R. Krzesinski (herton) wrote :

The commit for this issue came in via a stable upstream release (linux 3.0.46). As such it is not subject to the standard bug verification process.

tags: added: verification-done-oneiric
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers