Ubuntu

1002:7942 Please blacklist ATI XPRESS 1250 from Kernel mode-setting

Reported by Antoine Pairet on 2010-04-08
86
This bug affects 14 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Antoine Pairet

Bug Description

Please add ATI Technologies Inc Radeon Xpress 1250 [1002:7942] to the kernel drm KMS blacklist.

Testing has shown that KMS support for the ati xpress 1250 is inadequate, often resulting in a regression where the system hangs during boot up. Testers have found that booting with radeon.modeset=0 restores the system functionality. This is why this particular video card should be blacklisted.

As suggested by Brice Harrington in bug #542208, comment 17, it is better to keep one report per chip.

[initial bug report: symptoms of what happens when one tries to boot with kms enabled]
Here are some details of what happens:
  1. setting nomodeset option
  2. editing boot option, removing quiet and splash
  3. Selecting Try Ubuntu
  4. System begins to boot, lots of messages are printed on the screen
  5. After 2-3 seconds, screen goes black although disk activity continues
  6. Screen keeps being black and the computer is unusable

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3992 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd0000000 irq 16'
   Mixer name : 'Realtek ALC262'
   Components : 'HDA:11c13026,2117144d,00100700 HDA:10ec0262,144dc511,00100002'
   Controls : 18
   Simple ctrls : 12
Date: Thu Apr 8 11:35:16 2010
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MachineType: SAMSUNG ELECTRONICS CO., LTD. R19/R20/R21
Package: linux-image-2.6.32-16-generic 2.6.32-16.25
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz nosplash -- nomodeset console-setup/layoutcode=fr console-setup/variantcode=oss
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.32
Reproducible: Yes
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-16-generic x86_64
dmi.bios.date: 07/18/2007
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 14SH
dmi.board.name: R19/R20/R21
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr14SH:bd07/18/2007:svnSAMSUNGELECTRONICSCO.,LTD.:pnR19/R20/R21:pvr09SH:rvnSAMSUNGELECTRONICSCO.,LTD.:rnR19/R20/R21:rvr:cvnSAMSUNGELECTRONICSCO.,LTD.:ct1:cvrN/A:
dmi.product.name: R19/R20/R21
dmi.product.version: 09SH
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

Antoine Pairet (b-ly) wrote :
Antoine Pairet (b-ly) wrote :
Antoine Pairet (b-ly) wrote :

@ Shaved Wookie:
In a comment posted for bug #509273, you said:
      I get the third "possibility" (grub -> blackscreen) with an Xpress 1250. Not sure how to try nonmodeset

As we have the same graphic card and as you also experience black screen on boot, it would be great if could perform the following test:

1. Test lucid beta 1 with nomodeset option
    download lucid beta 1: http://cdimage.ubuntu.com/releases/10.04/beta-1/
    nomodeset option: When you see the ubuntu menu proposing to Try Ubunutu wihtout installing, to install, check disk or cancel and boot from 1st hard drive, press F6 and check the option nomodeset. Then choose: Try Ubuntu
    report if it you experience a black screen on boot

2. Test lucid beta 2 with the exact same procedure

If test 1 succeeds but test 2 fails, then this bug can be confirmed.

Antoine Pairet (b-ly) on 2010-04-08
description: updated
Antoine Pairet (b-ly) on 2010-04-08
tags: added: black-screen
Antoine Pairet (b-ly) on 2010-04-08
tags: added: freeze modeset
Shaved Wookie (shavedwookie) wrote :

I actually managed to fix this issue on my machine by replacing nomodeset in the kernel line with radeon.modeset=0,so I'm not sure how much of a help it would be to you for me to test this...

Antoine Pairet (b-ly) wrote :

Shaved Wookie is right. Option nomodeset no longer works. Instead radeon.nomodeset must be used. Thank you.

Changing description, title
Marking bug #558641 as duplicate

Antoine Pairet (b-ly) on 2010-04-08
description: updated
summary: - lucid no longer boots after beta1 upgrades
+ Please blacklist ATI XPRESS 1250 from Kernel mode-setting
Changed in linux (Ubuntu):
status: New → Confirmed
Antoine Pairet (b-ly) on 2010-04-08
description: updated
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
description: updated

when adding nomodeset to the kernel parameters on a Samsung R60
with ATI Technologies Inc Radeon Xpress 1250 [1002:7942]
the machine boots without freezing at the black screen

using the standard grub entry the system still freezes at a black screen
on a Beta 2 with all of today's updates that is.

tags: added: i386
charles r. (tcharlss) wrote :

ATI Xpress 1250M on a Samsung R60plus :
adding radeon.nomodeset=0 solved the problem for me

Just ran into this with Lucid final and my Samsung R20 (yet another Radeon Xpress 1250).
Live CD boots to a black screen by default (have to press Escape, F6 and check the nomodeset option).
Installed system then boots to a black screen as well (have to manually add radeon.modeset=0 to the kernel command line).

DeHuC (dengon) wrote :

Have the same one with Samsung R18plus. radeon.modeset=0 helps, but I have to change screen resolution manually after every boot (from 640x480).

hackeron (hackeron) wrote :

radeon.nomodeset=0 solved the problem on my Samsung R20

Madis (madisliias) wrote :

My xpress 1250 started to work with KMS with the latest kernel (2.6.35 RC1) (haven't tried 2.6.33 nor 2.6.34, though). There were some issues though - glxgears (or games like AlienArena) showed artifacts (and one maybe not related to graphics card - wifi didn't connect very well).

Madis (madisliias) wrote :

Just tried with Ubuntu 10.04 x64 2.6.32-24, works well.

Permalac (joanmarcriera) wrote :

I have a Dell latitude XT with same problem on ubuntu 10.10 netbook 32x.
aticonfig: No supported adapters detected
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Xpress 1250
thanks

tags: removed: regression-potential

Antoine Pairet, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc4

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

summary: - Please blacklist ATI XPRESS 1250 from Kernel mode-setting
+ 1002:7942 Please blacklist ATI XPRESS 1250 from Kernel mode-setting
Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
importance: Undecided → Medium
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers