Lenovo X100e: thinkpad_acpi: Not yet supported ThinkPad detected!

Bug #557736 reported by Alex Chekholko
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I see this message on boot (in dmesg output)

[ 12.787032] thinkpad_acpi: Not yet supported ThinkPad detected!

I believe this patch fixes it: http://<email address hidden>/msg02222.html

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-19-generic 2.6.32-19.28
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: alex 1379 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd0600000 irq 16'
   Mixer name : 'Conexant CX20582 (Pebble)'
   Components : 'HDA:14f15066,17aa21b2,00100301'
   Controls : 12
   Simple ctrls : 10
Date: Wed Apr 7 20:46:40 2010
HibernationDevice: RESUME=UUID=a1173ba9-f177-465a-b52b-4eae2437d6c8
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
MachineType: LENOVO 350828U
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=02d653f0-db79-4607-bfb7-c5238b07d969 ro crashkernel=384M-2G:64M,2G-:128M quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.33
RfKill:

SourcePackage: linux
dmi.bios.date: 03/12/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6XET36WW (1.20a)
dmi.board.name: INVALID
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6XET36WW(1.20a):bd03/12/2010:svnLENOVO:pn350828U:pvrThinkPadX100e:rvnLENOVO:rnINVALID:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 350828U
dmi.product.version: ThinkPad X100e
dmi.sys.vendor: LENOVO

Revision history for this message
Alex Chekholko (alex-chekholko) wrote :
summary: - thinkpad_acpi: Not yet supported ThinkPad detected!
+ Lenovo X100e: thinkpad_acpi: Not yet supported ThinkPad detected!
Revision history for this message
Jerone Young (jerone) wrote :

This support is being worked on upstream. The X100e has a different EC then other thinkpads.

http://sourceforge.net/mailarchive/forum.php?thread_name=20100403165521.GB17218%40khazad-dum.debian.net&forum_name=ibm-acpi-devel

Revision history for this message
Alex Chekholko (alex-chekholko) wrote :

How do we get it integrated upstream? The latest kernel source does not yet have this patch: http://git.kernel.org/?p=linux/kernel/git/next/linux-next.git;a=blob_plain;f=drivers/platform/x86/thinkpad_acpi.c;hb=HEAD

Revision history for this message
Henrique de Moraes Holschuh (hmh) wrote : Re: [Bug 557736] Re: Lenovo X100e: thinkpad_acpi: Not yet supported ThinkPad detected!

On Sun, 18 Apr 2010, Alex Chekholko wrote:
> How do we get it integrated upstream? The latest kernel source does not
> yet have this patch: http://git.kernel.org/?p=linux/kernel/git/next
> /linux-
> next.git;a=blob_plain;f=drivers/platform/x86/thinkpad_acpi.c;hb=HEAD

I will need to fix a few things in the driver, you need more than a simple
patch to find the EC for it to work well.

Most of the main fixes will be around soon, probably by the end of the week.

BTW, the X100e dumps and reports I got show some seriously buggy firmware.
Keep it up-to-date.

--
  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Hi Alex,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Alex Chekholko (alex-chekholko) wrote :

I installed the latest mainline deb: 2.6.34-999-generic at the moment. I can confirm that I still get the "thinkpad_acpi: Not yet supported ThinkPad detected!" message when I boot into that kernel.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
Revision history for this message
Lukáš Zapletal (lzap) wrote :

As another x100e owner I also offer testing on my piece. Let me know when you need something.

Revision history for this message
Vladimir Skubriev (v-skubriev) wrote :

Excusme, i am not understand by reading this bug wrotes: when it will be fixed ?

Revision history for this message
Vladimir Skubriev (v-skubriev) wrote :

I have an lenovo x100e notebook with Athlon Neo processor, i am running ubuntu 10.04 and kubuntu 10.04

ubuntu running, but sometimes it hangs up for example 1 in two hours.

kubuntu hang up when i am login via kdm(maybe) e.g. press enter after paste login and password, when the hdd icon is changing transparency e.g. computers loading KDE desktop

because kubuntu is not working fully.

Revision history for this message
Tyler Straub (tyler-straub) wrote :

any progress on this?

Revision history for this message
Lukáš Zapletal (lzap) wrote :

Fixed in mainstream. We need a patch. Can somebody confirm?

Revision history for this message
Vladimir Skubriev (v-skubriev) wrote :

I don't understand what to confirm. What can I do ?
I am a trivial user of lenovo x100e and installed kubuntu 10.04 with all updates

You think that this bug is fixed in mainstream. What do you think: when we can update our system and all work normally ?

Revision history for this message
Henrique de Moraes Holschuh (hmh) wrote :

On Mon, 07 Jun 2010, Vladimir Skubriev wrote:
> Excusme, i am not understand by reading this bug wrotes: when it will be
> fixed ?

When you get a new Ubuntu kernel with the thinkpad-acpi driver which is in
2.6.35-rc, or the latest thinkpad-acpi driver backports in ibm-acpi.sf.net.

I hope some Ubuntu kernel developer answers you with a date frame or
something. I work on the upstream kernel, only. I don't even run Ubuntu...

--
  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

Revision history for this message
Henrique de Moraes Holschuh (hmh) wrote :

On Mon, 07 Jun 2010, Vladimir Skubriev wrote:
> ubuntu running, but sometimes it hangs up for example 1 in two hours.

This is not related to thinkpad-acpi, so this bug will not help you.

--
  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

tags: added: kernel-acpi kernel-needs-review
removed: needs-upstream-testing
Revision history for this message
Vladimir Skubriev (v-skubriev) wrote :
Revision history for this message
Vladimir Skubriev (v-skubriev) wrote :

to Henrique de Moraes Holschuh

installing

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35-rc1-lucid/linux-image-2.6.35-020635rc1-generic_2.6.35-020635rc1_i386.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35-rc1-lucid/linux-headers-2.6.35-020635rc1-generic_2.6.35-020635rc1_i386.deb

fixed problem with hang up during loading KDE Desktop after succesful login, because functions of led display brightness control are working properly

Revision history for this message
Vladimir Skubriev (v-skubriev) wrote :

ONLY one question when this patches will backported in standart updates &

Will be in Ubuntu 10.04 or will be in later versions ?

Revision history for this message
Lukáš Zapletal (lzap) wrote :

I dont think it will be "done magically". Somebody have to do it. Did you identify which particular git commit fixed the problem? Then somebody could create a patch and propose it to 10.04.

Revision history for this message
Brian Candler (b-candler) wrote :

There is a good guide on recompiling individual modules here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/554099/comments/14

Unfortunately,
http://git.kernel.org/?p=linux/kernel/git/next/linux-next.git;a=blob_plain;f=drivers/platform/x86/thinkpad_acpi.c;hb=HEAD
is not a drop-in replacement for thinkpad_acpi.c with 2.6.32-22-generic source, giving some errors about missing functions and wrong numbers of args.

But I hacked about with it fairly blindly, making the minimum changes to make it compile with 2.6.32-22 (source attached). Now:

make O=../temp modules SUBDIRS=drivers/platform/x86/

modprobe thinkpad_acpi

gives the following results:

Jun 11 13:30:13 x100 kernel: [10886.706712] thinkpad_acpi: ThinkPad ACPI Extras v0.24
Jun 11 13:30:13 x100 kernel: [10886.706718] thinkpad_acpi: http://ibm-acpi.sf.net/
Jun 11 13:30:13 x100 kernel: [10886.706721] thinkpad_acpi: ThinkPad BIOS 6XET39WW (1.23 ), EC 6XHT39WW-1.179000
Jun 11 13:30:13 x100 kernel: [10886.706725] thinkpad_acpi: Lenovo ThinkPad X100e, model 35085EG
Jun 11 13:30:13 x100 kernel: [10886.709008] thinkpad_acpi: detected a 16-level brightness capable ThinkPad
Jun 11 13:30:13 x100 kernel: [10886.711563] thinkpad_acpi: possible tablet mode switch found; ThinkPad in laptop mode
Jun 11 13:30:13 x100 kernel: [10886.711596] thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness control, supported by the ACPI video driver
Jun 11 13:30:13 x100 kernel: [10886.711599] thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...
Jun 11 13:30:13 x100 kernel: [10886.716578] thinkpad_acpi: asked for hotkey mask 0x040808fc, but firmware forced it to 0x000808fc
Jun 11 13:30:13 x100 kernel: [10886.733126] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is blocked
Jun 11 13:30:13 x100 kernel: [10886.748479] thinkpad_acpi: rfkill switch tpacpi_wwan_sw: radio is unblocked
Jun 11 13:30:13 x100 kernel: [10886.748641] Registered led device: tpacpi::thinklight
Jun 11 13:30:13 x100 kernel: [10886.748683] Registered led device: tpacpi::power
Jun 11 13:30:13 x100 kernel: [10886.748708] Registered led device: tpacpi::standby
Jun 11 13:30:13 x100 kernel: [10886.748732] Registered led device: tpacpi::thinkvantage
Jun 11 13:30:13 x100 kernel: [10886.766321] thinkpad_acpi: Standard ACPI backlight interface available, not loading native one.
Jun 11 13:30:13 x100 kernel: [10886.766654] thinkpad_acpi: Console audio control enabled, mode: monitor (read only)
Jun 11 13:30:13 x100 kernel: [10886.771905] input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input10

This looks promising. Pressing Fn-F5 enables the bluetooth happily.

Revision history for this message
Brian Candler (b-candler) wrote :

Here's my hack as a diff against the HEAD version of thinkpad_acpi.c (i.e. changes I made to make it compile)

Revision history for this message
Brian Candler (b-candler) wrote :

and here's what you get if you diff it against the 2.6.32 version of thinkpad_acpi.c

Revision history for this message
Henrique de Moraes Holschuh (hmh) wrote :

Backports for several *upstream* kernels are available at:
http://repo.or.cz/w/linux-2.6/linux-acpi-2.6/ibm-acpi-2.6.git

(the git:// url is somewhere on that web page).

It is easier to work based on those than what is in -next or mainline.

The only active release/* branches are:

1. The one for whatever kernel I am using on my T43 (usually the latest or
second-to-latest stable upstream kernel).

2. The one for the latest upstream stable kernel, and after -rc5 or
thereabouts, the branch for the next upcoming kernel (if there is a reason
to create one, i.e., it would not be an empty branch).

3. release/2.6.32 (until it becomes too hard due to code divergence,
probably in an year or so).

Sometimes I keep a release/ branch alive for a bit, but there are no
promises.

If anyone is going to start providing Ubuntu kernel module packages based on
the above development tree backports, that someone is *urged* to subscribe
to the ibm-acpi-devel ML and the x86 platform drivers ML to get in the loop.

Those patches are development patches, so they should go through the
distro's QA and testing before they're shipped by any distro. If you want
stable, you have to get it from the upstream stable kernel.

--
  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

Revision history for this message
Brian Candler (b-candler) wrote :

Ah, then the correct one to use is I guess
http://repo.or.cz/w/linux-2.6/linux-acpi-2.6/ibm-acpi-2.6.git/blob_plain/release/2.6.32:/drivers/platform/x86/thinkpad_acpi.c

This is very close to the one I hacked together, and works identically. Thank you!

Revision history for this message
rCX (rcx) wrote :

This also occurs on the thinkpad edge. See bug #552880

Revision history for this message
Brad Figg (brad-figg) wrote :

The proper support for the X100e was added prior to the Maverick release. Is this still an issue for users?

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Revision history for this message
Brian Candler (b-candler) wrote :

Thinkpad ACPI was fine for me in Maverick and Natty.

(Still problems with wireless dropping out, and less frequently ethernet, but that's a different issue)

Revision history for this message
Peter Howe (peter-howe) wrote :

No problems in oneiric:

[ 21.888475] thinkpad_acpi: ThinkPad ACPI Extras v0.24
[ 21.888481] thinkpad_acpi: http://ibm-acpi.sf.net/
[ 21.888485] thinkpad_acpi: ThinkPad BIOS 6XET41WW (1.25 ), EC 6XHT40WW-1.180000
[ 21.888488] thinkpad_acpi: Lenovo ThinkPad X100e, model 35085GG
[ 21.894117] thinkpad_acpi: detected a 8-level brightness capable ThinkPad
[ 21.894183] thinkpad_acpi: possible tablet mode switch found; ThinkPad in laptop mode
[ 21.895765] thinkpad_acpi: asked for hotkey mask 0x040988fc, but firmware forced it to 0x000988fc
[ 21.999128] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is blocked
[ 22.066874] thinkpad_acpi: rfkill switch tpacpi_wwan_sw: radio is blocked
[ 22.066995] Registered led device: tpacpi::thinklight
[ 22.067110] Registered led device: tpacpi::power
[ 22.067205] Registered led device: tpacpi::standby
[ 22.067303] Registered led device: tpacpi::thinkvantage
[ 22.116658] thinkpad_acpi: Standard ACPI backlight interface available, not loading native one
[ 22.122853] thinkpad_acpi: Console audio control enabled, mode: monitor (read only)
[ 22.152273] input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input9

tags: added: patch
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.