kernel BUG at /build/buildd/linux-2.6.32/drivers/gpu/drm/drm_fops.c:146!

Bug #556962 reported by Charlie Kravetz on 2010-04-07
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

After installing Xubuntu Lucid, I can boot the system into the existing installation on sdb1 nor the new install on sda1 without many attempts. Most of the time, the monitor shuts down and the system appears to boot into hibernate. The keyboard is inactive, the monitor is turned off, and I can not gain access using ssh.

ProblemType: KernelOops
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-19-generic 2.6.32-19.28
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Annotation: Your system might become unstable now and might need to be restarted.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: wcadmin 1560 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe024000 irq 22'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,10192971,00100101'
   Controls : 28
   Simple ctrls : 16
CurrentDmesg:
 [ 20.122159] [drm] nouveau 0000:02:00.0: Allocating FIFO number 2
 [ 20.126485] [drm] nouveau 0000:02:00.0: nouveau_channel_alloc: initialised FIFO 2
 [ 28.810140] eth0: no IPv6 routers present
 [ 83.510026] Clocksource tsc unstable (delta = -272628919 ns)
Date: Tue Apr 6 18:09:51 2010
Failure: oops
HibernationDevice: RESUME=UUID=19c3163d-6ab1-4ee8-aebf-88d708810699
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: PCCHIPS A15G
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=2ea706c3-4965-475c-9ed3-5cba1554eaac ro quiet splash
RelatedPackageVersions: linux-firmware 1.33
RfKill:

SourcePackage: linux
Title: kernel BUG at /build/buildd/linux-2.6.32/drivers/gpu/drm/drm_fops.c:146!
dmi.bios.date: 12/05/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: A15G
dmi.board.vendor: PCCHIPS
dmi.board.version: 2.0
dmi.chassis.asset.tag: Unknow
dmi.chassis.type: 3
dmi.chassis.vendor: PCCHIPS
dmi.chassis.version: Unknow
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd12/05/2007:svnPCCHIPS:pnA15G:pvr2.0:rvnPCCHIPS:rnA15G:rvr2.0:cvnPCCHIPS:ct3:cvrUnknow:
dmi.product.name: A15G
dmi.product.version: 2.0
dmi.sys.vendor: PCCHIPS

Charlie Kravetz (charlie-tca) wrote :
tags: added: iso-testing
Steve Langasek (vorlon) on 2010-04-10
Changed in linux (Ubuntu Lucid):
importance: Undecided → High
Andy Whitcroft (apw) wrote :

------------[ cut here ]------------
kernel BUG at /build/buildd/linux-2.6.32/drivers/gpu/drm/drm_fops.c:146!
invalid opcode: 0000 [#2] SMP
last sysfs file: /sys/devices/pci0000:00/0000:00:09.0/0000:02:00.0/boot_vga
CPU 0
Modules linked in: snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi fbcon tileblit font bitblit softcursor snd_seq_midi_event vga16fb snd_seq vgastate snd_timer snd_seq_device nouveau ppdev edac_core ttm snd drm_kms_helper parport_pc drm i2c_algo_bit i2c_nforce2 lp psmouse serio_raw edac_mce_amd soundcore snd_page_alloc k8temp parport dm_raid45 sata_nv forcedeth pata_amd xor
Pid: 1066, comm: Xorg Tainted: G D 2.6.32-19-generic #28-Ubuntu A15G
RIP: 0010:[<ffffffffa00b805f>] [<ffffffffa00b805f>] drm_open+0x10f/0x120 [drm]
RSP: 0018:ffff8800ba3b1c68 EFLAGS: 00010206
RAX: ffff8800bab0cb48 RBX: 0000000000000000 RCX: 0000000000000015
RDX: 0000000000000000 RSI: ffff8800bb1c7240 RDI: ffff8800baa90820
RBP: ffff8800ba3b1c98 R08: ffff880001c11fe0 R09: 00000000000000c0
R10: ffff8800bc3323c0 R11: 0000000000000002 R12: ffff8800ba384c00
R13: ffff8800baab6970 R14: ffff8800baa90800 R15: ffff8800baa90820
FS: 00007f2ab9298700(0000) GS:ffff880001c00000(0000) knlGS:0000000000000000
CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00007f2ab5bc4c80 CR3: 00000000b9c24000 CR4: 00000000000006f0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process Xorg (pid: 1066, threadinfo ffff8800ba3b0000, task ffff8800baf02de0)
Stack:
 000000000e200000 ffffffffa00ca7e0 ffff8800baab6970 ffff8800bb1c7000
<0> 00000000ffffffed ffff8800baa90800 ffff8800ba3b1ce8 ffffffffa00b81a3
<0> ffff8800b9cc8380 ffff8800bc630000 0000000000000000 0000000000000000
Call Trace:
 [<ffffffffa00b81a3>] drm_stub_open+0x133/0x260 [drm]
 [<ffffffff8114650a>] chrdev_open+0x13a/0x240
 [<ffffffff811463d0>] ? chrdev_open+0x0/0x240
 [<ffffffff81140823>] __dentry_open+0x113/0x370
 [<ffffffff8125177f>] ? security_inode_permission+0x1f/0x30
 [<ffffffff8114cbaf>] ? inode_permission+0xaf/0xd0
 [<ffffffff81140b97>] nameidata_to_filp+0x57/0x70
 [<ffffffff81150dea>] do_filp_open+0x2da/0xba0
 [<ffffffff8115c89a>] ? alloc_fd+0x10a/0x150
 [<ffffffff81140599>] do_sys_open+0x69/0x170
 [<ffffffff811406e0>] sys_open+0x20/0x30
 [<ffffffff810131b2>] system_call_fastpath+0x16/0x1b
Code: 89 ff e8 15 17 f8 e0 66 90 eb 99 90 4c 89 ff e8 08 17 f8 e0 66 90 4c 89 f7 e8 ce f9 ff ff 89 c3 eb 82 49 3b 85 10 01 00 00 74 a7 <0f> 0b eb fe 66 66 66 66 2e 0f 1f 84 00 00 00 00 00 55 48 89 e5
RIP [<ffffffffa00b805f>] drm_open+0x10f/0x120 [drm]
 RSP <ffff8800ba3b1c68>
---[ end trace 0ec7af0ebca54358 ]---

Matt Zimmerman (mdz) wrote :

Which version of Ubuntu is the "existing installation"? Which version of Ubuntu worked correctly on this system, if any?

Charlie Kravetz (charlie-tca) wrote :

Existing installation is on sdb1, which I use on a daily basis. It is an installation of Lucid installed fresh. Xubuntu karmic worked, as did Xubuntu Alpha 2 and 3.

Brian Murray (brian-murray) wrote :

Charlie there have been some recent kernel updates and I was wondering if you are still affected by this bug report.

Changed in linux (Ubuntu Lucid):
status: New → Incomplete
Charlie Kravetz (charlie-tca) wrote :

Yes, I would gladly try another installation if it helps. I reinstalled, using both the Xubuntu alternate image, dated 2010-04-16, and the Xubuntu Desktop image, dated 2010-04-17. Both images installed and ran! I think I can say this issue is fixed, whether or not we know what fixed it. I was able to perform the same installations and additions without the monitor shutting off and the system inaccessible. The two items I did find are:

Alternate installer insists drives are a raid array if they are partitioned the same, regardless of mount points and denial from user. My third drive has two 110 GiB partitions, which are identified as failing to properly mount as a raid array. They are simply two partitions, which I designated be mounted as /usr/bak/Downloads and /usr/bak/Music. They are not accessible after the install from the alternate cd because it doesn't find the array usable.

The Desktop image does not recognize three hard drives as valid. I could use sda or sdb, but not sdc. I can not even tell it to use the third hard drive, because it is not in the partition editor.

Charlie Kravetz (charlie-tca) wrote :

This appears to be fixed. I did all hardware installs for the pre-rc testing, and never saw this issue again. Thanks for the efforts.

Changed in linux (Ubuntu Lucid):
status: Incomplete → New
tags: added: kj-triage
Brian Murray (brian-murray) wrote :

Setting to Fix Released since the original reporter indicates that it is fixed. Please feel free to reopen this bug if you are experiencing the exact same issue.

Changed in linux (Ubuntu Lucid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers