Intel WiFi Link 5150ABG - connection broken or freezing when transferring large files

Bug #554832 reported by RussianNeuroMancer on 2010-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by RussianNeuroMancer

Bug Description

When I transfer large files (few Gb for example) wifi connection can be broken or freezing. If this happened - I can't connect to AP until reboot the system.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-19-generic 2.6.32-19.28
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
CRDA: Error: [Errno 2] Нет такого файла или каталога
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf5500000 irq 22'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,17aa3872,00100001'
   Controls : 23
   Simple ctrls : 13
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xf5000000 irq 16'
   Mixer name : 'Nvidia ID a'
   Components : 'HDA:10de000a,10de0101,00100100'
   Controls : 0
   Simple ctrls : 0
Card1.Amixer.values:

Date: Sun Apr 4 06:16:19 2010
HibernationDevice: RESUME=UUID=da5821a8-2d25-41a3-a65c-c2b2a5851326
InstallationMedia: Error: [Errno 13] Отказано в доступе: '/var/log/installer/media-info'
MachineType: LENOVO 20017
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-19-generic root=UUID=3312396f-d048-4888-ad00-71ab21db6e27 ro quiet splash
ProcEnviron:
 LANGUAGE=ru_RU:ru:en_GB:en
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.33
SourcePackage: linux
dmi.bios.date: 10/11/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 15CN32WW(V2.05)
dmi.board.name: KIWB1
dmi.board.vendor: LENOVO
dmi.board.version: REFERENCE
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLENOVO:bvr15CN32WW(V2.05):bd10/11/2009:svnLENOVO:pn20017:pvrLenovoIdeaPadY550:rvnLENOVO:rnKIWB1:rvrREFERENCE:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: 20017
dmi.product.version: Lenovo IdeaPad Y550
dmi.sys.vendor: LENOVO

summary: - Intel WiFi Link 5150ABR - connection broken or freezing when
+ Intel WiFi Link 5150ABN - connection broken or freezing when
transferring large files

Hi RussianNeuroMancer,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Tested with 2.6.34rc5 - I can't just connect to AP, if 802.11n-only mode enabled! https://bugs.launchpad.net/ubuntu/+source/linux/+bug/560230

Changed in linux (Ubuntu):
status: Incomplete → New
summary: - Intel WiFi Link 5150ABN - connection broken or freezing when
+ Intel WiFi Link 5150AGN - connection broken or freezing when
transferring large files

After -22 or -23 kernel updatre for Lucid I can not reproduce this bug anymore. Looks like already fixed.

summary: - Intel WiFi Link 5150AGN - connection broken or freezing when
+ Intel WiFi Link 5150ABG - connection broken or freezing when
transferring large files
Changed in linux (Ubuntu):
status: New → Fix Released
Changed in linux:
status: Unknown → Fix Released
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.