Ubuntu

[lucid] Blank screen with KMS on Thinkpad X201 with Arrandale (i915)

Reported by Hendrick Musche on 2010-04-03
298
This bug affects 46 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Canonical Hardware Enablement Team
xf86-video-intel
Fix Released
High
Gentoo Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Ubuntu Kernel Team
Nominated for Karmic by Alex Nikolaev
Lucid
Medium
Manoj Iyer
Maverick
Medium
sarthor

Bug Description

Hi all,
On my new Thinkpad X201 with Core i5 and integrated Arrandale graphics with lucid i get a blank screen (no backlight) as soon as the i915 kicks in during boottime. Booting continues, i can hear the loginsound, but the display stays dark. External screen shows a picture, although with wrong resolution. Booting with the i915.modeset=0 results in working graphics, but only X with vesa. I tried several kernel-versions, including karmic livecd and the newest daily build from the kernel mainline ppa, both 2.6.33 and 2.6.34, all to no avail. The only kernel that works is from this ppa (https://launchpad.net/~csurbhi/+archive/karmic-stable) from bug #515246, but I couldn't isolate why. This could be a duplicate of that bug, but it has been marked fixed, but still remains with me.
The problem seems to be that the i915 cannot initialize the internal display properly. Following snip from syslog:

=== SNIP ===
Apr 2 17:22:46 serafina kernel: [ 16.851787] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 16.851843] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 16.851898] [drm:drm_fb_helper_restore] *ERROR* Failed to restore crtc configuration
Apr 2 17:22:46 serafina kernel: [ 16.854711] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 16.854756] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 16.854805] [drm:drm_fb_helper_restore] *ERROR* Failed to restore crtc configuration
Apr 2 17:22:46 serafina kernel: [ 17.027367] iwlagn 0000:02:00.0: loaded firmware version 9.176.4.1
Apr 2 17:22:46 serafina kernel: [ 17.112490] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.112542] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina bluetoothd[911]: Bluetooth daemon 4.60
Apr 2 17:22:46 serafina kernel: [ 17.130898] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.130903] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 17.135584] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.135591] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina bluetoothd[1184]: Starting SDP server
Apr 2 17:22:46 serafina kernel: [ 17.150923] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.150929] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 17.156446] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.156451] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 17.170953] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.170959] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 17.175573] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.175579] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 17.192107] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.192113] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 17.196464] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.196469] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 17.209264] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.209269] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 17.213608] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.213613] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 17.226658] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.226663] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
Apr 2 17:22:46 serafina kernel: [ 17.231147] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Apr 2 17:22:46 serafina kernel: [ 17.231152] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
=== SNIP ===

Eager to help here, but I'm out of options. Please state if you need more info from me, thx.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-19-generic 2.6.32-19.28
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-14.22+lid945gm-generic
Uname: Linux 2.6.32-14-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: hmu 1537 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf2520000 irq 17'
   Mixer name : 'Intel G45 DEVIBX'
   Components : 'HDA:14f15069,17aa2155,00100302 HDA:80862804,17aa21b5,00100000'
   Controls : 10
   Simple ctrls : 5
Date: Sat Apr 3 14:01:53 2010
HibernationDevice: RESUME=UUID=a3aa395d-ec8f-4843-9f13-6fa5262ad28d
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
MachineType: LENOVO 3626W15
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-14-generic root=UUID=1de2f719-73e0-41a7-bffb-2173f46dbe05 ro quiet splash
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.33
SourcePackage: linux
dmi.bios.date: 01/26/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET35WW (1.05 )
dmi.board.name: 3626W15
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET35WW(1.05):bd01/26/2010:svnLENOVO:pn3626W15:pvrThinkPadX201:rvnLENOVO:rn3626W15:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3626W15
dmi.product.version: ThinkPad X201
dmi.sys.vendor: LENOVO

Hendrick Musche (hmu) wrote :
Allan Day (allanday) wrote :

I'm experiencing the exact same thing. New x201, everything works, but nothing is displayed on screen.

Greg Rayburn (greg-motava) wrote :

Same here, get the black screen when booting up. Lenovo X201, although for me the only kernel that works currently on Lucid is 2.6.32-14. Anything newer than that and I get no graphics.

Allan Day (allanday) wrote :

I'm still experiencing this bug. A few more details: I've tried a number of Lucid dailys as well as the recent beta 2. I've also tried Karmic and Fedora 12. They all have the same problem. (This is on an x201 with an i5.)

The problem itself: a blank laptop screen. Everything seems to work fine(ish) apart from that. Login comes up as normal, and I can use an external monitor. I get the following error message:

[drm: intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
[drm: drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc f426800

Needless to say, I'm anxious to get this working!

Hendrick Musche (hmu) wrote :

Ok, if 2.6.32-14 is the last working kernel version, I tried to find out the changes to -15. One line related to Ironlake (the GPU integrated in the Core i5) is this in upstream kernel changes:

* drm/i915: disable hotplug detect before Ironlake CRT detect

Corresponding patch is available at http://lwn.net/Articles/375436/. IANAKernelHacker, but my guess is its got something to do with this.

Hendrick Musche (hmu) wrote :

Just FYI, the problem persists with linux-image-2.6.23-20, at least for me.

Greg Rayburn (greg-motava) wrote :

Just tried 2.6.32-21 and the problem is still there.

This means that people like me that want to install Ubuntu 10.04 RC on their X201 need to specify "xforcevesa i915.modeset=0" at the boot command line for the installer, then in grub for the first boot, and finally edit /etc/default/grub to make the change permanent.

Jonathon James (isamaranga) wrote :

I can confirm that the screen of my X201 remains blank when trying to install and boot Ubuntu 10.04 RC. The workaround suggested by Dennis Stone works for me, although I cannot enable visual effects (an admittedly small caveat). Hopefully this will get resolved soon.

Jonathon James (isamaranga) wrote :

I almost forgot: my kernel version is 2.6.32-32.32

Jonathon James (isamaranga) wrote :

^^^ wrong version - should be: 2.6.32-21.32

Jeremy Foshee (jeremyfoshee) wrote :

Hi Hendrick,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jonathon James (isamaranga) wrote :

Not sure if this is helpful, but in the course of my experiments, I've discovered that I only need to add "i915.modeset=0" to the boot line in order get graphics. The "xforcevesa" option is not necessary for me.

Greg Rayburn (greg-motava) wrote :

Tried Mainline version: linux-headers-2.6.34-999-generic_2.6.34-999.201004281008_i386.deb & linux-headers-2.6.34-999_2.6.34-999.201004281008_all.deb

But problem is, it won't boot up now, just sits there with a flashing cursor in the upper left corner.

Hendrick Musche (hmu) wrote :

@jeremyfoshee
just tried the daily version from the ppa (2.6.34-999.201004281008), no change. Sorry for the question, but do i remove the needs-upstream-testing tag anyway?

Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
tags: removed: needs-upstream-testing
Jonathon James (isamaranga) wrote :

Just updated to 2.6.32-22 from lucid-proposed and the bug persists.

S Johnsen (ubuntubugs9901) wrote :

Hi,
Had the same problem with my new X201 (core i5), but managed to get a working 9.10 setup, that is everything including the eye-candy works, with these instructions:
http://www.linwik.com/wiki/using+the+intel+arrandale+intel+graphics+media+accelerator+hd+with+ubuntu+9.10

HTH

Jonathon James (isamaranga) wrote :

@ Stian Flage Johnsen,
The newest xorg packages and mainline kernel (either 2.6.32 or 2.6.33) do not solve this issue for me in Ubuntu 10.04. Still need to boot with i915.modeset=0 to get graphics.

rampage (gfoster9055) wrote :

I have a Toshiba Satellite A505-S6020, 9.10 installs ok basic graphic, NVIDIA drivers install fine. I straight 10.4 install gets me the black screen (no back light either) before the grub menu comes up. I have the i5 with 310M graphics, will help with anything i can, I would love to run 10.4 and get the other issues fixed also.

Andy Whitcroft (apw) on 2010-05-05
tags: added: lucid-kms
Andy Whitcroft (apw) wrote :

@rampage -- you mention an NVIDIA chipset for your issue, this bug is specifically about Intel graphics and so you must have a separate bug. Please could you file a new one with ubuntu-bug linux. Thanks.

Andy Whitcroft (apw) wrote :

@Hendrick -- could we get a dmesg from a 'boot to black' 'KMS enabled' boot from your system with -proposed enabled and the -22.33 kernel or later installed please. The original dmesg is somewhat old and predates the update to DRM .33. Thanks a lot!

Changed in linux (Ubuntu):
assignee: nobody → Steve Conklin (sconklin)
Andrew Bortz (abortz) wrote :

I also have a Thinkpad X201, with the same problem, with the same dmesg output as earlier in the thread. In an attempt to isolate the problem, I tried the following kernel versions:

mainline 2.6.32.9 -- works
mainline 2.6.32.12 -- works
ubuntu 2.6.32-14.20 -- works
ubuntu 2.6.32-15.22 -- works
mainline 2.6.33.1 -- doesn't work
ubuntu 2.6.32-16.25 -- doesn't work
ubuntu 2.6.32-22.33 -- doesn't work
mainline edge -- doesn't work

Turns out -14.20 wasn't the last ubuntu kernel to work. I wasn't able to get my hands on debs for ubuntu 2.6.32-16.23, but I suspect it wouldn't work as well. Looking at all the changelogs, all this points to the update to DRM .33 as the culprit. But that is a big patch, and I'm totally out of my league. Help?

Jonathon James (isamaranga) wrote :

@Andrew Bortz, where do you find the old ubuntu kernel versions?

Martin Th. (ma-th) wrote :

@ Jonathon James: http://kernel.ubuntu.com/~kernel-ppa/mainline/
Anything new here? I've also tried 2.6.34 RC6. Didn't work out...

Hendrick Musche (hmu) wrote :

@andy whitcroft: sorry, i'm currently on a three month vacation and have no means to ssh to my machine to get the dmesg output. Maybe someone else here can help?

Stefan Gold (stefan-gold) wrote :

Hi,
here are my dmesg from a 'boot to black' 'KMS enabled' boot of the latest lucid 2.6.32-22-generic kernel and the latest 2.6.34-rc7 mainline kernel.

The problem occurs on my X201 with those kernels too. Btw, I'm using the recent BIOS 1.14-1.08/1.08 from Lenovo, released 2010/04/23.

Steve Conklin (sconklin) wrote :

It appears that the following upstream patch may be the fix:

b91ad0ec52770dcb622b94fc1f57e076686f427a drm/i915: Rework DPLL calculation parameters for Ironlake

Here's an upstream mailing list thread about it:
http://markmail.org/message/4yq3ejcke7uhe63i#query:+page:1+mid:ljfvjcr7or7yrd6n+state:results

I'll have a look and see about getting it into a test kernel, I'm busy at UDS this week

Steve Conklin (sconklin) wrote :

The patch above is already in the tree as part of the .33 drm backport, so I'll continue to investigate

Steve Conklin (sconklin) wrote :

This red hat bug no longer applies as it is now being used to track a network card issue.

Changed in linux (Fedora):
importance: Unknown → Undecided
status: Unknown → New
Steve Conklin (sconklin) on 2010-05-13
Changed in linux (Fedora):
status: New → Invalid
tags: added: patch
1 comments hidden view all 149 comments
mabawsa (mabawsa) wrote :

I am awaiting delivery of an X201 and wondered if anybody has tried the following ppa?

https://launchpad.net/~glasen/+archive/intel-driver

mabawsa, it doesn't work:(

Stefan Gold (stefan-gold) wrote :

I've tried a self-compiled 2.6.33.4 vanilla kernel, in which I assume the patch from #27 is already included (Please correct me if not!!!). Unfortunately, that approach hasn't solved the problem yet.

Jeffrey Baker (jwbaker) wrote :

The supposed workaround hard locks my laptop with a flashing caps lock LED, with or without xforcevesa.

Mubes (dave-marples) wrote :

Datapoint; With latest X201 BIOS (BIOS: 1.14 / ECP: 1.08/1.08) from lenovo I can get i915 driver working on the external display by removing the modeset and vesa elements from the kernel command line. I also get full effects etc. and i915 is in use according to lsmod. This is using 'stock' 64 bit 2.6.32-22 generic kernel. I cannot get any display on the LCD panel at all, although It will wake up the backlight if I try to switch on both screens.

This new BIOS has improved a few items - I understand that the ACPI is now more stable and certainly the display on the external (4x3) monitor 'fits' a lot better than it did before.

Not sure it's much use, but just in case....

DAVE

Eshat Cakar (eshat) wrote :

Same issue here on the Debian (sid) side using a X201 with latest BIOS from 23 Apirl.
I get same blinking CapsLock and freeze as Jeffrey Baker described.
Also I would like to add, that the blank screen remains with kernel 2.6.34-1-adm64 (from experimental and a self compiled one).

Booted with an external monitor connected (which works with wrong resolution, as mentioned above) my syslog says:

May 21 12:57:04 xoi kernel: [ 15.925841] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
May 21 12:57:04 xoi kernel: [ 15.925848] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff880133b79000
May 21 12:57:04 xoi acpid: client connected from 2128[0:0]
May 21 12:57:04 xoi acpid: 1 client rule loaded
May 21 12:57:04 xoi kernel: [ 16.126466] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
May 21 12:57:04 xoi kernel: [ 16.126474] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff880133b79000
May 21 12:57:04 xoi kernel: [ 16.126480] [drm:drm_fb_helper_restore] *ERROR* Failed to restore crtc configuration
May 21 12:57:05 xoi kernel: [ 16.727165] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
May 21 12:57:05 xoi kernel: [ 16.727173] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff880133b79000

aleij (alejoduque) wrote :

anyone knows if the kernels from this PPA:
http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=M;O=D
will fix our video card problem?

I tried a 2.6.34 kernel from that repo and it didn't help at all.

On Fri, May 21, 2010 at 7:34 AM, aleij <email address hidden> wrote:
> anyone knows if the kernels from this PPA:
> http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=M;O=D
> will fix our video card problem?
>
> --
> [lucid] Blank screen with KMS on Thinkpad X201 with Arrandale (i915)
> https://bugs.launchpad.net/bugs/554569
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Jeffrey Baker (jwbaker) wrote :

In the Xorg bug I linked here, there is a proposed one-line patch that some commenters report has worked for them on a X201, although others say it doesn't. Still others report that BIOS updates fix the problem (didn't help me).

I can confirm that the following patch solves the bug for me (X201, latest bios version 1.14, patch applied to the offical 10.04 kernel 2.6.32-22)

+++ intel_display.c
        bool found;
        /* approximately equals target * 0.00488 */
        int err_most = (target >> 8) + (target >> 10);
+ err_most += 50;
        found = false;

        if (intel_pipe_has_type(crtc, INTEL_OUTPUT_LVDS)) {

Changed in oem-priority:
importance: Undecided → High
Hugh Blemings (hughhalf) on 2010-06-15
Changed in oem-priority:
assignee: nobody → Haitao Zhang (minipanda)
Jerone Young (jerone) on 2010-06-27
Changed in oem-priority:
status: New → Confirmed
Changed in gentoo:
status: Unknown → Confirmed
Martin Pitt (pitti) on 2010-07-22
Changed in linux (Ubuntu Lucid):
milestone: none → ubuntu-10.04.1
importance: Undecided → Medium
Changed in linux (Ubuntu Lucid):
milestone: ubuntu-10.04.1 → ubuntu-10.04.2
Changed in gentoo:
status: Confirmed → Fix Released
Manoj Iyer (manjo) on 2010-08-03
Changed in linux (Ubuntu Lucid):
assignee: nobody → Manoj Iyer (manjo)
status: New → Incomplete
69 comments hidden view all 149 comments
Manoj Iyer (manjo) wrote :

Ray Wong: x86 kernel is uploaded in the same location.

Thomas: Thanks a ton for the quick test. I will SRU that patch asap.

Mark (mark-wege) wrote :

Which patch is the kernel using? I want to compile a kernel with pae support.

Manoj Iyer (manjo) wrote :

SRU JUSTFICATION
================
This patch fixes the issue with Thinkpad X201 with Arrandale (i915), it is
a critical patch needed to enable Thinkpad X201.

Steve Conklin (sconklin) on 2010-08-03
Changed in linux (Ubuntu Lucid):
status: Incomplete → Fix Committed

Fix from #110 does NOT work for me on my X201 :-( Happy to provide xorg.0.log and any other info you request.

Noufal Ibrahim (noufal) wrote :

I have an X201 (with the Arrandale chip and and an i5) and I tested the kernel in #107. It boots up okay but for some reason my trackpoint (and it's buttons) stops functioning (the trackpad and it's buttons work fine).

However, http://people.canonical.com/~hzhang/554569/linux-image-2.6.32-24-generic_2.6.32-24.39_amd64.deb seems to work just fine.

Just tested the trackpoint with kernel from #107 (I usually never use it): it works fine on my X201 i5.

Tested the kernel from #107 on my X201. Does not work!!! Same problem as posted in #102. Blinking cursor but brightness keys are working...

Whats the problem with this **** ******* bug???

Cima (andrea-cimatoribus) wrote :

I tested the 32bit kernel of #107 on an i5 Arrendale, and it doesn't fix the problem, it's exactly as before.

Lukas Svoboda (svoboda77) wrote :

64bit kernel from post #107 works for me.

Lukas Svoboda (svoboda77) wrote :

Kernel headers from post #107 are also OK, I was able to compile the latest VirtualBox kernel module against it.

Seif Lotfy (seif) on 2010-08-07
description: updated
Seif Lotfy (seif) wrote :

linux-image-2.6.32-24-generic is not working for me. I used the deb suggested from 107 however they get overwritten by the latest update 2.6.32-24.39. Any newer debs?

I'm using the subnotebook Lenovo U160 which has the same problem described in this bug. I also tried the kernel from #107 but it doesn't help to fix the problem here.

Eshat Cakar (eshat) wrote :

The latest kernel in Debian Unstable which is 2.6.32-19 works perfectly for me.
Anyone tried the official 2.6.35 vanilla kernel ?

Jens Georg (yg-jensge) wrote :

vanilla 2.6.35 from ubuntu mainline stuff works, but the graphics performance feels sluggish; probably one needs a matching X driver and libdrm

n8han (nathan-technically) wrote :

re: #122 I'm also not seeing any improvement with the updated kernel, on a Lenovo U160. There are two bugs open for blank screens on this model, bug #608907 and bug #610369

Chris Van Hoof (vanhoof) on 2010-08-12
Changed in oem-priority:
assignee: Haitao Zhang (minipanda) → Canonical Hardware Enablement Team (canonical-hwe-team)
status: Confirmed → Fix Committed

It appears the patch in question is now officially upstream and included in the upstream v2.6.35 kernel:

linux-2.6$ git describe --contains 6ba770dc5c334aff1c055c8728d34656e0f091e2
v2.6.35~33^2~9

commit 6ba770dc5c334aff1c055c8728d34656e0f091e2
Author: Adam Jackson <email address hidden>
Date: Fri Jul 2 16:43:30 2010 -0400

    drm/i915: Make G4X-style PLL search more permissive

Since Maverick has already been rebased on top of upstream v2.6.35, it subsequently already contains this patch. I'm therefore marking the Maverick linux task as Fix Released. The Lucid task still remains open and going through the SRU process.

Changed in linux (Ubuntu Maverick):
status: Triaged → Fix Released
Changed in linux (Ubuntu Maverick):
milestone: none → ubuntu-10.10-beta
Martin Th. (ma-th) wrote :

I use this now on my x201: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35.2-maverick/

it works. booting with 2nd monitor on vga output or removing monitor during operation causes trouble. but plugging in after boot seems to work

yeah nice one...finally #127 works for me!

edit:

worked for me!!!!!!! terrible thing happend, after trying the X201 with docking station xserver could not start,
even without docking station no graphic appears since xserver error is somethin about:

(EE) intel(o): No kernel modesetting driver detected.
(EE) Screens(s) found, but none have a usable configuration.
Fatal server error: no screens found

What the **** is the problem here....I donnt know if I should either cry or destroy the laptop for gods sake...

edit:

working now quiet good every 20th startup or so. the 19 times before that every time a different error occurs. sometimes even the blank screen appeared again. other times the touchpad did not start and therefore xserver stopped.

might be because of the maverick alpha version?

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Lucid):
status: Fix Released → Fix Committed
Cima (andrea-cimatoribus) wrote :

On my machine I don't really want to test an alpha release of a kernel, but I gave a try to #127. It doesn't boot on my laptop (core i5 540), but I think that's not connected with graphics but something else. Anyway, the good thing is that I can see the normal splash screen, so the screen doesn't go blank after grub. There is hope...

Download full text (8.5 KiB)

I've updated my Lucid Installation to the latest Maverick alpha and
downloaded the newest packages. This *does not* help for me. The boot
splash shows up after grub but the screen still goes blank after a
fraction of a second.

I have a Lenovo U160 with Core i7 920.

2010/8/20 Cima <email address hidden>:
> On my machine I don't really want to test an alpha release of a kernel,
> but I gave a try to #127. It doesn't boot on my laptop (core i5 540),
> but I think that's not connected with graphics but something else.
> Anyway, the good thing is that I can see the normal splash screen, so
> the screen doesn't go blank after grub. There is hope...
>
> --
> [lucid] Blank screen with KMS on Thinkpad X201 with Arrandale (i915)
> https://bugs.launchpad.net/bugs/554569
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in OEM Priority Project: Fix Committed
> Status in X.org xf86-video-intel: Unknown
> Status in “linux” package in Ubuntu: Fix Released
> Status in “linux” source package in Lucid: Fix Committed
> Status in “linux” source package in Maverick: Fix Released
> Status in “linux” package in Fedora: Invalid
> Status in Gentoo Linux: Fix Released
>
> Bug description:
> Hi all,
> On my new Thinkpad X201 with Core i5 and integrated Arrandale graphics with lucid i get a blank screen (no backlight) as soon as the i915 kicks in during boottime. Booting continues, i can hear the loginsound, but the display stays dark. External screen shows a picture, although with wrong resolution. Booting with the i915.modeset=0 results in working graphics, but only X with vesa. I tried several kernel-versions, including karmic livecd and the newest daily build from the kernel mainline ppa, both 2.6.33 and 2.6.34, all to no avail. The only kernel that works is from this ppa (https://launchpad.net/~csurbhi/+archive/karmic-stable) from bug #515246, but I couldn't isolate why. This could be a duplicate of that bug, but it has been marked fixed, but still remains with me.
> The problem seems to be that the i915 cannot initialize the internal display properly. Following snip from syslog:
>
> === SNIP ===
> Apr  2 17:22:46 serafina kernel: [   16.851787] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
> Apr  2 17:22:46 serafina kernel: [   16.851843] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
> Apr  2 17:22:46 serafina kernel: [   16.851898] [drm:drm_fb_helper_restore] *ERROR* Failed to restore crtc configuration
> Apr  2 17:22:46 serafina kernel: [   16.854711] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
> Apr  2 17:22:46 serafina kernel: [   16.854756] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88011faa2000
> Apr  2 17:22:46 serafina kernel: [   16.854805] [drm:drm_fb_helper_restore] *ERROR* Failed to restore crtc configuration
> Apr  2 17:22:46 serafina kernel: [   17.027367] iwlagn 0000:02:00.0: loaded firmware version 9.176.4.1
> Apr  2 17:22:46 serafina kernel: [   17.112490] [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
> Apr  2 17:22:46 serafina kernel: [   17.112542] ...

Read more...

Jerone Young (jerone) wrote :

@Gregor

Can you file a new bug for the Lenovo U160 and paste the link here .. make sure to include Xorg log so folks know the screen. Also try the latest daily build of 10.10 here: http://cdimage.ubuntu.com/daily-live/current/

Please do not update this bug with Lenovo U160 problems. It is for the Thinkpad X201.

Jerone Young (jerone) wrote :

@Gregor Müllegger

Add information to this bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/608907

glabeliol (akinstur) wrote :

Got the workaround proposed in #8 working using these instructions. This workaround was originally giving me a hard freeze with flashing capslock, but this seems to fix it:

http://ubuntuforums.org/showthread.php?p=9752385

Martin Th. (ma-th) wrote :

Wake-up from stand-by is not possible anymore with
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.36-rc3-maverick/
Screen remains black.

matt s (matt-smalley) wrote :

Have a brand new i5 540-based x201 and encountered this issue with 10.04 x86_64. #107 is working for me as well. After deb install and reboot X would not start though:

  (EE) VESA: Kernel modesetting driver in use, refusing to load
  (EE) No devices detected

Restarting X and removing /etc/X11/xorg.conf seemed to take care of it. Found the fix here:

  http://ubuntuforums.org/showthread.php?t=1497063

Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: Unknown → Fix Released

FWIW, I took the Maverick Kubuntu amd64 10.10 beta live CD for a spin today, and everything seemed to work beautifully.

Martin Th. (ma-th) wrote :

hi dave, have you tested the analog video out with a 2nd display?

Yep - works!

On Wed, 15 Sep 2010 at 17:47:19 you wrote:
> hi dave, have you tested the analog video out with a 2nd display?
>
>
--
Dave Moskovitz
Director, Thinktank Consulting Limited
<email address hidden> / Tel +64 27 220 2202
Twitter: @davemosk Calendar: http://dave.moskovitz.co.nz/calendar

Martin Th. (ma-th) wrote :

i installed the beta and i still have the problem with a second monitor, when it is plugged in during boot. when plugging in after the start up, it works most of the time. also laptop display brightness goes down...

Well, the latest production kernel, 2.6.32-25-generic-pae seems to fix everything on my X201, so long as /etc/X11/xorg.conf has been either moved or deleted. W00t! It's only taken six months, but I guess it was worth the wait to have a laptop I can use with a projector :-)

Finally!!!
I tried the same kernel (2.6.32-25-generic) and graphics is now working perfect, even brightness control.
Did not try external monitor, but will do soon.

Royce (huroyce) on 2010-10-02
Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Jobo (arkazon) wrote :

Hate to disappoint, but 2.6.32-25 (64-bit) still doesn't work properly on my X201 3249-CTO.

As before, I have to run with i915.modeset=0 and the vesa driver, or I get a hard freeze on boot.

Now I find I need xvideo, though, which vesa doesn't have. Any idea what I can do to help?

Jobo (arkazon) wrote :

I was running 1.17. Just updated to the latest version (1.22). Now it works if I specify i915.modeset=1 on the grub command line. Thank you!

Hooman (hooman118) wrote :

I just installed 10.10 (64-bit) on my X201 3249-39C and experienced this black screen dead.
My BIOS just updated to 1.22, and the kernerl was 2.6.35-22-generic.

I have to specify i915.modeset=0 to login into tty1.
But no graphic appears since xserver error is somethin about:

(EE) open /dev/fb0: No such file or directory
(EE) intel(0): No kernel modesetting driver detected.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Hooman (hooman118) wrote :

BTW, live CD and graphics installation works fine. It's strange.
Should I try 32bit kernel?

rgrover1@gmail.com (rgrover1) wrote :

I upgraded to 10.10 (64-bit) on my X201. I then deleted my /etc/X11/xorg.conf. Now I can boot correctly without needing the i915.modeset=0 boot parameter. Brightness controls also work correctly.

Chris Van Hoof (vanhoof) on 2010-11-08
Changed in oem-priority:
status: Fix Committed → Fix Released
sarthor (sarthor) on 2010-12-24
Changed in linux (Ubuntu Maverick):
assignee: Steve Conklin (sconklin) → sarthor (sarthor)
Steve Conklin (sconklin) on 2011-01-03
Changed in linux (Ubuntu):
assignee: Steve Conklin (sconklin) → Ubuntu Kernel Team (ubuntu-kernel-team)
Changed in xserver-xorg-video-intel:
importance: High → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → High
Changed in gentoo:
importance: Unknown → Medium
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: linux (Fedora)
Displaying first 40 and last 40 comments. View all 149 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.