Ubuntu

Dell Studio 155x hang on resume from suspend (SCI_EN)

Reported by Kamal Mostafa on 2010-04-01
108
This bug affects 16 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Kamal Mostafa
Lucid
High
Unassigned
Maverick
High
Kamal Mostafa

Bug Description

Dell Studio 1558 laptop (Core i5 Arrandale)

System hangs on resume from suspend (using gui menu to suspend, and power button to resume -- not a lid-related problem). On resume, screen remains black (not lit) and fan is stuck ON. Machine appears completely hung (fan normally runs only intermittently, cannot ssh in, no response to Ctrl-Alt-Fx, no response to CD eject).

Problem occurs in these kernels:
Lucid 2.6.32-19-generic #28~pre1 x86_64
Lucid 2.6.32-18-generic #27-Ubuntu x86_64
Lucid 2.6.32-16-generic (something) x86_64

Booting with 'notsc' does not affect the problem. Booting with 'mem=nopentium' causes panic (LP: #553464).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-18-generic 2.6.32-18.27
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kamal 1503 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0a00000 irq 22'
   Mixer name : 'Intel G45 DEVIBX'
   Components : 'HDA:111d7675,10280413,00100103 HDA:80862804,80860101,00100000'
   Controls : 22
   Simple ctrls : 13
Date: Thu Apr 1 11:49:49 2010
HibernationDevice: RESUME=UUID=e4c5fd19-ee8c-4877-9ab4-cb3d05e19cdf
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
Lsusb:
 Bus 002 Device 002: ID 8087:0020
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 0c45:6417 Microdia
 Bus 001 Device 002: ID 8087:0020
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Studio 1558
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-18-generic root=UUID=69a30c9b-1d3d-4e80-9e38-f712c55aeae8 ro
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.33
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
dmi.bios.date: 03/11/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0G939P
dmi.board.vendor: Dell Inc.
dmi.board.version: A04
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A04
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd03/11/2010:svnDellInc.:pnStudio1558:pvrA04:rvnDellInc.:rn0G939P:rvrA04:cvnDellInc.:ct8:cvrA04:
dmi.product.name: Studio 1558
dmi.product.version: A04
dmi.sys.vendor: Dell Inc.

Kamal Mostafa (kamalmostafa) wrote :
Kamal Mostafa (kamalmostafa) wrote :

Note similar bug report LP: #532874.

Kamal Mostafa (kamalmostafa) wrote :

Followed procedure https://wiki.ubuntu.com/DebuggingKernelSuspend but not sure if it actually worked properly or not. dmesg result attached. Note that it contains this:

   PM: Resume from disk failed
   Magic number ... acpi device:0f: hash matches

lspci | grep 0f yields nothing.

Changed in linux (Ubuntu):
assignee: nobody → Kamal Mostafa (kamalmostafa)
status: New → In Progress
Andy Ross (andy-plausible) wrote :

Confirmed on a pretty much identical system (these are both Dell 1558's configured without the discrete GPU parts and with the Intel 6200 wireless option). Same symptoms.

Kamal Mostafa (kamalmostafa) wrote :

I have developed a test fix for this problem. It reliably fixes suspend/resume on my Dell Studio 1558 and should have the same effect for the Studio 1557 and Studio 1555 models. No other models are affected by this change. The fix is currently being reviewed for a post-Lucid release update (but will not be included in Lucid at release time).

@Andy and other testers...

A test kernel including the fix (as well as the source patch itself) are available here:
    http://kernel.ubuntu.com/~kamal/dell_155x_resume/
To install this kernel, download the two .deb files and install them using
    sudo dpkg -i *kamal*.deb

Feedback to this bug report will be much appreciated.

Andy Ross (andy-plausible) wrote :

Kamal: works perfectly. Many thanks. You who brave the rats nest of ACPI conformance have my eternal respect and gratitude.

Andy Whitcroft (apw) on 2010-04-22
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: In Progress → Fix Committed
Kevin Hester (kevinh) wrote :

Thank you for this patch. I applied it to my own Lucid sources and my new laptop is now much happier. I hope it gets released officially soon. (I was on a Dell 1558 with an i3)

Andy Ross (andy-plausible) wrote :

This patch seems not to have made it into the 2.6.32-22 kernel just released. Is there something more that needs to be done?

Kamal Mostafa (kamalmostafa) wrote :

@Andy and other testers: I'm not sure why this didn't make it into 2.6.32-22.33. But it appears that it is staged for release in 2.6.32-22.34 and a pre-release version of that is available in this PPA:

   https://launchpad.net/~kernel-ppa/+archive/pre-proposed?field.series_filter=lucid

Thanks for your continued ongoing assistance folks.

Tabor Kelly (taborkelly) wrote :

Kamal,

I just installed the PPA. You don't know how happy you made me. I don't think I have ever had a laptop where all the hardware worked perfectly on linux until this evening. Thank You.

gavin (gavinewin) wrote :

I have been so frustrated with my Dell Latitude D430's inability to suspend (bug 474949 and many others if you do a search on Dell Suspend) I thought I would give this new kernel 2.6.32-22.34 a go because the problems with the Dell Studio described above seem so similar to mine. Alas, the kernel install fine but the suspend problem will Dell Latitude D430's still exists. I love the new Lucid environment but a notebook without suspend on lid close is very frustrating

madbiologist (me-again) wrote :

This fix has also been included upstream in kernel 2.6.34-rc7. From the changelog:

commit ea5bc73f4f56449b2d450068d492bcd17a675d7a
Author: Kamal Mostafa
Date: Tue Apr 27 14:02:40 2010 -0700

    ACPI: sleep: init_set_sci_en_on_resume for Dell Studio 155x

    Add Dell Studio models (1558, 1557, 1555) to the 'set_sci_en_on_resume'
    list to fix hang on resume.

    BugLink: http://bugs.launchpad.net/bugs/553498

    Signed-off-by: Kamal Mostafa
    Acked-by: Alex Chiang
    Cc: <email address hidden>
    Signed-off-by: Len Brown

I've exactly the same suspend problem on a Latitude E6410. I'm dowloading the pre-proposed kernel to test it.

Kamal Mostafa (kamalmostafa) wrote :

Hi folks. Please be aware that the patched kernels referenced in all the comments above will NOT have any effect on other machines, even if they seem to be experience the exact same problem. The patch works by identifying the actual model names "Dell Studio 1558" and "Dell Studio 1557" and "Dell Studio 1555" and only activates when it matches one of those.

Note, however, that further discussion upstream suggests that we will likely be shipping a much more general version of this fix in the near future. I will endeavor to produce a more general version of the fix also in the short term, so that others experiencing what appears to be the same problem can "manually" switch on the behavior. Stay tuned to this bug for further details.

Kamal, really thanks!

I have already tested the kernel pre-proposed image with no luck (as you have advised).

As long as i'm not sure that this is my problem, yesterday, i opened a bug #578673.

Any help to fix the issue on a Latitude E6410 would be really nice! :-)

madbiologist (me-again) wrote :

Good news - the patch mentioned in comments #9 and #12 is being reviewed upstream for kernel 2.6.32.13-stable.

Changed in linux (Ubuntu):
status: Fix Committed → In Progress
Kamal Mostafa (kamalmostafa) wrote :

I have built a test kernel for Ubuntu 10.04 LTS which includes the PRELIMINARY TEST patch (written by Matthew Garrett) that enables this suspend/resume fix on any machine (I.e. this variant no longer only activates on certain machines as I described in comment #14, nor does it require any sort of manual switch to enable it). Users experiencing a hang on resume (as described above) are welcome to try this kernel. Feedback to this bug report will be much appreciated -- if you try this test kernel ** whether or not it fixes resume ** please post your result here along with the BIOS Information (Vendor and Version) as shown by "sudo dmidecode".

The test kernel including JUST the fix described above (as well as the source patch itself) is available here:
    http://kernel.ubuntu.com/~kamal/scien
To install this kernel, download the two .deb files and install them using
    sudo dpkg -i *kamal*.deb

*** Note for Dell Studio 155x users (or others with brightness keys problems and i915-based graphics) ***
I have also built an alternate test kernel which includes the fix described above, plus the fix for LP: 568611 (brightness keys):
    http://kernel.ubuntu.com/~kamal/scien+i915bri/

summary: - Dell Studio 1558 (Arrandale) hangs on resume from suspend
+ Various machines hang on resume from suspend (SCI_EN)

Kernel 2.6.32.13 has been released upstream. The abovementioned patch has been included. Now we just have to wait for this to appear in a Lucid kernel update.

Changed in linux (Ubuntu):
importance: Medium → Critical
gavin (gavinewin) wrote :

I look forward to testing this patch, although I am a bit confused trying to follow this thread. Madbiologist are you saying the generic fix described by Kamal is included in 2.6.32.13 if so thanks for all the great work getting this implemented. I will test when it gets to ppa

madbiologist (me-again) wrote :

I'm referring to the fix written by Kamal and described in comment 12.

Matthew Garrett's fix is probably the best way forward as it works on any machine. Kamal has also built a test kernel with this generic fix, as described in comment 17. Matthew's patch will probably be included in kernel 2.6.35 - we will have to wait and see if it is backported to any earlier kernels. If you are unable to use Kamal's test kernel, just boot with the acpi_sleep=sci_force_enable parameter which has also been added to kernel 2.6.32.13 thanks to a mainline kernel commit from Zhang Rui.

Any thanks should go to Kamal, Matthew, Zhang and to Greg Kroah-Hartman (Greg is from Novell's SUSE team and lead the review process for the patches proposed for the stable kernel branch). I haven't done anything except a little research.

gavin (gavinewin) wrote :

Thanks for the reply, I tried setting acpi_sleep=sci_force_enable and it didn't fix the problem on the D430. I actually realized I have been barking up the wrong tree. The problem was not coming out of suspend but actually suspending. On further searching I found the Dell mini has the same problem. I found if I unmount the SD card the D430 suspends properly and comes back fine. Now I need to find how to fix the SD card problem. No need to put the Dell D430 on the blacklist for this bug.

I has also tested "acpi_sleep=sci_force" parameter but i get the same result.

I've also tried the same kernel that is posted on #17 but for 386 (kamal has just posted on comment #27 on bug #578673).

If you need any log, just ping me! :-)

Sorry, i've realized that i didn't tell that the kernel (rebuild for 386) is not working for my laptop, i'm having the same problem.

spinlock (andrew-d-dixon) wrote :

Hi everyone. I am experiencing this problem on a Dell Inspiron 600m. I have tried to install the generic fix referenced in comment #17, however, I get the following error when I try to install the deb:

>spinlock@sendak:~/Downloads$ sudo dpkg -i *kamal*.deb
>[sudo] password for spinlock:
>dpkg: error processing linux-headers-2.6.32-22-generic_2.6.32-22.34~kamal~scien_amd64.deb (-->install):
> package architecture (amd64) does not match system (i386)
>dpkg: error processing linux-image-2.6.32-22-generic_2.6.32-22.34~kamal~scien_amd64.deb (-->install):
> package architecture (amd64) does not match system (i386)
>Errors were encountered while processing:
> linux-headers-2.6.32-22-generic_2.6.32-22.34~kamal~scien_amd64.deb
> linux-image-2.6.32-22-generic_2.6.32-22.34~kamal~scien_amd64.deb

Is there a version of this fix for a generic i386 machine? Thanks.

Kamal Mostafa (kamalmostafa) wrote :

@spinlock- Yes, an i386 build of the "test kernel" is now also available:

I have posted a PPA build of the test kernel that I mentioned in comment #17. The PPA provides both the amd64 and i386 versions of the kernel. This is a test kernel for Ubuntu 10.04 LTS which provides a suspend/resume fix that may fix the "always hangs on resume" problem on Intel Core i5 (and possibly i3 and i7 systems):

https://launchpad.net/~kamalmostafa/+archive/linux-kamal-scien

Feedback will be much appreciated.

spinlock (andrew-d-dixon) wrote :

@kamal - Thanks for all of your hard work on this issue. Unfortunately, it doesn't look like your patch resolves the issue on a Dell Inspiron 600m. After updating my system as described, I still cannot resume from suspend. The disk spins up but the screen does not come back and I have to do a hard reset.

FYI - Just to make sure I have installed the fix correctly, here is the kernel signature from dmesg:

    [ 0.000000] Linux version 2.6.32-22-generic (buildd@einsteinium) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #34~pre201005061001-Ubuntu SMP Thu May 6 18:37:25 UTC 2010 (Ubuntu 2.6.32-22.34~pre201005061001-generic 2.6.32.11+drm33.2)

Should I open a new bug report or continue to use this one?

Thanks

spinlock (andrew-d-dixon) wrote :

OK, I've finally gotten the correct kernel installed:

spinlock@sendak:~$ uname -a
Linux sendak 2.6.32-22-generic #34~kamal~scien-Ubuntu SMP Tue May 18 01:14:38 UTC 2010 i686 GNU/Linux

Unfortunately, my Dell Inspiron 600m continues to hang after suspend.

farw (s-wankerl) wrote :

I am using a Dell Studio 1555 and it doesn't work either with the patched kernel. I'm not sure whether this is important but I'm having an ATI graphic card and I am using the fglrx driver.

Andy Ross (andy-plausible) wrote :

I just installed Kamal's "scien+i915bri" build, and unfortunately the fix has regressed for me also on a Studio 1558. The machine hangs trying to suspend, locks up, and rapidly drains the battery. Note this is a different symptom from the pre-fix kernel, which would suspend, but crash on resume.

Kamal Mostafa (kamalmostafa) wrote :

Folks, I suspect a problem with one or more of the test kernels that I recently produced (sorry for that, I'll sort it out ASAP). We know we had suspend/resume working reliably for the Dell Studio 155x machines using the kernels mentioned in comments #5 and #9.

@farw - You may want to try the kernel from comment #9.

@Andy - What about just the "scien"-only fix from comment #17?: http://kernel.ubuntu.com/~kamal/scien Does that one still fix suspend/resume at least?

People with other machines - it seems likely that you're experiencing bugs caused by a different problem. I recommend filing a separate bug so your specific hardware profile can be tracked and analyzed.

Andy Ross (andy-plausible) wrote :

No luck, both the scien and the scien+i915bri kernels behave the same, and busy-hang during suspend before the backlight is powered down. I'm going to back out to the 2.6.32-21 fix in comment #5 and verify that something else hasn't broken.

Andy Ross (andy-plausible) wrote :

Heh, oops. The used-to-work -21 kernel hangs the same way. It turns out that the configuration change that caused this bug is the presence of a uSD card in the card reader. Take it out and both -21 and scien boot fine (still have to try scien+i915bri, but I'm sure that's fine).

Apologies for the confusion. I'll file a separate bug.

AlexW (alex.wedensky) wrote :

Hi,

Dell Studio 1558, the scien-i915bri kernel -- suspend/resume works, display brightness keys work, wireless (albeit painfully) loads. Thank you for your work Kamal!

Sarah Strong (sarahstrong) wrote :

Dell Studio 1558, i3.

Patch from PPA in comment #25 fixes resume, patch from .debs at http://kernel.ubuntu.com/~kamal/scien+i915bri/ fixes both resume and suspend.

Thanks very much!

Andy Whitcroft (apw) on 2010-05-24
tags: added: kernel-power kernel-reviewed
soren121 (soren121) wrote :

The Dell Latitude D600 has the exact same problem with suspend. It was reported in bug #559163; as this bug seems to have more activity, I've marked 559163 as a duplicate of this one. I'll try the patches tonight and report back. :)

soren121 (soren121) wrote :

I can confirm that the patched kernel from Kamal's PPA does NOT work on the Latitude D600. :(

mxu (xumin100) wrote :

Confirm this bug on Dell Inspiron 1464

Linux mxu-laptop 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

tags: added: cherry-pick
removed: needs-upstream-testing
farw (s-wankerl) wrote :

@Kamal

The kernel posted in comment #9 doesn't work either. Currently, I am using
Linux kubuntu-nb 2.6.32-22-generic #35-Ubuntu SMP Tue Jun 1 14:18:25 UTC 2010 x86_64 GNU/Linux
which isn't working. Maybe it is important to mention, that I am not having an Intel i5 CPU but an Intel Core2Duo P8600. Furthermore, I am using the fglrx driver.

Thanks

Saúl Romero (spacetree) wrote :

2.6.32-22-generic #35-Ubuntu SMP Tue Jun 1 14:18:25 UTC 2010 x86_64 GNU/Linux

Not working for me. Im using a laptop with centrino framework....all is intel.

Thanks

Andy Ross (andy-plausible) wrote :

This fix has regressed (or not been included) in the 2.6.32-33-generic kernel that was just pushed. Any chance of a package respin? Does anything need to happen to make sure it gets included for the next kernel?

Kamal Mostafa (kamalmostafa) wrote :

As noted by Andy, the fix for "Dell Studio 155x hangs on resume" was (again) not included in the official kernel just released. The reason is because the last three kernel releases have been security-fix-only releases (rush jobs) and have not included any of the growing list of patches queued up for the next 'regular' kernel release. No action is needed to make sure this fix gets released (eventually) -- this patch got re-queued automatically and is now available in the latest pre-release PPA kernel.

To summarize:

  The latest released Lucid kernel DOES NOT include this fix: 2.6.32-22-generic #36-Ubuntu

  The pre-release PPA Lucid kernel (#37) DOES include this fix (for "Dell Studio 155x" only):
     https://launchpad.net/~kernel-ppa/+archive/pre-proposed/

Note also that I'm working on custom re-spin build which will also include my "i915 brightness" fix (for non-working brightness keys).

Kamal Mostafa (kamalmostafa) wrote :

Testers, please note:

This particular "hang on resume" fix relates only to a specific problem relating to the SCI_EN bit which seems to be peculiar to Intel Core i3, Core i5, and Core i7 CPU's (such as the Dell Studio 155x line). Systems with other CPU types (even if they experience a hang on resume) are not likely to be affected at all by this fix. Unless you are using a Core i3/i5/i7, you should file a separate bug report so that your hardware information and symptoms can be analyzed and tracked.

summary: - Various machines hang on resume from suspend (SCI_EN)
+ Intel Core i3/i5/i7 hang on resume from suspend (SCI_EN)

Update manager does not offer those packages. Is it possible to
configure that ppa on the server so that when you reference a patch, it
can be accessed via update manager software sources if we have that ppa
listed as a source for lucid main? Thanks.

On 06/04/2010 04:42 PM, Kamal Mostafa wrote:
> As noted by Andy, the fix for "Dell Studio 155x hangs on resume" was
> (again) not included in the official kernel just released. The reason
> is because the last three kernel releases have been security-fix-only
> releases (rush jobs) and have not included any of the growing list of
> patches queued up for the next 'regular' kernel release. No action is
> needed to make sure this fix gets released (eventually) -- this patch
> got re-queued automatically and is now available in the latest pre-
> release PPA kernel.
>
> To summarize:
>
> The latest released Lucid kernel DOES NOT include this fix:
> 2.6.32-22-generic #36-Ubuntu
>
> The pre-release PPA Lucid kernel (#37) DOES include this fix (for "Dell Studio 155x" only):
> https://launchpad.net/~kernel-ppa/+archive/pre-proposed/
>
> Note also that I'm working on custom re-spin build which will also
> include my "i915 brightness" fix (for non-working brightness keys).
>
>

Those of you waiting for this fix to appear in an official Lucid kernel can follow bug #583414 .

@Steve Farthing - That sounds a bit circular. See the section "Adding a Personal Package Archive (PPA)" at https://help.ubuntu.com/10.04/add-applications/C/adding-repos.html and then just use the information on the page that the PPA is listed on (the link in comment #41).

Thanks for the suggestion. Not sure about the circular comment. I have
already reviewed that information and it relies on importing a GPG key
and there is no such animal on the website for the pre-proposed kernels.
So that info does not help in this particular scenario.

FYI - I am running the #36 pre-proposed kernel and interested in getting
the #37 kernel.

The preprosed kernel website has other steps to accomplish the same end
and I've already done those steps with no errors before submitting the
previous post. So we are back to my original question regarding how to
get the updates to be offered in Update Manager once the software source
is successfully added and reloaded? (Now this dialogue IS circular!) So
I am still wondering - Is there something that needs to be done on the
server? Or what?

On 06/05/2010 09:55 PM, madbiologist wrote:
> Those of you waiting for this fix to appear in an official Lucid kernel
> can follow bug #583414 .
>
> @Steve Farthing - That sounds a bit circular. See the section "Adding a
> Personal Package Archive (PPA)" at https://help.ubuntu.com/10.04/add-
> applications/C/adding-repos.html and then just use the information on
> the page that the PPA is listed on (the link in comment #41).
>
>

The fix is part of the update to upstream stable 2.6.32.13 (see Bug #583414).

Changed in linux (Ubuntu Lucid):
importance: Undecided → High
status: New → Fix Committed
Stefan Bader (smb) wrote :

I lowering the importance as critical should be reserved for issues that cause the loss of data. Also Kamal, could you check current Maverick. I would think this should already be released there.

Changed in linux (Ubuntu):
importance: Critical → High
Dominik (dominik-dbruhn) wrote :

What Upstream-Version is it fixed in? I tried the "2.6.34-020634-generic" Kernel from
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-lucid/linux-image-2.6.34-020634-generic_2.6.34-020634_amd64.deb and the bug is still there, shouldn't it be fixed?

Dissenting Opinion - This should remain critical. If the mission is to
offer an OS alternative to Microsoft, then the criticality of defects should
be measured based on their likelihood of deterring Microsoft users from
trying or staying with Linux/Ubuntu. Since the word is basically out that
suspend/resume does not work (for various reasons in various numerous bug
reports)on many/most machines out there, this is a critical issue because
suspend/resume is a feature most users are aware of and a great many
utilize. It is also considered a very basic feature that any useable OS
would possess. Not being able to implement such a feature at this late date
reflects very poorly on the usability of the OS, at least in the view of
some prospective Linux converts. (And certainly having the user's session
devolve to a state where neither the keyboard, mouse or display work could
result in the loss of data.)

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Stefan Bader
Sent: Thursday, June 10, 2010 2:55 AM
To: <email address hidden>
Subject: [Bug 553498] Re: Intel Core i3/i5/i7 hang on resume from
suspend(SCI_EN)

I lowering the importance as critical should be reserved for issues that
cause the loss of data. Also Kamal, could you check current Maverick. I
would think this should already be released there.

** Changed in: linux (Ubuntu)
   Importance: Critical => High

--
Intel Core i3/i5/i7 hang on resume from suspend (SCI_EN)
https://bugs.launchpad.net/bugs/553498
You received this bug notification because you are a direct subscriber of
the bug.

Tried the lastest (#37) kernel from this ppa: https://launchpad.net/~kernel-ppa/+archive/pre-proposed/, the bug still presents.
I'm using Dell Inspiron 1464 with Core-i3, Intel HD Graphic

madbiologist (me-again) wrote :

@Funnnny - The fix in the pre-proposed kernel #37 is for "Dell Studio 155x" only - see comment #41. You may want to try the test kernel mentioned in comment #25 (and comment #17).

Kamal Mostafa (kamalmostafa) wrote :

More details about which kernels include a fix for this, and it what form...

Ubuntu Lucid:

  The latest released Lucid kernel (2.6.32-22 #36-Ubuntu) DOES NOT include any fix for this.

  The pre-release PPA Lucid kernel (2.6.32-23 #37) DOES include the fix, but only for some specific machines including "Dell Studio 155x": https://launchpad.net/~kernel-ppa/+archive/pre-proposed/

Ubuntu Maverick:

  The Maverick kernel (2.6.35) DOES include the "general" variant of the fix, enabled unconditionally, not just for a specific list of machines (Matthew Garrett's upstream patch 74ca255e19aac16a689d98126c935ad99a47778c).

Kamal Mostafa (kamalmostafa) wrote :

@Stefan - I propose that we 'git cherry-pick 74ca255e19aac16a689d98126c935ad99a47778c' in Lucid (I've tested that, it builds fine) in order to address this issue for all Core i3/i5/i7 machines.

Martin Pitt (pitti) on 2010-06-11
Changed in linux (Ubuntu Maverick):
milestone: none → maverick-alpha-2

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Kamal - I can't find 74ca255e19aac16a689d98126c935ad99a47778c in the upstream repo at git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git. Can you either confirm the SHA1 or list the commit log subject?

After speaking with kamal, it appears the following is the correct upstream sha1:

commit b6dacf63e9fb2e7a1369843d6cef332f76fca6a3
Author: Matthew Garrett <email address hidden>
Date: Tue May 11 13:49:25 2010 -0400

    ACPI: Unconditionally set SCI_EN on resume

It also seems this patch was incorporated upstream as of 2.6.35-rc1:

~/linux-2.6$ git describe --contains b6dacf63e9fb2e7a1369843d6cef332f76fca6a3
v2.6.35-rc1~20^2~3^2

Since we've already rebased Maverick to 2.6.35-rc2 this fix should be in Maverick by default. I'm therefore marking the Maverick task as Fix Released. Thanks.

Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Released
John Trostel (jtrostel-gmail) wrote :

should the new kernel mentioned by Martin show up now if I have lucid-proposed enabled or do I need to go get it?

Funnnny (ntcong-it) wrote :

I enabled the lucid-proposed and ran upgrade, but the problem still here.

$ uname -a
  Linux congnt-laptop 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 19:31:57 UTC 2010 x86_64 GNU/Linux

Did I install the correct kernel

Funnnny [2010-06-13 4:46 -0000]:
> $ uname -a
> Linux congnt-laptop 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 19:31:57 UTC 2010 x86_64 GNU/Linux
>
> Did I install the correct kernel

No, it's fixed in linux-image-2.6.32-23-generic. You can install that
manually, but for an automatic upgrade a linux-meta upload is still
missing. The kernel team will provide this as soon as possible.

@Funnnny -

Thảo luận # 59/Commento # 59

> $ uname -a
> Linux congnt-laptop 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 19:31:57 UTC 2010 x86_64 GNU/Linux
>
> Did I install the correct kernel

Không, đó là cố định trong linux-image-2.6.32-23-generic. Bạn có thể cài đặt mà
cách thủ công, nhưng đối với một nâng cấp tự động tải lên linux-meta vẫn còn
mất tích. Nhóm nghiên cứu hạt nhân sẽ cung cấp này càng sớm càng tốt.

No, è fissata in linux-image-2.6.32-23-generic. È possibile installare che
manualmente, ma per un aggiornamento automatico di un caricamento di linux-meta è ancora
mancanti. Il team del kernel fornirà al più presto possibile.

Thảo luận # 51/Commento # 51

Việc sửa chữa trong đề xuất hạt nhân trước # 37 là dành cho "Dell Studio 155x" chỉ - xem bình luận # 41. Bạn có thể muốn thử nghiệm hạt nhân được đề cập trong bình luận # 25 (và bình luận # 17).

La correzione nel kernel pre-proposta # 37 è per "Dell Studio 155x" solo - vedi commento # 41. Si consiglia di provare il kernel prova di cui al commento # 25 (e il commento # 17).

Thảo luận # 52/Commento # 52

Chi tiết về những hạt nhân bao gồm một sửa chữa cho điều này, và nó về hình thức ...

Ubuntu Lucid:

  Các hạt nhân mới nhất phát hành Lucid (2.6.32-22 # 36-Ubuntu) KHÔNG bao gồm bất kỳ sửa chữa cho việc này.

  Các bản phát hành trước PPA hạt nhân Lucid (2.6.32-23 # 37) CO bao gồm việc sửa chữa, nhưng chỉ cho một số máy cụ thể bao gồm cả "Dell Studio 155x": https: / / launchpad.net / ~ kernel-PPA / + lưu trữ / trước -đề nghị /

Ubuntu Maverick:

  Hạt nhân Maverick (2.6.35) CO bao gồm "nói chung" biến thể của sửa chữa, cho phép vô điều kiện, không chỉ cho một danh sách cụ thể của máy (74ca255e19aac16a689d98126c935ad99a47778c vá thượng nguồn của Matthew Garrett).

Maggiori informazioni su kernel che include una correzione per questo, e quale forma ...

Ubuntu Lucid:

  L'ultimo kernel rilasciato Lucid (2.6.32-22 # 36-Ubuntu) non include alcuna correzione per questo.

  La pre-release del kernel PPA Lucid (2.6.32-23 # 37) include la correzione, ma solo per alcune macchine specifiche, tra cui "Dell Studio 155x": https: / / launchpad.net / ~ kernel-ppa / archive + / pre-proposte /

Ubuntu Maverick:

  Il kernel di Maverick (2.6.35), include la "variante generale della correzione, ha consentito incondizionatamente, non solo per un elenco specifico di macchine (74ca255e19aac16a689d98126c935ad99a47778c patch upstream Matthew Garrett).

AlexW (alex.wedensky) wrote :

just my $0.02: with the kernel from "proposed", suspend-resume works, but screen brightness doesn't, and -- weirdly -- Broadcom STA driver doesn't load. With Kamal's kernel, all of the above works.

John Trostel (jtrostel-gmail) wrote :

on my dell e6410 with intel video and intel core i7 with new kernel from proposed, "2.6.32-23-generic #37-Ubuntu"

power cord plugged in:

1. suspend on lid closed: fails
2. hibernate on lid closed: works - screen brightness needed auto-adjust to resume to bright

on battery power

1. suspend on lid closed: fails
2. hibernate on lid closed: works

Is there something I'm missing here?

summary: - Intel Core i3/i5/i7 hang on resume from suspend (SCI_EN)
+ Dell Studio 155x hang on resume from suspend (SCI_EN)
Kamal Mostafa (kamalmostafa) wrote :

Thanks for your patience folks.

I have changed the title of this bug back to what it was originally, to reflect that the fix we have committed in Lucid (still awaiting release) is specific to the "Dell Studio 155x" line of machines. Other models -- even other Core i3/i5/i7 models with the same problem -- will NOT be helped by this "Dell Studio 155x"-specific version of the fix currently in Lucid.

A new bug 594837 has been opened to track the general (not model-specific) version of the fix in Lucid. Users with Intel Core i3/i5/i7 systems experiencing this problem in Lucid should subscribe to that new bug.

Users with any other CPU besides Intel Core i3/i5/i7 experiencing suspend/resume problems should file a separate bug.

(As has been stated, the not-model-specific version of this fix is already in Maverick).

Launchpad Janitor (janitor) wrote :
Download full text (25.2 KiB)

This bug was fixed in the package linux - 2.6.32-23.37

---------------
linux (2.6.32-23.37) lucid-proposed; urgency=low

  [ Alex Deucher ]

  * SAUCE: drm/radeon/kms/atom: fix dual-link DVI on DCE3.2/4.0
    - LP: #564559

  [ Andy Whitcroft ]

  * [Config] ports -- build in dm-mod to enable LVM boot
    - LP: #560717
  * tools -- fix perf version extraction for multi-part flavours
    - LP: #555130
  * SAUCE: ACPI: EC: Allow multibyte access to EC (v3)
    - LP: #526354
  * [Config] enforce -- ensure dm_mod is built-in for LVM
    - LP: #560717
  * update to ubuntu-debian:7e708d33054c373faf41da23b73e8b48c342d958
    - LP: #570500, #576274

  [ Chase Douglas ]

  * Revert "(pre-stable): input: ALPS - Add signature for HP Pavilion dm3
    laptops"
    - LP: #550625
  * Enable ftrace function profiler
    - LP: #570389
  * enforce CONFIG_TMPFS_POSIX_ACL=y
    - LP: #575940

  [ Leann Ogasawara ]

  * Revert "staging/comdi -- disable"
    - LP: #563436
  * [Config] Enable multicast routing for sparc
    - LP: #416266
  * [Config] Add ahci.ko to virtual sub-flavour
    - LP: #570542

  [ Stefan Bader ]

  * Revert "SAUCE: drm/i915: Disable FBC on 915GM and 945GM"
    - LP: #588832

  [ Tim Gardner ]

  * ubuntu: rtl8192se -- update to version 0015.0127.2010
    - LP: #567016
  * [Config] Add atl1c to nic-modules udeb
    - LP: #557130

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) iwlwifi: fix nfreed--"
    - LP: #575853
  * Revert "backlight: mbp_nvidia_bl - add five more MacBook variants"
    - LP: #575853
  * Revert "(pre-stable) pata_via: Add VIA VX900 support"
    - LP: #575853
  * Revert "(pre-stable) x86-32, resume: do a global tlb flush in S4
    resume"
    - LP: #575853
  * Revert "x86: disable IOMMUs on kernel crash"
    - LP: #575853
  * Revert "sunrpc: fix peername failed on closed listener"
    - LP: #575853
  * Revert "sunrpc: move the close processing after do recvfrom method"
    - LP: #575853
  * Revert "(pre-stable) drm/edid: allow certain bogus edids to hit a fixup
    path rather than fail"
    - LP: #575853
  * Revert "drm/radeon/kms: don't print error on -ERESTARTSYS."
    - LP: #575853
  * Revert "ath9k: fix lockdep warning when unloading module" on stable
    kernels
    - LP: #588832
  * Staging: comedi: removed "depricated" from COMEDI_CB_BLOCK
    - LP: #483343
  * fat: fix buffer overflow in vfat_create_shortname()
    - LP: #575853
  * xfs: simplify inode teardown
    - LP: #575853
  * xfs: fix mmap_sem/iolock inversion in xfs_free_eofblocks
    - LP: #575853
  * xfs: I/O completion handlers must use NOFS allocations
    - LP: #575853
  * xfs: Wrapped journal record corruption on read at recovery
    - LP: #575853
  * xfs: Fix error return for fallocate() on XFS
    - LP: #575853
  * xfs: check for not fully initialized inodes in xfs_ireclaim
    - LP: #575853
  * xfs: fix timestamp handling in xfs_setattr
    - LP: #575853
  * xfs: Don't flush stale inodes
    - LP: #575853
  * xfs: Ensure we force all busy extents in range to disk
    - LP: #575853
  * xfs: reclaim inodes under a write lock
    - LP: #575853
  * xfs: Avoid inodes in reclaim when flushing from inode cache
    - LP: #575853
  * xfs: recla...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
AlexW (alex.wedensky) wrote :

On a Dell Studio 1558 (i3/Intel Graphics/Broadcom wifi) with this new 2.6.32-23.37 kernel, suspend-resume works, but -- yet again -- brightness stays at maximum/can't be adjusted, and Broadcom STA wireless driver fails to load ("installed, activated, but not in use").

AlexW (alex.wedensky) wrote :

Kamal,

Has your fix (suspend AND brightness) made it into 2.6.32-24.41 kernel?

Kamal Mostafa (kamalmostafa) wrote :

@AlexW-

The suspend/resume fix for Dell Studio 1558 (this bug report) was released in 2.6.32-23.37 (see comment #64); it is still present in 2.6.32-24.41.

My "experimental" brightness fix (LP #568611) has not yet been applied to any official tree. My Dell Studio PPA, however, does contain that fix: https://launchpad.net/~kamalmostafa/+archive/linux-kamal-dellstudio

Arnau Alcázar (arnau) wrote :

I have similars problems to this bug with kernel 2.6.32.24.

mlaverdiere (mlaverdiere) wrote :

I was having the suspend/hang problem with Lucid on my Dell Studio 1458 with Intel core I3 M330 CPU. Now, with Maverick RC, i can successfully resume from suspend, but after the first resume, I get this problem: suspend upon lid closing is not working and all special functions keys (sound, brightness, etc.) are not working neither.

I guess I should open/use another bug report?

@mlaverdiere, Yes, since you're using another hardware, please file a new report. We can always mark as duplicate of this one later if it appears to be the same problem after investigation. Thanks in advance.

mlaverdiere (mlaverdiere) wrote :

New bug report open for problem related to special keys/lid close events now working after first resume: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/657338

Click and images will be loaded again

Elite Watches NOT-pricy!This May ten Top Watches’ clones are on discounts. You can carry Top Watch even tomorrow (overnight shipping!) and pay only hundred bucks for it!
Learn more

Wehope you found this message to be useful.However, if you'd rather not receive futuree-mails of this sort from us, pleaseopt-out here .

Please note that product prices andavailability are subject to change. Prices andavailability were accurate at the time thisnewsletter was sent; however, they may differfrom those you see when you visit us.

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers