Ubuntu

thinkpad edge - detected unsupported model

Reported by aljosa on 2010-03-31
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Chris Van Hoof
linux (Ubuntu)
Medium
Manoj Iyer

Bug Description

lucid reports on startup (after grub) that detected thinkpad model (edge) is not supported.

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8172 (rev 10)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)

Andrew Henry (adhenry) wrote :

im also getting this after doing some beta2 updates. Beta1 did not give me any visible issues.

Booting up drops me to consle view, says unsupported Thinkpad, then continues, but sometimes I get a low graphics mode X-Windows, which a warm reboot sometimes solves.

rCX (rcx) wrote :

I get the same error too. I think this bug is related to thinkpad_acpi. Here is the error in my kern.log:

Jul 1 18:00:11 edge kernel: [ 14.958998] thinkpad_acpi: Not yet supported ThinkPad detected!

rCX (rcx) on 2010-07-02
affects: acpi-support → acpi
affects: ubuntu → acpi-support (Ubuntu)
Changed in acpi-support (Ubuntu):
status: New → Confirmed
rCX (rcx) wrote :

People have also had this problem with thinkpad x100e. See bug #557736

Changed in acpi:
status: New → Invalid
rCX (rcx) on 2010-07-02
affects: acpi → null
Steve Langasek (vorlon) wrote :

acpi-support has nothing to do with model detection. Reassigning to the linux kernel.

affects: acpi-support (Ubuntu) → linux (Ubuntu)
rCX (rcx) wrote :
Chris Van Hoof (vanhoof) on 2010-08-26
Changed in null:
status: Invalid → Confirmed
Jerone Young (jerone) wrote :

This is fixed in latest thinkpad-acpi . Will post a dkms package so can test shortly.

Changed in oem-priority:
assignee: nobody → Canonical Platform QA Team (canonical-platform-qa)
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

assigning to the kernel team for further look.

Changed in linux (Ubuntu):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in oem-priority:
assignee: Canonical Platform QA Team (canonical-platform-qa) → nobody
Jerone Young (jerone) wrote :

I was thinking about the x100e with my above comment. Thinkpad ACPI support is not there yet in thinkpad-acpi.

Jerone Young (jerone) on 2010-09-07
Changed in oem-priority:
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

Any update to that?

Chris Van Hoof (vanhoof) on 2010-11-15
Changed in linux (Ubuntu):
assignee: Canonical Kernel Team (canonical-kernel-team) → Manoj Iyer (manjo)
Changed in oem-priority:
assignee: nobody → Chris Van Hoof (vanhoof)
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Changed in oem-priority:
status: Confirmed → Triaged
Chris Van Hoof (vanhoof) wrote :

Can anyone confirm on an edge model that this issue still exists with Maverick?

Steve Magoun (smagoun) wrote :

I've been unable to reproduce on 10.10 with any of Edge 11/13/14/15.

Chris Van Hoof (vanhoof) wrote :

Marking this as fixed released as we've not been able to reproduce this behaviour on recent edge models on 10.10.

--chris

tags: added: hwe-blocker
Changed in oem-priority:
status: Triaged → Fix Released
Changed in null:
status: Confirmed → Invalid
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Redsandro (redsandro) wrote :

I have the same message on my Lenovo ThinkPad Edge 15 with Ubuntu 10.04.2 LTS fully repo updated as per today:

<b>dmesg</b>
[ 14.822685] iwlagn 0000:03:00.0: Detected Intel Wireless WiFi Link 1000 Series BGN REV=0x6C
[ 14.851351] thinkpad_acpi: Not yet supported ThinkPad detected!
[ 14.856207] iwlagn 0000:03:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels

Hibernate hangs at the last second of waking up, showing the last thing that was on the screen.

Is this fix also backported to 10.04 LTS?

Redsandro (redsandro) wrote :

I still have this problem with my Lenovo ThinkPad Edge 15 with Ubuntu 10.04.2 LTS.
I am not getting a fix using normal updates or backports. Lucid is supported until 2013 so if status is "fix released", I shouldn't be having this problem anymore, right? Am I missing something?

slicks (slicks) wrote :

I have such bug too. Here is my information:
Lenovo Thinkpad edge 14 NVPJART
$uname -a
Linux IBM 2.6.32-32-generic #62-Ubuntu SMP Wed Apr 20 21:54:21 UTC 2011 i686 GNU/Linux
$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8172 (rev 10)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
$dmesg |grep acpi
[ 8.585581] thinkpad_acpi: Not yet supported ThinkPad detected!

slicks (slicks) wrote :

With kernel 2.6.38.8 Thinkpad ACPI works. No error messages in dmesg:
$ dmesg |grep acpi
[ 0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[ 0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x04] enabled)
[ 0.000000] ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
[ 0.000000] ACPI: LAPIC (acpi_id[0x03] lapic_id[0x05] enabled)
[ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
[ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x02] high edge lint[0x1])
[ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x03] high edge lint[0x1])
[ 2.037490] ACPI: acpi_idle yielding to intel_idle
[ 10.549645] thinkpad_acpi: ThinkPad ACPI Extras v0.24
[ 10.549649] thinkpad_acpi: http://ibm-acpi.sf.net/
[ 10.549651] thinkpad_acpi: ThinkPad BIOS 80ET40WW (1.17 ), EC 80HT32WW-1.176000
[ 10.549654] thinkpad_acpi: Lenovo ThinkPad Edge, model 0578JAG
[ 10.550769] thinkpad_acpi: detected a 8-level brightness capable ThinkPad
[ 10.923119] thinkpad_acpi: radio switch found; radios are enabled
[ 10.923146] thinkpad_acpi: possible tablet mode switch found; ThinkPad in laptop mode
[ 10.924056] thinkpad_acpi: asked for hotkey mask 0x04018070, but firmware forced it to 0x00018070
[ 10.933503] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
[ 10.934156] Registered led device: tpacpi::thinklight
[ 10.934224] Registered led device: tpacpi::power
[ 10.934867] Registered led device: tpacpi::standby
[ 10.935200] Registered led device: tpacpi::thinkvantage
[ 10.946196] thinkpad_acpi: Standard ACPI backlight interface available, not loading native one.
[ 10.946574] thinkpad_acpi: Console audio control enabled, mode: monitor (read only)
[ 10.950185] input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input9
[ 11.299911] acpi device:06: registered as cooling_device4

Redsandro (redsandro) wrote :

Interesting, thanks for sharing @slicks. I still have the message in 10.04 LTS, so unless I did something wrong, the fixes do not seem to be backported.

Ergo, supported acpi for Edge 15 only available from Ubuntu 11.04 and up, can anyone confirm?

Redsandro (redsandro) wrote :

I hope everyone who knew new kernels revisions don't come in updates or backports will have a real bad dinner tonight as punishment for not telling me this two months ago.

So let me tell myself: You should download .deb packages manually or enable lucid-proposed to force a backport.

Anyway, it doesn't work for me. I installed 2.6.38-10. The bug is gone, but so is the suspend capability. Now it just goes to the purple Ubuntu boot screen and hangs there indefinitely.

Back to 2.6.32 for me. I am not sure this ACPI support is 'fixed' since it breaks functionality that was working with the *unsupported ACPI detected* to begin with.

Redsandro (redsandro) wrote :

*Solution*

2.6.35(-25-generic) has support for these Lenovo models, too.
Add kernel-ppa, reload, and look for the .35 models in synaptic. This one plays nicely with Ubuntu 10.04 LTS.

>>> www.buypharma.com.ua

- There is no reason to feel depressed if you, like so many other men today, have hit the rough spot of your sexual life when you cannot seem to be performing as well as you used to do. Your agitation and frustration are easily understood, and still you should know that with the modern development of worldwide pharmacological industries it is but natural that there is bound to be a solution for your own needs when it comes down to solving your erectile dysfunction problems.

- We suggest you getting erectile dysfunction drugs from our online drugstore cheaply, easily and without much to-do. You will always be taken care of and attended to with extreme care, and you will have the possibility of choosing from a wide range of erectile dysfunction products to find a solution that will best suit your particular needs.

- The whole world puts great trust in those famous diamond shaped pills, and if you are not an exception we would like to revise some basic points that speak in favor of putting your male health in the hands of those magical tablets.
Firstly, there is no need for regular therapy – those blue pills have to be taken directly before the planned sexual contact, and extra convenience shines through when you come to realize that the pills will not start working unless sufficient sexual stimulation is provided.

- Secondly, this erectile dysfunction solution is known for its extremely low adverse side effects profile, which makes it available for all age groups of patients. Besides, it really does not matter how old you are when it goes about taking erectile dysfunction pills – just make sure that you do not overdose, and they will work for you at their best!

- Finally, those fabulous pills do not only provide you with stable erection that can be maintained for as long as you need it – they also help you to achieve unheard sensitivity during the sexual act as well as make your genitals look much more sizey!

- Think of all those benefits of taking erectile dysfunction pills and the effect you can produce on your loved one – and do not hesitate to make your order and / or refills right away!

--- > www.buypharma.com.ua < ---

 _V______C________L
 ___I_______I_______E
 _____A_______A_______V
 _______G_______L_______I
 _________R_______I_______T
 ___________A_______S_______R
 _____________________________A

   Ram the hell out of your girl and leave her ass in debt! These boosters will make your desire skyrocket! Try just once and you’ll understand all the benefits of this approach to solving male problems! Prices are Down for just two next days!
-
 - - -
--------- www.buypharma.com.ua
 - - -
-

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers