AMD64 alternate install fails to find CDROM on Thinkpad T400 in AHCI mode, only "Compatibility" mode works

Bug #548537 reported by Torrey on 2010-03-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Torrey

Bug Description

Attempted install of Lucid Lynx from the AMD64 "alternate" nightly build on March 25th.
Platform is a Thinkpad T400 with a laptop SATA hard drive and CDRW/DVD.

ISOLINUX loaded, the installer began, I chose my language and keyboard, and then got "No common CD-ROM drive was detected".
So the installation failed.

Additional information:

In the BIOS, my SATA mode is AHCI, which is what this computer came with.

The BIOS correctly detects my hard drive, which is a Hitachi HTS722010K9SA00
After the menu driven install failed, I switched to a console and did a little exploring.
dmesg shows no SATA driver being loaded, and no hard drives or CDROM drives detected.
There are no sd or cd devices under /dev.

I then rebooted, and in the BIOS changed the SATA mode to "Compatibility".
And then the installer worked, found the CDROM, configured the network, etc.

However before continuing, I rebooted, changed the SATA mode back to AHCI, and tried again.
And it failed again.

Obviously this would be a fatal bug for most users, who would only say "Ubuntu didn't work" and go back to windows :-(
Please fix before release!

affects: ubuntu → linux (Ubuntu)
holzkeil (larstalaschus) wrote :

I have the same problem with the 2010-03-26 daily build.
Mainboard is Gigabyte G33-DS3R and the cd rom drive nec 3540 is connected to the IDE port.
There is no Option to change the IDE mode, so the installation fails every time.

tags: added: kernel-series-unknown
Torrey (torrey-hoffman) wrote :

One followup: After I completed the installation, I changed the BIOS mode back to AHCI, and had no problems either booting or using the CDROM. So this is an installation-only issue.

Torrey (torrey-hoffman) wrote :

This is not just a problem with the Thinkpad T400. I just had the same issue with my workstation machine, which is based on a ASUS P5Q-EM LGA 775 Intel G45 motherboard, using two SATA hard drives and an IDE DVD-RW.

However on this machine I could not find a workaround changing BIOS settings, and after trying each SATA/IDE configuration option eventually gave up.

This is a regression... earlier versions of Ubuntu installed on this hardware with no problem.

Torrey (torrey-hoffman) wrote :

I'm happy to say that with Beta 2, installation now works on my workstation machine. I haven't yet tested the Thinkpad T400.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Torrey,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 548537

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Torrey (torrey-hoffman) wrote :

I can confirm that this bug is fixed in the final release version of Lucid Lynx.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers