Blank screen at first boot with ATI ES1000 and 10.04 server

Bug #546743 reported by Thomas Norheim on 2010-03-25
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft
Lucid
High
Andy Whitcroft

Bug Description

Binary package hint: linux-image-2.6.32-16-server

Blank screen at first boot after install.

$ lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04

$ lshw -C display
  *-display
       description: VGA compatible controller
       product: ES1000
       vendor: ATI Technologies Inc
       physical id: 1
       bus info: pci@0000:01:01.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list rom
       configuration: driver=radeon latency=64 mingnt=8
       resources: irq:22 memory:d0000000-d7ffffff(prefetchable) ioport:3000(size=256) memory:dfff0000-dfffffff memory:d8000000-d801ffff(prefetchable

$lspci
00:00.0 Host bridge: Intel Corporation 5000X Chipset Memory Controller Hub (rev 31)
00:02.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x8 Port 2-3 (rev 31)
00:03.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 3 (rev 31)
00:04.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x8 Port 4-5 (rev 31)
00:05.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 5 (rev 31)
00:06.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 6 (rev 31)
00:07.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 7 (rev 31)
00:08.0 System peripheral: Intel Corporation 5000 Series Chipset DMA Engine (rev 31)
00:10.0 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev 31)
00:10.1 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev 31)
00:10.2 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev 31)
00:11.0 Host bridge: Intel Corporation 5000 Series Chipset Reserved Registers (rev 31)
00:13.0 Host bridge: Intel Corporation 5000 Series Chipset Reserved Registers (rev 31)
00:15.0 Host bridge: Intel Corporation 5000 Series Chipset FBD Registers (rev 31)
00:16.0 Host bridge: Intel Corporation 5000 Series Chipset FBD Registers (rev 31)
00:1c.0 PCI bridge: Intel Corporation 631xESB/632xESB/3100 Chipset PCI Express Root Port 1 (rev 09)
00:1d.0 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #1 (rev 09)
00:1d.1 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #2 (rev 09)
00:1d.2 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB Controller #3 (rev 09)
00:1d.7 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset EHCI USB2 Controller (rev 09)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d9)
00:1f.0 ISA bridge: Intel Corporation 631xESB/632xESB/3100 Chipset LPC Interface Controller (rev 09)
00:1f.1 IDE interface: Intel Corporation 631xESB/632xESB IDE Controller (rev 09)
00:1f.3 SMBus: Intel Corporation 631xESB/632xESB/3100 Chipset SMBus Controller (rev 09)
01:01.0 VGA compatible controller: ATI Technologies Inc ES1000 (rev 02)
02:00.0 RAID bus controller: Adaptec AAC-RAID (Rocket) (rev 02)
03:00.0 PCI bridge: Broadcom EPB PCI-Express to PCI-X Bridge (rev c3)
04:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
05:00.0 PCI bridge: Broadcom EPB PCI-Express to PCI-X Bridge (rev c3)
06:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
07:00.0 PCI bridge: Broadcom EPB PCI-Express to PCI-X Bridge (rev c3)
08:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
10:00.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Upstream Port (rev 01)
10:00.3 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express to PCI-X Bridge (rev 01)
11:00.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Downstream Port E1 (rev 01)
11:01.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Downstream Port E2 (rev 01)

Excerpt from syslog:
Mar 25 08:18:53 ts25build kernel: [ 4.668673] [drm] radeon defaulting to kernel modesetting.
Mar 25 08:18:53 ts25build kernel: [ 4.668676] [drm] radeon kernel modesetting enabled.
Mar 25 08:18:53 ts25build kernel: [ 4.668733] radeon 0000:01:01.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
Mar 25 08:18:53 ts25build kernel: [ 4.670273] [drm] radeon: Initializing kernel modesetting.
Mar 25 08:18:53 ts25build kernel: [ 4.670429] [drm] register mmio base: 0xDFFF0000
Mar 25 08:18:53 ts25build kernel: [ 4.670430] [drm] register mmio size: 65536
Mar 25 08:18:53 ts25build kernel: [ 4.670686] [drm] GPU reset succeed (RBBM_STATUS=0x00000140)
Mar 25 08:18:53 ts25build kernel: [ 4.670702] [drm] radeon: VRAM 64M
Mar 25 08:18:53 ts25build kernel: [ 4.670703] [drm] radeon: VRAM from 0x00000000 to 0x03FFFFFF
Mar 25 08:18:53 ts25build kernel: [ 4.670705] [drm] radeon: GTT 512M
Mar 25 08:18:53 ts25build kernel: [ 4.670706] [drm] radeon: GTT from 0x20000000 to 0x3FFFFFFF
Mar 25 08:18:53 ts25build kernel: [ 4.670731] [drm] radeon: irq initialized.
Mar 25 08:18:53 ts25build kernel: [ 4.673925] [drm] Detected VRAM RAM=64M, BAR=128M
Mar 25 08:18:53 ts25build kernel: [ 4.673929] [drm] RAM width 16bits DDR
Mar 25 08:18:53 ts25build kernel: [ 4.674032] [TTM] Zone kernel: Available graphics memory: 3063990 kiB.
Mar 25 08:18:53 ts25build kernel: [ 4.674034] [TTM] Zone dma32: Available graphics memory: 2097152 kiB.
Mar 25 08:18:53 ts25build kernel: [ 4.674055] [drm] radeon: 16M of VRAM memory ready
Mar 25 08:18:53 ts25build kernel: [ 4.674057] [drm] radeon: 512M of GTT memory ready.
Mar 25 08:18:53 ts25build kernel: [ 4.674079] [drm] GART: num cpu pages 131072, num gpu pages 131072
Mar 25 08:18:53 ts25build kernel: [ 4.684887] [drm] radeon: cp idle (0x00008080)
Mar 25 08:18:53 ts25build kernel: [ 4.684942] [drm] Loading R100 Microcode
Mar 25 08:18:53 ts25build kernel: [ 4.684945] platform radeon_cp.0: firmware: requesting radeon/R100_cp.bin
...
Mar 25 08:18:53 ts25build kernel: [ 4.721307] [drm] radeon: ring at 0x0000000020000000
Mar 25 08:18:53 ts25build kernel: [ 4.721330] [drm] ring test succeeded in 1 usecs
Mar 25 08:18:53 ts25build kernel: [ 4.721427] [drm] radeon: ib pool ready.
...
Mar 25 08:18:53 ts25build cron[835]: (CRON) INFO (Running @reboot jobs)
Mar 25 08:18:55 ts25build kernel: [ 6.629264] bnx2: eth0 NIC Copper Link is Up, 100 Mbps full duplex
Mar 25 08:18:55 ts25build kernel: [ 6.630178] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Mar 25 08:18:55 ts25build kernel: [ 6.720015] [drm] ib test succeeded in 0 usecs
Mar 25 08:18:55 ts25build kernel: [ 6.720139] [drm] No valid Ext TMDS info found in BIOS
Mar 25 08:18:55 ts25build kernel: [ 6.720189] [drm] Radeon Display Connectors
Mar 25 08:18:55 ts25build kernel: [ 6.720191] [drm] Connector 0:
Mar 25 08:18:55 ts25build kernel: [ 6.720192] [drm] VGA
Mar 25 08:18:55 ts25build kernel: [ 6.720194] [drm] DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
Mar 25 08:18:55 ts25build kernel: [ 6.720195] [drm] Encoders:
Mar 25 08:18:55 ts25build kernel: [ 6.720197] [drm] CRT1: INTERNAL_DAC1
Mar 25 08:18:55 ts25build kernel: [ 6.720198] [drm] Connector 1:
Mar 25 08:18:55 ts25build kernel: [ 6.720199] [drm] DVI-D
Mar 25 08:18:55 ts25build kernel: [ 6.720200] [drm] HPD2
Mar 25 08:18:55 ts25build kernel: [ 6.720202] [drm] DDC: 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64
Mar 25 08:18:55 ts25build kernel: [ 6.720203] [drm] Encoders:
Mar 25 08:18:55 ts25build kernel: [ 6.720204] [drm] DFP2: INTERNAL_DVO1
Mar 25 08:18:55 ts25build kernel: [ 6.871178] [drm] fb mappable at 0xD0040000
Mar 25 08:18:55 ts25build kernel: [ 6.871179] [drm] vram apper at 0xD0000000
Mar 25 08:18:55 ts25build kernel: [ 6.871181] [drm] size 786432
Mar 25 08:18:55 ts25build kernel: [ 6.871182] [drm] fb depth is 8
Mar 25 08:18:55 ts25build kernel: [ 6.871183] [drm] pitch is 1024
Mar 25 08:18:55 ts25build kernel: [ 6.871246] fb0: radeondrmfb frame buffer device
Mar 25 08:18:55 ts25build kernel: [ 6.871248] registered panic notifier
Mar 25 08:18:55 ts25build kernel: [ 6.871253] [drm] Initialized radeon 2.0.0 20080528 for 0000:01:01.0 on minor 0
Mar 25 08:18:55 ts25build init: plymouth-splash main process (886) terminated with status 1
Mar 25 08:18:55 ts25build kernel: [ 6.912356] vga16fb: initializing
Mar 25 08:18:55 ts25build kernel: [ 6.912364] vga16fb: mapped to 0xffff8800000a0000
Mar 25 08:18:55 ts25build kernel: [ 6.912393] fb1: VGA16 VGA frame buffer device
Mar 25 08:18:56 ts25build kernel: [ 7.321272] [drm:radeon_i2c_sw_put_byte] *ERROR* i2c 0x08 0x30 write failed
Mar 25 08:18:56 ts25build kernel: [ 7.562523] [drm:radeon_i2c_sw_put_byte] *ERROR* i2c 0x09 0x00 write failed
Mar 25 08:18:56 ts25build kernel: [ 7.802523] [drm:radeon_i2c_sw_put_byte] *ERROR* i2c 0x0a 0x90 write failed
Mar 25 08:18:56 ts25build kernel: [ 8.042524] [drm:radeon_i2c_sw_put_byte] *ERROR* i2c 0x0c 0x89 write failed
Mar 25 08:18:56 ts25build kernel: [ 8.282523] [drm:radeon_i2c_sw_put_byte] *ERROR* i2c 0x08 0x3b write failed
Mar 25 08:18:56 ts25build kernel: [ 8.300458] Console: switching to colour frame buffer device 128x4

Thomas Norheim (thomas-norheim) wrote :
Thomas Norheim (thomas-norheim) wrote :

Installed from Ubuntu 10.04 Server Edition, Beta 1, AMD64.

tags: added: lucid
hovis (hovis) wrote :

Similar thing on a Supermicro 3U server on boot (same ATI ES1000). This is just at boot up and nothing to do with X as we don't use it.

Worked around it for the moment by setting "nomodeset" on the grub command line, manually at the grub menu for the first time, then in (/etc/default/grub->GRUB_CMDLINE_LINUX).

Without nomodeset, server locks up with flashing Capslock/Scroll lock so unable to get boot logs. Happy to experiment with the server to try and get logs out of it if any help to fix this (or try newer kernels etc).

Ronald McCollam (fader) wrote :

Running this with "nomodeset" allows the console to be visible. Switching vterms works properly as well.

Thierry Carrez (ttx) wrote :

This GPU is pretty common on IBM/Lenovo/? servers, raising prio.

Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Thomas Norheim (thomas-norheim) wrote :

It was IBM servers we experienced it on. Both with newer and older servers with ATI ES graphic cards. Tried on x3550 and x3650 M2 series servers.

hovis (hovis) wrote :

Just did a 'apt-get dist-upgrade' which upgraded the kernel from 2.6.32-16 to 2.6.32-20 and the bug has gone away. As a control test, re-booted into the old -16 kernel via the grub menu and the issue is present there still, so for me kernel 2.6.32-20 seems fine. This is on a Supermicro server with the ES1000.

hovis (hovis) wrote :

Sorry, spoke too soon. Using the console (ie I typed 'dmesg') caused a lockup as soon as the framebuffer started to scroll. Flashing Capslock/Scroll.

Thierry Carrez (ttx) wrote :

Needs at least to be work-arounded for release.

Changed in linux (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Robert Hooker (sarvatt) wrote :

Can you please run apport-collect 546743 after booting the 2.6.32-20 (or -21) kernels to attach more logs to this bug report so we can look into it further?

Robert Hooker (sarvatt) wrote :

Also if possible, can you please boot with the option drm.debug=0x04 added to your grub kernel command line and attach your dmesg output?

Ronald McCollam (fader) wrote :

Here is the requested dmesg

hovis (hovis) wrote :

Here is mine for Kernel 2.6.32-20 if it is of any help.

Andy Whitcroft (apw) on 2010-04-15
Changed in linux (Ubuntu Lucid):
assignee: nobody → Andy Whitcroft (apw)
status: Confirmed → In Progress

apport-collect seems to need some work when X is not installed...

Attached is the output from dmesg from an IBM x3550. Quite similar to the one posted by Ronald as far as I can see.

If you want me to do something else, please let me know.

$ uname -r
2.6.32-21-server

Ronald McCollam (fader) wrote :

apw asked me to try out a different kernel. Booting this kernel appears to make the console work correctly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-21.32

---------------
linux (2.6.32-21.32) lucid; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: i915 KMS -- support disabling KMS for known broken devices
    - LP: #563277
  * SAUCE: i915 KMS -- blacklist i830
    - LP: #542208, #563277
  * SAUCE: i915 KMS -- blacklist i845g
    - LP: #541492, #563277
  * SAUCE: i915 KMS -- blacklist i855
    - LP: #511001, #541511, #563277
  * SAUCE: radeon KMS -- support disabling KMS for known broken devices
    - LP: #546743
  * SAUCE: radeon KMS -- blacklist ES1000
    - LP: #546743
 -- Andy Whitcroft <email address hidden> Thu, 15 Apr 2010 17:18:49 +0100

Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Released
hovis (hovis) wrote :

Updated today to 2.6.32-21-server and the fix above works fine for me, giving a stable console upon every boot.

czh (zhhchen) wrote :

I install 10.04 on IBM X336

Linux ubuntu 2.6.32-21-server #32-Ubuntu SMP Fri Apr 16 09:17:34 UTC 2010 x86_64 GNU/Linux

[ 13.310501] [drm:radeon_i2c_sw_put_byte] *ERROR* i2c 0x08 0x3b write failed
[ 13.312561] [drm:radeon_i2c_sw_put_byte] *ERROR* i2c 0x0a 0x90 write failed
[ 13.314654] [drm:radeon_i2c_sw_put_byte] *ERROR* i2c 0x0c 0x89 write failed

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers