10de:0647 [MacBookPro5,2] Fails to boot into 12.04 desktop

Bug #546393 reported by Christopher "cv"
122
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Fix Released
Critical
Nominated for Trunk by Frank
linux (Ubuntu)
High
Unassigned

Bug Description

Unable to boot into the Ubuntu 10.04 beta1 Live-CD. Therefore also unable to install the OS. When nothing is set in the modes menu and no button is pressed then one can't even see the new Ubuntu Plymouth theme. The only thing one sees is a blinking cursor and it doesn't boot at all. If one presses F6 in the options menu and choose "nomodeset" then one does see the Ubuntu Plymouth theme but the laptop fails to boot and stops at the point there the b43 Wireless module gets loaded. The Wireless module seem not to be suppoted nativley. This would not be such a Critical issue HOWEVER only in this case the boot process HALTS. There is at this moment no know way to resume the boot to contine with the install. The option noload=b43 does not give any different solace. We repeated this procedure and the point where it stops is always the same:
"b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 8, Type 4, Revision4)"

Also using various boot options like: acpi=off noapic nolapic gave no different behaviour.
Attached are two 2 screenshots and a movie (post #3 and post #12) demonstrating the problem.

WORKAROUND: I may boot into the live environment of Trusty using both kernel parameters: acpi=off nomodeset

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: cv 1513 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xdf480000 irq 20'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,106b4600,00100103'
   Controls : 36
   Simple ctrls : 20
CheckboxSubmission: 57388072f927f9d98d4a0d5e9bab5d7c
CheckboxSystem: 7e42599bda39ea7ff8b528272b6ef52b
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=05fb757e-479a-45d9-96ee-ef89a9eec76c
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MachineType: Apple Inc. MacBookPro5,2
NonfreeKernelModules: wl nvidia
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=df469aef-e891-4ddc-9fea-456eea1cfa74 ro splash quiet splash
ProcEnviron:
 LANGUAGE=de:en
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Regression: No
RelatedPackageVersions: linux-firmware 1.33
Reproducible: Yes
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: lucid graphics needs-upstream-testing
Uname: Linux 2.6.32-19-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/04/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP52.88Z.008E.B05.0905042202
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F2268EC8
dmi.board.vendor: Apple Inc.
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 8
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F2268EC8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP52.88Z.008E.B05.0905042202:bd05/04/09:svnAppleInc.:pnMacBookPro5,2:pvr1.0:rvnAppleInc.:rnMac-F2268EC8:rvr:cvnAppleInc.:ct8:cvrMac-F2268EC8:
dmi.product.name: MacBookPro5,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

---
ApportVersion: 2.12.7-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2802 F.... pulseaudio
CasperVersion: 1.336ubuntu1
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64+mac (20140103)
MachineType: Apple Inc. MacBookPro5,2
MarkForUpload: True
Package: linux (not installed)
ProcFB:

ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- acpi=off nomodeset
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
RelatedPackageVersions:
 linux-restricted-modules-3.12.0-7-generic N/A
 linux-backports-modules-3.12.0-7-generic N/A
 linux-firmware 1.118
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: trusty
Uname: Linux 3.12.0-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 05/04/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP52.88Z.008E.B05.0905042202
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F2268EC8
dmi.board.vendor: Apple Inc.
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 8
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F2268EC8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP52.88Z.008E.B05.0905042202:bd05/04/09:svnAppleInc.:pnMacBookPro5,2:pvr1.0:rvnAppleInc.:rnMac-F2268EC8:rvr:cvnAppleInc.:ct8:cvrMac-F2268EC8:
dmi.product.name: MacBookPro5,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Revision history for this message
Christopher "cv" (vchristopher) wrote :
Revision history for this message
Christopher "cv" (vchristopher) wrote :
description: updated
description: updated
description: updated
summary: - MacBook Pro 5,2 fails to boot into 10.04 beta1
+ MacBook Pro 5,2 fails to boot into 10.04 beta1 desktop
Revision history for this message
Christopher "cv" (vchristopher) wrote : Re: MacBook Pro 5,2 fails to boot into 10.04 beta1 desktop

Movie with nomodeset + console output http://hanfi.net/ubuntu/mbp.mov

affects: ubuntu → linux (Ubuntu)
Revision history for this message
Cor Driehuis (cor3huis) wrote :

Exact same issue with same MacBookPro Type. Haveing a 500GB SATA HD + 8GB RAM using Lucid Beta 1 64Bit. Another Linux e.g http://www.sysresccd.org/ CD boots just fine on this macine. OSX works fine, just as Windows 7 64 Bit. Using rEFIt 0.14 (http://refit.sourceforge.net/) but even the LiveCD option does not boot.

Disabled videodrive nomodeset, hangs at Wireless driver PHY.

Will investigate other options, boot parameters or what else I think might lead to success in the meantime...

Note that I've installed Linux, OSX , Windows, FreeBSD etc on MANY systems, so the issue is likely not my fault.

Revision history for this message
Christopher "cv" (vchristopher) wrote :

In Ubuntu 9.10 the "ERROR: FOUND UNSUPPORTED PHY" was the same message but it managed to boot the Live CD which is not the case in 10.04.
It seems also to have some problems with a "usb device on port 2" of course I had NO usb devices plugged in at this time.

The only way to get Lucid working at the moment is to install karmic koala(9.10) and then do the "update-manager -d" command. This will update the system to Lucid but sound will not work because it didn't work in Karmic either.
( https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/462098 )
Also if you try to install the proprietary Nvidia driver with the "Hardware Driver" section in the menu of Ubuntu, it will fail to install. So if you upgrade from Karmic to Lucid you have a) No sound and b) no 3D proprietary Nvidia driver.

I really hope this problem gets fixed, so that the MacBook Pro will be able to boot into the Lucid desktop.

Revision history for this message
Christopher "cv" (vchristopher) wrote :

If you upgrade from Karmic to Lucid you need to use the Super Grub Disc to boot into Lucid by the way.
rEFIt will not work.

Revision history for this message
Cor Driehuis (cor3huis) wrote :

Thanks will remember when needed, BTW this bug is not about not an upgrade, no feedback since there is no 10.04 release as of this moment, but about a fresh install Beta1, yup a real BETA with severe bugs ;). FYI just tried a fresh install of Ubuntu 9.10 64Bit Karmic Koala, could start the installation in graphical mode without problems, it just worked.

Revision history for this message
Cor Driehuis (cor3huis) wrote :

Thanks for you time CV. You wrote in post #5

> Lucid but sound will not work because it didn't work in Karmic either.
That is not the case see the thread you mentioned yourselves ;)
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/462098

Get sound working by installing the newest (not yet in the repos) linux kernel 2.6.32 following these instructions:
http://www.ramoonus.nl/2009/12/03/linux-kernel-2-6-32-installation-guide-for-ubuntu-linux/

Hpe it helps you.

Also, no doubt NVidea will work sooon, will try later today, but first the Karmic Koala + Upgrade and see where we can go from there...

CV wrote in # "rEFIt will not work." has to be seen in the contects of his post, to get GRUB-EFI to work in 64Bit take bootx64.efi and some tweaking I bet. "Beta " the best time of your life >:-). Any sensible helpfull results will be posted here, however the original issue remains, at least till beta 2.

Revision history for this message
Cor Driehuis (cor3huis) wrote :

BTW a lot about EFI n GRUB here
http://ubuntuforums.org/showthread.php?t=995704

Revision history for this message
Christopher "cv" (vchristopher) wrote :

Thanks,
maybe someone could change the status to "confirmed" and the importance to "high" if not even "critical" ?

Revision history for this message
Rainer Rohde (rainer-rohde) wrote :

I have the same issue as well (macbook pro 5,2, 17")

I think that the 2nd issue (after disabling nouveau and continue to boot) might be a FOSS wireless driver for the mac's broadcom NIC, which fails to load. These issues are similar for both i386 and amd64 variants.

My workaround was, as already described, to install Karmic and upgrade from there, installing the restricted drivers for the nvidia and broadcom cards; to make it boot I had to install grub2 into the partition my Lucid was on, in my case /dev/sda4.

And I agree with "cv" - this issue should be raised to 'high' or 'critical' as this is a complete show-stopper for those macbook users curious to try Lucid. And, considering how *nice* Lucid really is, that would be a real shame. :)

Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Christopher "cv" (vchristopher) wrote :

Here is the same video as in my post #3 in ogg/.ogv format: http://hanfi.net/ubuntu/mbp.ogv (this video can be played on Ubuntu without any additional codecs)

Revision history for this message
Christopher "cv" (vchristopher) wrote :

I have great news regarding the "no sound issue".

This is how it currently works:

1. Installing Ubuntu 9.10
2. "update-manager -d" in console
3. Updating the fresh Lucid beta with all the new updates
4. Having 2.6.32.17 kernel installed automatically through the updates
5. Booting up the latest "Super Grub Disc" version 1.30(latest version) and choosing "Load grub.cfg even if mbr is broken" from the menu
6. Done! Sound works for the first time and everything else seems ok!

(this bug is about the Live-CD wish still fails) ;-)

Revision history for this message
Christopher "cv" (vchristopher) wrote :

I'm happy to add that the proprietary Nvidia driver (current, from the Hardware Driver menu) installed with no problems and now Nvidia driver AND sound both work. Amazing.

Let's hope Live CD gets fixed too.

Revision history for this message
Cor Driehuis (cor3huis) wrote :

I know the below writen information is not 100% related to the orignal bug but still very relevant

..to give people hope on enjoying Ubuntu 10.04 on their MacBookPro (5,2)

I write this in the case the final 10.04 release CD would still not work.
Then there still would be a path to 10.04 via upgrading a fully working 9.10

On Karmic 9.10, I'm a happy camper now since,

* Wifi via restricted STA drivers works well
* Videocard Nvidia Driver 185.x works well, albeit restricted *<:o)
* Magic Mouse Basic works, needs tweaking, had no time yet. See
http://github.com/entrope/linux-magicmouse
* Bluetooth thus also works... ;)
* Sound works well, I've adjusted the Ubuntu wiki instructions
* iSight camera, a quick test showed picture, for testing I instaled
  cheese (sudo apt-get install cheese)

The related page for all of this Karmic goodness is
https://help.ubuntu.com/community/MacBookPro5-1_5-2/Karmic

BTW this helpful guy with great SEO links for EFI boot issues
http://www.rickycampbell.com/booting-windows-linux-and-osx-on-your-mac-without-using-grublilo-to-boot-windows/

Now I will see if we can upgrade to Lucid Lynx 10.04 Beta 1, a bold move...

So far, the original bug remains...well... bugging us. Cannot install Ubuntu Lucid Lynx 10.04 Beta 1 direct booted from CD on latest Modern MAC Powerbook Pro 5,2 :-( IMHO indeed critical.

tags: added: b34-phy0 b43 broken error phy pipe terminated unreadahead unsupported usb wireless
description: updated
description: updated
tags: added: b43-phy0
removed: b34-phy0
Revision history for this message
Christopher "cv" (vchristopher) wrote :

As of Saturday night 11pm "update-manager -d" in a fresh Karmic Koala install (9.10) will NO LONGER result into a working 10.04 system. The 10.04 system will not boot anymore, not even with the super grub disc.

Also I tried the "Daily-Live" CD on Saturday afternoon which still fails to boot into the 10.04 Desktop.

If you have a working 10.04 Install right now then don't update or your system will not boot anymore since there is a serious bug right now which turns the system unbootable.

Cor Driehuis (cor3huis)
tags: added: 10.04 beta1 cd install lynx macbookpro unable
removed: book
Revision history for this message
Mikalv (mikalv) wrote :

I got a MacBookPro5,5
Boot ROM Version: MBP55.00AC.B03

And the same problem seems to be here.. I can't boot from a usb disk, or cdrom..

Revision history for this message
Christopher "cv" (vchristopher) wrote :

Ohh same problem on 5,5? This is getting worse.

summary: - MacBook Pro 5,2 fails to boot into 10.04 beta1 desktop
+ MacBook Pro 5,2 / 5,5 fails to boot into 10.04 beta1 desktop
Revision history for this message
Julian Suarez (juliansuarezlopera) wrote : Re: MacBook Pro 5,2 / 5,5 fails to boot into 10.04 beta1 desktop

Hi, I have a macbook Pro 5,1 and I also have the same problem, which is strange since I was able to boot the Live CD in karmic.
I've tried the LiveCD and also a live USB in conjunction with rEFIt....but no luck

summary: - MacBook Pro 5,2 / 5,5 fails to boot into 10.04 beta1 desktop
+ MacBook Pro 5,1 / 5,2 / 5,5 fails to boot into 10.04 beta1 desktop
Revision history for this message
Kenzu (jlindeberg) wrote : Re: MacBook Pro 5,1 / 5,2 / 5,5 fails to boot into 10.04 beta1 desktop

Hi, I have the same problem on a macbook pro 5,3 :-(

Revision history for this message
Christopher "cv" (vchristopher) wrote : Re: MacBook Pro 5,1 / 5,2 / 5,3 / 5,5 fails to boot into 10.04 beta1 desktop

Anyone of the true heroes should finally
just raise the importance to critical since all 5,x MacBook Pro's seem to have this problem. Ubuntu will loose 1000's of users if this is bit fixed in beta 2.

summary: - MacBook Pro 5,1 / 5,2 / 5,5 fails to boot into 10.04 beta1 desktop
+ MacBook Pro 5,1 / 5,2 / 5,3 / 5,5 fails to boot into 10.04 beta1 desktop
Revision history for this message
Christopher "cv" (vchristopher) wrote :

bit=not (I'm typing on a iPhone) ;-)

Revision history for this message
Julian Suarez (juliansuarezlopera) wrote :

has anyone tried using the alternate-install cd?? does it work or does it hang like the live cd?

Revision history for this message
Christopher "cv" (vchristopher) wrote :

I tried it, it doesn't wotrk. Nothing does work at the moment, NOTHING...

Revision history for this message
Christopher "cv" (vchristopher) wrote :

The installation using the alternative CD works but it hangs on the boot. I also tried the current live CD daily and daily-live. Both bot working. I also tried the DVD, not working too.
"update-manager -d" in Karmic not working too but I will try this tonight again...

Revision history for this message
Julian Suarez (juliansuarezlopera) wrote :

so how do we get someone to pay attention to this bug? it's affecting all recent macbook pro users, and because of the similarities with the macbook I bet it is affecting that too, so I think there's a lot of people affected with this bug so we should try to get it noticed

Revision history for this message
Christopher "cv" (vchristopher) wrote :

Spam the mailing lists is my first idea what comes to mind. But I`m not going to do that, somebody else has to ruin his name ,-)

Revision history for this message
Cor Driehuis (cor3huis) wrote :

Trying to stop the driver from loading would be a first step to unravel the mistery, however adding the following bootline (F6)

noload=b43,b43-pci-bridge,ssb,b43legacy,b44 debug

Did not help :(. It could be that I'm using the wrong module name (b43 etc.) but since we cannot boot we must find the modulename via goin through kernal source ... sigh

NOTE the original bug still should be solved ofcourse. This info is soly ment to help solving the bug in the first place.

Cor Driehuis (cor3huis)
description: updated
Revision history for this message
Christopher "cv" (vchristopher) wrote :

I can happily add that updating a fresh Karmic Koala install using the "update-manager -d" command results in a working Lucid Lynx again. (describted in post #13), so this is the only way to get a Lucid Lynx working at the moment.

Revision history for this message
Julian Suarez (juliansuarezlopera) wrote :

Hi I have just found this thread that might give us a workaround to install Lucid using the LiveCD http://ubuntuforums.org/showthread.php?t=1442133&highlight=install+lucid+lynx+on+macbook+pro

Revision history for this message
Christopher "cv" (vchristopher) wrote :

Thanks, I'll try that.

Revision history for this message
Christopher "cv" (vchristopher) wrote : Re: MacBook Pro 5,1 / 5,2 / 5,3 / 5,5 fails to boot into 10.04 desktop

Thanks Cor Driehuis for updating the description, I didn't know everybody can do that ;-)

summary: - MacBook Pro 5,1 / 5,2 / 5,3 / 5,5 fails to boot into 10.04 beta1 desktop
+ MacBook Pro 5,1 / 5,2 / 5,3 / 5,5 fails to boot into 10.04 desktop
Revision history for this message
Christopher "cv" (vchristopher) wrote :

Following the forum in post #30 it seems that nouveau is the actual problem which would make sence since nouveau was NOT included in Karmic Koala 9.10

Changed in nouveau:
status: New → Confirmed
Revision history for this message
Christopher "cv" (vchristopher) wrote :

I can confirm that adding "nouveau.noaccel=1 blacklist=vga16fb" (without the ") after the quite splash in the Live CD works.
It will boot and installation works.
After that you have to install the nvidia driver and then you have to reboot.
 NOTE, IMPORTANT: the second time you report after you installed the nvidia driver, the boot will fail, you need to add this time "nouveau.noaccel=0" (NOT 1) and after that you dont have to add anything else and it will always work.
If you have any questions about this or if you would like to have this in a movie, feel free to ask me.

tags: added: noveau
removed: b43-phy0
tags: added: nouveau
removed: noveau
Changed in linux (Ubuntu):
importance: Undecided → High
Revision history for this message
Cor Driehuis (cor3huis) wrote :

BIG thanks for Christopher V. for the tips that at least made progress possible and for Chris Halse Rogers for the Undecided → High change. Now lets find some other Beta bug and report as best as we can!

Revision history for this message
Chris Halse Rogers (raof) wrote :

It looks like there might be a couple of problems here - one vga16fb related, which *might* be fixed by a change we've made in a more recent daily LiveCD, one related to nouveau's acceleration.

It would be helpful if someone could describe the behaviour of a recent livecd with “blacklist=vga16fb” and *without* “quiet splash”. Does the livecd boot? If it doesn't, how far does it get? Do you get graphical corruption?

If it boots all the way with corruption, or you can get to a VT (with blacklist=vga16fb), could *one* person please run “apport-collect 546393”

Revision history for this message
Cor Driehuis (cor3huis) wrote :

Post #36 the: "recent livecd" meaning a daily build CD of after 20100402 ?

Revision history for this message
Christopher "cv" (vchristopher) wrote :

I will try the daily-live CD tomorrow and tell you if it works without "quite splash" and with "blacklist=vga16fb", I will also post a movie online to show the bug in a better way if it boots at all.
I don't understand how this "apport-collect 546393" thing works or where to type this so this could maybe someone else please do.

Revision history for this message
Christopher "cv" (vchristopher) wrote : AlsaDevices.txt

apport information

tags: added: apport-collected
description: updated
Revision history for this message
Christopher "cv" (vchristopher) wrote : AplayDevices.txt

apport information

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in nouveau:
status: Confirmed → Fix Released
Andy Whitcroft (apw)
Changed in linux (Ubuntu Lucid):
status: New → Fix Released
importance: Undecided → High
Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Andy Whitcroft (apw)
Changed in linux (Ubuntu):
milestone: none → ubuntu-10.10
assignee: nobody → Andy Whitcroft (apw)
status: Confirmed → In Progress
Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in nouveau:
status: Fix Released → Confirmed
Changed in linux (Ubuntu):
status: Fix Released → Confirmed
summary: - MacBook Pro 5,1 / 5,2 / 5,3 / 5,5 fails to boot into 10.04 desktop
+ MacBook Pro 5,1 / 5,2 / 5,3 / 5,5 fails to boot into 12.04 desktop
Changed in linux (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Confirmed
164 comments hidden view all 244 comments
Revision history for this message
In , Jamie Macdonald (jamie-alban) wrote :

On my Macbook Pro 5,2 (early 2009) with 9400M and 9600M GT, I also have this bug. nouveau freezes the computer after kernel module load with no extra parameters.

Using nouveau.noaaccel=1, It boots with scrambled console to graphical openbox session with artifacts at the top of the screen, but openbox is not functional (I can only waive my cursor around).

Here: http://pastebin.com/4yhXK0Rt is output of dmesg after booting to commandline with nouveau.noaccel=1

Here: http://ge.tt/8Cn0b0m/v/0 is an mmiotrace & dmesg & lspci from starting openbox session with the nvidia blob.

Revision history for this message
In , Ilia Mirkin (imirkin) wrote :

*** Bug 58556 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Ilia Mirkin (imirkin) wrote :

You guys are probably all aware of this, but it seems like one solution is to have the bootloader kill the NV96 card on boot, if you're using grub2:

https://help.ubuntu.com/community/UEFIBooting#Selecting_the_graphic_card
http://askubuntu.com/questions/149921/how-to-add-a-command-permanently-to-grub2

One could also make an early quirk that does this as well based on a DMI match. I wrote up a quick patch to do that, but it's completely untested (see below). I doubt it'd be upstream-appropriate though, as it would kill the possibility of using the second card entirely.

diff --git a/arch/x86/kernel/acpi/boot.c b/arch/x86/kernel/acpi/boot.c
index 230c8ea..8cb7665 100644
--- a/arch/x86/kernel/acpi/boot.c
+++ b/arch/x86/kernel/acpi/boot.c
@@ -1357,6 +1357,12 @@ static int __init dmi_ignore_irq0_timer_override(const struct dmi_system_id *d)
        return 0;
 }

+static int __init disable_macbook_second_video(const struct dmi_system_id *d)
+{
+ outb(0, 0x750);
+ return 0;
+}
+
 /*
  * If your system is blacklisted here, but you find that acpi=force
  * works for you, please contact <email address hidden>
@@ -1432,6 +1438,15 @@ static struct dmi_system_id __initdata acpi_dmi_table[] = {
                     DMI_MATCH(DMI_PRODUCT_NAME, "TravelMate 360"),
                     },
         },
+ {
+ .callback = disable_macbook_second_video,
+ .ident = "Apple MacBook5",
+ .matches = {
+ DMI_MATCH(DMI_SYS_VENDOR, "Apple Inc."),
+ DMI_MATCH(DMI_PRODUCT_NAME, "MacBook5"),
+ },
+ },
+
        {}
 };

tags: added: needs-upstream-testing
removed: 10.04 b43 beta beta1 broken cd error install lynx mac macbookpro mbp nouveau phy pipe terminated unable unreadahead unsupported usb wireless
Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
milestone: ubuntu-10.10 → none
status: Confirmed → Incomplete
summary: - MacBook Pro 5,1 / 5,2 / 5,3 / 5,5 fails to boot into 12.04 desktop
+ 10de:0647 [MacBookPro5,2] Fails to boot into 12.04 desktop
tags: added: trusty
description: updated
description: updated
tags: added: does-not-need-any-more-upstream-testing kernel-bug-exists-upstream kernel-bug-exists-upstream-v3.12.0-7 mac macbookpro mbp nouveau
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: needs-upstrema-testing
removed: does-not-need-any-more-upstream-testing kernel-bug-exists-upstream-v3.12.0-7 mac macbookpro mbp nouveau
description: updated
description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: latest-bios-b05
Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

I've made some progress on this bug, enabling Nouveau to be loaded with acceleration enabled. However, X is **absolutely not** usable: complete garbage screen, lots of Nouveau errors, only action available is power down the computer (or reboot). But for using Nouveau with acceleration in console mode, it works fine.

There are (at least) two main problems:

* 9400M acceleration is broken (resulting in Nouveau locking up on boot);
* it seems there is a lockup when starting a working X with both cards enabled.

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Created attachment 106246
Temporary patch for 9400M GT acceleration

Could you please test this patch along with Ilia's one? It should fix acceleration on the 9400M GT, allowing you to boot without nouveau.noaccel=1 and to launch X.

I'll need to refine the patch a bit as it introduces some errors on the 9600M.
Another patch may be mandatory to get both cards to get along: for now, the laptop seems to be hitting an infinite loop when launching X with both cards enabled.

Revision history for this message
In , Rolf Offermanns (rolf-offermanns) wrote :

Pierre, the patch works for me (MacBookPro5,2). I had to modify Ilia's patch to have "MacBookPro5" in the DMI_MATCH instead of "MacBook5" and now I can boot into a KDE5 session with the nouveau driver. I checked the xorg log file and verified that it is indeed using hardware accelaration.

I used a fresh git clone of Linus tree for the test.

Let me know if you need further information.

Thanks,
Rolf

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Awesome! Thanks for testing Rolf! I tested it on my laptop, but as it sometimes behaves in a strange way, I preferred to get confirmation by at least someone else. :)

I'll see later today if I can get both cards to get along without locking up the GPU. Otherwise I'll try to get the patch into 3.17 (not sure if it's still possible).

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

*** Bug 26546 has been marked as a duplicate of this bug. ***

Revision history for this message
In , joanandk (macgyver031-web) wrote :

I confirm that the patch works, screen is NOT scrambled.
Unsing my ancient gpupwr-programm to deactivate 9600M, I am able to start xorg-x11 + fluxbox with accleration.

Pierre, thank you very much.

I have seen that vga-switcheroo does not get started, probably due to the 9600M fallen off the bus.

I cannot await your fix for 9600M with acceleration.

BR.

(In reply to comment #29)
> Created attachment 106246 [details] [review]
> Temporary patch for 9400M GT acceleration
>
> Could you please test this patch along with Ilia's one? It should fix
> acceleration on the 9400M GT, allowing you to boot without nouveau.noaccel=1
> and to launch X.
>
> I'll need to refine the patch a bit as it introduces some errors on the
> 9600M.
> Another patch may be mandatory to get both cards to get along: for now, the
> laptop seems to be hitting an infinite loop when launching X with both cards
> enabled.

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Created attachment 106803
Option for disabling acceleration for given chipset

Rather than completely disabling the discrete card, disabling the acceleration on that card also works. Use nouveau.chipsetnoaccel=0x96 in this case to disable acceleration on the 9600M GT.

Revision history for this message
In , Ilia Mirkin (imirkin) wrote :

(In reply to comment #34)
> Created attachment 106803 [details] [review]
> Option for disabling acceleration for given chipset
>
> Rather than completely disabling the discrete card, disabling the
> acceleration on that card also works. Use nouveau.chipsetnoaccel=0x96 in
> this case to disable acceleration on the 9600M GT.

How about changing noaccel instead to optionally be able to take a list of pci addresses? (Or even just one to start...) I think that would have a much higher chance of being accepted upstream.

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Created attachment 106804
Fix acceleration on 9400M

This is the minimalistic version of the previous patch.

I'll send the patches to the list, and hopefully they can still be merged into 3.17.

Revision history for this message
In , joanandk (macgyver031-web) wrote :

Hi Pierre,
Both patches seems to work (tested 1x on 3.17.rc6).

Xorg-x11 starts with fluxbox, messages show that 9600 is unacclerated and 9400 is acclerated. There is are two errors in your patch "option for disabling accleration for given chipset":
* The entries DRM_DEBUG_DRIVER are not available on 3.17.rc6, but it works either way.
* In the kernel < 3.17 it should be "if (nouveau_noaccel || !nouveau_fifo(device) /*XXX*/)" not only "if (nouveau_noaccel)"

Terminating xorg-x11 crashed, probably because I switched off discrete graphichs adapter after starting xorg. Someone else should check.

Further testing is in queue.

The previous patch you have sent: It solved a problem I had in the past: System kernel panics if the lid is closed during startup!

Thanks.

Do you think that acceleration for 9600M will be possible sometime?

BR.

(In reply to comment #36)
> This is the minimalistic version of the previous patch.

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

(In reply to comment #37)
> Hi Pierre,
> Both patches seems to work (tested 1x on 3.17.rc6).
>
> Xorg-x11 starts with fluxbox, messages show that 9600 is unacclerated and
> 9400 is acclerated. There is are two errors in your patch "option for
> disabling accleration for given chipset":
> * The entries DRM_DEBUG_DRIVER are not available on 3.17.rc6, but it works
> either way.
> * In the kernel < 3.17 it should be "if (nouveau_noaccel ||
> !nouveau_fifo(device) /*XXX*/)" not only "if (nouveau_noaccel)"
>
> Terminating xorg-x11 crashed, probably because I switched off discrete
> graphichs adapter after starting xorg. Someone else should check.
>
> Further testing is in queue.
>
> The previous patch you have sent: It solved a problem I had in the past:
> System kernel panics if the lid is closed during startup!
>
> Thanks.
>
> Do you think that acceleration for 9600M will be possible sometime?
>
> BR.
>
> (In reply to comment #36)
> > This is the minimalistic version of the previous patch.

Hi Joanand,

I based my patches on the linux-3.18 branch of Nouveau's repo, which is more up-to-date than 3.17-rc6: this explains the "if (nouveau_noaccel)" at least.

Great for the kernel panic! I noticed that using the patches, screen resumes correctly when resuming the computer, rather than staying completely black.

Well, I'll work 9600M Gt acceleration, but I can't say if I'll succeed, nor when. ;)

Best regards

Revision history for this message
In , Gurutonic (gurutonic) wrote :

Pierre,

I have tested your patch with the 9400M in my macbookpro 5,2. The card boots correctly with acceleration enabled, and loads GDM. GDM looks completely correct, but hangs on login with a cursor on a grey screen. It's possible that LXDE, KDE, or some other DE might work, but gnome-shell never loads. I will try slim/lxde when I get a chance.

At this point I can switch back to VT where I notice some nouveau errors in dmesg. Killing GDM (and x11 with it) produces a kernel panic.

Next I booted with the 9600GT with acceleration disabled. The display looks correct with efifb, but loading nouveau scrambles the VT.

Thank you for your efforts!

Revision history for this message
In , Gurutonic (gurutonic) wrote :

Created attachment 106977
dmesg 9400 w/ accel + gdm

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Hi Thomas,

(In reply to comment #39)
> Pierre,
>
> I have tested your patch with the 9400M in my macbookpro 5,2. The card boots
> correctly with acceleration enabled, and loads GDM. GDM looks completely
> correct, but hangs on login with a cursor on a grey screen. It's possible
> that LXDE, KDE, or some other DE might work, but gnome-shell never loads. I
> will try slim/lxde when I get a chance.

Oh... I didn't test with Gnome or KDE, as I'm using Awesome (which works fine). Maybe if you deactivate composing it will be better (as a temporary solution)?
I'm working on improving the patch: at the moment, it turns some bits on (enabling some features?), but the blob also writes some things (feature configuration?) before turning each bit on. So maybe finding what those things are and implementing them will fix the errors.
>
> At this point I can switch back to VT where I notice some nouveau errors in
> dmesg. Killing GDM (and x11 with it) produces a kernel panic.
>
> Next I booted with the 9600GT with acceleration disabled. The display looks
> correct with efifb, but loading nouveau scrambles the VT.

I have seen it once or twice too, but not at each boot.
On a similar note, I sometime get PDISP errors about an unknown method when loading Nouveau, but as it rarely happen, I haven't tried to fix it yet. I'll have a look at both errors later on.
>
> Thank you for your efforts!

Thanks for testing! :)

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Created attachment 107262
Fix acceleration on 9400M v2

Here is an updated version of the patch.

Thomas,
Do you still get screen corruption with it? (I can't reliably reproduce the screen corruption unfortunately.)
GDM seems to work fine on my laptop with only 9400M having acceleration enabled. I'll try with 9600M GT acceleration enabled too. :/

Revision history for this message
In , Gurutonic (gurutonic) wrote :

(In reply to Pierre Moreau from comment #42)
> Created attachment 107262 [details] [review]
> Fix acceleration on 9400M v2
>
> Here is an updated version of the patch.
>
> Thomas,
> Do you still get screen corruption with it? (I can't reliably reproduce the
> screen corruption unfortunately.)
> GDM seems to work fine on my laptop with only 9400M having acceleration
> enabled. I'll try with 9600M GT acceleration enabled too. :/

Hi Pierre,

I've applied your v2 patch and the results are similar. The 9400M works correctly. GDM loads fine, but it won't start a gnome-shell session. However, SLIM works correctly and is able to load both gnome-shell and Awesome. I'm writing this from gnome-shell now, and performance is good. I haven't had any screen corruption with the 9400M. I'll use this configuration for now and report any issues I encounter.

The 9600M GT (acceleration disabled) still has corruption in VT as before, but this time the screen blanks when X is loaded.

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

(In reply to thomas from comment #43)
> (In reply to Pierre Moreau from comment #42)
> > Created attachment 107262 [details] [review] [review]
> > Fix acceleration on 9400M v2
> >
> > Here is an updated version of the patch.
> >
> > Thomas,
> > Do you still get screen corruption with it? (I can't reliably reproduce the
> > screen corruption unfortunately.)
> > GDM seems to work fine on my laptop with only 9400M having acceleration
> > enabled. I'll try with 9600M GT acceleration enabled too. :/
>
> Hi Pierre,
>
> I've applied your v2 patch and the results are similar. The 9400M works
> correctly. GDM loads fine, but it won't start a gnome-shell session.
> However, SLIM works correctly and is able to load both gnome-shell and
> Awesome. I'm writing this from gnome-shell now, and performance is good. I
> haven't had any screen corruption with the 9400M. I'll use this
> configuration for now and report any issues I encounter.
>
> The 9600M GT (acceleration disabled) still has corruption in VT as before,
> but this time the screen blanks when X is loaded.

Hi Thomas,

Good to hear you can use gnome-shell! :)

By
> I haven't had any screen corruption with the 9400M.
do you mean with the 9600M GT completely disabled?

When using the 9600M GT without acceleration, do you have screen corruption in VT each time? If so, could you try to modify the patch a bit, like:
- removing the write to 0x100c1c;
- if removing the write doesn't work, changing the offset applied to priv->r100c08 maybe testing all 4-multiples should do it, from 0 to 28.

Revision history for this message
In , Gurutonic (gurutonic) wrote :

(In reply to Pierre Moreau from comment #44)
>
> Hi Thomas,
>
> Good to hear you can use gnome-shell! :)
>
> By
> > I haven't had any screen corruption with the 9400M.
> do you mean with the 9600M GT completely disabled?
>

I use the efi stub loader with refind bootloader. Refind doesn't have an option to use outb as in grub. I have set OSX preferences to "battery saving", so that the firmware sets up the 9400 initially, but the 9600 is still technically enabled. It shows up in lspci, etc. Whenever I test the 9600, I change the setting in OSX back to "performance". So yes, with both cards enabled, the 9400 works without corruption.

> When using the 9600M GT without acceleration, do you have screen corruption
> in VT each time? If so, could you try to modify the patch a bit, like:
> - removing the write to 0x100c1c;
> - if removing the write doesn't work, changing the offset applied to
> priv->r100c08 maybe testing all 4-multiples should do it, from 0 to 28.

I've only tested the 9600 about 10 times, but I've always had corruption. I will try your changes and see if it makes a difference.

Revision history for this message
In , Gurutonic (gurutonic) wrote :

(In reply to thomas from comment #45)
> (In reply to Pierre Moreau from comment #44)
> > When using the 9600M GT without acceleration, do you have screen corruption
> > in VT each time? If so, could you try to modify the patch a bit, like:
> > - removing the write to 0x100c1c;
> > - if removing the write doesn't work, changing the offset applied to
> > priv->r100c08 maybe testing all 4-multiples should do it, from 0 to 28.
>
> I've only tested the 9600 about 10 times, but I've always had corruption. I
> will try your changes and see if it makes a difference.

No change, unfortunately. I first removed the write, then tried each of the offsets.

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

(In reply to thomas from comment #46)
> (In reply to thomas from comment #45)
> > (In reply to Pierre Moreau from comment #44)
> > > When using the 9600M GT without acceleration, do you have screen corruption
> > > in VT each time? If so, could you try to modify the patch a bit, like:
> > > - removing the write to 0x100c1c;
> > > - if removing the write doesn't work, changing the offset applied to
> > > priv->r100c08 maybe testing all 4-multiples should do it, from 0 to 28.
> >
> > I've only tested the 9600 about 10 times, but I've always had corruption. I
> > will try your changes and see if it makes a difference.
>
> No change, unfortunately. I first removed the write, then tried each of the
> offsets.

After switching to "Higher Performances" in OS X, I understand what you were explaining to me about having both cards enabled but having corrupted screen only in one case. With that in mind, tweaking the patch can't fix the corruption as we are modifying things on the 9400M but it's the 9600M GT which is responsible for displaying; I suggest opening another bug report for that.

I'll continue working on this patch and find how to use 0x100c1c before switching to the 9600M GT.

Some side notes about what is wrong with the 9600M GT:
- screen corruption when using it to drive the display
- interrupt 0x04000000 + lockup when starting X with acceleration on for 9400M and 9600M GT, and the 9400M is driving the screen
- when powering it down using vgaswitcheroo:
  * if accel isn't enabled:
    E[ PDISP][0000:02:00.0][0xc000887d][ffff880137b94400] fini: 0x490e0008
    E[ PDISP][0000:02:00.0][0xc000887d][ffff880137b94400] failed suspend, -16
  * if accel is enabled:
    flush timeout + (interrupt 0x04000000 iirc) + lockup

Revision history for this message
In , Ratchanan Srirattanamet (peat-new) wrote :

Will Pierre Moreau's patch be merged? This patch fix acceleration on system with only 9400M too. Symptom is X can start but gets locked up when I run glxgears for a while. System is Ubuntu 14.10 with Linux 3.17 compiled from git. After apply this patch, the symptom disappear.

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

(In reply to Ratchanan Srirattanamet from comment #48)
> Will Pierre Moreau's patch be merged? This patch fix acceleration on system
> with only 9400M too. Symptom is X can start but gets locked up when I run
> glxgears for a while. System is Ubuntu 14.10 with Linux 3.17 compiled from
> git. After apply this patch, the symptom disappear.

Hi Ratchanan,

My patch wasn't merged into 3.17 as it was a bit too short before the release, plus it didn't had time to be properly tested on other machines to check if it didn't introduce some regressions; I'll use the extra time to reverse-engineer the registers I modify. However it should be able to go into 3.18 if reverse-engineering goes well.

Revision history for this message
In , joanandk (macgyver031-web) wrote :

Hi Pierre,
My Macbook Pro 5,1 died two weeks ago. The screen backlight flickered and after reboot there was no screen at all.
An attempt to find the dead chip was unsuccessful (fuse is ok) so I think after 6 years of MacBook is to move on.
It has been a fun and frustrating time with *unsupported* hardware.

I cannot be able to contribute to this project (as a tester).

Thank you so much for the support and good luck.

Revision history for this message
In , 6-j-p (6-j-p) wrote :

(In reply to Pierre Moreau from comment #49)

> My patch wasn't merged into 3.17 as it was a bit too short before the
> release, plus it didn't had time to be properly tested on other machines to
> check if it didn't introduce some regressions; I'll use the extra time to
> reverse-engineer the registers I modify. However it should be able to go
> into 3.18 if reverse-engineering goes well.

I would LOVE to see a fix for this merged into 3.18. Please let me know if I can help at all. I have a MacBook Pro 5,1 that exhibits this bug.

Revision history for this message
In , 6-j-p (6-j-p) wrote :

I have a MacBook Pro 5,1 which has two GPUs: GeForce 9600M GT and GeForce 9400M.

Here is what happens when I 'insmod nouveau' while running Linux 3.18 rc5 on my system: http://hastebin.com/qusumotusi.m

I hope that helps!

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Hi,

@Joanand
Sorry for not fixing the issue before your MBP died... I hope your next laptop will have better support.

@l3iggs
The RE revealed nothing interesting. I'll try again when I can manage to spare some time. I asked the Nvidia guys about it, it should help getting a better patch.
I guess you set 'Better Performances' in Mac OS before getting that dmesg. In that case the 9600M GT is driving the screen, and with acceleration enabled causes this issue (you can try without acceleration, but you'll get another issue ;) ). You should fill a bug report for that issue.

Revision history for this message
In , 6-j-p (6-j-p) wrote :

(In reply to Pierre Moreau from comment #53)
> @l3iggs
> The RE revealed nothing interesting. I'll try again when I can manage to
> spare some time. I asked the Nvidia guys about it, it should help getting a
> better patch.
Great, thank you for your effort here! I'm more than happy to test anything you come up with and provide any feed back I can.
> I guess you set 'Better Performances' in Mac OS before getting that dmesg.
> In that case the 9600M GT is driving the screen, and with acceleration
> enabled causes this issue (you can try without acceleration, but you'll get
> another issue ;) ). You should fill a bug report for that issue.
I actually haven't installed OSX on this machine in years. I assume it's in high performance mode. I've actually been trying to switch over to the low power GPU in my testing here with no success. So I'm not having too much success with many of the workarounds & patches posted in this thread. Am I correct in understanding that you think I should start another bug report with this trace? Does that mean this bug report is only concerned with issues when running from the 9400M then?

I'll keep trying to produce some more info relevant to this bug by working on getting switched over to my 9400M.

Does anyone know if it's possible to switch from "9600M GT mode" to "9400M mode" without using OSX? I've tried several of the mysterious outb grub directives. "outb 0x750 0" turns my screen off (I assume that's shutting off the 9600M GT) but I can't seem to enable/switch to the 9400M to get the screen back on.

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

(In reply to l3iggs from comment #54)
> (In reply to Pierre Moreau from comment #53)
> > @l3iggs
> > The RE revealed nothing interesting. I'll try again when I can manage to
> > spare some time. I asked the Nvidia guys about it, it should help getting a
> > better patch.
> Great, thank you for your effort here! I'm more than happy to test anything
> you come up with and provide any feed back I can.
> > I guess you set 'Better Performances' in Mac OS before getting that dmesg.
> > In that case the 9600M GT is driving the screen, and with acceleration
> > enabled causes this issue (you can try without acceleration, but you'll get
> > another issue ;) ). You should fill a bug report for that issue.
> I actually haven't installed OSX on this machine in years. I assume it's in
> high performance mode. I've actually been trying to switch over to the low
> power GPU in my testing here with no success. So I'm not having too much
> success with many of the workarounds & patches posted in this thread. Am I
> correct in understanding that you think I should start another bug report
> with this trace? Does that mean this bug report is only concerned with
> issues when running from the 9400M then?

I just opened a bug report for it: #86537. Everyone here has at least the 9400M, but nor necessarily the 9600M GT, and as both issues are different, it seems better to focus this one on the 9400M and open another one for the other card, rather than vice-versa.

>
> I'll keep trying to produce some more info relevant to this bug by working
> on getting switched over to my 9400M.
>
> Does anyone know if it's possible to switch from "9600M GT mode" to "9400M
> mode" without using OSX? I've tried several of the mysterious outb grub
> directives. "outb 0x750 0" turns my screen off (I assume that's shutting off
> the 9600M GT) but I can't seem to enable/switch to the 9400M to get the
> screen back on.

The gmux is probably configured differently. You can have a look at this utility https://gfx.io/ code, as it can switch from integrated to discrete, and back.

Revision history for this message
In , 6-j-p (6-j-p) wrote :

Created attachment 109963
9400M dmesg

What follows is my partially working workaround for my 9400M in my MacBook Pro 5,1. For my fully working workaround for my 9600M GT see https://bugs.freedesktop.org/show_bug.cgi?id=86537

The following was tested with a kernel 3.18-rc6 (without applying any of the patches here):

(1) Append 'modprobe.blacklist=nouveau' to the kernel boot parameters
This allows the system to boot.
(2) Once booted, as root, reset the 9400M GPU: 'echo 1 > /sys/bus/pci/devices/0000:03:00.0/reset'
(3) 'echo 1 > /sys/bus/pci/devices/0000:03:00.0/rescan'
(4) 'echo 1 > /sys/bus/pci/devices/0000:02:00.0/remove'
This completely removes the 9600M GT GPU from the system so nouveau does not use in when we load the module in the next step.
(5) 'modprobe nouveau'

where
0000:03:00.0 is the PCI address of my 9400M
and
0000:02:00.0 is the PCI address of my 9600M GT.

Nouveau seemingly loads fine for the 9400M, however I find myself unable to actually use my 9400M GPU for anything (while repeating the same above steps for my 9600M GT works fine). For example, starting gdm with the 9400M does nothing. I believe this is because the 9400M GPU is not "connected" to any display (since it was not selected in OSX). I've attached dmesg logs for loading nouveau for each of the GPUs in my laptop here. Notice that for the working 9600M GT, the log shows:
nouveau [ DRM] allocated 1440x900 fb: 0x70000, bo ffff88014750d400
1449x900 is the native resolution of my laptop's display.

while for the non-working 9400M, the log shows:
nouveau 0000:03:00.0: No connectors reported connected with modes
[drm] Cannot find any crtc or sizes - going 1024x768
nouveau [ DRM] allocated 1024x768 fb: 0x50000, bo ffff88014715a400

I think I'm pretty close to having a universal working solution for both GPUs here. Does anyone know how I can "connect" my 9400M GPU with my display?

I've tried fiddling a bit with xrandr after loading nouveau for the 9400M, but it seems to always report no displays found.

Revision history for this message
In , 6-j-p (6-j-p) wrote :

Created attachment 109964
9600M GT dmesg

Attaching dmesg for 'modprobe nouveau' for 9600M GT

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Created attachment 110350
[Patch] Fix acceleration on 9400M v4

This should be the final verson of this patch, thanks to answers given by the Nvidia guys.

Please check that you can use the NVAC with acceleration. If you want to start X or power off the NV96 (if you have one), you will either need to deactivate acceleration for it (noaccel=0000:02:00.0) or use the trick describe by l3iggs **before** loading Nouveau.

Revision history for this message
In , 6-j-p (6-j-p) wrote :

(In reply to Pierre Moreau from comment #58)
> Created attachment 110350 [details] [review]
> [Patch] Fix acceleration on 9400M v4
>
> This should be the final verson of this patch, thanks to answers given by
> the Nvidia guys.
>
> Please check that you can use the NVAC with acceleration. If you want to
> start X or power off the NV96 (if you have one), you will either need to
> deactivate acceleration for it (noaccel=0000:02:00.0) or use the trick
> describe by l3iggs **before** loading Nouveau.

Thanks very much for your work on this Pierre (and thanks to your Nvidia contacts too). With your previous patch, my NVAC was able to start a fully accelerated gnome session via X, although it was very unstable and was quite unusable (however, weston seemed to work fine for me with that patch). With this latest patch, things seem quite stable. I'm writing this from a google-chrome browser in gnome-shell/X and generally things seem to be working so far.

~l3iggs

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Created attachment 110376
[Patch v4.5] Enable non-isometric poller

Sorry, there is a new version of the patch to test.
The fix is still the same, but it integrates better with the rest of the code. It still works on my laptop but it is best to have some more reports.

Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Patch was merged. I'll close the bug report once a version containing the patch is released.

Changed in linux (Ubuntu):
assignee: nobody → kirby reyes (kirbyreyes121)
status: Incomplete → Confirmed
Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

Patch is now present in 3.19-rc4, closing this bug report as solved.

For those who have the NV96 along the NVAC, you need to use l3iggs technique and reset+rescan (echo 1 > /sys/bus/pci/devices/0000:02:00.0/{reset,rescan}) the NV96 **before** loading Nouveau to avoid a hang when starting X and another hang when trying to power off the NV96.

Mathew Hodson (mhodson)
Changed in nouveau:
importance: Undecided → Unknown
status: Confirmed → Unknown
Mathew Hodson (mhodson)
tags: added: needs-upstream-testing
removed: needs-upstrema-testing
Changed in linux (Ubuntu):
assignee: kirby reyes (kirbyreyes121) → nobody
Mathew Hodson (mhodson)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Mathew Hodson (mhodson)
affects: linux (Fedora) → linux
Mathew Hodson (mhodson)
tags: removed: kernel-bug-exists-upstream
Mathew Hodson (mhodson)
Changed in linux:
status: New → Incomplete
Revision history for this message
In , Pierre-morrow (pierre-morrow) wrote :

For those with a dual card setup (NVAC + NV96), you should follow bug 86537 if you want updates on fixing the NV96. Unfortunately there hasn't been much progress, apart from finding that changing some register's value makes it work (most likely by disabling some things, so it is not a valid fix).

Changed in nouveau:
importance: Unknown → Critical
status: Unknown → Fix Released
Mathew Hodson (mhodson)
no longer affects: linux (Ubuntu Lucid)
affects: linux → ubuntu
no longer affects: ubuntu
Revision history for this message
Mathew Hodson (mhodson) wrote :

Upstream bug indicates that this issue doesn't occur anymore.

affects: linux (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Invalid
affects: xserver-xorg-video-nouveau (Ubuntu) → linux (Ubuntu)
Displaying first 40 and last 40 comments. View all 244 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.