Intel Pro/Wireless 4965 AG or AGN stopped working in kernel 2.6.32-17

Bug #545708 reported by Roger on 2010-03-24
108
This bug affects 22 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Michael

Bug Description

This on a fully updated Lucid amd64 system:

My Intel Pro/Wireless 4965 AG or AGN suddenly stopped working after an upgrade to the generic 2.6.32-17 kernel. It used to work flawlessly, with the iwlagn module, up until (and including) 2.6.32-16. It seems NetworkManager thinks there's still a connection, but there really isn't. Disconnecting and reconnecting, I can sometimes get it to work again, but only for a few seconds - sometimes even fractions of a second, it seems. Also, this is easily reproducible: it happens whenever I boot into the 2.6.32-17 generic 64-bit kernel.

A few details:

ifconfig:

wlan0 Link encap:Ethernet HWaddr 00:1f:3b:59:03:83
          inet addr:192.168.0.199 Bcast:192.168.0.255 Mask:255.255.255.0
          inet6 addr: fe80::21f:3bff:fe59:383/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:312 errors:0 dropped:0 overruns:0 frame:0
          TX packets:769 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:259528 (259.5 KB) TX bytes:77698 (77.6 KB)

iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:"dlink"
          Mode:Managed Frequency:2.472 GHz Access Point: 00:1C:F0:B8:C2:21
          Bit Rate=1 Mb/s Tx-Power=15 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=70/70 Signal level=-30 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

lshw -C network

 *-network
       description: Wireless interface
       product: PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:10:00.0
       logical name: wlan0
       version: 61
       serial: 00:1f:3b:59:03:83
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn ip=192.168.0.199 latency=0 multicast=yes wireless=IEEE 802.11abgn
       resources: irq:30 memory:e4000000-e4001fff

And this is the network related stuff I could find in dmesg up until wireless had stopped working:

[ 24.049175] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27k
[ 24.049178] iwlagn: Copyright(c) 2003-2009 Intel Corporation
[ 24.049259] iwlagn 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 24.049267] iwlagn 0000:10:00.0: setting latency timer to 64
[ 24.049315] iwlagn 0000:10:00.0: Detected Intel Wireless WiFi Link 4965AGN REV=0x4
[ 24.070484] cfg80211: World regulatory domain updated:
[ 24.070487] (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 24.070490] (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 24.070492] (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 24.070494] (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 24.070496] (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 24.070498] (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

[ 24.127098] iwlagn 0000:10:00.0: Tunable channels: 13 802.11bg, 19 802.11a channels
[ 24.127169] alloc irq_desc for 30 on node -1
[ 24.127171] alloc kstat_irqs on node -1
[ 24.127193] iwlagn 0000:10:00.0: irq 30 for MSI/MSI-X

[ 25.120957] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 25.122037] iwlagn 0000:10:00.0: firmware: requesting iwlwifi-4965-2.ucode
[ 25.183775] iwlagn 0000:10:00.0: loaded firmware version 228.61.2.24

[ 60.270216] wlan0: deauthenticating from 00:1c:f0:b8:c2:21 by local choice (reason=3)
[ 60.270259] wlan0: direct probe to AP 00:1c:f0:b8:c2:21 (try 1)
[ 60.472537] wlan0: direct probe to AP 00:1c:f0:b8:c2:21 (try 2)
[ 60.476985] wlan0: direct probe responded
[ 60.476988] wlan0: authenticate with AP 00:1c:f0:b8:c2:21 (try 1)
[ 60.478737] wlan0: authenticated
[ 60.478758] wlan0: associate with AP 00:1c:f0:b8:c2:21 (try 1)
[ 60.482453] wlan0: RX AssocResp from 00:1c:f0:b8:c2:21 (capab=0x431 status=0 aid=2)
[ 60.482456] wlan0: associated
[ 60.488850] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 70.810051] wlan0: no IPv6 routers present
[ 407.032288] iwlagn 0000:10:00.0: iwl_tx_agg_start on ra = 00:1c:f0:b8:c2:21 tid = 0
[ 657.257865] CE: hpet increasing min_delta_ns to 15000 nsec

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: roger 1693 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe8044000 irq 17'
   Mixer name : 'Analog Devices AD1981'
   Components : 'HDA:11d41981,103c30c3,00100200 HDA:14f12c06,103c1379,00100000'
   Controls : 11
   Simple ctrls : 9
Date: Wed Mar 24 04:47:05 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=4b34ab31-af73-4156-8fba-a6b31706ae4f
MachineType: Hewlett-Packard HP Compaq 8710p
NonfreeKernelModules: nvidia
Package: linux-image-2.6.32-17-generic 2.6.32-17.26
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   3.3V 16-bit PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-17-generic root=UUID=a760888c-a4a1-4227-b961-772270dc9654 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Regression: Yes
RelatedPackageVersions: linux-firmware 1.33
Reproducible: Yes
SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-17-generic x86_64
WpaSupplicantLog:

dmi.bios.date: 04/14/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68MAD Ver. F.0C
dmi.board.name: 30C3
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 73.31
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68MADVer.F.0C:bd04/14/2008:svnHewlett-Packard:pnHPCompaq8710p:pvrF.0C:rvnHewlett-Packard:rn30C3:rvrKBCVersion73.31:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP Compaq 8710p
dmi.product.version: F.0C
dmi.sys.vendor: Hewlett-Packard

Roger (r-wiberg) wrote :
Michael (mike984) wrote :

I'm having the same issue. I have a similar set up too. Using Ubuntu Lucid 64bit on HP dv6000 series laptop with Intel 4965 AGN. Wireless worked fine in 2.6.32-16 and once I updated to 2.6.32-17 - no wireless. The wireless icon at the top says it is connect to my LAN but you cannot access any web pages or devices on the network. Also, I noticed that it even has trouble displaying the home folder in Nautilus - seems very slow. I have to boot into 2.6.32-16.

Ben Romer (bromer) wrote :

Having the same problem on Sony Vaio NR498 with Intel 4965. It was working fine with the previous kernel.

Roger (r-wiberg) wrote :

I "solved" this by compiling the bleeding-edge compat-wireless drivers from wireless.kernel.org. Have a look at http://linuxwireless.org/en/users/Download for instructions.

In the short run, this probably means that the problem is going to go away once the linux-backports-modules-wireless-2.6.32-17-generic package is built and installed (uninstall the compat-wireless drivers before installing this package) . In the slightly longer run, it would be nice if an updated iwlagn module could be included in the generic kernel proper before release.

Michael (mike984) wrote :

Roger, Does this mean that this capability used to be included in the generic kernel and now it isn't? I don't have any backports installed at the moment.

Thanks

Dylan McCall (dylanmccall) wrote :

Same issue here on 32 bit.

There is a connection for a while, from what I've found; I can ping my router and get a response, and even load a few web pages. However, it's very very slow. (NM Applet says the network speed is 1mb/s).

A bit of struggling later, it loses connection completely and, as you've observed, NM Applet still claims to be connected. (I can then disconnect, reconnect and repeat the horrible process, or restart with the old kernel).

Graham (graham-morris) wrote :

I can confirm this issue on Ubuntu 10.04 amd64 / Dell XPS M1330 / Intel Wireless 4965.

Exactly the same complaint: I can connect and begin browsing, but as soon as any real load is placed on the card it drops. The problem only started after the recent kernel update to 2.6.32-17.

Graham (graham-morris) wrote :

Just a quick update in case it helps diagnose and solve the problem. The problem does not occur if I connect to an unsecured wireless access point.

darylb (darylblanc) wrote :

I'm seeing the same issue with 2.6.32-17. Booting the 2.6.32-16 kernel allows wireless to work again. Marking as confirmed.

$ lspci | grep Wireless
06:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

Changed in linux (Ubuntu):
status: New → Confirmed
summary: - Inte Pro/Wireless 4965 AG or AGN stopped working in kernel 2.6.32-17
+ Intel Pro/Wireless 4965 AG or AGN stopped working in kernel 2.6.32-17

Same problem here.

It seems that when I choose wep instead of wpa the wireless works.
I haven't tested that over a longer period, so it could be that it works only for å little while (as it did with wpa cryptation).
Wep is not an option since it gives to little security.

I hope this problem will be solved soon since I love Ubuntu 10.04.

My machine: Acer Aspire 5920G with Intel Pro/wireless 4965 AGN

Petr (petr-skocek) wrote :

Same issue for me, connected for few seconds and then "freeze". HP DV6700, Kubuntu Lucid. Happen with latest kernel only. Pretty annoying as I have to use cable now, any workaround? :)

I tried to follow the Roger's instructions (#4). Now I'm a newbie and probably didn't go about it 100%, but it worked for me. Now I can use the wireless again.

It did fall out when i closed the lid on my laptop. Probably a powerdown lag on the wireless card cause it worked again after a minutte or two.

I use the 32bit system by the way.

Prime3869 (prime3869) wrote :

I was having the same issue described in the OP. I'm running 10.04 32bit with all the latest updates on a Dell Latitude D630 and Intel 4965. I use WPA2 with AES and default settings on TX power and such. I tried everything on my card that I could think of and after all of that, I changed my Linksys WRT320N to wireless G only rather than the default mixed (ABGN) mode. I have NO disconnects since. Not one.

Michael (mike984) wrote :

Seems to be ok with today's update to 2.6.32-18.

Ben Romer (bromer) wrote :

Working here so far on 2.6.32-18 64-bit, with the wireless backport installed.

Graham (graham-morris) wrote :

It is fine for me on 2.6.32-18

Michael (mike984) on 2010-04-01
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
sillyxone (sillyxone) wrote :

I'm still having this problem on 10.04 release (2.6.32-21 32bit), 4965 AG. Connect fine to unsecured network. Can authenticate and connect to WPA2 (PEAP, MSCHAPv2) but connection is slow (stays at 1Mbps). I tried swcrypto=1 for iwlagn but doesn't solve the problem.

Been using Hardy for the last three years, no problem on the same wireless networks, until upgrading to Lucid yesterday.

sillyxone (sillyxone) wrote :

tried Wicd, thinking it could be NetworkManager problem, but didn't help.

switched to ndiswrapper. The latest XP driver from Intel (13.1.1.1) doesn't work with ndiswrapper 1.55 (util 1.9). Found an old driver (12.1.0.14) from Asus (http://www.download3k.com/Drivers/Network/Asus/Download-Asus-Intel-4965-WiFi-Wireless-LAN-Driver.html), ndiswrapper works fine with it. The connection is stable and very fast now (130Mbps).

Note: I had no problem with WPA-Personal at home last night (was still using iwlagn), so the problem seems to only happen with WPA2-Enterprise.

sillyxone (sillyxone) wrote :

sorry, my problem is best described by bug #548992

Asterix1423 (2cops) wrote :

Ik have the same problem here. I own a HP Compaq 8710w, with Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61).

Websurfing is possible, with hick-ups. Speeds constantly goes up and down. Downloading is almost impossible. Speeds drop to zero.
This is not a specific Ubuntu issue. I tried openSuse, Mandriva and Pardus Linux on this rigg. All with the same problems. There is something very wrong in the latest kernels, concerning this wireless chip. It worked ok until Ubuntu 9.10 showed up. From that moment on it became worse and worse.

Asterix1423 (2cops) wrote :

Oh.. forgot to mention: I use Ubuntu 10.04 at the moment.

Saint DanBert (saintdanbert) wrote :

See bug #604175. It seems to speak to similar issues.

I have posted comments about my situation and a syslog extract under that other bug.

~~~ 0;-Dan

Rykel from Singapore (rykel98) wrote :

Hi, Intel PRO/Wireless 4965 AG or AGN [Kedron] is NOT working well in kernel 2.6.32-24-generic-pae. It can see the networks around it, but connect to none of them. I am running Ubuntu Lucid on Dell XPS M1330 if this info is useful.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers