lucid iwlagn free more than tfds_in_queue

Bug #545585 reported by Steffen Rusitschka
124
This bug affects 23 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Stefan Bader
linux-2.6 (Debian)
Fix Released
Unknown

Bug Description

on lucid beta 1 my connection drops completely for approx a minute or degrades to 1 mbit/s

this may be related to http://bugs.archlinux.org/task/18735 and/or http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=574526 which seem to make wpa2 responsible for the problem...

kern.log is flooded with "free more than tfds_in_queue" messages

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rusi 1745 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf1000000 irq 22'
   Mixer name : 'IDT 92HD73C1X5'
   Components : 'HDA:111d7675,102802bd,00100103'
   Controls : 16
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xcfeec000 irq 17'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed Mar 24 00:19:36 2010
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=38e84f57-d19f-47e4-b9b1-9752de70b1a1
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Dell Inc. Studio 1557
Package: linux-image (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-17-generic root=UUID=46a74632-c62d-4013-bb2b-e947599b9434 ro quiet splash
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Regression: Yes
RelatedPackageVersions: linux-firmware 1.33
Reproducible: Yes
SourcePackage: linux
TestedUpstream: Yes
Uname: Linux 2.6.32-17-generic i686
dmi.bios.date: 03/02/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0KM426
dmi.board.vendor: Dell Inc.
dmi.board.version: A04
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A04
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd03/02/2010:svnDellInc.:pnStudio1557:pvrA04:rvnDellInc.:rn0KM426:rvrA04:cvnDellInc.:ct8:cvrA04:
dmi.product.name: Studio 1557
dmi.product.version: A04
dmi.sys.vendor: Dell Inc.

Revision history for this message
Steffen Rusitschka (rusi) wrote :
Revision history for this message
Tobias Wolf (towolf) wrote :

Confirmed, it has DOS proportions here. My kern.log is already at 700MB and rsyslog is taking nearly one core at full CPU.

Revision history for this message
Tobias Wolf (towolf) wrote :

grep -c tfds_in_queue /var/log/syslog
5194725

uptime
 01:04:16 up 5:16, 5 users, load average: 0.04, 0.03, 0.00

Tobias Wolf (towolf)
Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Carsten (carsten-tschense) wrote :

Same for me. Happened after update from 2.6.32-16 to 2.6.32-17.

Revision history for this message
Munzir Taha (منذر طه) (munzirtaha) wrote :

I guess this patch should fix it
https://patchwork.kernel.org/patch/86722/

Revision history for this message
Stefan Bader (smb) wrote :

I am preparing a test kernel for the message issue. This probably does not fix any continuous drops and reconnects. Those I would continue on https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/544254 to keep things separated.

Changed in linux (Ubuntu):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Undecided → Medium
status: Confirmed → In Progress
Revision history for this message
Stefan Bader (smb) wrote :

Ok, test kernels have been uploaded to http://people.canonical.com/~smb/lp545585/ Please test and give feedback here. Thanks you.

Revision history for this message
Carsten (carsten-tschense) wrote :

Works for me! Messages are gone.

Revision history for this message
Steffen Rusitschka (rusi) wrote :

works here, too!

Revision history for this message
Adrian (urobythos) wrote :

Works for me =]

Revision history for this message
bravebearman (bernie-haverkamps) wrote :

Me too! Only real issue I have had so far ;)

Stefan Bader (smb)
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-18.27

---------------
linux (2.6.32-18.27) lucid; urgency=low

  [ Chase Douglas ]

  * SAUCE: Don't register vga16fb framebuffer if other framebuffers are
    present
    - LP: #527369

  [ Loïc Minier ]

  * [Config] armel/versatile: Set CRAMFS=m
    - LP: #524893
  * [Config] armel: Reset default command-line
    - LP: #524893

  [ Stefan Bader ]

  * build/modules: Update d-i to reflect recent config changes
    - LP: #546929

  [ Upstream Kernel Changes ]

  * (pre-stable) drm/nouveau: report unknown connector state if lid closed
    - LP: #523072
  * (pre-stable) Staging: rt2870: Add USB ID for Buffalo Airstation
    WLI-UC-GN
    - LP: #441990
  * (pre-stable) iwlwifi: fix nfreed--
    - LP: #545585
  * (pre-stable) pata_via: Add VIA VX900 support
    - LP: #548675
 -- Stefan Bader <email address hidden> Fri, 26 Mar 2010 18:39:42 +0100

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux-2.6 (Debian):
status: Unknown → Confirmed
Changed in linux-2.6 (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.