Lucid on Asus EEE PC 901 and 1000H fails to connect to any wireless network

Bug #545443 reported by Johan Ehnberg on 2010-03-23
230
This bug affects 46 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Johan Ehnberg

Bug Description

Binary package hint: network-manager

This may also belong to linux.

My Asus EEE PC 901 running lucid beta1 live cd from USB cannot connect to any WLAN network, protected or not. The same network works with the installed system (9.10), and with another computer running mythbuntu 10.04 beta1. Network manager tries to connect but fails after a timeout.

ProblemType: Bug
Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
Date: Tue Mar 23 22:47:22 2010
DistroRelease: Ubuntu 10.04
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 10.0.0.0/24 dev eth0 proto kernel scope link src 10.0.0.110 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
 default via 10.0.0.1 dev eth0 proto static
Keyfiles: Error: [Errno 2] No such file or directory
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
Package: network-manager 0.8-0ubuntu2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: network-manager
Uname: Linux 2.6.32-16-generic i686

Johan Ehnberg (johan-ehnberg) wrote :
Johan Ehnberg (johan-ehnberg) wrote :

I have to add that I did get it to connect once, but trying to connect again immediately after failed. I tried to reproduce this seemingly random success (simply boot from clean live USB with wired plugged in, and connect as soon as the desktop is available) but failed.

I have exactly the same problem.
I have a eee PC 1000H

sazmer (sazmer) wrote :

I also am experiencing this problem with 1000H.
I noticed though that by turning the network on and off using the eee shortcut (either Fn+F2 or just clicking the eee icon in the taskbar) I can make it work. Sometimes at the first try, just now at the 10th try..

Johan Ehnberg (johan-ehnberg) wrote :

We have confirmed this bug. I wonder how many affected EEE PC:s are being tested with lucid, because this could be pretty serious if it affects all 901 and 1000H (and other models?).

Changed in network-manager (Ubuntu):
status: New → Confirmed
Johan Ehnberg (johan-ehnberg) wrote :

I tried manually with iwconfig and dhclient to rule out NetworkManager, and confirmed it still happens. It seems setting the ESSID does not work correctly, only succeeding around one out of 5-10 times.

Here's a quick test command that I used:
sudo killall dhclient; sudo ifconfig wlan0 down; sleep 1; sudo ifconfig wlan0 up; sleep 1; sudo iwconfig wlan0 essid Wippies ap 0A:1D:19:AE:D2:B5; sleep 1; sudo iwconfig; sudo dhclient wlan0

- When the ESSID is not set the command exits normally but dhclient gets no address.
- When the ESSID is set correctly, dhclient gets an address and everything else works.

affects: network-manager (Ubuntu) → linux (Ubuntu)
Johan Ehnberg (johan-ehnberg) wrote :

This still happens in Beta 2. Can we narrow it down to this specific PCI ID?

RaLink RT2860 [1814:0781] with Subsystem: RaLink Device [1814:2790]

summary: - Lucid Beta 1 on Asus EEE PC 901 Fails to connect to any wireless network
+ Lucid on Asus EEE PC 901 Fails to connect to any wireless network
summary: - Lucid on Asus EEE PC 901 Fails to connect to any wireless network
+ Lucid on Asus EEE PC 901 and 1000H fails to connect to any wireless
+ network
tommyasplund (tommy-asplund) wrote :

I also have this problem in updated Beta 2 on Asus eee pc 901.

Ian Smith (m4r35n357) wrote :

Confirmed (me too), eeepc 901, lucid beta 2, no connection whatsoever.

AFonseca (ajcf89) wrote :

The funny thing here is that Lubuntu's latest beta works flawlessly for me in terms of wireless networks. Strange, heh?

I'm using an EeePC 901 by the way.

Johan Ehnberg (johan-ehnberg) wrote :

With the latest updates today, I was able to connect to every network I managed to find (1 unprotected with WDA, 1 unprotected rather typical AP from TP-LINK, 1 unprotected in hotel mode with web authentication, 1 WPA/WPA2 protected private network). Rinsed and repeated each network a few times. Fingers crossed, this may be fixed. Can those of you who experience the same confirm?

Johan Ehnberg (johan-ehnberg) wrote :

Correction: any non-protected network works. After that, protected networks also seem to work mostly. Connecting to a protected network as the first network works as often/seldom as before.

Ian Smith (m4r35n357) wrote :

Well it's the day before release, this is clearly not going to be fixed :(

Atasa (rossios) wrote :

I confirm this bug on eeepc 1000H so sad... (it was working before)

don caffrey (don-caffrey) wrote :

To confirm, the original bug report states that this problem occurred while using the beta on a USB live CD. Does the problem also occur with the full install? I am running the full install on my Eee PC 901 which has the same Ralink RT2860, Ralink device 2790 and the wireless connection works great for everything, secure, unsecure, WEP, WPA.

My full install was a clean wipe but I also ran the beta as an upgrade and that worked as well.

I'm setting up a thumb drive to run the live CD and test that on my 901 now.

SnackAdmiral (snackadmiral) wrote :

I just upgraded to 10.04 and I am experiencing this problem on my eepc 1000.
Symptoms are identical to original report - connected once, for about 5 minutes, on the first boot after upgrade. Has not worked since.

Confirmed after full install of 10.04 LTS on EEEPC 901. Everything seemingly works fine, but trying to connect (WPA2) I get repeated timeouts. Now and then, tho, it'll connect, but those are rare occasions. Apparently it works a bit better with unprotected networks.

Changed in linux (Ubuntu):
assignee: nobody → Ubuntu Kernel Network Team (ubuntu-kernel-network)
Changed in linux (Ubuntu):
assignee: Ubuntu Kernel Network Team (ubuntu-kernel-network) → nobody
Johnathan Lugo (johnlugo) wrote :

I'm affected by this as well i'm using a ASUS Eee PC 1201T i can connect through LAN no problem but the wireless is still jumpy. It lets me see other networks but can't connect.

njsf (nelson-ferreira) wrote :

Confirm on EeePC 901.
Cannot connect to WAP2 network on 10.04 LTS at all, previously working on 9.10.
Keeps asking for the network password.
I can connect to open networks.

njsf (nelson-ferreira) wrote :

I just managed to get it working reliably by choosing to use only WPA2 Personal and AES for encryption on my LinkSys router instead of WPA2 Personal with TKIP+AES.

I have the same trouble, even after a clean install. I have a Eee PC 1000HE.

h1repp (heinz-repp) wrote :

confirming for a fresh install of Lucid final Ubuntu Netbook Edition with latest updates on my EeePC 1000H: trying to connect to different WLANs with known valid WPA keys leads to repeated timeouts and failure to connect. Could we provide any further data to narrow down the cause of this severe bug?

Ian Smith (m4r35n357) wrote :

Confirmed that eliminating TKIP from the access point config cured the problem, now just using WPA2/AES. Fortunately I have control over the access point. Also fortunately my Debian machine set up using TKIP still works with CCMP allowed.

Shame such a horrible regression on such common hardware went unacknowledged for so long . . . still there is a workaround, I think.

josel777 (josel777) wrote :

Add me to the list. The WIFI on my EEE 1000H is not working ever since I installed Ubuntu 10.04. This was a clean install.

Hajo (h-meyer) wrote :

This bug is not related to "mixed mode WPA/WPA2 secured wireless networks". It appears on pure WPA2 or WEP secured networks, too.

Confirmed also on MSI Wind U120 with:

02:00.0 Network controller: RaLink RT2860

Keeps trying to connect and asking for the password. Worked perfectly on 9.10.

Elton Woo (elton-woo) wrote :

There are currently two fixes that work:
Ricardo Salvetri's patched kernel
http://rsalveti.net/pub/ubuntu/kernel/lucid/linux-image-2.6.32-21-generic_2.6.32-21.32rsalveti1_i386.deb
or:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33.3-lucid/

Both work for me on my Asus EEE 1000 PC. I have the 2.6.33.3 kernel installed.

frankernet (frankernet) wrote :

unfortunately the kernel above does not work with eeepc 1000H :-(

Elton Woo (elton-woo) wrote :

@ frankernet: which one? an update in the channel broke the salvetri fix, so I installed the 2.6.33 one instead. You can get the RaLink drivers here: http://www.ralinktech.com/support.php?s=2. The ubuntuforums networking section might help you, too ... or look at the comments posted in (the duplicate of this bug) #496093

Marc Poulhiès (marc-poulhies) wrote :

I have an eeepc 901 and can't connect to WEP wlan. It was working fine with karmic, but since the update to lucid, I haven't been able to connect to my lab's wlan (WEP). I can connect to WPA or unprotected wlans.

I can't modify network settings as I don't own the AP and I did not test with another WEP network as they tend to disapear (expect in my lab...)

I tried various "fix" without luck. In particular, I installed 2.6.33 from rsalveti & kernel-ppa. I also installed drivers from ralink.

I'm not commenting in the "duplicate" parent, as I have no problem connecting to WPA networks...

Elton Woo (elton-woo) wrote :

@ Marc Poulhiès: I myself am running Lucid on an EEE 1000 PC. You would do well to look at the postings in the Networking section of ubuntuforums.org. I'm sure you'll find the solution there. I've also posted on how I did a clean install of Lucid on the netbook.

Marc Poulhiès (marc-poulhies) wrote :

Elton: Thanks. But The lucid I'm using IS a fresh install, so doing a clean install won't fix my problem... I'll read the forums (again), but I'm a bit disappointed here...

frits (f-j-a-m-suurmeijer) wrote :

Same problem here on Asus Eee 1000H with fresh install Mint 9 with updates. It worked only once and very short. Tried after that with Live USB Mint 9 Isadora and Peppermint. All based on Lucid. Wireless networks are shown, but it does not work after giving password.

On the Asus Eee 1005HA it works without any problem.

Eee PC901 - Netbook Remix. Upgraded to Lucid when it came out of beta.
I hadn't updated for a while. Today everything was perfect until I did an update. Previous to that I had the internal WiFi as well as an external WiFi dongle working perfectly. Now try as I may I can't get anything to connect - except once it did connect after a while but that was it, have tried lots of stuff to try to get it working to no avail. Works OK on ethernet.
I had Jolicloud on a USB stick. I tried that and it connected no bother - so definitely not a hardware problem.
Hope something is sorted soon. :-(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers