Ubuntu

Suspend fails to resume on Dell 8600 / ATI video

Reported by Stuart Bishop on 2010-03-23
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

With Lucid beta, my Dell Inspiron 8600 with ATI Radeon Mobility 9600 graphics no longer resumes after a suspend. The screen stays black.

This may be a duplicate of Bug #361853. However, that bug report is for an nvidia chipset so I've opened a fresh bug.

Suspend / Resume was last known to work with Jaunty.

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: stub 1585 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'I82801DBICH4'/'Intel 82801DB-ICH4 with STAC9750,51 at irq 7'
   Mixer name : 'SigmaTel STAC9750,51'
   Components : 'AC97a:83847650'
   Controls : 36
   Simple ctrls : 23
Date: Tue Mar 23 15:51:14 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=94038095-e250-4fe2-bc83-bbfe9ddd311d
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 413c:8000 Dell Computer Corp. BC02 Bluetooth Adapter
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Computer Corporation Inspiron 8600
Package: linux-image-2.6.32-16-generic 2.6.32-16.25
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=fbf6b96d-3d38-4f78-a57b-6ec7ea8b55ac ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.33
Reproducible: Yes
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 06/30/2005
dmi.bios.vendor: Dell Computer Corporation
dmi.bios.version: A14
dmi.board.name: 0Y4572
dmi.board.vendor: Dell Computer Corporation
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Computer Corporation
dmi.modalias: dmi:bvnDellComputerCorporation:bvrA14:bd06/30/2005:svnDellComputerCorporation:pnInspiron8600:pvr:rvnDellComputerCorporation:rn0Y4572:rvr:cvnDellComputerCorporation:ct8:cvr:
dmi.product.name: Inspiron 8600
dmi.sys.vendor: Dell Computer Corporation

Stuart Bishop (stub) wrote :
Martin Spacek (mspacek) wrote :

I'm having the same problem on my Thinkpad T41 with Radeon Mobility 9000 (RV250) GPU. This is a problem that showed up in lucid, but wasn't present in karmic. Resume seems to work, backlight turns on right away (I can even control the backlight level), but I either get:

1) A black screen
2) A screen that starts out mostly dark, but then a sort of marbled pattern emerges on screen that gets progressively brighter over a minute or two, until the whole screen is basically white. Very strange.

There's no mouse cursor visible. From the fan and the heat, I think the CPU is at 100%. I can't switch to another TTY using ctrl-alt-F1 or any other F key. I have to do a hard shutdown. Once or twice I managed to shut down normally using dead reckoning with the mouse, or by simply pressing the power button for a short while (this presumably brought up the shut down dialog box), and then hitting enter.

Sometimes when I reboot after a hard shutdown, the network manager starts up with networking disabled for some reason, and I have to manually re-enable it.

Changed in linux (Ubuntu):
status: New → Confirmed
Martin Spacek (mspacek) wrote :

By the way, resuming from hibernation works fine for me. Also, unlocking the locked machine works fine.

I added the ati xorg driver as affected, since that seemed reasonable. Please correct me if I'm wrong. I'm happy to provide any logs or try other kernels or drivers that anyone might suggest.

Tormod Volden (tormodvolden) wrote :

Can you please try a 2.6.34 snapshot from the kernel mainline PPA? https://wiki.ubuntu.com/KernelTeam/MainlineBuilds

Martin Spacek (mspacek) wrote :

After a bit more testing, I've noticed some further subtleties. When I get a black screen (as opposed to the weird marbled one that gets brighter and brighter) on resume from suspend, I do in fact get a mouse cursor. What's more, the mouse switches to a text insertion "I" bar when I hover it over the spot where the password entry box should be displayed. Also, it doesn't seem the CPU is being loaded - no hot air blowing out. Finally, with the black screen I can switch to another TTY. None of this is possible when I get the weird marbled screen.

Stuart Bishop (stub) wrote :

Same behavior with 2.6.34 snapshot from 25/3/2010. Screen remains black.

Tormod Volden (tormodvolden) wrote :

Martin, I have the exact same symptoms as in your black screen case, in bug 548377, plus I get an error flood when switching to the console. This was solved by using the 2.6.34 snapshot.

Martin Spacek (mspacek) wrote :

Tormod, I just tried the /daily/current snapshot (2.6.34 from 2010-03-25), and I can't seem to boot with it. Not even in recovery mode. I get a screen of log messages that stop at about 0.4 seconds at "kernel_thread_helper" or "? uart_send_xchar" or "? uart_register_driver", and then I have to do a hard reset. Same goes for the next most recent snapshot (2.6.34. from 2010-03-15). Maybe I'm doing something wrong.

I also just did a big update (~100MB), which included some plymouth stuff. Now I get a plymouth error on bootup with the normal 2.6.32-17 kernel. I've also noticed that sometimes when I get the black screen on resume, I might not get the mouse cursor or the ability to switch TTYs.

Stuart Bishop (stub) wrote :

@Martin - you might want to open a fresh bug. Your symptoms do not sound like mine and you are using different a different laptop with a different graphics chipset.

LinuxfanGDA (astucatti) wrote :

The same problem with ATI Radeon mobility X700 on my notebook AND Ubuntu 9.10 Karmic.

After suspend mode, no login screen, no video signal on display. Only Shutdown totally and restart helps.

hi all, i have the same issue on my Dell Xps 1647 with ubuntu 2.6.32-25-generic 64bit. I have 1gb ATI card.

tags: removed: regression-potential

Stuart Bishop, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

tags: added: resume suspend
affects: xserver-xorg-driver-ati → null
Changed in null:
status: New → Invalid
tags: added: regression-release
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Stuart Bishop (stub) wrote :

No longer have a working 8600 here

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers