[RS600] video freeze with KMS (X and plymouth) (upstream patches available)

Bug #544590 reported by Rafi on 2010-03-22
52
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Lucid
High
Manoj Iyer

Bug Description

SRU justification:

Impact: The function interfaceof this adapter is missing suspend and resume hooks. This causes hangs after suspend.

Fix: Included in 2.6.34 upstream. Adds missing hooks.

Testcase: Suspend/resume cycle with affected hardware.

---

Binary package hint: xorg

Screen goes black without nomodeset boot parameter.

This occurs both with plymouth and X (booted with plymouth removed).

This occurs with the installer kernel, the initially installed kernel and the currently loaded multitouch kernel.

I have also tested on a debian unstable installation with a bleeding edge kernel (2.6.34-rc2). KMS did work in that environment, though I should probably test again to verify.

ProblemType: Bug
Architecture: amd64
Date: Mon Mar 22 18:12:42 2010
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
EcryptfsInUse: Yes
MachineType: Dell Inc. Latitude XT
Package: xorg 1:7.5+3ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=bcaf68d1-10af-4f74-bb07-0428122643ed ro nomodeset
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=zsh
ProcVersionSignature: Ubuntu 2.6.32-16.26~multitouch3-generic
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
Uname: Linux 2.6.32-16-generic x86_64
dmi.bios.date: 01/12/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd01/12/2010:svnDellInc.:pnLatitudeXT:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude XT
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-16-generic

Rafi (rafi-seas) wrote :

Hi Rafi,
avivotool can be used to assist in debugging this issue. avivotool is provided with the radeontool package, so to install it run:

    sudo apt-get install radeontool

After installing it, you run it like this:

    avivotool regs all > regdump_good.txt
    avivotool regs all > regdump_broke.txt

Run it two times. Once when you have a working screen (for any driver), and once in the broken case (either from the tty console or logged into the sick box remotely). Attach both of those to this bug report, and we can then forward this issue upstream. Thanks ahead of time!

affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
summary: - video freeze with KMS (X and plymouth) RadeonRadeon Xpress 1250
+ [RS600] video freeze with KMS (X and plymouth)
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
Robert Hooker (sarvatt) wrote :

This commit for the kernel is the fix for these RS600's that cannot boot with KMS

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=32b3c2abaf8c61c80a8b02071c73f05252122ffe

affects: xserver-xorg-video-ati (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Simple enough patch, severe enough issue. Looks worth an SRU for Lucid.

Changed in linux (Ubuntu Lucid):
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

This commit also looks worth pulling for RS600 fixing: http://lists.freedesktop.org/archives/dri-devel/2010-April/000094.html

summary: - [RS600] video freeze with KMS (X and plymouth)
+ [RS600] video freeze with KMS (X and plymouth) (upstream patches
+ available)
Jim Gettys (jg-laptop) wrote :

This happens to me on my Dell Latitude XT.

Xavi (x-sanz35) wrote :

I also have and RS600 as a graphics cards, and I also run into problem always installing ubuntu 10.04, when I run a live session from cd all is ok, but when I do an install, it doesn't boots. Also when I did a 9.10 -> 10.04 update.

So with this fix problem will be solved?

I should perform a clean install, or updating from ubuntu 9.10?

Robert Hooker (sarvatt) wrote :

The commit bryce mentioned in comment #5 is in 2.6.33.3

tags: added: kernel-graphics kernel-reviewed
Manoj Iyer (manjo) on 2010-06-04
Changed in linux (Ubuntu Lucid):
assignee: nobody → Manoj Iyer (manjo)
Manoj Iyer (manjo) wrote :

Can you please try the lucid kernel with the patch in

http://people.canonical.com/~manjo/lp544590-lucid/

and report back here? If that works I will submit SRU for lucid.

Changed in linux (Ubuntu Lucid):
status: Triaged → Incomplete
silo4321 (silo4321) wrote :

This has fixed my problem.

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Xpress 1250

before using the patched kernel it would only boot with radeon.modeset=0

Manoj Iyer (manjo) wrote :

Patch submitted for SRU in lucid.

Stefan Bader (smb) wrote :

Fix is upstream and was included in 2.6.34. The stable tree for 2.6.33.y is expected to get discontinued soon. So this is a fix might not come back via any upstream stable update.

Changed in linux (Ubuntu Lucid):
status: Incomplete → Fix Committed
description: updated
Stefan Bader (smb) wrote :

Fix was part of 2.6.34 and is included in Maverick.

Changed in linux (Ubuntu):
status: Triaged → Fix Released

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I've been experiencing this bug too, on an integrated Radeon HD 2100:

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon 2100

The fix from proposed seems to have solved it.

R4v3n (philippe-raven) on 2010-06-17
Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
madbiologist (me-again) on 2010-06-18
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (25.2 KiB)

This bug was fixed in the package linux - 2.6.32-23.37

---------------
linux (2.6.32-23.37) lucid-proposed; urgency=low

  [ Alex Deucher ]

  * SAUCE: drm/radeon/kms/atom: fix dual-link DVI on DCE3.2/4.0
    - LP: #564559

  [ Andy Whitcroft ]

  * [Config] ports -- build in dm-mod to enable LVM boot
    - LP: #560717
  * tools -- fix perf version extraction for multi-part flavours
    - LP: #555130
  * SAUCE: ACPI: EC: Allow multibyte access to EC (v3)
    - LP: #526354
  * [Config] enforce -- ensure dm_mod is built-in for LVM
    - LP: #560717
  * update to ubuntu-debian:7e708d33054c373faf41da23b73e8b48c342d958
    - LP: #570500, #576274

  [ Chase Douglas ]

  * Revert "(pre-stable): input: ALPS - Add signature for HP Pavilion dm3
    laptops"
    - LP: #550625
  * Enable ftrace function profiler
    - LP: #570389
  * enforce CONFIG_TMPFS_POSIX_ACL=y
    - LP: #575940

  [ Leann Ogasawara ]

  * Revert "staging/comdi -- disable"
    - LP: #563436
  * [Config] Enable multicast routing for sparc
    - LP: #416266
  * [Config] Add ahci.ko to virtual sub-flavour
    - LP: #570542

  [ Stefan Bader ]

  * Revert "SAUCE: drm/i915: Disable FBC on 915GM and 945GM"
    - LP: #588832

  [ Tim Gardner ]

  * ubuntu: rtl8192se -- update to version 0015.0127.2010
    - LP: #567016
  * [Config] Add atl1c to nic-modules udeb
    - LP: #557130

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) iwlwifi: fix nfreed--"
    - LP: #575853
  * Revert "backlight: mbp_nvidia_bl - add five more MacBook variants"
    - LP: #575853
  * Revert "(pre-stable) pata_via: Add VIA VX900 support"
    - LP: #575853
  * Revert "(pre-stable) x86-32, resume: do a global tlb flush in S4
    resume"
    - LP: #575853
  * Revert "x86: disable IOMMUs on kernel crash"
    - LP: #575853
  * Revert "sunrpc: fix peername failed on closed listener"
    - LP: #575853
  * Revert "sunrpc: move the close processing after do recvfrom method"
    - LP: #575853
  * Revert "(pre-stable) drm/edid: allow certain bogus edids to hit a fixup
    path rather than fail"
    - LP: #575853
  * Revert "drm/radeon/kms: don't print error on -ERESTARTSYS."
    - LP: #575853
  * Revert "ath9k: fix lockdep warning when unloading module" on stable
    kernels
    - LP: #588832
  * Staging: comedi: removed "depricated" from COMEDI_CB_BLOCK
    - LP: #483343
  * fat: fix buffer overflow in vfat_create_shortname()
    - LP: #575853
  * xfs: simplify inode teardown
    - LP: #575853
  * xfs: fix mmap_sem/iolock inversion in xfs_free_eofblocks
    - LP: #575853
  * xfs: I/O completion handlers must use NOFS allocations
    - LP: #575853
  * xfs: Wrapped journal record corruption on read at recovery
    - LP: #575853
  * xfs: Fix error return for fallocate() on XFS
    - LP: #575853
  * xfs: check for not fully initialized inodes in xfs_ireclaim
    - LP: #575853
  * xfs: fix timestamp handling in xfs_setattr
    - LP: #575853
  * xfs: Don't flush stale inodes
    - LP: #575853
  * xfs: Ensure we force all busy extents in range to disk
    - LP: #575853
  * xfs: reclaim inodes under a write lock
    - LP: #575853
  * xfs: Avoid inodes in reclaim when flushing from inode cache
    - LP: #575853
  * xfs: recla...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers