Wifi broken for Toshiba Satellite M500 series with RTL 8192 (r8192se_pci driver)

Bug #544485 reported by Daniel G. Taylor on 2010-03-22
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Canonical Kernel Team

Bug Description

The wireless driver shipped with the current Lucid Beta 1 will find some (but not all) wireless networks and allow you to connect but will not allow traffic to be sent and you will be kicked off within seconds/minutes.

Installing the latest driver from:

http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PFid=48&Level=5&Conn=4&ProdID=230&DownTypeID=3&GetDown=false&Downloads=true

Fixes the issue. Workaround instructions for anybody else experiencing this issue:

Download driver package
sudo apt-get install build-essential
tar -xvzf rtl8192*
cd rtl8192*
sudo make
sudo rmmod r8192se_pci
sudo ./wlan0up

Because of the way the drivers are installed in Ubuntu doing a sudo make install doesn't seem to help, on reboot you will need to perform the rmmod and wlan0up scripts again.

Please update or backport the driver as it is required for the wireless to work out of the box!

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dan 1609 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf4800000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,1179ffc9,00100004'
   Controls : 18
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xf3080000 irq 16'
   Mixer name : 'Nvidia ID b'
   Components : 'HDA:10de000b,10de0101,00100100'
   Controls : 0
   Simple ctrls : 0
Card1.Amixer.values:

CheckboxSubmission: 05aca13fc6016f1ef7d0b36968d248b8
CheckboxSystem: b1865df84255b8716d3bcc269ff410d1
Date: Mon Mar 22 16:30:42 2010
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=f25a2512-018e-45c1-ab12-3584cabe8d0e
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
MachineType: TOSHIBA Satellite M500
NonfreeKernelModules: nvidia
Package: linux-image (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=0547fa6c-751a-42aa-b7dd-f2623ec4172f ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Regression: No
RelatedPackageVersions: linux-firmware 1.32
Reproducible: Yes
RfKill:

SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 01/28/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.60
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: JPTR
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.60
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.60:bd01/28/2010:svnTOSHIBA:pnSatelliteM500:pvrPSMLMU-03M008:rvnTOSHIBA:rnJPTR:rvr1.60:cvnTOSHIBA:ct9:cvrToBeFilledByO.E.M.:
dmi.product.name: Satellite M500
dmi.product.version: PSMLMU-03M008
dmi.sys.vendor: TOSHIBA

Matt Price (matt-price) wrote :

Similar problem on my lenovo thinkpad T410; my workaround was to upgrade to the mainline 2.6.33 deb in the kernel-ppa repository and make/make install as above. Seems to wrk fine on reboot. At least this should be available as a dkms package; unfortunately I can't get dkms to build on my tree or I would post a package to a ppa.

relevant section of lspci -vv:

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8172 (rev 10)
        Subsystem: Realtek Semiconductor Co., Ltd. Device e020
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 17
        Region 0: I/O ports at 2000 [size=256]
        Region 1: Memory at f2400000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: rtl819xSE
        Kernel modules: r8192se_pci

thanks,
matt

Matt Price (matt-price) wrote :

I managed to get the dkms package to build in the end; in order to post it to a ppa I needed to rebuild it with debuild -S so I could get a valid changes file (should I be able to do that directly with dkms?); I've just now posted it to my newly-created ppa, and hile the package hasn't appeared yet it should be accessible here in the next couple of hours:

https://launchpad.net/~matt-price/+archive/mattprice

Im not sure whehter it wil work with the ubuntu kernels as rtl8192 is included in that tree; any advice from the kernel team on how to proceed?

Alex Maverick (maverickalex) wrote :

Same issue on the new ThinkPad Edge 13 (AMD Version).

However, now stock kernel wireless driver is loaded, but something stops it from operate

I can see WiFi networks around, but can not connect.

Still need to use the original driver from tar.gz from Realtek site and make/make install (or copy firmware).

Sad thing that after kernel is upgraded it needs to be done again...

It would be nice the original driver is included into stock kernel.

It seems all peeps who use that chip based wireless cards suffer.

Michael Skov (mupost) wrote :

I have the same problem on my toshiba satellite L500 laptop

lshw -c network

 *-network
       description: Wireless interface
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:14:00.0
       logical name: wlan0
       version: 10
       serial: 70:1a:04:0d:51:52
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl819xSE driverversion=0014.0115.2010 firmware=62 latency=0 multicast=yes wireless=802.11bgn
       resources: irq:19 ioport:4000(size=256) memory:f2200000-f2203fff

Alex Maverick (maverickalex) wrote :

Hey guys, anyone has any good news on progress?

Changed in linux (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
Alex Maverick (maverickalex) wrote :

Soon is release. People suffer. Same stuff works well when mixed whith the other distros.

There are a lot of people who affected by this bug or what ever.

Please do anything!

The problem migrates from the release to release.

Time to finish with it finally.

Changed in linux (Ubuntu):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Richard.Downes (rdownes-uk) wrote :

Migration from Karmic to Lucid has broken the Realtek wireless driver. Previously, following the "unclaimed driver" fix in the forums had resolved the problem for me on my Msi Wind U130 netbook. When I check my wireless adapter it does not appear in the networking settings. Has anyone else had this problem and if so can someone guide me to the solution?

Brad Philips (bradphilips) wrote :

I am also affected by this bug. I was able to get around it (somehow) in Beta 2 and RC1 by installing the driver into /lib/modules/'uname -r'/kernel/drivers/net and running depmod -a and copying the firmware to the /lib/firmware. This also worked for reboots, but when I upgraded to the Final; this is now broken again. Problem is, though I did a lot of attempts before I got it to work and I cant really remember what I did. I think the kernel driver is somehow overriding the installed version. And as stated before, the only solution seems to be either:

rmmod r8192se_pci
insmod /lib/modules/'uname -r'/kernel/drivers/net/r8192se_pci.ko

or run the ./wlan0down - up scripts.

BTW.. I also tried the make install which installs it to /lib/modules/'uname -r'/kernel/drivers/net/wireless. Does anyone know the right location for this??

Has anyone tried blacklisting the kernel driver? I don't know if this will also blacklist the installed driver too; but I think I'll try it and write the outcome in this issue.. I've been working with linux for awhile, but still a little bit of a newbie in the kernel world...: )

Brad Philips (bradphilips) wrote :

Alright!! The blacklist of the kernel module worked..well sorta. What I had to do was this:

In /etc/modprobe.d/blacklist.conf add the following under (comment is just for docs):

# r8192se_pci is a bad/old driver (Ubuntu: #544485)
blacklist r8192se_pci

do the make/make install to install the driver. Now, what you have to do is rename the module so that the blacklist doesn't blacklist it too:

cd /lib/modules/'uname -r'/kernel/drivers/net/wireless/
sudo mv r8192se_pci.ko r8192.ko
sudo depmod -a

On the next reboot the driver should be loaded.. :) Now if I only get the CIFS shutdown hang fixed, I'll have a workable system.. :)

Anyway, hope this helps some people. This is obviously a temporary solution until the updated driver gets in the kernel or ubuntu provides an update to fix this.. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers