Please blacklist i830 from Kernel mode-setting

Bug #542208 reported by John Nogatch on 2010-03-19
104
This bug affects 15 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Andy Whitcroft
Lucid
Critical
Andy Whitcroft

Bug Description

Please add i830 (8086:3577) to the kernel drm KMS blacklist.

Testing has shown that KMS support for the i830 chipset is inadequate, often resulting in a regression where the system hangs during boot up. While the issues have been reported upstream, solutions seem not soon forthcoming. Testers have found that booting with i915.modeset=0 generally tends to restore the system functionality.

[Original Report]
Dell C400 with Intel 82830 CGC, booting
lucid 2.6.32-16-generic causes screen to flash
several times and graphics are then hung
with blank screen and no cursor. No response
to ctrl-alt-F1. Backlight eventually turns off
and then comes back when Shift is pressed.
Remote login with ssh works OK.

ProblemType: Bug
Architecture: i386
Date: Fri Mar 19 13:58:31 2010
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Dell Computer Corporation Latitude C400
Package: xorg 1:7.5+3ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=958089fb-1b14-440d-865b-6188671382e0 ro quiet splash quiet
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 08/02/2002
dmi.bios.vendor: Dell Computer Corporation
dmi.bios.version: A06
dmi.board.name: Latitude C400
dmi.board.vendor: Dell Computer Corporation
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Computer Corporation
dmi.modalias: dmi:bvnDellComputerCorporation:bvrA06:bd08/02/2002:svnDellComputerCorporation:pnLatitudeC400:pvr:rvnDellComputerCorporation:rnLatitudeC400:rvr:cvnDellComputerCorporation:ct8:cvr:
dmi.product.name: Latitude C400
dmi.sys.vendor: Dell Computer Corporation
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-16-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82830 CGC [Chipset Graphics Controller] [8086:3577] (rev 04)
     Subsystem: Dell Device [1028:00c8]

John Nogatch (jnogatch) wrote :
Bryce Harrington (bryce) on 2010-03-20
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Bryce Harrington (bryce) on 2010-03-20
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
John Nogatch (jnogatch) wrote :

Additional info:
1. ctrl-alt-F1 apparently does work, but the screen remains blank. After ctrl-alt-F1, "username\n password\n sudo reboot\n" does cause a reboot. It appears that the system is working, but the screen is displaying black on black after graphics mode is entered.

2. Booting older release 2.6.31-20-generic does succeed in bringing up graphics. I thought that I had tried this release previously, and that it had not worked. I have installed several updates since then.

In summary, in 2.6.32-16 graphics screen goes blank after initial boot messages, but now appears to work OK in 2.6.31-20.

Bryce Harrington (bryce) on 2010-03-22
tags: added: black-screen

Can you please try booting with i915.modeset=0 added to grub and see if there are any issues with that? We are looking at defaulting 8xx series GPU's to that option which should fix your issue and your feedback would be appreciated.

summary: - graphics hang blank screen on lucid boot
+ [i830] graphics hang blank screen on lucid boot
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
importance: Medium → High
Download full text (3.1 KiB)

Which line are we supposed to add it on, just to be sure? Is it the one with
linux and splash or the one with initrd?

On the one with initrd, there was no effect.

On the one with linux, ro and splash, Adding it changes my framebuffer font
go away and the ubuntu loader logo disappeared. No X.

Is there any commands/documents I can look at to retrieve more logs for you?

On Tue, Mar 23, 2010 at 1:44 AM, Robert Hooker <email address hidden> wrote:

> Can you please try booting with i915.modeset=0 added to grub and see if
> there are any issues with that? We are looking at defaulting 8xx series
> GPU's to that option which should fix your issue and your feedback would
> be appreciated.
>
> ** Summary changed:
>
> - graphics hang blank screen on lucid boot
> + [i830] graphics hang blank screen on lucid boot
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Importance: Medium => High
>
> --
> [i830] graphics hang blank screen on lucid boot
> https://bugs.launchpad.net/bugs/542208
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-intel” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: xorg
>
> Dell C400 with Intel 82830 CGC, booting
> lucid 2.6.32-16-generic causes screen to flash
> several times and graphics are then hung
> with blank screen and no cursor. No response
> to ctrl-alt-F1. Backlight eventually turns off
> and then comes back when Shift is pressed.
> Remote login with ssh works OK.
>
> ProblemType: Bug
> Architecture: i386
> Date: Fri Mar 19 13:58:31 2010
> DistroRelease: Ubuntu 10.04
> DkmsStatus: Error: [Errno 2] No such file or directory
> Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> MachineType: Dell Computer Corporation Latitude C400
> Package: xorg 1:7.5+3ubuntu1
> PccardctlIdent:
> Socket 0:
> no product info available
> PccardctlStatus:
> Socket 0:
> no card
> ProcCmdLine: root=UUID=958089fb-1b14-440d-865b-6188671382e0 ro quiet splash
> quiet
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
> SourcePackage: xorg
> Symptom: display
> Title: Xorg freeze
> Uname: Linux 2.6.32-16-generic i686
> dmi.bios.date: 08/02/2002
> dmi.bios.vendor: Dell Computer Corporation
> dmi.bios.version: A06
> dmi.board.name: Latitude C400
> dmi.board.vendor: Dell Computer Corporation
> dmi.chassis.type: 8
> dmi.chassis.vendor: Dell Computer Corporation
> dmi.modalias:
> dmi:bvnDellComputerCorporation:bvrA06:bd08/02/2002:svnDellComputerCorporation:pnLatitudeC400:pvr:rvnDellComputerCorporation:rnLatitudeC400:rvr:cvnDellComputerCorporation:ct8:cvr:
> dmi.product.name: Latitude C400
> dmi.sys.vendor: Dell Computer Corporation
> system:
> distro: Ubuntu
> codename: lucid
> architecture: i686
> kernel: 2.6.32-16-generic
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/542208/+subsc...

Read more...

Yes, adding "i915.modset=0" to the "kernel..." line allows 2.6.32-16-generic to start graphics successfully on Dell C400.

I had tried "i915.modeset=0 nomodeset" last week, and it had not worked at that time. I have installed updates several times since then.

I also see that starting without "i915.modeset=0" causes the black screen to flash white approximately once per second. This is different than what was previously seen, i.e. black screen only.

How can I make this parameter the default? I have not yet found how to do that in "info grub".

Where is "i915" documented?

Bryce Harrington (bryce) on 2010-03-24
description: updated
Rola (pabswiss) wrote :

Have the same problems since karmic, but only when system started with an external monitor plugged in. I noticed that downgrading kernel then fixed that issue (but brought up many new ones).Now I was trying to install Lucid, and since gnome loaded I had white flickering and kind of "drunken-view-mode", which made the system barely usable. Switching off KMS made the miracle! Installing now.

BTW... what negative consequences can disabling KMS have other than losing plymouth boot screen?

John Nogatch (jnogatch) wrote :

In order to make it the default setting, I added the "i915..." option to this line in /boot/grub/menu.lst
kernel /boot/vmlinuz-2.6.32-16-generic root=UUID=958089fb-1b14-440d-865b-6188671382e0 ro splash quiet i915.modeset=0

This workaround solves the graphics startup problem.

I had the same issue on a Macbook2,1. Adding "i915.modeset=0" worked for me as well.

Bryce Harrington (bryce) wrote :

Alright well sounds like perhaps we should blacklist i830 from kms.

However, I've just now uploaded a new -intel which has cherrypicks for fixing several 8xx bugs. No idea if any will fix this bug (most likely not), but would be worthwhile to test just in case.

Please test -intel_2.9.1-3ubuntu1 and let us know if it resolves the issue or not. If it does not, then we will go through with a blacklist to force UMS for this hardware.

solved with 2.9.1-3ubuntu1... still a lot of i830 bugs remain

Bryce Harrington (bryce) wrote :

Well that's good news. John, do you concur this particular issue is resolved with 2.9.1-3ubuntu1?

John Nogatch (jnogatch) wrote :

I still find it necessary to use "i915.modeset=0" with 2.6.31-generic, xserver-xorg-video-intel 2:2.9.1-3ubuntu1

I installed all available updates yesterday on a Dell C400 and the initial bug is solved.
I don't say that it looks pretty booting (way too little colours) and that it is like it should be (dithering problem)
also the console flickers and UNR doesn't work ... but the machine doesn't hang with a blank
screen anymore (but is still unusable though).

jerrylamos (jerrylamos) wrote :

All available updates on Thinkpad R31 i830 failed.

i915.modeset=0

worked!

I'd really recommend blacklisting i830, i845, and ati Radeon Mobility 7500 from KMS with default i915.modeset=0 on the intel's and radeon.modeset=0 on the ati.

Of four systems, only one that's not screwed up with Lucid Beta 1 is ati Radeon Express 200. All four did work with Lucid Alpha 3.

Jerry

jerrylamos (jerrylamos) wrote :

Finally saw hints to replace "nomodeset" with "i915,modeset=0" and i830 is now running.

I'd recommend "i915.modeset=0" be default for both i830 and i845 since there's been persistent disabling X failures over Lucid, Karmic, Jaunty, ... On Beta even ati Mobility 7500 failed which required "radeon.modeset=0".

Three out of my four test pc's were disabled by Beta until these commands were put into /etc/default/grub. i830 wouldn't even boot in "recovery" mode; I did "ssh" from another pc to make the changes.

Also there doesn't appear to be any way to communicate to us Beta users that there's been a change and "nomodeset" has been replaced by "i915.modeset=0", or if there was a concerted effort to tell us I missed it.

Thanks to the Lucid forums (Yay!), I'm running again.

Jerry

@Bryce @John, sorry, I just double-checked and

GNOME login
with 2.6.32-17 / 2.6.32-19 + xserver-xorg-video-intel_2.9.1-3ubuntu1
I only get a really messed up screen with i915.modeset=0, without modeset just the boot to black screen.

with 2.6.31-21, xserver-xorg-video-intel_2.9.1-3ubuntu1 and modeset it works,

Ubuntu Netbook Remix login
the only usable configutation is 2.6.31-21 without modeset. (with modeset it freezes when loading the netbook screen)

Bryce Harrington (bryce) on 2010-04-07
summary: - [i830] graphics hang blank screen on lucid boot
+ Please blacklist i830 from Kernel mode-setting
Changed in xserver-xorg-video-intel (Ubuntu):
importance: High → Critical
milestone: none → ubuntu-10.04
status: Incomplete → Triaged
assignee: nobody → Andy Whitcroft (apw)
Bryce Harrington (bryce) on 2010-04-08
description: updated
Bryce Harrington (bryce) wrote :

Alright, I'm convinced. Let's focus one bug report per chip, for accounting purposes. It's likely that if/when fixes come they'll be done for chips individually.

While it sounds like KMS works for some i830 users, non-KMS should also work for them, so this blacklisting will result in more total cases booting ok.

Perhaps we may get fixes for i830 in time for release, but i8xx is not a high priority upstream, and so I think I'd rather blacklist it into a working state and then if/when we get a patch to undo the blacklist, than to leave it as is and risk forgetting about it in the pell mell of final release.

Andy - for testing purposes what would people do to unblacklist? Will i915.modeset=1 do it, or would they need to remove a line from the blacklist file, or patch a kernel?

affects: xserver-xorg-video-intel (Ubuntu Lucid) → linux (Ubuntu Lucid)
Andy Whitcroft (apw) wrote :

@Bryce --- the patches I have for blacklisting effectivly invert the default. i915.modeset=1 should do the trick.

Andy Whitcroft (apw) on 2010-04-09
Changed in linux (Ubuntu Lucid):
status: Triaged → In Progress
Bryce Harrington (bryce) wrote :

I wish we had more testing evidence to base this decision on, but I've posted a kernel bug report requesting KMS disablement on three of the older 8xx cards: lp #563277

We've already sent up a fair plentitude of bug reports to upstream, so I'm hopeful that they'll come up with fixes to this and to KMS, so we can re-enable in meerkat, or maybe even in 10.04.1, but we'll have to see how things go.

This is an unfortunate situation. There are users with 830 chips who are impacted by a regressions in stability in the current x stack when running 3d and KMS.

We have opted for a "stability first" approach for these users. We will disable 3D and KMS for these chips in Lucid final release. This will have the unfortunate effect of disabling compiz. This will introduce a functional regression. So we will be sacrificing functionality for these users in favor of stability. This is a painful choice to make, but we feel that stability must trump functionality when we are forced to make such choices.

We will be pursuing functional fixes. However, we will do this outside the main release, for example in a PPA. If we are able to provide a fix that delivers stability and functionality, we will consider this a potential SRU in 10.04.1.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-21.32

---------------
linux (2.6.32-21.32) lucid; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: i915 KMS -- support disabling KMS for known broken devices
    - LP: #563277
  * SAUCE: i915 KMS -- blacklist i830
    - LP: #542208, #563277
  * SAUCE: i915 KMS -- blacklist i845g
    - LP: #541492, #563277
  * SAUCE: i915 KMS -- blacklist i855
    - LP: #511001, #541511, #563277
  * SAUCE: radeon KMS -- support disabling KMS for known broken devices
    - LP: #546743
  * SAUCE: radeon KMS -- blacklist ES1000
    - LP: #546743
 -- Andy Whitcroft <email address hidden> Thu, 15 Apr 2010 17:18:49 +0100

Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Released
Stan Behrens (sbehrens) wrote :

Hallo everyone,

I am not able to use my Sony Vaio VGN-B1VP without adding i915.modeset=1 to the Kernel Commandline. If I am going to try to boot it without that setting the Laptop freezes as soon as the X-Server comes up. It is impossible the switch to VT, use the SysRQ-Keys (e.g. Alt-Print-R for Reboot) or login remotely via OpenSSH.

Here is the interesting part of lspci -vvnn:
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)
 Subsystem: Sony Corporation Device [104d:8192]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
 Latency: 0
 Interrupt: pin A routed to IRQ 9
 Region 0: Memory at e8000000 (32-bit, prefetchable) [size=128M]
 Region 1: Memory at e0000000 (32-bit, non-prefetchable) [size=512K]
 Region 2: I/O ports at 1800 [size=8]
 Capabilities: [d0] Power Management version 1
  Flags: PMEClk- DSI+ D1+ D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: i915
 Kernel modules: i915

I am sorry for you that keeping KMS disabled for every i855 chipset is not the best choice you could have made.

Bye, Stan.

Nathaniel Wilson (dubrict) wrote :

I am having problems with the 830m chipset in my dell 2600, using the release version of lucid. adding "i915.modeset=0" does not solve anything, nor does "nomodeset." (using both doesn't work either.) Plymouth is flickering like crazy and kind of looks like an old TV set with a loose connection, and when it gets to the desktop it looks like just a small part of it is visible but stretched out, and there are several horizontal lines through it. The colors are way off as well.

As described above is what happens with the live CD. I tried installing with wubi, and that won't even load GDM without spitting out errors all over the place. I'll try a few things like updating firmware and I'll try to pull some logs out of this mess.

jerrylamos (jerrylamos) wrote :

i830 on my Thinkpad R31 is only stable on Lucid if I do:
boot in recovery mode
select root prompt
nano /etc/X11/xorg.conf
Section "Device"
 Identifier "Configured Video Device"
 Driver "vesa"
EndSection
Ctrl-o
Ctrl-x
reboot

Now I also see I have in /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 i915.nomodeset=0 quiet"

Do sudo gedit /etc/default/grub to make those changes
save
quit
sudo update-grub

I don't remember who recommended the ipb6.disable=1

Whatever, with both those it's working (but watch out for the dread update)

Jerry

Same issue for me installing ubuntu 10.04.1 on Sony Vaio B1VP. Solved using i915.modeset=1 on boot (press F6 to edit kernel options).

O-Zone

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers