Ubuntu

[RV515] [LENOVO T60] external screen display shows "shivering", horizontal refresh offset

Reported by Mathieu Trudel-Lapierre on 2010-03-18
238
This bug affects 42 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: xorg

As described, the external display shows massive horizontal offsetting (shivering of some sort) between lines. See http://www.youtube.com/watch?v=8Ky9Yk3pNuI

The effect on actual legibility of the screen depends on resolution and refresh rate. Tested on two independent T60s by swapping the hard drive.

ProblemType: Bug
Architecture: i386
Date: Thu Mar 18 11:53:22 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: LENOVO 2623D6U
Package: xorg 1:7.5+3ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=8a9bc647-d729-45f0-bc68-51b0b137e213 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_CA.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: xorg
Symptom: display
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 09/12/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 79ETE3WW (2.23 )
dmi.board.name: 2623D6U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr79ETE3WW(2.23):bd09/12/2008:svnLENOVO:pn2623D6U:pvrThinkPadT60:rvnLENOVO:rn2623D6U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2623D6U
dmi.product.version: ThinkPad T60
dmi.sys.vendor: LENOVO
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-16-generic

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M52 [Mobility Radeon X1300] [1002:7149]

Created an attachment (id=32218)
Kernel log for 2.6.32 (working)

Created an attachment (id=32219)
Kernel log for 2.6.33-rc1 (flickering)

Created an attachment (id=32220)
xrandr output with 2.6.32

Created an attachment (id=32221)
xrandr output with 2.6.33-rc1

Created an attachment (id=32222)
Xorg output with 2.6.32

Created an attachment (id=32223)
Xorg output with 2.6.33-rc1

There are actually two bugs here:

1. missing edid on lvds

It appears we are selecting a different i2c line in 2.6.33. I think I know where the problem is. Can you attach your video bios? (as root):
cd /sys/bus/pci/devices/<pci bus id>
echo 1 > rom
cat rom > /tmp/vbios.rom
echo 0 > rom

2. flickering on VGA

Does loading radeon with new_pll=1 fix this problem?

Created an attachment (id=32230)
M76 video BIOS

(In reply to comment #7)
> There are actually two bugs here:
>
> 1. missing edid on lvds
>
> It appears we are selecting a different i2c line in 2.6.33. I think I know
> where the problem is. Can you attach your video bios? (as root):

Attached.

> 2. flickering on VGA
>
> Does loading radeon with new_pll=1 fix this problem?

It's enabled by default. Will try with 0.

new_pll=0 does not work. This is the internal panel:

-[drm:radeon_compute_pll_avivo], 71000 84.1, 2, 16
+[drm:radeon_compute_pll], PLL freq 71000 2 1023
 executing set pll
 executing set crtc timing
 [drm] LVDS-13: set mode 1280x800 2e

and this is the external monitor (different one, since I'm at home)

-[drm:radeon_compute_pll_avivo], 108000 88.0, 2, 11
+[drm:radeon_compute_pll], PLL freq 108000 2 1023
 executing set pll
 executing set crtc timing
 [drm] TV-9: set mode 1280x1024 2d

Visual result is the same. For reference 2.6.32 says:

[drm:radeon_compute_pll], PLL freq 108000 2 1023
executing set pll
executing set crtc timing
[drm] TV-9: set mode 1280x1024 2e

[drm:radeon_compute_pll], PLL freq 71000 2 1023
executing set pll
executing set crtc timing
[drm] LVDS-13: set mode 1280x800 2f

I can attached the complete logs with debug enabled if needed.

I've bisected both problems.

The flickering is causes by:

279b215ecb8acc735c01ac89b1aa28c4a27dcafa is the first bad commit
commit 279b215ecb8acc735c01ac89b1aa28c4a27dcafa
Author: Alex Deucher <email address hidden>
Date: Tue Dec 8 14:07:03 2009 -0500

    drm/radeon/kms: make sure ss id matches

    entries in the ss table aren't always ordered
    by id.

    Signed-off-by: Alex Deucher <email address hidden>
    Signed-off-by: Dave Airlie <email address hidden>

While the missing EDID on LVDS points to:

d3f420d1089169fb48366e1aa750bdd92db0a04b is the first bad commit
commit d3f420d1089169fb48366e1aa750bdd92db0a04b
Author: Alex Deucher <email address hidden>
Date: Tue Dec 8 14:30:49 2009 -0500

    drm/radeon/kms: make sure i2c id matches

    Entries in the i2c table aren't always ordered
    by id. This allows us to remove some quirks
    that are no longer needed.

    Signed-off-by: Alex Deucher <email address hidden>
    Signed-off-by: Dave Airlie <email address hidden>

Created an attachment (id=32336)
add missing breaks

This patch should fix it.

(In reply to comment #12)
> Created an attachment (id=32336) [details]
> add missing breaks
>
> This patch should fix it.

The EDID is back, the flickering is still there, but I think I see the problem.
The old code used "id" as offset into the asSS_Info array; now this is the PPLL_SS_Info table on my M76:

data_table 0000ae26 #12 (PPLL_SS_Info):

  Size 000c
  Format Rev. 01
  Param Rev. 00
  Content Rev. 02

  00000000: 1e00 0101 2a01 0202 ....*...

  0000: ATOM_COMMON_TABLE_HEADER sHeader :
    0000: USHORT usStructureSize = 0x000c (12)
    0002: UCHAR ucTableFormatRevision = 0x01 (1)
    0003: UCHAR ucTableContentRevision = 0x02 (2)
  0004: ATOM_SPREAD_SPECTRUM_ASSIGNMENT asSS_Info [0] :
    0004: USHORT usSpreadSpectrumPercentage = 0x001e (30)
    0006: UCHAR ucSpreadSpectrumType = 0x01 (1)
    0007: UCHAR ucSS_Step = 0x01 (1)
    0008: UCHAR ucSS_Delay = 0x2a (42)
    0009: UCHAR ucSS_Id = 0x01 (1)
    000a: UCHAR ucRecommandedRef_Div = 0x02 (2)
    000b: UCHAR ucSS_Range = 0x02 (2)
[cut]

Note that the size is 12 bytes, so there's only one ATOM_SPREAD_SPECTRUM_ASSIGNMENT; ucSS_Id in the LVDS block is 0x1 and the old code ended up reading past the end of array. For example now it's trying to set:

[ 37.652741] usSpreadSpectrumPercentage = 0xf8
[ 37.652783] ucSpreadSpectrumType = 0x1
[ 37.652824] ucSS_Step = 0x2
[ 37.652867] ucSS_Delay = 0xf
[ 37.652910] ucSS_Range = 0x0
[ 37.652953] ucRecommendedRef_Div = 0x3c

I guess that atombios validates the data and discards it. The new code picks up the correct data... and causes flickering. Why is this causing flickering on the _external_ display? I'm not sure what happens at boot when the outputs are cloned, but with X running the outputs are "uncloned" and are using different CRTCs; the kernel module enables SS on CRTC 1, and xrandr reports that it's used by LVDS.

Created an attachment (id=32509)
Add a module parameter to disable spread spectrum unconditionally

In case this turns out to be a bug in my card bios or a hardware problem; it's really a show-stopper for me.

I have the same VGA ripple effect.

01:00.0 VGA compatible controller: ATI Technologies Inc M76 [Radeon Mobility HD 2600 Series]

agd5f on IRC suggested to try 'avivotool regset 0x458 0x00000000' or 'avivotool regset 0x45c 0x00000000'. The first command fixes it (didn't try the second one).

avivotool is a part of radeontool and can be found here: http://cgit.freedesktop.org/~airlied/radeontool

Created an attachment (id=33815)
dmesg with 2.6.33 KMS enabled

Created an attachment (id=33816)
Xorg log with Kernel 2.6.33 KMS

Created an attachment (id=33817)
possible fix

Does this patch help?

(In reply to comment #18)
> Created an attachment (id=33817) [details]
> possible fix
>
> Does this patch help?

No. However fiddling with avivotool as suggested by Philipp fixes the issue.
From the output of the tool it seems that the kernel driver is setting the wrong (PLL id swapped?) register:

#. /avivotool regset 0x458 0x00000000
OLD: 0x458 (0458) 0x2a020101 (704774401)
NEW: 0x458 (0458) 0x00000000 (0)

# ./avivotool regset 0x45c 0x00000000
OLD: 0x45c (045c) 0x00000000 (0)
NEW: 0x45c (045c) 0x00000000 (0)

Setting 0x458 (AVIVO_P1PLL_INT_SS_CNTL) stops the flickering on the external VGA monitor.

(In reply to comment #19)
> (In reply to comment #18)
> > Created an attachment (id=33817) [details] [details]
> > possible fix
> >
> > Does this patch help?
>
> No. However fiddling with avivotool as suggested by Philipp fixes the issue.
> From the output of the tool it seems that the kernel driver is setting the
> wrong (PLL id swapped?) register:
>
> #. /avivotool regset 0x458 0x00000000
> OLD: 0x458 (0458) 0x2a020101 (704774401)
> NEW: 0x458 (0458) 0x00000000 (0)
>
> # ./avivotool regset 0x45c 0x00000000
> OLD: 0x45c (045c) 0x00000000 (0)
> NEW: 0x45c (045c) 0x00000000 (0)
>
> Setting 0x458 (AVIVO_P1PLL_INT_SS_CNTL) stops the flickering on the external
> VGA monitor.
>

Do things work properly if you boot without the VGA monitor attached and then connect and enable it later?

(In reply to comment #20)
> Do things work properly if you boot without the VGA monitor attached and then
> connect and enable it later?
>

Yes, this works for me.

Maybe this is related: When booting with UMS and VGA connected, the LVDS Panel is the first Monitor and VGA the second. With KMS it is the other way round.

Created an attachment (id=33870)
fix spread spectrum

This should do the trick. Please apply this on top of the previous patch.

(In reply to comment #22)
> Created an attachment (id=33870) [details]
> fix spread spectrum
>
> This should do the trick. Please apply this on top of the previous patch.

Works for me, thanks!

Patch sent to Dave.

Binary package hint: xorg

As described, the external display shows massive horizontal offsetting (shivering of some sort) between lines. See http://www.youtube.com/watch?v=8Ky9Yk3pNuI

The effect on actual legibility of the screen depends on resolution and refresh rate. Tested on two independent T60s by swapping the hard drive.

ProblemType: Bug
Architecture: i386
Date: Thu Mar 18 11:53:22 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: LENOVO 2623D6U
Package: xorg 1:7.5+3ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=8a9bc647-d729-45f0-bc68-51b0b137e213 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_CA.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: xorg
Symptom: display
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 09/12/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 79ETE3WW (2.23 )
dmi.board.name: 2623D6U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr79ETE3WW(2.23):bd09/12/2008:svnLENOVO:pn2623D6U:pvrThinkPadT60:rvnLENOVO:rn2623D6U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2623D6U
dmi.product.version: ThinkPad T60
dmi.sys.vendor: LENOVO
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-16-generic

Bryce Harrington (bryce) on 2010-03-19
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) on 2010-03-19
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Thanks, this sounds sort of like a modesetting issue and probably should go upstream. That would explain why the behavior varies on different resolutions. Does it work properly if you boot with the radeon.modeset=0 grub option?

Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
mathieg2 (graeme-salsaholics) wrote :

Same Shivering Effect happening on my vaio (radeon mobile m6 ly) on laptop screen (Bug 539262)

Bryce Harrington (bryce) wrote :

I think it's likely that the modeline is just slightly off.

Boot without KMS (radeon.modeset=0) and capture an Xorg.0.log, then boot with KMS on. We should compare the calculated modelines shown in each log for the activated resolution to see if there's any differences.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Incomplete
Robert Hooker (sarvatt) wrote :

Can you try booting with radeon.new_pll=0 added to your kernel command line (not at the same time as the radeon.modeset=0 request above) to see if it fixes the issue also?

description: updated
summary: - [lucid] [LENOVO T60] external screen display shows "shivering",
+ [RV515] [LENOVO T60] external screen display shows "shivering",
horizontal refresh offset
tags: added: flicker
Bryce Harrington (bryce) on 2010-03-22
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete

Thanks, will try this now and report back on the results for each case (new_pll and modeset at 0, individually, and attaching logs). In the interest of full disclosure, I may only have this hardware available to me until the end of the week, so I might not be able to offer more testing past that point.

It ends up that 'radeon.new_pll=0' didn't really change the behavior. The screen seemed to flicker just as much.

Bryce, 'radeon.modeset=0' really did cause the problem to completely disappear. Note that this behavior was new from at most a couple of weeks ago, at the beginning of March this system was running fine with modesetting enabled and no flickering.

Attached is the Xorg.0.log when modesetting is disabled.

Attaching Xorg.0.log as it is when modesetting is enabled.

Robert Hooker (sarvatt) on 2010-03-22
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Robert Hooker (sarvatt) wrote :

Thanks for checking that, would you mind trying with radeon.dynclks=0 this time?

Bryce Harrington (bryce) on 2010-03-22
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete

I left my system on overnight and the flickering seems to have return, even while radeon.modeset is set to 0. I will reboot now to test 'radeon.dynclks=0' and see if I can reproduce the screen's degradation over time.

Bryce, Robert,

'radeon.dynclks=0' alone doesn't have any more effect than 'radeon.new_pll' did. I tried it again in addition to disabling modesetting, but did have the flickering reoccur after about an hour.

*** Bug 27278 has been marked as a duplicate of this bug. ***

Bryce Harrington (bryce) on 2010-03-24
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Triaged
Bryce Harrington (bryce) wrote :

I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=27278 and subscribed you to it. Please follow up with them in case they need further information or wish you to test something.

The timing of starting to see this as of a few weeks ago is interesting in that roughly that's when we moved from the .32 to the .33 drm (the 2.6.32-16.25 kernel). Now, if drm was at fault, I would suspect that turning kms off would work around the issue, so it's odd it only delayed when it appeared.

Hopefully upstream will give us some good feedback on this. Meanwhile, another thing to just check would be to boot to an older kernel - get into grub and select a kernel of version 2.6.32-15 or earlier. If my guess is right, the issue should go away at that point, and it will pinpoint the problem to a regression in the .33 drm.

On the other hand, if it still shows the bad behavior, I would start wondering if there is a hardware issue maybe? I've seen this on my own hardware when there was magnetic interference near the monitor or the cable, or when using an extra long cable. Electric interference (such as a non-grounded outlet on the same circuit as an appliance or tv) could cause it. From how thorough your reporting has been I assume you've ruled out something like this already, but thought it would be worth asking.

Bryce Harrington (bryce) wrote :

fixed in this patch:
http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=commitdiff;h=267364ac17f6474c69b03034340f769b22f46105

Since that's a kernel patch, I'm refiling to the linux kernel, so the kernel team can review and pick this one up.

affects: xserver-xorg-video-ati (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Triaged → New
Changed in linux (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-2
tags: added: xorg-needs-kernel-fix
Changed in xserver-xorg-driver-ati:
status: Unknown → Fix Released

As suggested, booting to 2.6.32-14 doesn't show the problem. I expect 2.6.32-15 should work as well, but I usually had to reboot a couple of times to not get plymouth to crash and get just a corrupted image at the top of the screen at boot; and tried it a couple of time without success.

Gary B (gar37bic) wrote :

I have something similar on my Z61m with the standard ATI card. In my case, if I leave the machine running for a while, after some period of time the screen will go crazy. I can still see what's running, and I can carefully move the mouse and do things but it's really unusable. Logging out does not fix it, and it also does it when I switch to one of the virtual screens.

So far it has always happened while the machine was idle - I've been working on another machine while I sort out the various issues with 10.04, and periodically moving the mouse on the laptop, so it's always happened while the screensaver was running. But I don't know that's a requirement because the screensaver is running most of the time.

I have found that putting the machine to sleep and then turning it back on fixes it - for a while.

Gary B (gar37bic) wrote :

I should add my graphics card is ATI Radeon Mobility x1400

From the look of things, the patch above is applied in 2.6.32-17-generic, but the behavior is still occurring.

saniac (stephen-vital) wrote :

I seem to have this problem as well. I upgraded from Jaunty last night. I have an ATI X1400 in a Toshiba laptop.

saniac (stephen-vital) wrote :

Note: the kernel that shows the problem is the one installed by the upgrade, 2.6.32-16. I tried booting with the older 31-20, and there was no problem.

Changed in linux (Ubuntu Lucid):
status: New → Triaged
Sergio D Marquez (baqtor) wrote :

I seem to have this problem as well, but the flickering is much heavier and makes my external screen unreadable. I upgraded from karmic a month ago. I have an ATI X1200 in a Dell 1521 Laptop, with an external 23" LG lcd monitor (wich is the only display that shows flickering). If I use radeon.modeset=0 the problem dissappears and I get much better performance.

Steve Langasek (vorlon) on 2010-04-10
Changed in linux (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
dieterv (dieterv77) wrote :

I am having the same problem on an IBM ThinkPad T60 running up to date Lucid.
Here is the lspci output for the video card:

01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon X1300]

When i added radeon.modeset=0 with the kernel options, the problem appears to have gone away,
and has stayed away for about 12hrs.

saniac (stephen-vital) wrote :

Adding radeon.modeset=0 to /etc/modprobe.d/radeon-kms.conf fixed it for me too. ATI X1400.

Gary B (gar37bic) wrote :

My screen (z61m also with ATI x1400) doesn't shiver horizontally as much as vertically - it looks like vertical hold problems on an old TV. I hope it's the same bug.

In any case, I checked my radeon-kms.conf file, it already had 'options radeon modeset=1' (I must have set that long ago, trying to fix other issues with ATI back in the 8.04 install) so I changed to modeset=0. One immediate change after reboot was that previously, the splash screen had been coming up in high resolution and the text in the virtual screens (ctl-alt-F1, etc.) had been very, very tiny. Now on the new boot the splash is big and the text in the virtual screens is large (same as it was in 8.04). I have mixed feelings about the font size - it was hard to read but allowed me to put a lot of text on the screen at once! :)

I haven't seen the vertical hold issue again yet,. It's been running for about six hours. So apparently changing the modeset works for me too.

Steve Langasek (vorlon) on 2010-04-16
Changed in linux (Ubuntu Lucid):
milestone: ubuntu-10.04 → lucid-updates

could the concerned people please have a look at the bug https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/541501 (i marked it as duplicate of this one). There are videos/pics showing the bug appearing.

Robert Hooker (sarvatt) wrote :

Can anyone affected please try this kernel out to see if the problems still exist? I have one confirmation that it is fixed by it, and the fixes will be in the next update when 2.6.33.3's drm is added to the kernel if so.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33.3-lucid/

Vish (vish) wrote :

I'v had some similar problems in a ATI radeom Mobility X1400 [rv515].
For me the problem was during a guest or second session. [my whole screen would shiver in a guest session]
If i used the new_pll=0 quirk the new_pll=0 the problem was delayed for ~6hrs. After which i would notice the problem again.

+ I had additional problems where when system was running for long hours , the memory usage was a bit high [gem objects unrelated] and CPU usage by Xorg would spike with wallpaper changes .. and a couple of other problems where Xorg CPU usage would spike.

I installed mainline kernel .33.3 from > http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33.3-lucid/

And I'm not having any problems now. I dont used the new_pll=0 even. Several problems i was having are solved too.

Valentin Longchamp (longfield) wrote :

I've been annoyed by this same bug and can confirm that the modeset=0 option for the radeon resolved the problem for me. I'm a little surprised that this fix as well as the one from bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/543045 were not fixed for the official 10.04 release.

Fortunately with two radeon options it could be fixed, but I guess usual people who do not often handle module options are going to be lost and much more annoyed than I have been.

You just need to add the line: options radeon new_pll=0 modeset=0 in a (for instance) /etc/modprobe.d/radeon.conf file (or any /etc/modprobe.d/ file).

Günter (guenter-grodotzki) wrote :

still having the problems even after suggested fixes

erik (erik-eriksson) wrote :

I can confirm that adding file /etc/modprobe.d/radeon.conf with contents "options radeon new_pll=0 modeset=0" fixes the problem. (Lenovo T60 with external Samsung 950B 19" monitor). Thanks!

Günter (guenter-grodotzki) wrote :

hmm erik I did that too but in my Xorg.log I read:

"(II) [KMS] Kernel modesetting enabled."

So I guess its not reading my settins :( - dunno what I am doing wrong.

jrierab (jrierab-ls) wrote :

Hi Robert,

I've tried kernel 2.6.33.3-lucid as recommended in #25, but the problem still exists.

I have an ATI X1400 mobility on a Toshiba Tecra A06 with up-to-date Lucid. My problem is more similar to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/543045

As a workaround, I can use radeon.modeset=0 at boot and the problem disappears.

Timo Derstappen (teemow) wrote :

Same bug on a Lenovo R60 with ATI X1400.

With single head the screen starts flickering after a while like Gary B. described above. I added modeset=0 and the flickering takes longer, but it is still there. Seems to be related to the machines temperature. If the cpu is busy for a while the flickering gets worse.

If I use dual head the shivering is always present like in the youtube video. modeset didn't change anything.

Today I installed mainline kernel 2.6.34 and the dual head shivering was fixed. But the flickering with single head is still there.
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc6-lucid/

Furthermore if I reboot the machine it hangs with some red garbage on the top of the screen.

Let me know if there is more information needed.

Cheers,
Timo

jrierab (jrierab-ls) wrote :

My issues are solved in http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc6-lucid/. Many thanks to the developers team.

I have an ATI X1400 mobility on a Toshiba Tecra A06 with up-to-date Lucid.

Scott Howard (showard314) wrote :

I have this bug, reported as duplicate bug #557814.

I have found that the screen shivering is still present in:
$ uname -a
Linux s-desktop 2.6.34-020634rc6-generic #020634rc6 SMP Fri Apr 30 09:08:46 UTC 2010 x86_64 GNU/Linux

with an r350 -ati driver (more info is at the linked bug report).

Eric Carroll (eric-carroll) wrote :

I have this problem on a T60p as well, and the modset=0 hack resolved it.

After significant research, I believe this problem is resolved upstream. See fdo bug 25741 http://bugs.freedesktop.org/show_bug.cgi?id=25741. A patch was committed on 2010-03-09. I haven't found where it has been integrated as yet.

Changed in linux (Ubuntu):
assignee: nobody → Steve Conklin (sconklin)
Changed in linux (Ubuntu Lucid):
assignee: nobody → Steve Conklin (sconklin)
Eric Carroll (eric-carroll) wrote :

Backtracking the patch for fdo 25751 it appears it was integrated in v2.6.34-rc4.

Eric Carroll (eric-carroll) wrote :

I see I missed Bryce Harrington's posting #13 above which is in fact the patch for fdo 25741. Sorry for the duplication.

klingelheller (klingelheller) wrote :

this might also be my bug on a ThinkPad T60, ATI mobility radeon x1400, as it looks pretty exactly like in the youtube video on the first post.

 ... but two things differ:
1. I got the pink errors and distortion not on an external display, but on the default laptop screen.
2. overall performance of the GPU has degraded from karmic to lucid.

I posted a bug description here: https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/545096/comments/38

I seem to be having mixed luck with using the modeset=0 option; the first couple of times I tried it, my machine hung while booting. I tried the new_p11=0 option (which did nothing at all), and then after trying that tried modeset=0 again (just for giggles), and it worked.

This was all tested on a Lenovo T60.

Thomas87 (knot-tomas) wrote :

I have same problem with external display. My HW is Thinkpad R60 with Ati Mobility Radeon x1400.
In the Kubuntu 9.10 was everything OK. I upgraded from 9.10 to 10.04.

Josh Stump (joshs-pcinw) wrote :

I have a Lenovo Thinkpad T60 with an ATI X1400 graphics chipset. Upgrading to kernel 2.6.34-rc7 has resolved the issue completely for me. My system has been up for several days straight without a single noticeable issue. Kernel was retrieved from... I am using the amd64 build
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc7-lucid/

Eric Carroll (eric-carroll) wrote :

@josh what external display are you using? Is this with modeset off?

Den 03. juni 2010 16:14, skrev Eric Carroll:
> @josh what external display are you using? Is this with modeset off?
>

My problem was also fixed when trying this RC-kernel. Though I needed to
boot the computer three times to be able to log in.

I'm on a Thinkpad T60p, running an external 23" Acer P243W monitor.
My GPU is a ATI M56GL [Mobility FireGL V5200].

I haven't touched my kernel options so I'm guessing I'm running this
with KMS (radeon.modeset).

--
Alexander Karlstad

nathan wessel (wesselns) wrote :

I'm having the same problem.

Lenovo T60P with an Asus VE245H desktop monitor.

Has this been fixed yet?

bwebber92 (bwebber92) wrote :

I have a Toshiba Satellite Pro A300D with a Radeon X1200
Using the kernel at http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc7-lucid/ (i386) fixes the shivering problem for me. However it will only allow me to use 1024x768, 800x600 and 640x480 on the external display with the same image on all monitors option and only the 1024x768 option works. With the extended desktop it gives me the option for 1280x768 but this does not work.
In addition watching videos in full-screen makes them very jerky and now viewable. As a result I've gone back to my original kernel and at this time am trying to find another fix.

Florian Echtler (floe) wrote :

Just a quick note: I've fixed this problem on my Thinkpad T60 by switching to the 2.6.34-lucid kernel from the mainline kernels archive.

korgman (korgie) wrote :

Still it's problem. I have occasionally access to the laptop, please be patient for whatever you ask.

1. Laptop's TFT is fine.
2. Connected external display = weird horizontal lines on BOTH screens either in clone mode or in "expand".
3. The fn + F7 buttons are cycle the diplay: LCD only, External only, BOTH. Every time a press the buttons some other "effect" is active. Horizontal lines (Both screns), Weird image like wave (really .. relaxing like compiz) only on external display, weird lines (as seen on youtube video on original bug reporter).

Thinkpad T60, ATI X1300 + kernel 2.6.32-24-generic.

I don't tried the proposed fixes, but I will.

Excuse my bad English.

Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
everflux (tklaunchpad) wrote :

I can confirm this bug with Maverick and Lucid on Thinkpad T60 / radeon X1300.
Trying modeset/pll parameters, but it seems like random problems related to firmware in the radeon card, memory layout of the machine or something else. (I have two T60, one with 3GB and 64bit, the other one with 2GB and 32bit. One has the problem only with external VGA display, the other one (2GB/32bit) has the problem on the internal screen as well.)
Both run the latest BIOS from Lenovo - Lenovo doesn't provide ATI firmware updates.
Sometimes the flickering starts after some time using the machine, but not related to temperature or load.

inos (guehring+ubuntu) wrote :

I can confirm the bug with Maverick 32bit 2.6.35-22-generic on a T60 2GB with radeon X1300.
After switching several times by pressing Fn+F7, the picture becomes stable (some times only).
Anyway, sometimes compiz crashes when switching, then, the picture is stable as well...

Changed in linux (Ubuntu):
assignee: Steve Conklin (sconklin) → nobody
Changed in linux (Ubuntu Lucid):
assignee: Steve Conklin (sconklin) → nobody
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Oliver Joos (oliver-joos) wrote :

I am affected too, but only sometimes when I switch screen mode (e.g. with Ctrl+Alt+Fx) or suspend/resume my laptop.

Unfortunately "radeon.new_pll=0" does not fix it for me, although it seems to lower the probability and/or intensity of flickering.

I use Lucid LTS with kernel 2.6.35-22 on a HP nx8220 with an ATI X600 (RV380) and I added the kernel options "nomodeset radeon.modeset=0" (both, to be sure its disabled everywhere).

Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
cement_head (andor-udel) wrote :

I also have this issue; how do I upgrade my kernel

Running 2.6.32-28-generic-pae

- CH

Bryce Harrington (bryce) on 2011-06-28
tags: removed: xorg-needs-kernel-fix
tags: added: kernel-handoff-graphics

The patch noted in comment #39 was included in the upstream v2.6.34-rc4 release. As such, this patch should be included in our actively developed Oneric kernel release (currently targeting v3.0). The patch is also included in the Maverick and Natty releases which shipped with a 2.6.35 and 2.6.38 kernel. Thus, I'm marking the actively developed linux task as Fix Released. The Lucid nomination will remain open.

For anyone still experiencing issues running with a newer kernel, please open a new bug report as you are likely suffering from a separate issue. Thanks.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.