i915.powersave causes hangs particularly following suspend/resume on i945 and older cards

Bug #539609 reported by Amber Graner on 2010-03-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft
Lucid
High
Andy Whitcroft

Bug Description

After installing Lucid, Alpha 3, I noticed when I was using x-chat, gmail, gwibber, empathy, or switching between chromium tabs - that I would be able to move my mouse, but if I clicked on anything nothing happened. I could not change desktops, applications nor could I reboot or shut down up my Dell M1330. I would have to do a hard reboot in order for the mouse to work.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: akgraner 1396 F.... pulseaudio
 /dev/snd/pcmC0D1p: akgraner 1396 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6dfc000 irq 21'
   Mixer name : 'Silicon Image SiI1392 HDMI'
   Components : 'HDA:83847616,1028020a,00100402 HDA:10951392,1028020a,00100000'
   Controls : 32
   Simple ctrls : 19
DistroRelease: Ubuntu 10.04
Frequency: Once a day.
HibernationDevice: RESUME=UUID=8407fa09-d230-43d5-bc50-e1cc869f56ad
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100308)
MachineType: Dell Inc. XPS M1330
NonfreeKernelModules: wl
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=a6932e3b-fe4a-4750-8e2b-eb0dfc548174 ro quiet splash i915.powersave=0
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.32
Reproducible: No
Tags: lucid needs-upstream-testing regression-potential
TestedUpstream: No
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.name: 0N6705
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn0N6705:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Andy Whitcroft (apw) wrote :

We have a return of the i915.powersave breaking graphics particularly when suspending and resuming. It seems that this only affects i945 and below so we will try and turn this off for those cards only to start with.

summary: - i915.powersave causes desk top to hang.
+ i915.powersave causes hangs particularly following suspend/resume on
+ i945 and older cards
Changed in linux (Ubuntu):
importance: Undecided → Wishlist
status: New → In Progress
assignee: nobody → Andy Whitcroft (apw)
importance: Wishlist → High
milestone: none → ubuntu-10.04-beta-2
tags: added: lucid
Andy Whitcroft (apw) on 2010-03-31
Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package linux - 2.6.32-19.28

---------------
linux (2.6.32-19.28) lucid; urgency=low

  [ Andy Whitcroft ]

  * [Config] enable various multitouch devices
    - LP: #541453

  [ Chase Douglas ]

  * (pre-stable): input: ALPS - Add signature for HP Pavilion dm3 laptops
    - LP: #545307
  * SAUCE: Disable function tracing after hitting __schedule_bug
  * SAUCE: Reduce ACPI resource conflict message to KERN_INFO, printf
    cleanup
    - LP: #440470

  [ Jesse Barnes ]

  * SAUCE: drm/i915: don't change DRM configuration when releasing load
    detect pipe
    - LP: #488328

  [ John Johansen ]

  * SAUCE: AppArmor: Remove null_profile's use of PFLAG_NO_LIST_REF
    - LP: #539437
  * SAUCE: AppArmor: Stop page allocation warnings that can occur on policy
    load
    - LP: #458299
  * SAUCE: AppArmor: Return string len rather than the allocation size
    - LP: #551844
  * SAUCE: AppArmor: Fix oops in profile verification if profile unpack
    fails.

  [ Luke Yelavich ]

  * [Config] Enable Nouveau DRM module on powerpc

  [ Stefan Bader ]

  * SAUCE: Pull in thinkpad-acpi from v2.6.34-rc1
    - LP: #357673
  * [Config] Enable thinkpad-acpi ALSA volume control
    - LP: #357673

  [ Steve Conklin ]

  * SAUCE: drm/i915: Disable FBC on 915GM and 945GM
    - LP: #492392, #539609

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP,
    Dell Inspiron 700m"
    - LP: #515246
  * (pre-stable) softlockup: Stop spurious softlockup messages due to
    overflow
    - LP: #551068
  * backlight: mbp_nvidia_bl - add five more MacBook variants
    - LP: #511965
  * drm/nv04-nv40: Fix up the programmed horizontal sync pulse delay.
    - LP: #529130
  * drm/nouveau: Fix fbcon corruption with font width not divisible by 8
    - LP: #544739
  * (pre-stable) USB: fix usbfs regression
  * drm/radeon/bo: add some fallback placements for VRAM only objects.
    - LP: #507148
  * drm/radeon/kms: don't print error on -ERESTARTSYS.
    - LP: #507148
  * Input: add the ABS_MT_PRESSURE event
    - LP: #541453
  * HID: Support for 3M multitouch panel
    - LP: #541453
  * HID: make 3M PCT touchscreen driver standalone config option
    - LP: #541453
  * HID: add support for Stantum multitouch panel
    - LP: #541453
  * HID: make Stantum driver standalone config option
    - LP: #541453
  * HID: add support for Acer T230H multitouch
    - LP: #541453
  * HID: add support for Pixart Imaging Optical Touch Screen
    - LP: #541453
  * HID: fixed bug in single-touch emulation on the stantum panel
    - LP: #541453
  * HID: add pressure support for the Stantum multitouch panel
    - LP: #541453
  * HID: Support for MosArt multitouch panel
    - LP: #541453
  * HID: hid-ntrig add multi input quirk and clean up
    - LP: #541453
  * HID: n-trig: remove unnecessary tool switching
    - LP: #541453
  * HID: hid-ntrig: multitouch cleanup and fix
    - LP: #541453
  * HID: hid-ntrig: Single touch mode tap
    - LP: #541453
  * hid: ntrig touch events
    - LP: #541453
  * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
    - LP: #531309
  * drm/i915: Part of: Add initial bits for VGA mode...

Read more...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
trouts2 (trouts2) wrote :

My system hangs very often and seems to be related to hibernation or power down on no use. I leave the system and come back and it's hung. There are a few ways it hangs i.e. when overly busy but often when doing nothing for long periods.
A hang today with a Sysrq dump shows (I think) i915 as the pid farther with as the trace getting a 120 second timeout at __mutex_ock_slowpath.
I'm running Ubuntu 9.10 with all updates as of 4-12-2010. This happened on 10.04 LTS also.
I have a few traces with mem and blocked from sysrq if anyone would want to look at them.

roger64 (rogqip-suse) wrote :

6th of May 2010

For me, this bug has not, repeat NOT, been solved.

I use a Toshiba A80 laptop with a i915 graphic card. My Ubuntu experience with it is not too good...
- Jaunty: faulty driver release, after some weeks, I downgraded to driver 2.4
- Karmic: computer can't be used for suspend to RAM during the full time of this release, i.e. six months
- Lucid: the same (one week).

I have now the normal kernel 2.6.32.22.23 and, after resume, I always experience a freeze between 10 minutes to 40 minutes. Sometimes, I am informed that I must switch to low resolution mode, sometimes it's just a black screen...

I've upgraded to kernel 2.6.33.3 but I've the same result.

This bug has NOT been solved. Thanks for help.

roger64

Jeremy Foshee (jeremyfoshee) wrote :

trouts2 / roger64,
    Please open new bugs for your issues using apport-bug linux. We;d like to take a look at your issues separately from hardware profile standpoints.

Thanks!

~JFo

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints