Ubuntu

Asus EEE 1201N bios reset when changing brightness

Reported by Markus on 2010-03-15
120
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Linux
Expired
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

Using Lucid Netbook Edition, kernel 2.6.32-16-generic, all updates installed until now

Asus EEE 1201N (Atom 330, Nvidia ION)

Bios-Version: 0324

Symptoms:

Rebooting from Linux when on battery causes bios settings to be reset. Additionally, only 768mb of RAM are detected to be usable (though 2Gigs are installed). Applying settings in Bios and restarting gives back full 2Gig of RAM, and everything works as expected until restarting from Linux again. When working with AC-power the bug doesn't show up.

Other users detected this to be a problem with brigthness-setting, see http://permalink.gmane.org/gmane.linux.debian.devel.eeepc/2923 or http://vip.asus.com/forum/view.aspx?board_id=20&model=Eee+PC+1201N&id=20100211135511828&page=1&SLanguage=en-us

This looks like to be a bug in the bios of the 1201N, but working with windows (and changing brightness there) does not reset the bios. So there must at least be a workaround.

Steps to reproduce:

Boot with a 1201N
Change brightness
Disconnect AC-power-source if connected
Reboot

Regards,
Markus

Markus (doits) on 2010-03-15
description: updated
Bob (bjg) wrote :

Similar issue here. Asus 1201N, Ubuntu 9.10 installed, fully updated. BIOS rev. 0324
Selecting restart will cause the netbook's bios to be reset, prompting you to enter it by pressing F1 when the machine restarts.
Selecting Turn off will not cause this.
Do not recall if memory value is shown correctly or not.

Markus (doits) wrote :

you're right, "shutdown" does not seem to cause the issue...

for reference the bug i opened on kernel.org (there was some investigation already going on, but nothing came out yet): https://bugzilla.kernel.org/show_bug.cgi?id=15554 - if you have something more, post it there, too.

Luca Aluffi (aluffilu) wrote :

Same here with 1201NL. Same board, lesser powered processor. I don't open another issue just because they're almost "brother".

My BIOS rev is 0205.

I also filed a support request to ASUS, but I don't really believe they will do something.

sol1tude (sol1tude) wrote :

can confirm BIOS reset
model: 1201n, my bios: 0318
it does not depends on boot booster setting.
tested os: ubuntu 9.10, 10.04 rc1

Luuk (hendriks-luuk) wrote :

I noticed this too:
1201n, bios 325
Running Arch 64 (2.6.33-ARCH)

When more information is needed, please ask.

Luca Aluffi (aluffilu) wrote :

Update my bios to 0304 and it's still the same. To recap, I'm running on:
ASUS 1201NL, bios 0304.

Dmitry Rakovsky (rakodin) wrote :

Can confirm this.
ASUS 1201N bios 0326
Bios resets anytime after restart, with or w/o AC power.
Also it resets, if pm-hibernate mode is set to default (platform).
Memory value is show incorrectly (768m detected)
Sorry for bad english

This bug is also present in Asus 1201NL with BIOS 0205.

When I restart Kubuntu 10.04, it resets BIOS settings and shows 768 MB of RAM instead of 2048 MB.

Jérémy Bethmont (jeremb) wrote :

Same problem here with Lucid Lynx 32bits on 1201N Bios 0326.

Confirmed Maverick 32bit Bios 0325
uname -a Linux ubuntu 2.6.35-7-generic-pae #12-Ubuntu SMP Fri Jul 9 22:48:27 UTC 2010 i686 GNU/Linux

kslen (pewpew) wrote :

Confirmed.

Ubuntu 10.04 32-bit running 2.6.32-23-generic on a 1201N.

kslen (pewpew) wrote :

..BIOS 0326.

Eric Jorgensen (alhaz) wrote :

adding "acpi_osi=Linux acpi_brightness=vendor" to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub resolved this issue for me.

raphxl (raphxl) wrote :

thk you Eric, the GRUB_CMDLINE_LINUX_DEFAULT options solved the issue for me too.

Stas Titov (ststitov) wrote :

Similar issue same. Asus EEE PC 1201N, Ubuntu 10.10 installed, fully updated. The latest version of the BIOS 0326.

After append to kernel parameters "acpi_osi = Linux acpi_brightness = vendor" the number of resseting bios greatly reduced, but sometimes it happens.

David Tombs (dgtombs) wrote :

Assigning to linux. Confirming due to others' comments.

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux:
status: Unknown → Incomplete
Changed in linux:
importance: Unknown → High
gratefulfrog (gratefulfrog) wrote :

I am running 10.10 netbook remix on asus 1201n. This happens to me also. Very annoying...

Confirmed on Ubuntu 11.04 with a Asus EEE 1201n with latest BIOS

GaaL (gaal33) wrote :

The workaround "acpi_osi=Linux acpi_brightness=vendor" works for my asus 1201n on Maverick and since yesterday for Natty.

Thanks.

Soheb Mahmood (soheb) wrote :

I've tried the workaround that GaaL posted with little success.

In my experience, when adding the line "acpi_osi=Linux acpi_brightness=vendor" into the /etc/default/grub file (to the GRUB_CMDLINE_LINUX_DEFAULT" line), the ability to increase or decrease the brightness is removed (i.e. the brightness stays the same, no matter if you hit the brightness up or brightness down keys). On the plus side, the BIOS didn't reset... ;)

Maybe I've missed a step?

sol1tude (sol1tude) wrote :

Yes, you should use acpi_backlight=vendor, not acpi_brightness=vendor

pablo (prglaz) wrote :

I have tried both acpi_osi=Linux acpi_brightness=vendor and acpi_osi=Linux acpi_backlight=vendor but in both cases I lose the ability to change brightness although with the second option the brightness bar changes but it doesn´t change anything, do you know if I can do anything else to change brightness?

Marco Chiappetta (mardurhack) wrote :

I confirm pablo's experience. If you change that line you're unable to change brightness in ANY way (both with Fn keys and gnome-power-management panel). I'm very concerned about this bug. It exists from version 9.10 and I still have it on Ubuntu 11.04 with linux 2.6.38-11. Anyone who's trying to solve it? Thanks in advance.

David Tombs (dgtombs) wrote :

Unfortunately since this seems to be a bug in the hardware itself, it is pretty unlikely to be fixed by Ubuntu with its limited resources. Your best hope would be to work with Asus on a fix.

Changed in linux:
status: Incomplete → In Progress

Markus, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, as per http://www.asus.com/Eee/Eee_PC/Eee_PC_1201N_Seashell/#download your BIOS is outdated. Could you please update your BIOS and report on if this fixes the problem?

As well, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

tags: added: lucid needs-kernel-logs needs-upstream-testing
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Markus (doits) wrote :

Not using ubuntu anymore, so cannot test. Someone other must run those tests.

Markus, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/539047/comments/26 regarding you no longer using Ubuntu. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux:
status: In Progress → Incomplete
Changed in linux:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.