[Intel D945GCLF] "hda-intel spurious response" messages and intermittent GDM startup

Bug #536699 reported by Peter Harding on 2010-03-10
This bug affects 28 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Description: Ubuntu lucid (development branch)
Release: 10.04

I have tried Lucid i386, amd64 and currently UNR alpha 3 with the Intel D945GCLF atom based motherboard and I think with the upgrade to 2.6.32-16-generic #24 kernel when I turn on the audio hardware in BIOS the following message fills std out it alternates between 0x0 and 0x1 and the system doesn't continue to startup:

hda-intel: spurious response 0x0:0x0, last cmd=0x000000
hda-intel: spurious response 0x0:0x1, last cmd=0x000000
hda-intel: spurious response 0x0:0x0, last cmd=0x000000
hda-intel: spurious response 0x0:0x1, last cmd=0x000000

I can't get into the machine when audio hardware is on so the enclosed files reflect the machine when audio hardware is off in the BIOS and may therefore be less helpful. The motherboard reports that it is using an ALC662 audio device with other os's.

Lucid i386 and amd64 seemed to be experiencing other issues as well (problems with ethernet and usb) but UNR only seems to have this one issue for me so far. SUSE 11.2, Karmic 9.10 i386 were working fine. Please let me know what else I can report to help solve this issue. I will see what happens after today's updates.

WORKAROUND: In the BIOS, set the IGD Aperture size from 128MB to 256MB.

ProblemType: Bug
AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access /dev/snd/: No such file or directory
AplayDevices: aplay: device_list:223: no soundcards found...
Architecture: i386
ArecordDevices: arecord: device_list:223: no soundcards found...
CheckboxSubmission: 9c358cb907639c680b6859f7a2543722
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
Date: Wed Mar 10 09:23:59 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100224.3)
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Package: linux-image-2.6.32-16-generic 2.6.32-16.24

ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=d44c9b2f-cb5d-4c85-9285-88439a13ea6f ro quiet splash
ProcVersionSignature: Ubuntu 2.6.32-16.24-generic
Regression: Yes
Reproducible: Yes
SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 07/31/2008
dmi.bios.vendor: Intel Corp.
dmi.bios.version: LF94510J.86A.0099.2008.0731.0303
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: D945GCLF
dmi.board.vendor: Intel Corporation
dmi.board.version: AAE27042-301
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrLF94510J.86A.0099.2008.0731.0303:bd07/31/2008:svn:pn:pvr:rvnIntelCorporation:rnD945GCLF:rvrAAE27042-301:cvn:ct3:cvr:

Peter Harding (phh-hardnet) wrote :
summary: - "intel-hda spurious response" message prevents startup
+ "intel-hda spurious response" message prevents startup with Intel
+ D945GCLF Motherboard
summary: - "intel-hda spurious response" message prevents startup with Intel
+ "hda-intel spurious response" message prevents startup with Intel
D945GCLF Motherboard

Update today of kernel to 2.6.32-16-generic #25 with no change. Selecting 2.6.32-14 from grub boot menu results in same message and no startup.

I seem to be able to intermittently startup properly. Attaching more info...

Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :

dmesg with noapic option from grub boot menu

Peter Harding (phh-hardnet) wrote :

It will usually startup with noapic or noacpi boot option selected but without sound usually. Could it be some sort of irq problem.

Peter Harding (phh-hardnet) wrote :

noapic usually allows full startup with audio hardware detected, with or without actual sound

nolapic usually allows full startup with no audio hardware detected and no sound

noacpi usually seems to have no effect on the ability to startup but the machine will boot very intermittently

summary: - "hda-intel spurious response" message prevents startup with Intel
- D945GCLF Motherboard
+ "hda-intel spurious response" message and no startup with Intel D945GCLF
+ Motherboard

This seems to be some major IRQ issue for your system. Can you test the latest mainline build available at http://kernel.ubuntu.com/~kernel-ppa/mainline/ to see if there's a fix upstream? If not, I suggest opening a bug at bugzilla.kernel.org. If you do open a bug there, please post the url here so we can link the two bugs.


Changed in linux (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Peter Harding (phh-hardnet) wrote :

The current daily mainline build (20100310) worked. Sorry about the false alarm, I can see that ferreting out these upstream kernel issues can use up some time. Thanks for yours.

Peter Harding (phh-hardnet) wrote :

The "intel-hda spurious response" message is still being produced with the newer kernel but the machine is starting into the gdm with sound but is slower than normal.

Lucid Beta still has the same symptoms originally reported. I would like to hear that other Intel D945GCLF users are experiencing the problem before creating any more bug reports.

summary: - "hda-intel spurious response" message and no startup with Intel D945GCLF
- Motherboard
+ "hda-intel spurious response" messages and intermittent GDM startup with
+ Intel D945GCLF Motherboard

Problem continues in Lucid Beta2.

Add blacklist snd_hda_intel to /etc/modprobe.d/blacklist.conf to startup without sound.

Also tried sudo apt-get install linux-backports-modules-alsa-lucid-generic with some success.

Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :

Turning off audio worked for me as well.

W2IBC (w2ibc) wrote :

i can confirm this as well.

turning audio off in bios dose stop this message. is this a kernel issue or is this a pulse audio problem. cause it seems this sound problem showed up for me when ubuntu went to pulse audio. and each version got worse on the sound issues. with 9.10 being the worst(now into 10.04)

motherboard specs.

PCCHIPS P53G v 1.0

biso info vender American Megatrends INC version 080014 release date 2/21/2008 address 0xF0000 runtime size 64kb rom size 512kb BIOS revision 8.14

this box is one i built from parts so it not a normal OEM (dell,hp,ect) so some of the "fixes" i have seen never worked for me

fcicq (spam-fcicq) wrote :

I can also confirm it. using motherboard D945GCLF2D. Disabling Audio in BIOS Settings solves the problem, but no sound now :D.

Fedora 12 kernels does not have this problem.

dastillero (dastillero) wrote :

I can confirm it too. Using an HP 2133 Mini Note with Via based motherboard and CPU.

dastillero (dastillero) wrote :

Just added "options snd-hda-intel position_fix=1" (without the quotes) to /etc/modprobe.d/alsa-base.conf and the problem seems to be corrected altough "hda-intel: spurious response 0x0:0x0, last cmd=0x000000" log entries keep appearing in the messages file. The idea was taken from http://www.alsa-project.org/main/index.php/Changes_v1.0.22_v1.0.23#HDA_Intel_driver

Nick Moeck (nickmoeck) wrote :

I've been experiencing a slightly similar problem on my Toshiba Satellite U305 that I think may be related. Sound no longer works, and after boot, KDE reports that the sound device has been removed, and asks if I want KDE to forget about the device. This problem originally started when I was on 9.10. It would turn up about once a month, and then the next morning, it would be fine, so I passed it off as just a hardware problem. It continued happening after updating to 10.04 during the beta period, and now it is back, and it appears to be here to stay. Attached is my /var/log/syslog, which shows numerous "spurious response" messages. Adding "options snd-hda-intel position_fix=1" to /etc/modprobe.d/alsa-base.conf" as suggested above does not resolve the problem. I've also included my /etc/modprobe.d/alsa-base.conf, as I recall having to add something in the past to get something working properly (but I don't recall what was added).

Nick Moeck (nickmoeck) wrote :

Upon just now rebooting my computer, sound works properly again. Perhaps the cause of this issue is some sort of race condition?

Peter Harding (phh-hardnet) wrote :

Thanks for the suggestions, options snd-hda-intel position_fix=1 has not helped me with the Intel D945GCLF motherboard. Same problems continue to occur, even with the update to the 2.6.32-22-generic #33 kernel. I am still not sure if it is a kernel or alsa problem. The gdm often starts but it is really slow due to the overwhelming "spurious response" error messages being sent to the logs.

Paul Tansom (aptanet) wrote :

I'm suffering the same problems on my HP Mini 2133. Sound would drop out after a suspend and resume sometimes on 9.10, but I've only noticed the logged errors since upgrading to 10.04. The original install was UNR 9.04.

Acetone (hormone) wrote :

I have the same problem in the same motherboard, the only way I found to solve this problem is turning off the sound from motherboard..

I'm using 10.04 and have D945GCLF motherboard, at 9.10 did not have that problem.

I've installed ubuntu 9.10 but but I started with a hard disk failure, then upgrade to 10.04 (expected "spurious response"solved with the new kernel) now I have no sound and I have the same problem with the hard disk.

sorry my english.

Joe Mulloy (jdmulloy) wrote :

I'm having this same issue on a D945GCLF board. I just upgraded from Karmic to Lucid and the system would have an intermittent boot issue where it would just hang at boot with a black screen. I disabled the boot splash and now it's just sitting here spitting out tons of these spurious response message.

I am running Kubuntu

WTF? Why is Lucid such junk? While I doubt it's related to this issue my Laptop is doing something very similar. Every once in a while X will just refuse to start, it just hangs with a blank screen. Is the Gnome version of Ubuntu this crappy or is it just Kubuntu? I have one system left to upgrade to Lucid but now I'm not sure I'm willing to do it. Ubuntu is nice because it's easy to install whatever I want but if it's going to be this low quality I'm going to have to use something else.

Allen (cuda) wrote :

Just chirping in here to say confirm the same issue on D945GCLF2D mobo running Debian. It seems to have started after the 2.6.30 kernel. If I boot into 2.6.30 kernel, I get sound and no "hda-intel: spurious response" messages. If I boot into 2.6.32, I get tons of the spurious response messages, but no sound. 2.6.34 has fewer messages, but still no sound. Has anyone posted a bug report upstream? I think that's where it will have to go, ultimately.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired

Problem still extant - no updated comments because no-one has suggested a fix and there are only so many 'me too' messages it is worth posting....

Problem on Intel atom board, mythbuntu 10.04, latest ALSA drivers as of 12/6/2010 loaded & built & still there. And also on HP mini2133 but that would at least start up.

System boots with sound off in bios or with snd-hda-intel blacklisted.
Modprobe snd-hda-intel causes a hang, with spurious responses logged via syslog to serial. These did eventually stop after many minutes and I was able to rmmod the snd-hda-intel module.

Interestingly cat /proc/interrupts did NOT show the sound module associated with any interrupts although there was an interrupt line shown with a blank where the owner should have been...

Suspect this is really a bug for the ALSA folks...


Changed in linux (Ubuntu):
status: Expired → New
Allen (cuda) wrote :

Setting the IGD Aperture size from 128MB to 256MB cured the problem for me.

Allen (cuda) wrote :

I should have added that the IGD Aperture Size setting is done in the BIOS video settings, and also that the board I'm using is an Intel model D945GCLF2D.

chrone (chrone81) wrote :

thanks Allen, set the IGD aperture size back to 256 fixed my no audio problem too! :D

it's funny how VGA could affect Audio nowadays..

Sean Seago (speedkreature) wrote :

Are we treating this as a bug on the Intel D945GCLF2D or on any mainboard? I have a Biostar Viotech 3100+ with a VIA C7-D processor that I built for a Linux CNC box. I was curious why I/O's during testing were so low only to find my this Spurious I/O error filling my messages log.
My BIOS has "IGP" instead of "IGD" but I do have the option of setting it among 64M, 128M and 256M. Changing this setting has no effect for me.
I just want to make sure I'm posting to the right place before I start uploading logs and system info.

Serguei (sguk12) wrote :

after I set aperture size = 256 in BIOS the "hda-intel: spurious response" message disappeared for me too.

mobo: D945GTP with latest BIOS
Ubuntu 10.04 desktop 64 (updated to latest everything yesterday).

Peter Harding (phh-hardnet) wrote :

Changing the video aperture size to 256MB solved the problems I originally posted about in this thread with the D945GCLF motherboard. Thanks for the suggestion Allen!

cadet willy (timmyzecat) wrote :

same for me, i have a agp video card
video aperture size to 256MB in the BIOS, the message disapeared
hourra for Allen

Usama Akkad (damascene) wrote :

I've similar problem but my mother-board is IPIGC-NL or something and it started when I used dd to copy the content of IDE hard disk to SATA one

I have to reset the machine once or twice for it to continue booting

abondendAccount (hennr) wrote :

Here are some people discussing the same issue:


I also marked a similar bug as a dupe of this:

abondendAccount (hennr) wrote :
abondendAccount (hennr) wrote :

Oh, and there is also a bug report on kernel.org:


Maybe some more people should post there to make clear that this is a common problem.

abondendAccount (hennr) wrote :

Added the upstream (Linux Kernel) bug report and two more duplicates from the ubuntu tracker to this bug.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
abondendAccount (hennr) wrote :

So, what do we do with this bug now?

Will anybody re report it to the kernel devs?

dastillero (dastillero) wrote :

I've solved the no sound problem on my HP 2133 with Lucid by installing Alsa 1.0.24, but the "spurious response" messages are still there. No chance to change AGP aperture size to 256MB as the BIOS does not have the option.

Gregor (gregor-g) wrote :

@ dastillero - I can confirm that upgrading alsa does seem to solve the bug and keeps the messages. However upon kernel update and certain system updates it will overwrite the Alsa and you would need to upgrade and configure the alsa again. I even tried to lock the alsa packages but somehow they still get overwritten.

Brad Figg (brad-figg) on 2011-04-06
Changed in linux (Ubuntu):
status: New → Confirmed
tags: removed: regression-potential
Alex Cornejo (acornejoc) wrote :

This bug is happening on my system too.

I am running ubuntu oneiric with latest updates. My sound does work, but sometimes the machine locks on bootup with the "spurious" messages flooding my screen, most of the time it boots proplery but slowly.

I also believe this to be an IRQ issue, but I do not know how to solve it.

Sandra Unger (spinache01) wrote :

had the same bug today for the first time. I am running natty narwhal 64-bit on my Asus ul80-vt and this is the first time I have this bug since I use Ubuntu (2010). It came up after the last alsa update. Maybe there is a connection.

Gregor (gregor-g) wrote :

It's year 2012 and this bug is still here. At least sound came back, but it seems one of the latest updates destroyed any compatibility.

i get same message and as others before with .24 ALSA i received the messages, but sound was there. only analog stereo though never digital and HD.
Now the sound is gone.

Chipset is recognised by lspci: VIA Technologies, Inc. VT8237A/VT8251 HDA Controller (rev 10)

but not by sound manager or alsamixer.

sudo alsa reload -c

partially solves the issue for default session, however sound is then lost on reboot. it oslves it only partially as input is not working.

medium priority for the bug seems ridiculous especially since many built in sound cards (laptops...) use these intel chips.

Mauricio (mruibal) wrote :

Solved for my motherboard 4Coredual-sata2 adding the next lines to /etc/modprobe.d/alsa-base.conf

# Solucion para ALC888 de 4Coredual-sata2
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=6stack-dig position_fix=0 single_cmd=1

Now there is not "spurious response..." in dmesg and the sound is always starting right.

description: updated

Peter Harding, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested. For example:

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:

If the mainline kernel does not fix this bug, please add the following tags:

As well, please remove the tag:

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-0278
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

This bug is still present on Ubuntu 12.04 and on 3.2.0-4-686 kernel in Crunchbang (Ubuntu-Debian based) regarding the HP Mini 2133.

Stella Delichatsiou, so your hardware may be tracked, could you please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

summary: - "hda-intel spurious response" messages and intermittent GDM startup with
- Intel D945GCLF Motherboard
+ [Intel D945GCLF] "hda-intel spurious response" messages and intermittent
+ GDM startup

I'm sorry Christopher M. Penalver, I can't help you out with this one at the moment.
I am running Crunchbang, not Ubuntu right now, but another HP Mini 2133 user I know who installed Ubuntu 12.04 1 month ago didn't have sound and received the "hda intel: spurious response" error. Sound was working on 10.04 though.

I am using kernel 3.2, where the bug is known to be present, but I'm planning to upgrade it to at least 3.10 and see if I still face the same problem.

Thank you so much for effort.

Stella Delichatsiou, you could just simply test this in the live environment, and file the report as requested in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/536699/comments/51 . Please note "Me too!" comments are largely unhelpful.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.