an audio device is active 100.0% of the time.

Bug #536631 reported by Eyad Salah on 2010-03-10
This bug affects 27 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Binary package hint: powertop

When I run powertop I get this message saying "an audio device is active 100.0% of the time" so I press "A" to turn hd audio powersaving on. 5 seconds later I get the same suggestion over and over. I guess its just not working or perhaps the device doesn't support powersaving mode.

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: f1b15b20a09c88034055ebde1ac7d6a2
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Wed Mar 10 14:58:51 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: powertop 1.11+git20091208-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: powertop
Uname: Linux 2.6.32-16-generic x86_64

Eyad Salah (eyad-salah) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in powertop (Ubuntu):
status: New → Confirmed

The same problem exists in oneiric with powertop 1.97:

PowerTOP 1.97 Overview Idle stats Frequency stats Device stats Tunables

Summary: 0.0 wakeups/second, 0.0 GPU ops/second and 0.0 VFS ops/sec

                Usage Events/s Category Description
            100.0% Device Audio codec hwC0D1: LSI
            100.0% Device Audio codec hwC0D0: Analog Devices

mpe (michael-petritsch) wrote :

in 11.10 it's using a third of my total power consumption on my laptop:
The battery reports a discharge rate of 21.4 W
Power est. Usage Events/s Category Description
  7.24 W 100.0% Device Audio codec hwC0D1: LSI

Gintaras (gintaras-sakalauskas) wrote :

                Usage Events/s Category Description
            100.0% Device Audio codec hwC0D1: LSI

The same here. Subscribed to this bug, please notify if any info is needed.

Philippe Coval (rzr) wrote :

I tested using a snapshot of powertop (ask my deb if needed) and same results with :

            100.0% Audio codec alsa:hwC0D3: auto (Intel)

I fear the issue should be redirected to asla or other package ...

I'll update my notes at :

Lorenzo Bettini (bettini) wrote :

I have the same problem

                Usage Events/s Category Description
            100.0% Device Audio codec hwC0D0: SigmaTel

by the way, the new version 1.97 has a different interface... I can't see the "suggestions" part anymore... how can one see powertop's suggestions and apply them?

Gintaras (gintaras-sakalauskas) wrote :

@Lorenzo, use the arrow keys to navigate to Tunables tab. Then enter, to toggle some 'suggestions'. I don't think these are saved after reboot, though.

Lorenzo Bettini (bettini) wrote :

@Gintaras, I already discovered that Tunables tab, though it's a little bit counterintuitive... for instance, if I want to enable a suggestion I should toggle it so that it becomes 'good', I assume... but the previous interface was more intuitive...

Philippe Coval (rzr) wrote :

I can use sysfs to change the values too
I just worked for mine :

now how to make this permanant the smart way ?

should this be edited :


Lorenzo Bettini (bettini) wrote :

@Phillippe: I'm not sure I understand: have you managed to solve the 100% audio issue?

In precise the relevant power saving parameters are correctly set:

# cat /sys/module/snd_hda_intel/parameters/power_save_controller
# cat /sys/module/snd_hda_intel/parameters/power_save

but I still see HDA at 100% in powertop.

dfsmith (dfs1122) wrote :

I could remove the "100% device hwC0D0" usage in PowerTop by playing with my mixer switches (Mic feedthrough to Main, etc.). However, this did not change my idle power usage by any significant amount.
20.2W +/- 1W
Lenovo ThinkPad T60
Ubuntu/Xfce 12.04

tags: added: precise

ComputerJy, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested. For example:

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:

If the mainline kernel does not fix this bug, please add the following tags:

As well, please remove the tag:

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

affects: powertop (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-kernel-logs needs-upstream-testing
tags: removed: precise

This bug no longer exists on my system with raring and the following kernel:

Linux vougeot 3.8.0-29-generic #42-Ubuntu SMP Tue Aug 13 19:40:39 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers