linux-image-2.6.32-16-generic depends on linux-tools which is not in main

Bug #534635 reported by Joel Ebel
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft

Bug Description

linux-image-2.6.32-16-generic fails to install during a network install because it depends on linux-tools, which is not in main. Universe is not available during install time. In addition, having a package in main depend on a package in universe is a bad idea. linux-tools needs to either be moved to main, or the dependency needs to be removed.

Andy Whitcroft (apw)
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → High
status: New → Triaged
Revision history for this message
Andy Whitcroft (apw) wrote :

We either should promote linux-tools or move the dependancy over to a Depends:. The binary package is currently tiny, and architecture all, so probabally not a huge problem to be in main:

    -rw-r--r-- 1 apw apw 48584 2010-03-04 13:01 linux-tools_2.6.32-16.23_all.deb

Pulling it out to universe would leave binaries in main with their manuals in universe. Not sure if thats valid under the current Policy.

Andy Whitcroft (apw)
Changed in linux (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Andy Whitcroft (apw) wrote :

Talking to archive admins it seems that making this dependancy a Depends: requires this package to be on the CD which is not required. The compromise seems to be to make the dependancy a Suggest: on the package, move the package to main, and to explicitly seed the package for developers.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-16.25

---------------
linux (2.6.32-16.25) lucid; urgency=low

  [ Andy Whitcroft ]

  * linux-tools -- move to Suggests: with explicit seeding
    - LP: #534635

  [ Tim Gardner ]

  * [Config] CONFIG_HID=m

  [ Upstream Kernel Changes ]

  * (pre-stable) sched: Fix SMT scheduler regression in
    find_busiest_queue()
  * KVM: introduce kvm_vcpu_on_spin
  * KVM: VMX: Add support for Pause-Loop Exiting
 -- Andy Whitcroft <email address hidden> Tue, 09 Mar 2010 14:13:51 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers