Ubuntu

Support for DELL H200/H700/H800 SAS cards is missing in the CD/DVD installer for Lucid (mpt2sas)

Reported by Janåke Rönnblom on 2010-03-01
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Andy Whitcroft
Nominated for Lucid by Janåke Rönnblom

Bug Description

When trying to install Lucid Alpha 3 on a DELL R210 equipped with a PERC H200 SAS controller no disks are found. The installer doesn't recognize the PERC H200 card which is based on the mpt2sas driver.

I'll add the information from the installer tomorrow as requested.

1) uname -a > uname-a.log
2) cat /proc/version_signature > version.log
3) dmesg > dmesg.log
4) sudo lspci -vnvn > lspci-vnvn.log

Janåke Rönnblom (jan-ake) wrote :
Janåke Rönnblom (jan-ake) wrote :
Janåke Rönnblom (jan-ake) wrote :
Janåke Rönnblom (jan-ake) wrote :
satriaNIC (nico-starprint66) wrote :

Had the same issue while installing ubuntu 9.10 server (from the netinstall CD) on a R710 dell poweredge (also using perc H200 controler -so I needed the mpt2sas module)

Janåke Rönnblom (jan-ake) wrote :

satriaNIC: How did you solve your problem did you open and include the mpt2sas in the ISO cd? OR is the server running something else

-J

tags: added: kernel-series-unknown
Michiel Brandenburg (apex) wrote :

Having the same problem with debian, it might not be ubuntu related. I have checked all the scsi*.udev packages and so far failed to find the mpt2sas.
Solution I used was to extract the /lib/modules/<kernelversion>/kernel/drivers/scsi/mpt2sas/* and place them in the initrd.gz file.

Note: I use PXE booting so changing the initrd file was relatively quick.
Note: last installer checked used kernel 2.6.30

Janåke Rönnblom (jan-ake) wrote :

Driver is still missing in Lucid 10.4 Beta 1 with kernel 2.6.32-16-generic

Lucid can't be installed on new DELL servers.

jfabrizio (jfabrizio84) wrote :

I have the same problem with the Ubuntu-server installation.
See http://ubuntuforums.org/showthread.php?p=9029610#post9029610

Janåke Rönnblom (jan-ake) wrote :

Three solutions for running Linux on your new server:

1. Install another linuxdistribution from a leading vendor ;)
2. Sell the server on ebay and buy another with support for Ubuntu.
3. Do like this:

1. Boot from the installcd
2. Go to one of the console (alt+f2)
3. Insert USB key with driver on it. (mount -t vfat /dev/sda /mnt --> or something like that)
4. Copy the required driver to /tmp (otherwise the usb i /dev/sda which is where we want the disks from the RAID card)
5. Unmount the USB key6
6. insmod the mpt2sas driver from /tmp
7. Go into the install menu and detect the disks again.
9. After install replace the generic kernel with the server kernel

The driver can be found in the generic kernel. I did install a virtual machine and then installed the generic kernel to it (afterwards) so I could get my hands on the mpt2sas driver.

jfabrizio (jfabrizio84) wrote :

Hi janake. I'm reading that you resolve the problem!

- Point 1
Must I start the installation with ubuntu-server or ubuntu desktop?
- Point 3
Could you link or upload the driver (zip file) that I must add in USB key?
- Point 6
I must to run the command >insmod /tmp/mpt2sas(folder or file)
- Point 9
I don't understand this point.

Thanks

Fabrizio

Andy Whitcroft (apw) on 2010-04-13
tags: added: lucid
removed: kernel-series-unknown
Changed in linux (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) on 2010-04-13
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-21.31

---------------
linux (2.6.32-21.31) lucid; urgency=low

  [ Andy Whitcroft ]

  * allow modules.builtin to be optional
  * d-i: add mpt2sas to the message-modules udeb
    - LP: #530361

  [ Christopher James Halse Rogers ]

  * SAUCE: Nouveau: Add quirk framework to disable acceleration
    - LP: #544088, #546393
  * SAUCE: Nouveau: Disable acceleration on MacBook Pros
    - LP: #546393
  * SAUCE: Nouveau: Disable acceleration on GeForce3 cards
    - LP: #544088
  * SAUCE: Nouveau: Disable acceleration on 6100 cards
    - LP: #542950

  [ Stefan Bader ]

  * SAUCE: dma-mapping: Remove WARN_ON in dma_free_coherent
    - LP: #458201

  [ Surbhi Palande ]

  * SAUCE: sync before umount to reduce time taken by ext4 umount
    - LP: #543617

  [ Upstream Kernel Changes ]

  * tipc: Fix oops on send prior to entering networked mode (v3)
    - CVE-2010-1187
  * KVM: x86 emulator: Add Virtual-8086 mode of emulation
    - LP: #561425
  * KVM: x86 emulator: fix memory access during x86 emulation
    - LP: #561425
  * KVM: x86 emulator: Check IOPL level during io instruction emulation
    - LP: #561425
  * KVM: x86 emulator: Fix popf emulation
    - LP: #561425
  * KVM: Fix segment descriptor loading
    - LP: #561425
  * KVM: VMX: Update instruction length on intercepted BP
    - LP: #561425
  * KVM: VMX: Use macros instead of hex value on cr0 initialization
    - LP: #561425
  * KVM: SVM: Reset cr0 properly on vcpu reset
    - LP: #561425
  * KVM: VMX: Disable unrestricted guest when EPT disabled
    - LP: #561425
  * KVM: x86: disable paravirt mmu reporting
    - LP: #561425
  * AppArmor: Fix put of unassigned ns if aa_unpack fails
  * AppArmor: Fix refcount bug when exec fails
    - LP: #562063
  * AppArmor: Take refcount on cxt->profile to ensure it remains a valid
    reference
    - LP: #367499
  * AppArmor: fix typo in scrubbing environment variable warning
    - LP: #562060
  * AppArmor: fix regression by setting default to mediate deleted files
    - LP: #562056
  * AppArmor: fix refcount order bug that can trigger during replacement
    - LP: #367499
  * AppArmor: Make sure to unmap aliases for vmalloced dfas before they are
    live
    - LP: #529288
  * AppArmor: address performance regression of replaced profile
    - LP: #549428
  * AppArmor: make the global side the correct type
    - LP: #562047
  * AppArmor: use the kernel shared workqueue to free vmalloc'ed dfas
  * sky2: add register definitions for new chips
    - LP: #537168
  * sky2: 88E8059 support
    - LP: #537168
  * net: Fix Yukon-2 Optima TCP offload setup
    - LP: #537168
  * net: Add missing TST_CFG_WRITE bits around sky2_pci_write
    - LP: #537168
  * sky2: print Optima chip name
    - LP: #537168
  * (Upstream) dell-laptop: defer dell_rfkill_update to worker thread
    - LP: #555261
  * drm/nv40: add LVDS table quirk for Dell Latitude D620
    - LP: #539730
 -- Andy Whitcroft <email address hidden> Tue, 13 Apr 2010 18:50:58 +0100

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
jfabrizio (jfabrizio84) wrote :

So, in which version of Ubuntu this bug was/will fixed?

I'm reading that the ubuntu 10.04 includes the 2.6.32-16.25 kernel based on 2.6.32.9 and NOT the 2.6.32-21.31.

Should I attend a next beta?

Thanks

Thierry Carrez (ttx) wrote :

The daily ISO at:
http://cdimage.ubuntu.com/ubuntu-server/daily/20100414/
includes 2.6.32.20.21 so it should work...
Or wait for the RC next week :)

Thierry Carrez (ttx) wrote :

Hm, sorry, the daily is still at 2.6.32-20.30, maybe tomorrow.

KM (plot-lost) wrote :

Can anyone advise if there is an iso image (i386 server) for Lucid that now has the mpt2sas modules in - trying to install on Dell R210 with no luck so far (exact problems as described above) but all images I've tried so far don't seem to work.

jfabrizio (jfabrizio84) wrote :

I have installed ubuntu 10.04 (64 bit ) without any problems or procedures!!

Lin Avator (lavator) wrote :

I follow the procedures Janåke Rönnblom on 2010-03-29 to install Ubuntu server 9.04 x86_64. Everything goes well, but in the last step, i can not build initramfs for server version successfully.

   Even i follow the manpage of mkinitramfs to modify /etc/modules & /etc/initramfs-tools/modules, it still does not work. Could you provide the detailed command to build initramfs supporting scsi_transport_sas.ko & mpt2sas.ko ?

Lin Avator (lavator) wrote :

Eventually, i try out to vi lib/modules/2.6.28-11-server/modules.order in initrd.img-xxx to add support for mpt2sas, and then re-package initrd.img-xxx. It works now.

===
...
kernel/drivers/scsi/scsi_transport_sas.ko
kernel/drivers/scsi/libsas/libsas.ko
kernel/drivers/scsi/mpt2sas.ko
kernel/drivers/scsi/scsi_transport_srp.ko
...
===

jfabrizio (jfabrizio84) wrote :

I resolved this problem in the following way:
1) I have installed the daily ISO ubuntu desktop (as suggest from Thierry Carrez) in normal way (this version recognizes the PERC controller)
2) I have installed the ubuntu-server package.

So, my dell-ubuntu server works perfectly!!

Hi,
Glad to see that the bug has been fixed.
JFabrizio, can you please help me out ? Which version of Ubuntu desktop did you install ? 32 or 64 bits ?
Did you disable anything in the bios ? When did you configure the RAID ?

I have the 2.6.32-24 (Ubuntu 10.04.1 x64), which contains /lib/modules/2.6.32-24-generic/kernel/drivers/scsi/mpt2sas - but no sure what I have to do next.
If I start the installation, it won't see the RAID.
Thanks

Roger Gardner (r-gardner) wrote :

I have now have Ubuntu 10.10 x64 and there is still no easy way to get the mpt2sas driver to work on my Megaraid SAS9240. It uses megaraid_sas, which does not support automatic rebuild of Raid 1 when a drive is pulled and a new formatted drive is put in. This is a very important step for a server. If I can not get this to work, we will probably go to SLES11 with SP1 and I can look for a new job.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers