[LUCID] EEEPC-1201N missing RTL8192SE module required for wifi card

Bug #530275 reported by Manoj Iyer
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Needs porting RTL8192SE to ubuntu-delta.

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1427 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xf9f78000 irq 23'
   Mixer name : 'Nvidia MCP7A HDMI'
   Components : 'HDA:10ec0269,104383ce,00100004 HDA:10de0007,10de0101,00100100'
   Controls : 16
   Simple ctrls : 8
Date: Mon Mar 1 14:05:59 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=db5693a5-1dc8-46f3-9c5c-d64c82e187b9
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224)
IwConfig:
 lo no wireless extensions.

 eth4 no wireless extensions.

 pan0 no wireless extensions.
MachineType: ASUSTeK Computer INC. 1201N
Package: linux-image-2.6.32-14-generic 2.6.32-14.20
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-14-generic root=UUID=351be7d7-6a7e-4fd4-92c6-62c86233b01a ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
Regression: No
RelatedPackageVersions: linux-firmware 1.31
Reproducible: Yes
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
TestedUpstream: Yes
Uname: Linux 2.6.32-14-generic i686
dmi.bios.date: 12/21/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0318
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1201N
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0318:bd12/21/2009:svnASUSTeKComputerINC.:pn1201N:pvrx.x:rvnASUSTeKComputerINC.:rn1201N:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1201N
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Revision history for this message
Manoj Iyer (manjo) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-16.23

---------------
linux (2.6.32-16.23) lucid; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: PM report driver and device suspend/resume times -- move config
  * update to standards version 3.8.4.0
  * printenv -- expose all of the package selectors
  * source package -- cleanup source content control
  * doc package -- ensure we do build package content on buildd
  * lintian -- correct the address in the debian/copyright
  * lintian -- update debhelper package version dependancy
  * lintian -- fix ghostscript dependancy
  * lintian -- add required misc:Depends
  * lintian -- move our debhelper compat level to debian/compat
  * perf -- build the kernel carried tools
  * perf -- add linux-tools carrying the version switches and manuals
  * SAUCE: fix up Kconfig for staging drivers
  * [Config] enable NOUVEAU etc following drm backport
  * update DRM to mainline v2.6.33
  * [Config] Remove AppArmor config options that no longer exist (ports)
  * [Config] updateportsconfigs following drm update

  [ John Johansen ]

  * ubuntu: AppArmor -- update to mainline 2010-03-04
  * SAUCE: AppArmor: Reintroduce AppArmor 2.4 compatibility
  * SAUCE: AppArmor: replace strim with strstrip for 2.6.32 kernels
  * [Config] Remove AppArmor config options that no longer exist

  [ Manoj Iyer ]

  * ubuntu: rtl8192se -- version 2010-0115,0014
    - LP: #530275
  * [Config] added CONFIG_RTL8192SE module.
    - LP: #530275

  [ Tim Gardner ]

  * [Config] Added vmw_pvscsi to d-i/scsi-modules
    - LP: #531017
  * [Upstream] netfilter: xt_recent: Add an entry reaper

  [ Upstream Kernel Changes ]

  * Revert "KVM: x86 emulator: Check CPL level during privilege instruction
    emulation"
  * Revert "KVM: x86 emulator: Fix popf emulation"
  * Revert "KVM: x86 emulator: Check IOPL level during io instruction
    emulation"
  * Revert "KVM: x86 emulator: Add Virtual-8086 mode of emulation"
  * Revert "KVM: fix memory access during x86 emulation."
  * Add vlan (8021.Q) module package for d-i.
  * (pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP, Dell
    Inspiron 700m
    - LP: #515246
  * [Upstream] docbook: need xmldoclinks for all doc types
  * x86: set_personality_ia32() misses force_personality32
  * lib: Introduce generic list_sort function
  * drm/nv50: Implement ctxprog/state generation.
  * drm/nv50: Remove redundant/incorrect ctxvals initialisation.
  * (pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP, Dell
    Inspiron 700m
    - LP: #515246
 -- Andy Whitcroft <email address hidden> Fri, 05 Mar 2010 15:40:38 +0000

Changed in linux (Ubuntu):
status: New → Fix Released
Revision history for this message
feiy (eshangrao) wrote :

ubuntu: rtl8192se -- version 2010-0115,0014 not stable enough in amd64 kernel(will lost connect or can't connet the ap with wpa2),and the rtl8192se_linux_2.6.0010.1020.2009 amd64(http://launchpadlibrarian.net/34090404/rtl8192se_linux_2.6.0010.1012.2009_64bit.tar.gz) is work fine!

Changed in linux (Ubuntu):
status: Fix Released → Incomplete
Revision history for this message
iniurb (iniurb) wrote :

wifi do not work

dmesg:

4558.421071] <-----------rtl8192se_check_hw_scan()
[ 4558.426098] GPIOChangeRF - HW Radio OFF
[ 4560.432358] GPIOChangeRF - HW Radio ON, RF ON
[ 4560.546899] rtl8192_SetWirelessMode(), wireless_mode:4, bEnableHT = 0
[ 4658.420043] ----------->rtl8192se_check_hw_scan()
[ 4658.420053] FW Scan long time without stop, stop hw scan
[ 4658.421069] <-----------rtl8192se_check_hw_scan()

lspi -v

07:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8171 (rev 10)
 Subsystem: Device 1a3b:1107
 Flags: bus master, fast devsel, latency 0, IRQ 19
 I/O ports at d800 [size=256]
 Memory at fbefc000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: rtl819xSE
 Kernel modules: r8192se_pci

iwconfig

wlan0 802.11bg ESSID:"INIURB" Nickname:"rtl8191SEVA1"
          Mode:Managed Frequency=2.422 GHz Access Point: 00:1A:2B:19:9E:4A
          Bit Rate=54 Mb/s
          Retry:on RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=10/100 Signal level=0 dBm Noise level=-100 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Revision history for this message
Daniel (internalkernel) wrote :
Download full text (4.0 KiB)

I can confirm this is still an issue. I'm running this on a 1201N Asus eeePC. I have lbm-wireless 2.6.32-19 installed as well.

$ uname -r
2.6.32-19-generic

$ lscpi -v
07:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8171 (rev 10)
 Subsystem: Device 1a3b:1107
 Flags: bus master, fast devsel, latency 0, IRQ 19
 I/O ports at d800 [size=256]
 Memory at fbefc000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: rtl819xSE
 Kernel modules: r8192se_pci

$ iwconfig
wlan0 802.11bg ESSID:"summit" Nickname:"rtl8191SEVA1"
          Mode:Managed Frequency=2.412 GHz Access Point: 00:17:0F:D8:3A:81
          Bit Rate=54 Mb/s
          Retry:on RTS thr:off Fragment thr:off
          Power Management period:0us mode:All packets received
          Link Quality=90/100 Signal level=-53 dBm Noise level=-115 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

$ ifconfig
wlan0 Link encap:Ethernet HWaddr 1c:4b:d6:6e:f5:ae
          inet addr:10.40.29.251 Bcast:10.40.31.255 Mask:255.255.248.0
          inet6 addr: fe80::1e4b:d6ff:fe6e:f5ae/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:1213 errors:0 dropped:0 overruns:0 frame:0
          TX packets:380 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:929371 (929.3 KB) TX bytes:30638 (30.6 KB)
          Interrupt:19 Memory:f84b0000-f84b0100

~~
Here's the interesting part... it looks like everything is okay. It associates with the network and gets an IP address, however I am unable to ping any hosts on the network.

$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.40.24.0 0.0.0.0 255.255.248.0 U 2 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
0.0.0.0 10.40.31.254 0.0.0.0 UG 0 0 0 wlan0

$ ping 10.40.31.254
PING 10.40.31.254 (10.40.31.254) 56(84) bytes of data.
From 10.40.29.251 icmp_seq=2 Destination Host Unreachable
From 10.40.29.251 icmp_seq=3 Destination Host Unreachable
^C
--- 10.40.31.254 ping statistics ---
5 packets transmitted, 0 received, +2 errors, 100% packet loss, time 4022ms
, pipe 2

$ dmesg
[ 2039.097785] Linking with summit,channel:1, qos:1, myHT:0, networkHT:0, mode:6 cur_net.flags:0x40e
[ 2039.097830] Linking with summit,channel:1, qos:1, myHT:0, networkHT:0, mode:6 cur_net.flags:0x40e
[ 2039.098110] ===>rtllib_associate_procedure_wq(), chan:1
[ 2039.098120] HTSetConnectBwMode():pHTInfo->bCurBW40MHz:0
[ 2039.108140] rtllib_authentication_req():auth->algorithm is OPEN
[ 2039.109903] rtl8192_SetWirelessMode(), wireless_mode:4, bEnableHT = 0
[ 2039.113867] Associated successfully
[ 2039.113876] normal associate
[ 2039.113904] Using G rates:108
[ 2039.113911] Successfully associated, ht not enabled(0, 0)
[ 2039.115597] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 2042.470364] DHCP pkt src port:68, dest port:67!!
[ 2049.504017] wlan0: no IPv6 routers ...

Read more...

Revision history for this message
Matt Price (matt-price) wrote :

Caleb, can you try the dkms package in my ppa:
https://launchpad.net/~matt-price/+archive/mattprice

it fixes a similar issue for me on my thinkpad T410

Revision history for this message
Daniel (internalkernel) wrote :

You... sir, are a scholar and a gentleman... I added your ppa, installed the rtl8192se-dkms package... quick reboot, and wireless is working as expected. Interestingly enough, previously my wlan signal strength would alternate from 10% to 70% - now it's steady at 90%.

Thanks again...

Revision history for this message
yunta (yunta83) wrote :

Matt, your package also fixes similar problem on Aristo C140 laptop. Thank you.

Revision history for this message
Matt Price (matt-price) wrote : Re: [Bug 530275] Re: [LUCID] EEEPC-1201N missing RTL8192SE module required for wifi card

excellent, glad to hear it! There's clearly something weird about the
way the rtl8192 module was added to the ubuntu source tree -- it's hard
to say exactly what the issue is as the docs and other supporting files
don't seem to have been included on that commit. I have some more info
on a separate bug I filed: lp:550123. That should probably be marked as
a duplicate of this one, or vice-versa. Are there any kernel developers
listening out there?

Revision history for this message
Matthew Ballard (matthewrobertballard) wrote :

Matt, thanks so much. I went from detecting no networks to a solid connection with my home network.

Revision history for this message
Martin Lindhe (martinlindhe) wrote :

lp bug #401126 might be a duplicate of this one. the same driver rtl8192se is a suggested solution in that bug

Revision history for this message
pablomme (pablomme) wrote :

@ Matt Price:

> There's clearly something weird about the way the rtl8192 module
> was added to the ubuntu source tree

It seems to be based on a different version. Yours is version 0015 (released on the 11th of March), while in the Ubuntu kernel version 0014 is used instead. The files under linux-2.6.32/ubuntu/rtl8192se correspond to the ones under rtl8192se-2.6.0015.0127.2010/HAL/rtl8192 in your dkms package -- which are indeed the ones compiled into the .ko according to your Makefile. If you diff the files in those directories ('-bB' to eliminate rubbish), you'll see lots of small changes.

I think what we basically want here is the ubuntu module to be rebased against version 0015 from Realtek, which appears to work reliably.

Revision history for this message
iniurb (iniurb) wrote :

I agree, I went back to a clear 9.10, installed 0015 driver on my Asus 1201N and it works fine now.

Revision history for this message
travtek (bddunham) wrote :

Thanks Matt Price! your patch fixed the wireless problem on my Thinkpad T-510

Revision history for this message
Michael Stucky (mike-stucky) wrote :

@ Matt Price:

Will your dkms package work for a 64-bit system? I'm running Ubuntu 10.4 64-bit on my Asus 1201N.

Revision history for this message
Matt Price (matt-price) wrote :

in fact i think it will only work with 64-bit; anyway if it installs on
your system it should run. good luck! hopefulyl soon the devs will fix
the bug anyway. all the best,

matt

On Fri, 2010-04-23 at 23:40 +0000, Michael Stucky wrote:
> @ Matt Price:
>
> Will your dkms package work for a 64-bit system? I'm running Ubuntu 10.4
> 64-bit on my Asus 1201N.
>

--
Matt Price
<email address hidden>

Revision history for this message
pablomme (pablomme) wrote :

@matt: no, it works on 32-bit just fine. This is the sources we are dealing with, it should (and does) work on all architectures.

Revision history for this message
martux (martin-knoopnet) wrote :

hi folks,

i can also confirm, that installing the package rtl8192se-dkms_2.6.0015.0127.2010_all.deb (2.1 MiB) solves the wlan-probs on my eeepc 1201T with kernel 2.6.32-21 (10.04 rc). good work, matt!

Revision history for this message
iniurb (iniurb) wrote :

Patch already needed on RC and probably on Final Release

Revision history for this message
Laura (bbbmc59) wrote :

Thank you SO much Matt! Wireless did not work on Asus Eee 1201n and now works super. Great work and thank you for sharing.

Revision history for this message
pablomme (pablomme) wrote :

I've noticed kernel 2.6.32-22 has popped into lucid-proposed, with the change:

[ Tim Gardner ]
  * ubuntu: rtl8192se -- update to version 0015.0127.2010
    - LP: #567016

which should fix this bug. Bug #567016 is yet another unflagged dupe of this one.

I'm a bit concerned about Launchpad's efficiency with dupes. The bug that got addressed is 10 days old. This one is two months old, and has contained a link to a PPA with a fix for 3 weeks (not an attachment flagged as "patch", though). Bug #401126 is 9 months old at the moment. The vendor's fix (version 0015) is 50 days old.

As users, apart from flagging dupes (which we haven't in this case), is there anything we can do to help here, especially to get developers to notice an existing fix?

Anyway, I'm going to mark all these bugs as dupes of the newer one so that they get the "fixed released" status.

Revision history for this message
anthonycoyle (coyle-anthony) wrote :

I am newish to Ubuntu. On making a new install on my dual boot Aesus eee 1000H netbook of Ubuntu netbook 10.4 I have no wireless connection. The router shows up on my netbook and when I try to connect I am asked for the passkey. Despite correctly typing this the netbook fails to connect. Ethernet connection fine. On checking drivers I get report no propriatry drivers are in use. Please help restore wireless connection. When I boot into XP the netbook connects wirelessly to the router at once

Revision history for this message
MikeZ83 (michael-zock) wrote :

@anthonycoyle: Have you tried to replace the default network manager with wicd (simply install the "wicd" package using a package manager like synaptic or aptitude)?
I've had a similar problem with the same chipset and switching to wicd actually not only solved the problem but made managing network connections more comfortable.

Revision history for this message
anthonycoyle (coyle-anthony) wrote :

Hi Mike,
I downloaded wicd and used this to try to connect. I could see my router with very strong signal. However I could not connect wirelessly. The report was "Bad password" though the password was in fact exact, Bug /545443 is still alive and well on my Asus eee 1000H netbook with Ubuntu 10,4

Revision history for this message
JTux (juliette-tux) wrote :

Thanks alot Matt Price! The packet fixed the issue with wifi on Lenovo Thinkpad L412 with default kernel in Ubuntu 10.04.

Revision history for this message
Matt Price (matt-price) wrote :

On 11-03-31 12:07 PM, JTux wrote:
> *** This bug is a duplicate of bug 567016 ***
> https://bugs.launchpad.net/bugs/567016
>
> Thanks alot Matt Price! The packet fixed the issue with wifi on Lenovo
> Thinkpad L412 with default kernel in Ubuntu 10.04.
>
hey, glad to hear it. I thought that recent lucid kernels included the
fix... I will look back over my thinkpad records and see whether I'm
still using that package!
matt

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions