Ubuntu

Misidentified HP pavilion bios fails kernel suspend

Reported by Edward Lee on 2010-02-28
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Edward Lee

Bug Description

ahci_broken_suspend( ..... ) in the current Lucid kernel misidentifies the new revision of HP dv6 laptops. It mistakenly believes that the new Core iX dv6 series laptops, with their bios revisions < F.21, do not support AHCI suspend. This causes suspend to fail on these laptops.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
 Vendor: Hewlett-Packard
 Version: F.13
 Release Date: 12/03/2009
 ROM Size: 1536 kB
 Characteristics:
  PCI is supported
  BIOS is upgradeable
  BIOS shadowing is allowed
  Boot from CD is supported
  Selectable boot is supported
  EDD is supported
  Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
  Japanese floppy for Toshiba 1.2 MB is supported (int 13h)
  5.25"/360 KB floppy services are supported (int 13h)
  5.25"/1.2 MB floppy services are supported (int 13h)
  3.5"/720 KB floppy services are supported (int 13h)
  3.5"/2.88 MB floppy services are supported (int 13h)
  8042 keyboard services are supported (int 9h)
  CGA/mono video services are supported (int 10h)
  ACPI is supported
  USB legacy is supported
  BIOS boot specification is supported
  Targeted content distribution is supported
 BIOS Revision: 15.33
 Firmware Revision: 50.35

Handle 0x0001, DMI type 1, 27 bytes
System Information
 Manufacturer: Hewlett-Packard
 Product Name: HP Pavilion dv6 Notebook PC
 Version: 049D210000241210000020000
 Serial Number: CNF95136DF
 UUID: 434E4639-3531-3336-4446-00269EC35C40
 Wake-up Type: Power Switch
 SKU Number: WA788UA#ABC
 Family: 103C_5335KV

Handle 0x0002, DMI type 2, 16 bytes
Base Board Information
 Manufacturer: Hewlett-Packard
 Product Name: 3658
 Version: 32.23
 Serial Number: CNF95136DF
 Asset Tag: Base Board Asset Tag
 Features:
  Board is a hosting board
  Board is replaceable
 Location In Chassis: Base Board Chassis Location
 Chassis Handle: 0x0003
 Type: Motherboard
 Contained Object Handles: 0

Handle 0x0003, DMI type 3, 22 bytes
Chassis Information
 Manufacturer: Hewlett-Packard
 Type: Notebook
 Lock: Not Present
 Version: N/A
 Serial Number: None
 Asset Tag:
 Boot-up State: Safe
 Power Supply State: Safe
 Thermal State: Safe
 Security Status: None
 OEM Information: 0x00000112
 Height: Unspecified
 Number Of Power Cords: 1
 Contained Elements: 0

Feb 28 09:30:00 fish-laptop kernel: [ 3064.133516] CPU0 attaching NULL sched-domain.
Feb 28 09:30:00 fish-laptop kernel: [ 3064.133524] CPU1 attaching NULL sched-domain.
Feb 28 09:30:00 fish-laptop kernel: [ 3064.133528] CPU2 attaching NULL sched-domain.
Feb 28 09:30:00 fish-laptop kernel: [ 3064.133531] CPU3 attaching NULL sched-domain.
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194422] CPU0 attaching sched-domain:
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194426] domain 0: span 0-1 level SIBLING
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194430] groups: 0 (cpu_power = 589) 1 (cpu_power = 589)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194437] domain 1: span 0-3 level MC
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194440] groups: 0-1 (cpu_power = 1178) 2-3 (cpu_power = 1178)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194447] CPU1 attaching sched-domain:
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194450] domain 0: span 0-1 level SIBLING
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194452] groups: 1 (cpu_power = 589) 0 (cpu_power = 589)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194458] domain 1: span 0-3 level MC
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194461] groups: 0-1 (cpu_power = 1178) 2-3 (cpu_power = 1178)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194468] CPU2 attaching sched-domain:
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194470] domain 0: span 2-3 level SIBLING
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194472] groups: 2 (cpu_power = 589) 3 (cpu_power = 589)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194478] domain 1: span 0-3 level MC
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194481] groups: 2-3 (cpu_power = 1178) 0-1 (cpu_power = 1178)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194487] CPU3 attaching sched-domain:
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194490] domain 0: span 2-3 level SIBLING
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194492] groups: 3 (cpu_power = 589) 2 (cpu_power = 589)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194498] domain 1: span 0-3 level MC
Feb 28 09:30:00 fish-laptop kernel: [ 3064.194501] groups: 2-3 (cpu_power = 1178) 0-1 (cpu_power = 1178)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.195070] CPU0 attaching NULL sched-domain.
Feb 28 09:30:00 fish-laptop kernel: [ 3064.195074] CPU1 attaching NULL sched-domain.
Feb 28 09:30:00 fish-laptop kernel: [ 3064.195076] CPU2 attaching NULL sched-domain.
Feb 28 09:30:00 fish-laptop kernel: [ 3064.195079] CPU3 attaching NULL sched-domain.
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304245] CPU0 attaching sched-domain:
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304250] domain 0: span 0-1 level SIBLING
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304253] groups: 0 (cpu_power = 589) 1 (cpu_power = 589)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304259] domain 1: span 0-3 level MC
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304262] groups: 0-1 (cpu_power = 1178) 2-3 (cpu_power = 1178)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304270] CPU1 attaching sched-domain:
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304273] domain 0: span 0-1 level SIBLING
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304275] groups: 1 (cpu_power = 589) 0 (cpu_power = 589)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304281] domain 1: span 0-3 level MC
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304284] groups: 0-1 (cpu_power = 1178) 2-3 (cpu_power = 1178)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304291] CPU2 attaching sched-domain:
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304293] domain 0: span 2-3 level SIBLING
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304295] groups: 2 (cpu_power = 589) 3 (cpu_power = 589)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304301] domain 1: span 0-3 level MC
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304304] groups: 2-3 (cpu_power = 1178) 0-1 (cpu_power = 1178)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304310] CPU3 attaching sched-domain:
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304313] domain 0: span 2-3 level SIBLING
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304315] groups: 3 (cpu_power = 589) 2 (cpu_power = 589)
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304321] domain 1: span 0-3 level MC
Feb 28 09:30:00 fish-laptop kernel: [ 3064.304324] groups: 2-3 (cpu_power = 1178) 0-1 (cpu_power = 1178)
Feb 28 09:30:11 fish-laptop kernel: [ 3065.520870] PM: Syncing filesystems ... done.
Feb 28 09:30:11 fish-laptop kernel: [ 3065.680421] PM: Preparing system for mem sleep
Feb 28 09:30:11 fish-laptop kernel: [ 3065.680429] Freezing user space processes ... (elapsed 0.00 seconds) done.
Feb 28 09:30:11 fish-laptop kernel: [ 3065.681283] Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
Feb 28 09:30:11 fish-laptop kernel: [ 3065.681323] PM: Entering mem sleep
Feb 28 09:30:11 fish-laptop kernel: [ 3065.681345] Suspending console(s) (use no_console_suspend to debug)
Feb 28 09:30:11 fish-laptop kernel: [ 3065.920072] sd 0:0:0:0: [sda] Synchronizing SCSI cache
Feb 28 09:30:11 fish-laptop kernel: [ 3065.920244] sd 0:0:0:0: [sda] Stopping disk
Feb 28 09:30:11 fish-laptop kernel: [ 3071.855195] ACPI handle has no context!
Feb 28 09:30:11 fish-laptop kernel: [ 3071.855351] wl 0000:02:00.0: PCI INT A disabled
Feb 28 09:30:11 fish-laptop kernel: [ 3071.871842] ahci 0000:00:1f.2: BIOS update required for suspend/resume
Feb 28 09:30:11 fish-laptop kernel: [ 3071.871854] pci_legacy_suspend(): ahci_pci_device_suspend+0x0/0xb0 returns -5
Feb 28 09:30:11 fish-laptop kernel: [ 3071.871862] pm_op(): pci_pm_suspend+0x0/0x130 returns -5
Feb 28 09:30:11 fish-laptop kernel: [ 3071.871865] PM: Device 0000:00:1f.2 failed to suspend: error -5
Feb 28 09:30:11 fish-laptop kernel: [ 3071.871867] PM: Some devices failed to suspend
Feb 28 09:30:11 fish-laptop kernel: [ 3071.891885] wl 0000:02:00.0: restoring config space at offset 0x1 (was 0x100002, writing 0x100006)
Feb 28 09:30:11 fish-laptop kernel: [ 3071.891943] wl 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Feb 28 09:30:11 fish-laptop kernel: [ 3071.891956] wl 0000:02:00.0: setting latency timer to 64
Feb 28 09:30:11 fish-laptop kernel: [ 3071.977419] sd 0:0:0:0: [sda] Starting disk
Feb 28 09:30:11 fish-laptop kernel: [ 3074.996987] Registered led device: xpad11
Feb 28 09:30:11 fish-laptop kernel: [ 3074.997062] input: Microsoft X-Box 360 pad as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/input/input24
Feb 28 09:30:11 fish-laptop kernel: [ 3074.997198] PM: resume devices took 3.130 seconds
Feb 28 09:30:11 fish-laptop kernel: [ 3074.997209] PM: Finishing wakeup.
Feb 28 09:30:11 fish-laptop kernel: [ 3074.997210] Restarting tasks ... done.
Feb 28 09:30:11 fish-laptop kernel: [ 3075.134746] r8169: eth0: link up
Feb 28 09:30:12 fish-laptop kernel: [ 3075.580790] CPU0 attaching NULL sched-domain.
Feb 28 09:30:12 fish-laptop kernel: [ 3075.580798] CPU1 attaching NULL sched-domain.
Feb 28 09:30:12 fish-laptop kernel: [ 3075.580802] CPU2 attaching NULL sched-domain.
Feb 28 09:30:12 fish-laptop kernel: [ 3075.580805] CPU3 attaching NULL sched-domain.
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705606] CPU0 attaching sched-domain:
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705611] domain 0: span 0-1 level SIBLING
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705615] groups: 0 (cpu_power = 589) 1 (cpu_power = 589)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705622] domain 1: span 0-3 level MC
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705625] groups: 0-1 (cpu_power = 1178) 2-3 (cpu_power = 1178)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705633] CPU1 attaching sched-domain:
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705636] domain 0: span 0-1 level SIBLING
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705638] groups: 1 (cpu_power = 589) 0 (cpu_power = 589)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705644] domain 1: span 0-3 level MC
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705647] groups: 0-1 (cpu_power = 1178) 2-3 (cpu_power = 1178)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705654] CPU2 attaching sched-domain:
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705656] domain 0: span 2-3 level SIBLING
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705659] groups: 2 (cpu_power = 589) 3 (cpu_power = 589)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705664] domain 1: span 0-3 level MC
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705667] groups: 2-3 (cpu_power = 1178) 0-1 (cpu_power = 1178)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705674] CPU3 attaching sched-domain:
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705676] domain 0: span 2-3 level SIBLING
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705678] groups: 3 (cpu_power = 589) 2 (cpu_power = 589)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705684] domain 1: span 0-3 level MC
Feb 28 09:30:12 fish-laptop kernel: [ 3075.705687] groups: 2-3 (cpu_power = 1178) 0-1 (cpu_power = 1178)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.706299] CPU0 attaching NULL sched-domain.
Feb 28 09:30:12 fish-laptop kernel: [ 3075.706303] CPU1 attaching NULL sched-domain.
Feb 28 09:30:12 fish-laptop kernel: [ 3075.706306] CPU2 attaching NULL sched-domain.
Feb 28 09:30:12 fish-laptop kernel: [ 3075.706308] CPU3 attaching NULL sched-domain.
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925180] CPU0 attaching sched-domain:
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925185] domain 0: span 0-1 level SIBLING
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925188] groups: 0 (cpu_power = 589) 1 (cpu_power = 589)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925195] domain 1: span 0-3 level MC
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925198] groups: 0-1 (cpu_power = 1178) 2-3 (cpu_power = 1178)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925207] CPU1 attaching sched-domain:
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925209] domain 0: span 0-1 level SIBLING
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925212] groups: 1 (cpu_power = 589) 0 (cpu_power = 589)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925218] domain 1: span 0-3 level MC
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925220] groups: 0-1 (cpu_power = 1178) 2-3 (cpu_power = 1178)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925227] CPU2 attaching sched-domain:
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925229] domain 0: span 2-3 level SIBLING
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925232] groups: 2 (cpu_power = 589) 3 (cpu_power = 589)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925238] domain 1: span 0-3 level MC
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925240] groups: 2-3 (cpu_power = 1178) 0-1 (cpu_power = 1178)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925247] CPU3 attaching sched-domain:
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925249] domain 0: span 2-3 level SIBLING
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925252] groups: 3 (cpu_power = 589) 2 (cpu_power = 589)
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925258] domain 1: span 0-3 level MC
Feb 28 09:30:12 fish-laptop kernel: [ 3075.925260] groups: 2-3 (cpu_power = 1178) 0-1 (cpu_power = 1178)

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: fish 1496 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd6400000 irq 22'
   Mixer name : 'Intel G45 DEVIBX'
   Components : 'HDA:111d7603,103c3658,00100202 HDA:80862804,80860101,00100000'
   Controls : 24
   Simple ctrls : 13
Date: Sun Feb 28 09:32:07 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100122)
MachineType: Hewlett-Packard HP Pavilion dv6 Notebook PC
NonfreeKernelModules: wl
Package: linux-image-2.6.32-14-generic 2.6.32-14.20
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-14-generic root=UUID=f2c0791a-3474-4589-be78-bf34111fa2e7 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
Regression: No
RelatedPackageVersions: linux-firmware 1.31
Reproducible: Yes
RfKill:

SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-14-generic x86_64
dmi.bios.date: 12/03/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.13
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3658
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 32.23
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.13:bd12/03/2009:svnHewlett-Packard:pnHPPaviliondv6NotebookPC:pvr049D210000241210000020000:rvnHewlett-Packard:rn3658:rvr32.23:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6 Notebook PC
dmi.product.version: 049D210000241210000020000
dmi.sys.vendor: Hewlett-Packard

Edward Lee (tigerfishdaisy) wrote :
Edward Lee (tigerfishdaisy) wrote :

(The F.13 BIOS is the latest revision, on the new laptops)

Changed in linux:
status: Unknown → Confirmed
Tejun Heo (tj-kernel) wrote :

Can someone please attach dmidecode output at bko#15462?

  http://bugzilla.kernel.org/show_bug.cgi?id=15462

Thanks.

Edward Lee (tigerfishdaisy) wrote :

Patch is upstream now. Bring it into Ubuntu?

Changed in linux (Ubuntu):
status: New → Confirmed
Edward Lee (tigerfishdaisy) wrote :

Patch from upstream.

Edward Lee (tigerfishdaisy) wrote :

Patch works, as expected.

Chase Douglas (chasedouglas) wrote :

Because of the size of this patch, I'd prefer to see it be incorporated upstream first. In general, the Ubuntu kernel is based on the -stable kernel tree. When this patch is accepted upstream, it can be sent to <email address hidden> for inclusion into the -stable tree. Once it's included in a -stable release, we will incorporate the patch into the Ubuntu kernel.

I will monitor the kernel bug to determine the best course of action for this issue.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: nobody → Chase Douglas (chasedouglas)
tags: added: patch
Changed in linux:
status: Confirmed → Fix Released
Chase Douglas (chasedouglas) wrote :

According to the linux bugzilla entry, the fix has been sent to the linux-ide mailing list, but not yet pulled into any development trees. It has also been Cc'd to <email address hidden>, so it will be evaluated through that process on its way to Ubuntu. So for now we wait.

Changed in linux (Ubuntu):
assignee: Chase Douglas (chasedouglas) → nobody
Edward Lee (tigerfishdaisy) wrote :

It's been pulled into 2.6.34-rc2.

Changed in linux:
importance: Unknown → Medium
Julian Wiedmann (jwiedmann) wrote :

This patch ("ahci: use BIOS date in broken_suspend list") landed in Lucid with 2.6.32-20.29.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.