Ubuntu

Screen goes "Out of Range" when boot into live cd and first time ubuntu boot up

Reported by Ed Hewitt on 2010-02-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

This is a bug which has been affecting me since Ubuntu 7.10 (its the first release I started with), and has happened in every single Ubuntu release since then. I have been putting off writing this bug report, because I am not sure how I can explain the problem well enough.

The issue is with the monitor I use with Ubuntu. Its a Advent F159 15inch (4:3) monitor (http://www.amazon.co.uk/Advent-F159-Silver-LCD-Monitor/dp/B000GRU6O2)

It supports 800x600 and 1024x768 with 60hz. When I boot off the live CD with Ubuntu, when the it gets to the stage with xorg takes over, it chooses the wrong setting for the monitor, the monitor says "Out of Range". What I have to do is start the Ubuntu live CD, tell it to boot into live cd mode, then unplug the vga port on monitor. After about 5mins (enough time for Ubuntu to boot), I plug in the monitor and I can see the Ubuntu desktop. It will be running on 800x600 at 60hz, 16bit.

Here, I am able to install Ubuntu. Once install is complete, and I boot into Ubuntu for the first time, the problem will happen again if I leave the monitor plugged in. So I have force a restart and unplug the monitor, boot into Ubuntu, and plug the monitor back in. Ubuntu will again set the monitor to 800x600 at 60hz, 16bit. I will then configure xorg.conf file. All I do is tell it to use 1024x768 @ 60hz, on 24bit. I restart Ubuntu, and its running at the correct resolution for me. I can now leave the monitor plugged in and it will not give me the "out of range" message.

In the time I have had Ubuntu, I have used 3 computers with this monitor. First Ubuntu PC used an ATi Radeon 7000 card (using ati open source driver), my next computer used a Intel i815 (using intel opensource driver) and my latest computer is using nVidia ION (using nvidia's drivers). This out of range problem happened with all these computers. I attach my xorg configure for all these computers.

ProblemType: Bug
Architecture: i386
Date: Sun Feb 28 09:38:58 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/Xorg
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Lsusb:
 Bus 002 Device 003: ID 05e3:1205 Genesys Logic, Inc. Afilias Optical Mouse H3003
 Bus 002 Device 002: ID 04f3:0103 Elan Microelectronics Corp.
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 004: ID 059f:0c41 LaCie, Ltd
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Acer Aspire R3600
NonfreeKernelModules: nvidia
Package: xserver-xorg-core 2:1.6.4-2ubuntu4.1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-19-generic root=UUID=121a561f-c5ef-411e-a726-1ac13fe0dd9c ro quiet splash
ProcEnviron:
 LANG=en_GB.UTF-8
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu10
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2.1
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xorg-server
Uname: Linux 2.6.31-19-generic i686
dmi.bios.date: 07/22/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R01-A2L
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: FMCP7A-ION
dmi.board.vendor: Acer
dmi.chassis.type: 3
dmi.chassis.vendor: Acer
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR01-A2L:bd07/22/2009:svnAcer:pnAspireR3600:pvr:rvnAcer:rnFMCP7A-ION:rvr:cvnAcer:ct3:cvr:
dmi.product.name: Aspire R3600
dmi.sys.vendor: Acer
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-19-generic

Also, just a bit more information.

When I have install Windows XP and Windows 7 using this monitor, it has never gone out of range in windows, During install and first time bootup, it has always selected the correct resolution.

Bryce Harrington (bryce) on 2010-03-02
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic

Bryce, it happens in Lucid as well. To be honest, its happen in Gusty, Hardy, Intrepid, Jaunty, Karmic and now Lucid.

Bit more information for you. The screen supports upto 1024x768 @ 75hz. I think the reason it goes out of range is due to Ubuntu setting the refresh at 85.

Also, do you want me to update this bug with information regarding lucid?

tags: added: lucid
Bryce Harrington (bryce) wrote :

Hi Chewit, yes if you could run 'apport-collect 529387', that'll automatically attach all the info needed.

Thank you for taking the time to write such a clear and concise bug report. From your description I can make some pretty good guesses about what's going on. Every monitor has a circuit embedded in it which communicates the device's capabilities (refresh rates, resolutions, etc.) to the computer when asked. It is not uncommon for this information to be incorrectly encoded by the hardware manufacturer. For example, we've seen some manufactures specify the monitor's dimensions in cm's instead of in mm's, or putting in plain old typos. In some cases, for whatever reason, Linux is not able to retrieve the data. This data from the monitor is called EDID. My guess is that something is wrong with your monitor's EDID or X.org's ability to retrieve it.

Unfortunately none of the files attached here include the EDID so I can't verify this. Sometimes this is included in the output of 'xrandr --auto' or listed in the Xorg.0.log file itself. In your case neither happened. There is also a pair of tools in the read-edid package to retrieve this - you run it as "get-edid | parse-edid". A lot of times this just shows 'EDID fail' though so it might not be helpful.

Another angle to try would be to uninstall -nvidia. With Lucid we've brought in an alternative open source video driver for NVIDIA hardware called -nouveau. This uses the linux kernel to retrieve the EDID and configure the resolution modes (this is referred to as Kernel Mode-Setting, or KMS). I doubt this will do any better with your hardware but it's worth a shot. KMS is considered the "way forward" and is where developer efforts are being focused.

Probably the easiest way to test -nouveau would be to boot Lucid via a LiveCD. If you choose to test it on your installed system, note that you'll need to uninstall (and maybe purge) your old -nvidia installation. See http://wiki.ubuntu.com/X/Troubleshooting for a page about conflicts between nvidia and nouveau.

Finally, I have to ask... why are you sticking with such an old video monitor? 1024x768 is such a limited resolution. If you've been able to upgrade to newer CPUs and graphics, why not a new monitor while you're at it?

Thanks for the input Bryce.

First, I'm not currently able to get to my computer, but I will be able to next week to try those commands out.

Second, I think you could be right about the EDID, that might be the problem, Windows does not seem to have an issue with it though.

Third, you talk about trying out the new nouveau, this does not fix the issue! I have try this monitor with radeon, ati, intel and nv drivers, the only drivers which stops the monitor going out of range is the official binary nvidia drivers. In the past, the way I have installed Ubuntu is to unplug the monitor before boot up, and plug it back in after. It selects a resolution which the monitor can use, which is 800x600. WHY CANT UBUNTU DO THIS WITH THE MONITOR PLUGGED IN??? <<< Please answer!

The new nouveau drivers do not allow me to unplug the monitor and plug it back in, since it crashes Xorg, thats why I discovered this bug, WHICH STILL NEEDS PATCHING! https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/538501

Bryce Harrington (bryce) on 2010-04-07
Changed in xorg-server (Ubuntu):
importance: Undecided → High
Bryce Harrington (bryce) on 2010-04-08
Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete

Just ran this command, sudo get-edid | parse-edid, which you told me to try. Here is the output:

ed@ed-desktop:~$ sudo get-edid | parse-edid
parse-edid: parse-edid version 2.0.0
get-edid: get-edid version 2.0.0

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
 Function supported
 Call successful

 VBE version 300
 VBE string at 0x2110 "NVIDIA"

VBE/DDC service about to be called
 Report DDC capabilities

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
 Function supported
 Call successful

 Monitor and video card combination does not support DDC1 transfers
 Monitor and video card combination supports DDC2 transfers
 0 seconds per 128 byte EDID block transfer
 Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
 Read EDID

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
 Function supported
 Call successful

parse-edid: EDID checksum passed.

 # EDID version 1 revision 1
Section "Monitor"
 # Block type: 2:0 3:fc
 Identifier "17'' LCD"
 VendorName "RTK"
 ModelName "17'' LCD"
 # Block type: 2:0 3:fc
 # Block type: 2:0 3:fc
 # Block type: 2:0 3:fd
 HorizSync 20-92
 VertRefresh 43-85
 # Max dot clock (video bandwidth) 140 MHz
 # Block type: 2:0 3:ff
 # DPMS capabilities: Active off:yes Suspend:yes Standby:yes

 # Block type: 2:0 3:fc
 # Block type: 2:0 3:fc
 # Block type: 2:0 3:fd
 # Block type: 2:0 3:ff
EndSection

I wonder if the problem lies here with the EDID output:

Identifier "17'' LCD"
VendorName "RTK"
ModelName "17'' LCD"

Its a15 inch monitor.

Just fixed my own problem!

When I start the Live CD, I enter a custom configuration before Ubuntu boots off the CD. If i type;

video=CTR-0:800x600

The screen does not go out of range! Instead it sets the resolution to the correct 1024x768!!!

This is with the Ubuntu 10.04 RC Live CD!

Not sure if you want to changed this to fix Bryce???

It appears this morning, the following command is not working on the 10.04RC live cd.

video=CRT-0:800x600

Can anyone see a problem with this command.

Update. Just tried video=CRT-0:800x600 command on Ubuntu 9.10 Live CD and it worked fine. I wonder if this is a bug in Lucid.

Daniel Hollocher (chogydan) wrote :

hey chewit, I marked this confirmed because it looks like you answered Bryce's question.

Changed in xorg-server (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Thanks for your testing, it looks like the issue is due to the kernel setting wrong video modes so I'm going to bump it over to the kernel team to look at. I'm glad to hear you were able to work around the problem with the video= option. That should probably be advertised more widely...

affects: xorg-server (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: High → Undecided
status: Confirmed → New
Jeremy Foshee (jeremyfoshee) wrote :

Hi chewit,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

I dont think I am able to install that kernel on my current computer, because the bug will not occur since my resolution has set correctly. This bug only happens if I have not set the correct resolution, so it only happens on the live cd and first time boot up. I am able to test the new kernel if I am able to get a re-spun ubuntu live cd with this particular kernel.

tags: removed: needs-upstream-testing

I have got a new screen now, so this bug might as well be closed, since i cant do anymore work on it.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
nUboon2Age (nuboon2age) wrote :

Bug is not really fixed and not invalid -- original reporter chewit just found a workaround and then marked it invalid. Returned to 'confirmed' as it was previously realizing that unless someone else runs into the bug and provides further testing information there may be no more work done on it.

Changed in linux (Ubuntu):
status: Invalid → Confirmed
nUboon2Age (nuboon2age) wrote :

Correction: changed back to incomplete as Jeremy Foshee had set it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu development release http://cdimage.ubuntu.com/daily-live/current/ . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.