WARNING: at /build/buildd/linux-2.6.32/net/wireless/core.c:614 wdev_cleanup_work+0xa7/0xd0 [cfg80211]()

Bug #528688 reported by Marjo F. Mercado
854
This bug affects 242 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

This crash occurred after restarting system. Before the restart I was using xchat, evolution & firefox over a wireless network.

ProblemType: KernelOops
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Annotation: Your system might become unstable now and might need to be restarted.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marjomercado 1343 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfbcb8000 irq 16'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,1043834a,00100004'
   Controls : 12
   Simple ctrls : 7
Date: Thu Feb 25 11:58:09 2010
DistroRelease: Ubuntu 10.04
Failure: oops
Frequency: This has only happened once.
HibernationDevice: RESUME=UUID=175c6736-c8c1-45f5-bd47-0d7b33415a29
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100129)
MachineType: ASUSTeK Computer INC. 1008HA
Package: linux-image-2.6.32-14-generic 2.6.32-14.20
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-14-generic root=UUID=7a480c2c-0ce9-4645-98af-9a8b43e84f1e ro quiet splash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.31
Reproducible: No
SourcePackage: linux
TestedUpstream: No
Title: WARNING: at /build/buildd/linux-2.6.32/net/wireless/core.c:614 wdev_cleanup_work+0xa7/0xd0 [cfg80211]()
Uname: Linux 2.6.32-14-generic i686
dmi.bios.date: 04/27/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0302
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1008HA
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0302:bd04/27/2009:svnASUSTeKComputerINC.:pn1008HA:pvrx.x:rvnASUSTeKComputerINC.:rn1008HA:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1008HA
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Revision history for this message
Marjo F. Mercado (marjo-mercado) wrote :
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Chase Douglas (chasedouglas) wrote :

We've seen this issue a few times from a few people now. I think I may have a fix (http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=c0ce77b8323c1a0d4eeef97caf16c0ea971222a9), but I'm not positive. I can build a test kernel with the fix, but we need a way to properly test whether the fix works.

Is anyone able to reproduce this issue, and/or can anyone do some stress testing (seems to be triggered by suspend/resume) to see if they can reproduce it?

Thanks

Revision history for this message
nanog (sorenimpey) wrote :

I get this sporadically while resuming and can test.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@nanog:

I've built a new kernel with the patch: http://people.canonical.com/~cndougla/528688/. Please test it out to determine if it fixes the issue.

Thanks

Changed in linux (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
status: Confirmed → In Progress
Revision history for this message
Chase Douglas (chasedouglas) wrote :

BTW, anyone else who wants to test out the new kernel, please do.

Thanks

Changed in linux (Ubuntu):
status: In Progress → Incomplete
Revision history for this message
dl.zerocool (dl.zerocool) wrote :

I'm going to test the new dev, results are coming asap.

Revision history for this message
dl.zerocool (dl.zerocool) wrote :

Sorry I'm unable to test it :
Preparing to replace linux-headers-2.6.32-16-generic 2.6.32-16.23~lp528688 (using linux-headers-2.6.32-16-generic_2.6.32-16.23~lp528688_amd64.deb) ...
Unpacking replacement linux-headers-2.6.32-16-generic ...
Selecting previously deselected package linux-image-2.6.32-16-generic.
Unpacking linux-image-2.6.32-16-generic (from linux-image-2.6.32-16-generic_2.6.32-16.23~lp528688_amd64.deb) ...
Done.
Setting up linux-headers-2.6.32-16-generic (2.6.32-16.23~lp528688) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 2.6.32-16-generic /boot/vmlinuz-2.6.32-16-generic
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common 2.6.32-16-generic /boot/vmlinuz-2.6.32-16-generic

dpkg: dependency problems prevent configuration of linux-image-2.6.32-16-generic:
 linux-image-2.6.32-16-generic depends on linux-tools; however:
  Package linux-tools is not installed.

linux-tools-common replace linux-tools so I'm not able to install it.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@dl.zerocool:

The -16 kernel is a bit old now. Perhaps the dependency has been fixed in a newer kernel. I will build a new kernel with the patch. I'll reply when it's available.

Thanks

Revision history for this message
Chase Douglas (chasedouglas) wrote :

I've uploaded a new kernel based on the 2.6.32-19 kernel. Please install it and test.

Thanks

Revision history for this message
Ralph (ralph-s) wrote :

I reported this same issue in bug 546469 and I tested the new kernel.

I didn't get a kernal panic but I still suffered from the same problem of my wireless network connection randomly dropping.

Revision history for this message
Slimfat Jan (slimfatjan) wrote :

I just updated the system and have the same issue.

Revision history for this message
Marius Adrian (rav3nspy) wrote :

Same problem here after update

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@Slimfat and @Marius:

Have you tested the kernel I provided? The patch is not in any Ubuntu released kernels because it hasn't seen sufficient testing and success reports.

Thanks

Revision history for this message
mozgreen (mozgren) wrote :

Crash report at startup on last four consecutive boots. I haven't a clue why except that a box tells me it's a kernel prob.

Revision history for this message
Matthew Babbs (matt-babbs) wrote :

I've been hammering suspend and hibernate all day with the 2.6.32-19 patch and haven't seen any more of this problem. Can't say for sure as I don't have a reliable STR, but it looks like the patch fixes the problem without introducing any new bugs :)

Revision history for this message
Nicholas Christian Langkjær Ipsen (ncli) wrote :

I'm testing it as well. So far so good.

Revision history for this message
Nicholas Christian Langkjær Ipsen (ncli) wrote :

I've now restarted three times, and suspended three times. Nothing at all. I think this can be marked as "Fix Committed," unless someone else encounters a problem.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

Great! Thanks for testing. I will send the patch to the kernel-team mailing list for review. However, this will be too late for the Lucid release. It will hopefully land in the first kernel update though.

Changed in linux (Ubuntu):
status: Incomplete → In Progress
Revision history for this message
Franz Altmüller (franz-altm) wrote :

This error occurs on my system only if i plug in the networkcable. The cablenetwork is not going 'on', and the error occurs when turning off the wireless-network-option.

regards
frank

Revision history for this message
Franz Altmüller (franz-altm) wrote :

After reconfiguring 'Cable_Network' to 'auto' the error didnt occur, and the connection was established.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

Due to the positive reports in comments #15, #16, and #17 I have sent the patch to the kernel-team mailing list for inclusion in 10.04 LTS. It is not likely to make it in for the release image, but it should make it into the first update release.

tags: added: metabug
Revision history for this message
Matthew Babbs (matt-babbs) wrote :

I see the proposed fix hasn't yet made it in, but for whatever reason the issue hasn't appeared for me since the upgrade to stock Lucid kernel 2.6.32-21.

Revision history for this message
Garrett Nievin (gnievin) wrote : Re: [Bug 528688] Re: WARNING: at /build/buildd/linux-2.6.32/net/wireless/core.c:614 wdev_cleanup_work+0xa7/0xd0 [cfg80211]()

On Fri, 23 Apr 2010 17:51:50 -0000
Matthew Babbs <email address hidden> wrote:

> I see the proposed fix hasn't yet made it in, but for whatever reason
> the issue hasn't appeared for me since the upgrade to stock Lucid kernel
> 2.6.32-21.
>

Same here. It's no longer happening for me since upgrading.

Revision history for this message
Øyvind Stegard (oyvindstegard) wrote :

I've got issues with wireless connectivity and have seen the kernel warning recently in linux-image-2.6.32-21-generic [ 2.6.32-21.32] (lucid/main) x86 iwl3945.

Revision history for this message
YoBa (ya-baeyens) wrote :

I was also affected by the problem, having a HP Pavilion HDX9200 notebook. Actually, I was able to boot but I had to specify the following kernel parameter at boot time: acpi=no_irq. The webcam was not working any longer with this parameter.

The kernel proposed by Chase Douglas solved the problem. I'm now able to boot.

Thanks a lot, Chase !

Revision history for this message
YoBa (ya-baeyens) wrote :

Strange ... since an upgrade to kernel 2.6.32-22 ... seems like it is no longer working. Even when I try to boot with the older 2.6.32-19 kernel !

Revision history for this message
YoBa (ya-baeyens) wrote :

Do not consider my previous comment. I don't think it is an upgrade of the kernel that caused the problem. I checked the date of the installation of this kernel version in /var/log/dpkg.log. It is dated from 2010-05-11. So the installation of this kernel was before the installation of Chase's kernel. My problem can't be related to an upgrade of the kernel. To be honest ... I don't know what happened.

Revision history for this message
pat.pannuto (ppannuto) wrote :

I'm running 2.6.32-22-generic and this problem still persists. The warning appears to be the same:

[347134.298465] ------------[ cut here ]------------
[347134.298490] WARNING: at /build/buildd/linux-2.6.32/net/wireless/core.c:614 wdev_cleanup_work+0xe9/0x110 [cfg80211]()
[347134.298500] Hardware name: 2746CTO
[347134.298502] Modules linked in: binfmt_misc ppdev rfcomm sco bridge stp bnep l2cap openafs(P) vboxnetadp vboxnetflt vboxdrv snd_hda_codec_intelhdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep fbcon tileblit font bitblit softcursor snd_pcm_oss snd_mixer_oss snd_pcm vga16fb vgastate snd_seq_dummy snd_seq_oss snd_seq_midi arc4 snd_rawmidi joydev i915 snd_seq_midi_event drm_kms_helper iwlagn snd_seq snd_timer snd_seq_device sbp2 uvcvideo iwlcore drm snd btusb videodev i2c_algo_bit psmouse mac80211 soundcore v4l1_compat sdhci_pci bluetooth snd_page_alloc sdhci v4l2_compat_ioctl32 serio_raw cfg80211 intel_agp video output asus_laptop led_class ricoh_mmc lp parport ohci1394 ahci ieee1394 r8169 mii
[347134.298551] Pid: 9, comm: events/0 Tainted: P 2.6.32-22-generic #36-Ubuntu
[347134.298553] Call Trace:
[347134.298562] [<ffffffff81066d0b>] warn_slowpath_common+0x7b/0xc0
[347134.298566] [<ffffffff81066d64>] warn_slowpath_null+0x14/0x20
[347134.298572] [<ffffffffa00b50f9>] wdev_cleanup_work+0xe9/0x110 [cfg80211]
[347134.298579] [<ffffffffa00b5010>] ? wdev_cleanup_work+0x0/0x110 [cfg80211]
[347134.298584] [<ffffffff81080777>] run_workqueue+0xc7/0x1a0
[347134.298587] [<ffffffff810808f3>] worker_thread+0xa3/0x110
[347134.298591] [<ffffffff81085320>] ? autoremove_wake_function+0x0/0x40
[347134.298594] [<ffffffff81080850>] ? worker_thread+0x0/0x110
[347134.298597] [<ffffffff81084fa6>] kthread+0x96/0xa0
[347134.298601] [<ffffffff810141ea>] child_rip+0xa/0x20
[347134.298604] [<ffffffff81084f10>] ? kthread+0x0/0xa0
[347134.298607] [<ffffffff810141e0>] ? child_rip+0x0/0x20
[347134.298610] ---[ end trace 935f3f6d63ec3f2f ]---

Any ideas?

Revision history for this message
Chase Douglas (chasedouglas) wrote :

The patch that seems to fix this issue will be in the next kernel release. It would actually be good if someone could test the kernel in lucid-proposed, as it has the patch and will likely be the next kernel that is pushed out.

Thanks!

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
YoBa (ya-baeyens) wrote :

Hello Chase,

It is working with 2.6.32-19-generic #29~lp528688. But it isn't working, on my HP Pavilion HDX9200 with 2.6.32-23.37 (lucid-proposed). I just can't boot with the latter kernel.

Yoba

Revision history for this message
YoBa (ya-baeyens) wrote :

Hello Chase,

One important information. It is said in the comments of bug #561190 that the bug is similar to bug #528688. That's why I tested your kernel. Kernel 2.6.32-19-generic #29~lp528688 actually solved my problem: I'm able to boot with it.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

YoBa,

I'm not sure why the latest -proposed kernel won't boot for you. Please file a new bug for the issue because this bug should not cause a failure to boot.

Thanks

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
assignee: Chase Douglas (chasedouglas) → nobody
To post a comment you must log in.