Ubuntu

MacBook gets extremely hot under Linux

Reported by Bart Verwilst on 2006-07-13
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6-686

When using Kubuntu on my macbook, after an hour or so, i can hardly touch the bottom of the laptop, it's really hot, especially on the left side. When i reboot to MacOS X and check the cpu temperature with CoreDuoTemp, it's 68-69°. Leaving MacOS X running slowly brings down the temperature to +- 58-60°. The bottom panel of the laptop is also a lot cooler when touching it. ( still pretty warm, but no more tinteling 'damn, i'm going to burn my skin!' feeling :)

Ben Collins (ben-collins) wrote :

Please provide the exact kernel version using:

cat /proc/version

Thanks

Bart Verwilst (verwilst) wrote :

Linux version 2.6.15-25-686 (buildd@terranova) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 SMP PREEMPT Wed Jun 14 11:34:19 UTC 2006

martinbures (needemesleepe) wrote :

I have the same problem.

Linux version 2.6.15-26-686 (buildd@terranova) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 SMP PREEMPT Thu Aug 3 03:13:28 UTC 2006

Is there any other information that I can get you to help solve this problem?

Henk Koster (h-a-j-koster) wrote :

Same problem here.

I notice that "acpi -V" says: "No support for device type: thermal".
Gnome CPU-Frequency-applet shows 54% (1.0GHz out of 1.83GHz max) for both cores when idling.

Under similar conditions the OS X frequency is usually 1.5GHz. Yet, after running Ubuntu for a while the area around the power connector gets very hot (with or without power connected). When I then quickly reboot to OS X, the temperature is close to 70C, and then (still in OS X) slowly dropping to 55-60C.

During this all I never hear a fan (but then my hearing ain't too good).

Henk Koster (h-a-j-koster) wrote :

When I "saved" (submitted) the above message, one of the core frequencies shot momentarily up to 100%, only to quickly settle down to 54% again in a number of steps. So, I don't think that the problem is CPU frequency related...

One difference that I notice is that without input activity the screen switches to half-bright very quickly, and then dims completely with the computer going to sleep not much later.
In Ubuntu this does not happen (the screen will switch to screensaver, which is not the same), and will not automatically go to sleep. BTW, the sleep function works OK on closing the lid, requiring password to get going on wakeup.

Could it be powersupply related then?

martinbures (needemesleepe) wrote :

My sleep does _not_ work.

Bart Verwilst (verwilst) wrote :

Same here, sleep does not work...

I also noticed my MacBook (Black) getting very hot (much hotter than in OS X). I recently applied a firmware update which claimed to improve fan behavior, but so far I didn't notice any difference.

The directories /proc/acpi/fan/ and /proc/acpi/thermal_zone/ are both empty - so Ubuntu's power management hasn't discovered the fan and cooling systems!

I'm not sure if the MacBook firmware itself can and will prevent serious overheating. If it doesn't, couldn't that cause permanent damage to the device? In that case, this bug should be addressed with higher priority, it certainly is of highest priority to MacBook users who care for the safety of their pricy MacBooks!

(About the "sleep not working" comments: Can't comment, but if it doesn't work, please file another bug since it's not directly related to the overheating issue.)

cat /proc/version

Linux version 2.6.15-26-686 (buildd@terranova) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 SMP PREEMPT Thu Aug 3 03:13:28 UTC 2006

(Same as the other's version!)

Timothy Smith (tas50) wrote :

I have a Macbook "Ultimate" (as the Apple retail stores call it) and I haven't had any issues with the heat under Ubuntu Edgy. Could any of you try a Edgy Beta and see if the problems persist.

Martijn Vermaat (mvermaat) wrote :

This is not fixed in current Edgy. There is no temperature information in /proc and the MacBook slowly gets hotter even when almost idle.

With coretemp.c [1] I can see the temperature of the two cores going up to about 78 and 79 degrees Celcius and at that point the fan kicks in. The fan seems to be able to bring back the temperature to about 54 degrees Celcius (but the bottom of the MacBook still feels pretty hot) and then the process repeats.

The Gnome CPU frequency applet reports 1GHz about 80% of the time, with the occasional 1.83GHz peaks (this is a 1.83GHz MacBook). This behaviour seems independent of the temperature.

I guess the cause for all this is that the kernel has no temperature information available, also reported in bug #56785 .

[1] http://svn.sourceforge.net/viewvc/mactel-linux/trunk/tools/temperature/

This may be a fix.

A new GPL'ed OSX application called "smcFanControl" allows a user to control the minimum fan speed on Intel MacBooks through a simple interface. It appears that this minimum fan speed setting carries over into Edgy without issue on a multi-boot system, but more testing is needed.

A firmware upgrade helped cool the CPU temperature on my MacBook from 70C+ to 55C-60C during extended "normal" use. With the above "fix" [minimum speed of 4500rpm (will probably lower this later)], my current temperature is 41C after an hour of "normal" use.

It's nice to have a MacBook that I can call a "laptop". I hope this continues to work without issue.

In reference to my comment above, it holds the speed during a reboot from OSX to Ubuntu (using refit). It's a step in the right direction, I suppose.

Roel Huybrechts (rulus) on 2006-11-28
Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed
Timothy Smith (tas50) wrote :

Can someone test this with Edgy + updates and Feisty so we can see if this bug can be closed?

martinbures (needemesleepe) wrote :

I have a fully updated Edgy system and it gets very hot when running idle and I get about 1/2 the battery life of what I can expect in OS X. I found this and tried it:

http://wiki.debian.org/MacBook

CPU frequency scaling is governed by SPEEDSTEP_CENTRINO kernel module.

echo speedstep_centrino >> /etc/modules

So I tried it. It seems to make a bit of a difference. It definitely cooled the thing down in my lap a little bit. I would say that I probably get an extra 30 minutes of run time.

Philipp Edelmann (tukss) wrote :

I notice the same behavior with the standard kernel from feisty and a gutsy 2.6.22 kernel from git with mactel patches applied. I have a Macbook Pro with a C2D processor.
The acpi-cpufreq module seems to work. It sets the correct values for the MSRs and a lower frequency is displayed. But if you use measurefreq from linux-phc you see that speedstepping doesn't work at all and the CPU works at 2.16 GHz (in my case) the whole time. speedstep-centrino doesn't work at all

FATAL: Error inserting speedstep_centrino (/lib/modules/2.6.22-8-generic/kernel/arch/i386/kernel/cpu/cpufreq/speedstep-centrino.ko): No such device

Bart Verwilst (verwilst) wrote :

Removing myself from this bug since i havent had a macbook in ages! Not even sure if this is still an issue..

Bart Verwilst (verwilst) wrote :

Ah crap i reported this :) If nobody has any objections/additions, i guess this can be closed invalid?

Steffen Röcker (sroecker) wrote :

This is still an issue for me under hardy. I have an MacBook1,1.
Tried intrepid yesterday and it seems to get better, need to test it longer though.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Steffen Röcker (sroecker) wrote :

Intrepid and 2.6.27 solved this problem for me. I think you can close it now.

Since this is quite old with no change for quite some time, and since there is also a newer discussion at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/262550, I am marking this as a duplicate. Hope you don't mind.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments