Ubuntu

hotplug interferes with ethernet card

Reported by Rolf Leggewie on 2010-02-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Manoj Iyer
Lucid
Medium
Manoj Iyer

Bug Description

it is not exactly clear to me what triggers this, but it's absolutely reproducible (big Thank You to SynrG from #eeepc for telling me how to fix this). Ethernet works fine when booting the ASUS 1001P pinetrail netbook from one of the live CD, but my legacy karmic system (lucid kernel!) on HD booted from USB will not show the ethernet device in lspci or ifconfig unless giving the kernel the boot param eeepc_laptop.hotplug_disabled=1. Upstream knows about this and has committed a fix, although that needs to be broadened to include the 1001P as well, not only the 1005P, it seems. Please look through http://bugzilla.kernel.org/show_bug.cgi?id=14570, especially comment 31 and make up your mind what's happening here. I don't understand it ;-)

I think we should have a fix for this in lucid and possibly in karmic as well. These are cheap and popular devices that many newcomers will use for taking Ubuntu for a test drive.

Rolf Leggewie (r0lf) on 2010-02-24
Changed in linux (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-2
status: New → Triaged
description: updated
description: updated
Changed in linux:
status: Unknown → Fix Released
Andy Whitcroft (apw) on 2010-05-24
tags: added: kernel-net kernel-reviewed
Manoj Iyer (manjo) wrote :

We can make sure that this is available in Maverick, since this is not a critical bug to SRU, I am afraid it will not apply to Lucid.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Rolf Leggewie (r0lf) wrote :

I'm really saddened to see that a Canonical employee and member of bug control use their privileges without due care. If your new at this, take your time to learn, please, and try to be more careful in the future.

The current status before your change was just as you described how it should be (triaged for the current dev release). Reopening the ticket.

Changed in linux (Ubuntu):
status: Won't Fix → Triaged
Manoj Iyer (manjo) wrote :

Request to include SHAID bc9d24a3aeb1532fc3e234907a8b6d671f7ed68f subject eeepc-laptop: check wireless hotplug events in 2.6.32 stable sent to <email address hidden>.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
assignee: nobody → Manoj Iyer (manjo)
Stefan Bader (smb) wrote :

For the current development release this is fixed. Also I would not classify this as high as there seems to be a workaround. Trying to get the patch into Lucid looks acceptable. The goal however is to get this generally into the .32 stable series and from there let it float back into Lucid. For Karmic this is not an issue that qualifies for SRU as it is past the time-frame where we fix non-critical bugs.

Changed in linux (Ubuntu):
importance: High → Medium
status: Incomplete → Fix Released
Changed in linux (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Triaged
Manoj Iyer (manjo) wrote :

There are 2 patches pointed to in the BZ report, the 1st patch is already in Lucid (eeepc-laptop: dmi blacklist to disable pci hotplug code), the 2nd patch (eeepc-laptop: check wireless hotplug events) is not in lucid, but it is in mainline. I emailed stable requesting that this patch (eeepc-laptop: check wireless hotplug events) be included in 2.6.32 stable. The patch does not cleanly apply to Ubuntu Lucid tree, I have a kernel with this patch backported. Can you please test this kernel and report back here ?

http://people.canonical.com/~manjo/lp527361-lucid/

Changed in linux (Ubuntu Lucid):
status: Triaged → Incomplete
assignee: nobody → Manoj Iyer (manjo)
Manoj Iyer (manjo) wrote :

Can someone try the kernel I posted above and report back here?

Changed in linux:
importance: Unknown → Medium
Rolf Leggewie (r0lf) wrote :

I revisited this ticket today and I'm happy to report that apparently the latest lucid kernel also correctly boot from USB without the boot parameter and still brings up the ethernet device (albeit as eth3 which I assume is not a problem). Closing as fix released.

Changed in linux (Ubuntu Lucid):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.