No longer able to resume from suspend with the Lucid kernel

Bug #523072 reported by David Planella
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Chase Douglas

Bug Description

After the upgrade to Lucid, my laptop does no longer resume from suspend.

Whenever I start a suspend cycle, the machine seems to suspend without trouble (at least it seems to go to sleep and reports no error). When I press the power button to wake it up, I see some disk activity, the power LED is lit but the screen remains blank and I must end up keeping pressed the power button to shut down.

I use the 'nouveau' driver'. At the time of reporting the bug I had tested with the nvidia and nv drivers with the same result, but currently the nvidia driver seems to work (i.e. it can resume from suspend normally).

As for the questions on https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume:

* I've got o encrypted swap
* The machine never wakes up
* Reproducible every time, I've tested it about 10 times by either calling Suspend... from the GUI, by letting the machine suspend on inactivity and by using 'sudo sh -c "sync; echo 1 > /sys/power/pm_trace; pm-suspend"'
* Suspend and resume worked fine in Karmic
* I do not end up with flashing caps-lock
* This seems to be a regression from Karmic on this particular machine, where the suspend/resume process had worked without trouble

Suspending from text mode I did not get any error messages, either.

I also tried https://wiki.ubuntu.com/DebuggingKernelSuspend, but the hash did not seem to match any device, here are the relevant lines:

[ 0.570639] Magic number: 0:202:348
[ 0.570641] hash matches /build/buildd/linux-2.6.32/drivers/base/power/main.c:430

Let me know if you need more info.

Thanks!

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC861-VD Analog [ALC861-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC861-VD Analog [ALC861-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dpm 2262 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc300000 irq 22'
   Mixer name : 'Realtek ALC861-VD'
   Components : 'HDA:10ec0862,17aa3867,00100001'
   Controls : 19
   Simple ctrls : 12
Date: Wed Feb 17 09:20:49 2010
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=dc33e405-30f5-4f0a-94da-3eef7e1f406b
MachineType: LENOVO 0769AP2
NonfreeKernelModules: nvidia
Package: linux-image-2.6.32-13-generic 2.6.32-13.18
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-13-generic root=UUID=c1368c5e-eecd-4c2d-ac4e-883437f7455b ro quiet splash
ProcEnviron:
 LANGUAGE=ca_ES.UTF-8
 LANG=ca_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.29
Reproducible: Yes
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-13-generic i686
WifiSyslog: Feb 17 09:15:36 lenovo kernel: [ 1064.308188] NVRM: Xid (0001:00): 6, PE0000 0200 05000000 0000f7d4 00ffffff 03200000
WpaSupplicantLog:

dmi.bios.date: 07/29/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 68ET37WW
dmi.board.name: IEL10
dmi.board.vendor: LENOVO
dmi.board.version: REFERENCE
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLENOVO:bvr68ET37WW:bd07/29/2008:svnLENOVO:pn0769AP2:pvr3000N200:rvnLENOVO:rnIEL10:rvrREFERENCE:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: 0769AP2
dmi.product.version: 3000 N200
dmi.sys.vendor: LENOVO

Revision history for this message
David Planella (dpm) wrote :
Revision history for this message
Chase Douglas (chasedouglas) wrote :

I am not sure whether nv supports suspend/resume or not, but nvidia does. There's an open bug that this is very likely a duplicate of. You can check the bug and try the fix. If it does not solve your issues, unduplicate the bug and we can take a closer look.

Thanks

Revision history for this message
David Planella (dpm) wrote :

I've now stopped using the nvidia driver, I'm using nouveau instead.

Still the same problem, I'm not able to resume from suspend. I tried again the RTC trick and this time it gave me:

[ 0.659267] Magic number: 0:523:347
[ 0.659269] hash matches /build/buildd/linux-2.6.32/drivers/base/power/main.c:471
[ 0.659311] pci0000:00: hash matches

I'm not sure the second 'has matches' is meaningful

Revision history for this message
David Planella (dpm) wrote :

Tried it again with the nvidia driver, and I could not reproduce it. It seems the bug now only affects 'nouveau'.

Perhaps it needs the same quirk in /usr/lib/pm-utils/sleep.d/98-video-quirk-db-handler from pm-utils as the nvidia driver in bug 488720?

description: updated
description: updated
Revision history for this message
lavinog (lavinog) wrote :

I am having the same problem except I am using the open source radeon driver.

enabling pm_trace yielded this result:
[ 0.601249] Magic number: 0:523:740
[ 0.601295] hash matches /build/buildd/linux-2.6.32/drivers/base/power/main.c:471

Distributor ID: Ubuntu
Description: Ubuntu lucid (development branch)
Release: 10.04
Codename: lucid

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@lavinog:

Because of the nature of suspend/resume issues, your issue is likely to be due to a different cause than the original submitter's. Please search for a suspend/resume issue dealing with the radeon driver, or open a new one if you can't find one.

Thanks

Revision history for this message
Chase Douglas (chasedouglas) wrote :

I've done some debugging of this issue. This seems to be a poor interaction between lid closure and suspend. If you run pm-suspend (or send the dbus signal the gnome-power-manager uses when it detects a lid closure), my laptop resumes fine both by using the power button and by closing and opening the lid. However, if the suspend is initiated through a lid closure the backlight fails to come back on resume.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

Setting the nouveau param ignorelid to 1 fixes things for me. I'd be interested to hear if it fixes things for others. I'm going to try to figure out what the best solution to this is.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

I've found the nouveau commit from 2.6.34 that fixes the issue:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=b30083bdb990bcc2829fce83d871a86059ff4fc1;hp=c52e53fd38b195169c67a8cc9ed1af0125d2655c

With this patch, lucid suspends and resumes flawlessly for me. I sent the patch to <email address hidden> and to the Ubuntu kernel team mailing list.

Changed in linux (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
importance: Undecided → Medium
status: New → In Progress
Stefan Bader (smb)
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-18.27

---------------
linux (2.6.32-18.27) lucid; urgency=low

  [ Chase Douglas ]

  * SAUCE: Don't register vga16fb framebuffer if other framebuffers are
    present
    - LP: #527369

  [ Loïc Minier ]

  * [Config] armel/versatile: Set CRAMFS=m
    - LP: #524893
  * [Config] armel: Reset default command-line
    - LP: #524893

  [ Stefan Bader ]

  * build/modules: Update d-i to reflect recent config changes
    - LP: #546929

  [ Upstream Kernel Changes ]

  * (pre-stable) drm/nouveau: report unknown connector state if lid closed
    - LP: #523072
  * (pre-stable) Staging: rt2870: Add USB ID for Buffalo Airstation
    WLI-UC-GN
    - LP: #441990
  * (pre-stable) iwlwifi: fix nfreed--
    - LP: #545585
  * (pre-stable) pata_via: Add VIA VX900 support
    - LP: #548675
 -- Stefan Bader <email address hidden> Fri, 26 Mar 2010 18:39:42 +0100

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
David Planella (dpm) wrote :

The bug in the way I reported originally is still not fixed on my system, and I can still reproduce it in exactly the same way.

The upstream patch apparently fixes an issue when suspending through closing the lid, but I do not generally suspend or resume this way. I generally use the menu option or the sleep button on the laptop.

Sorry for the delay in providing some more input, but I had gone back to using the proprietary driver because it seems it's the only way my laptop can suspend.

I'm not changing the bug status, as I'm not sure what the bug workflow for the kernel team is, but this is still a Confirmed rather than a Fix Released one for me. Please let me know if I can provide more info if you need it. Thanks!

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@David:

I'm sorry to hear that. We like to track only one issue per bug report. I suggest opening a new bug to track your specific issue.

Thanks

Revision history for this message
flm (flmommens) wrote :

I just installed Beta 2 and have the same issue. The system suspends fine but on wake up I get a blank screen and unresponsive caps-lock. I'm using driver 195.36.15.
Let me know which additional information I need to post or if I need to open a new bug.
Thanks.

Revision history for this message
Nicolás Abel Carbone (nicocarbone) wrote :

I am having a similar problem in Lucid AMD64, completely updated. Let me know if there is something I need to post or if a new bug report needs to be open.

Revision history for this message
Nicolás Abel Carbone (nicocarbone) wrote :

I was able to solve the problem by activating ACPT HPET Table in the BIOS. May this be also a solution for the other people affected by this problem?

Revision history for this message
Glenn Smith (glenn-smith) wrote :

I have the same problem on a PackardBell EasyNote K5266. Suspend worked fine with Karmic, doesn't work with Lucid. I notice that, just before the machine suspends, the User/Password window that should appear at resume is already displayed. I have not installed the Nvidia driver.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers