keyboard freezes with kernel 2.6.32-13

Bug #522091 reported by Hein van Dam on 2010-02-15
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Live CD as well as installed kernel 2.6.32-13 freezes the system when I type something either in a terminal or in e.g. a search box. No problem with the mouse and typing passwords.

On the installed system I reinstalled 2.6.32-12 (which I am now using) this freezing doesn't occur.

Also the live i386 system freezes on the desktop with a AMD Athlon 64 X2 Dual Core Processor 4000+, not however on a netbook with an Intel Atom CPU N270.

This effect is reproducible with various updates of the daily-build of Lucid Lynx.

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tjapko 3635 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe020000 irq 16'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,10438232,00100002'
   Controls : 38
   Simple ctrls : 21
Date: Mon Feb 15 11:58:08 2010
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=711714a4-2e17-4b8a-9be3-b82c55cd0ac4
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091218)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: linux-image-generic 2.6.32.13.13
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-12-generic root=UUID=284f41ef-0c56-41e2-b441-f021b9dee72f ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.utf8
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.29
Reproducible: Yes
RfKill:

SourcePackage: linux-meta
TestedUpstream: No
Uname: Linux 2.6.32-12-generic x86_64
dmi.bios.date: 10/26/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2A-VM ACPI BIOS Revision 1501
dmi.board.name: M2A-VM
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2A-VMACPIBIOSRevision1501:bd10/26/2007:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2A-VM:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Hein van Dam (h-t-vandam) wrote :
Hein van Dam (h-t-vandam) wrote :

I'm afraid I jumped in too early thinking the kernel was responsible for my problem. It did start with the 2.6.32-13, but reinstalling 2.6.32-12 now gives the same problem. Starting in recovery mode, asking for a root terminal and performing 'start gdm' gives a stable system. So it is probably a NVIDIA problem as ususal.

My apologies.

Andy Whitcroft (apw) wrote :

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was reported against the linux-meta package when it likely should have been reported against the linux package instead. We are automatically transitioning this to the linux kernel package so that the appropriate teams are notified and made aware of this issue.

If this bug really is a bug in the linux-meta package you can move it back to linux-meta and tag it kj-linux-meta, or contact us on the #ubuntu-kernel channel on the FreeNode IRC server. Thanks.

affects: linux-meta (Ubuntu) → linux (Ubuntu)

It seems this was accidentally tagged regression-proposed. As there haven't been any Lucid kernels in -proposed up to this point I'm removing the tag.

Does this still exist with the latest Lucid daily images?

Thanks.

tags: removed: regression-proposed
NoBugs! (luke32j) on 2010-04-29
Changed in linux (Ubuntu):
status: New → Confirmed
Bert Claes (bertmlclaes) wrote :

@Leann

Yes, it still exist in the new release of Ubuntu (10.04), I've posted a message: Bug #364530. Starting in recovery mode, asking for a root terminal and performing 'start gdm' gives a stable system too for me.

ktp (kari-petersen) wrote :

@Bert Claes

Could you try to login to console with your user account or connect usb-keyboard after normal login and try
xmodmap -e "clear lock"
from console or console window and then logoff and login again?

This worked for me.

Bert Claes (bertmlclaes) wrote :

@ktp
Thanks for the info. but since I downloaded the nvidea proprietary driver, I don't even have time to log in the normal way. I just have 2 seconds before the computer freezes (typing, moving the mouse or doing nothing). If I log in to the console, and use the command I get the message "xmodmap: unable to open display ' ' ".

I don't thing it has anything to do with X or with the keyboard.
If I use the recovery mode and then..
a) normal boot, login in console, no X: I get the problems after a minute
b) root console, no X: everythings ok (can start gdm, gnome, everything).

ktp (kari-petersen) wrote :

@Bert Claes
I should have thought of that xmodmap requires X started.
I have a USB keyboard attached to my laptop. I noticed that I could not type after login so i removed the keyboard and plugged it in again to be sure that it is connected. After that it was usable, but the keyboard of the laptop still didn't react. Could you try if this behaves the same for you?

A little sidenote:
I use the ubuntu-x-swat x-updates ppa
Do you use this ppa?

Bert Claes (bertmlclaes) wrote :

@ktp
Yes, I've got the same behaviour.
I've got a PS/2 mouse and PS/2 keyboard standard connected to my desktop computer. When the computer freezes at the login screen, a newly connected USB keyboard did work, for just a few more letters of my password, but did freeze too.
(a newly connected USB mouse worked too, after a PS/2 mouse-freeze)
I do not use this ppa, I just have a fresh installation of Ubuntu 10.4

Lorenz (lorenz-schwaerzler) wrote :

hi,
I installed Lucid 10.04 with today downloaded image. my mouse (logitech, radio via usb) freezes and I can move it after 30-50sec for 4-9sec (estimated). it then freezes again. of course this is impossible to work. hope 10.04 will get useable soon.

have a AMD64 CPU. furtunatelly I have dualboot and can report this with my 9.10 installation. attached my xsession-errors from 10.04

Lorenz

Lorenz (lorenz-schwaerzler) wrote :

forgot to mention: am on kernel 2.6.32.22

Erik van Roode (evanroode) wrote :

ps/2 mouse & keyboard freeze, seems to be random, haven't noticed any correlation between freezes and things I'm doing yet at least.

Noticed something in /var/log/kern.log:

May 16 17:36:44 battlefield kernel: [ 2830.150052] atkbd.c: Unknown key pressed (translated set 2, code 0x0 on isa0060/serio0).
May 16 17:36:44 battlefield kernel: [ 2830.150054] atkbd.c: Use 'setkeycodes 00 <keycode>' to make it known.
May 16 17:36:52 battlefield kernel: [ 2838.198208] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.

Erik

Feo (alslovtsov) wrote :

If freezing does not appear after you start Ubuntu in recovery mode and type "gdm" - try to remove "irqbalance" (sudo aptitude purge irqbalance). This solution helped me.

Hein van Dam, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc4

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers