Ubuntu

Cannot boot 64-bit live CDs

Reported by doctordruidphd on 2010-02-09
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Charlie Kravetz

Bug Description

I cannot boot the 64-bit Live CDs for Karmic ubuntu, xubuntu, or kubuntu. When I attempt to boot, I get the language select screen, then the menu. When I choose either Run... or Install..., it goes immediately to a black screen with cursor in the upper left, and hangs. There is no response to CTRL-ALT-DEL or ALT-SYSRQ-REISUB; it requires powering down by turning off the power switch. The same problem exists with Lucid (which I realize is alpha) cds. The problem also exists with the most recent Sidux live CD (Sidux is another debian-sid distribution, using the 2.6.32 kernel). Note that I CAN boot with an installed karmic (2.6.31) and sidux (2.6.32) 64-bit systems, and with a karmic system upgraded to 2.6.32 kernel. Attempting to upgrade the karmic system to lucid produces a system that fails after the udev warnings, apparently unable to mount the file system.

This system is:
Dell XPS630i, 64-bit, Intel Q9550 core2dual quad processor, 8gb ram, NVIDIA board, dual NVIDIA 9800GT video cards, no onboard video.

What I have done:
 Verified MD5SUM of downloads and burns.
 Attempted removing the slave video card, does not help.
 Tried unplugging one or both hard disks, does not help.
 Tried booting off USB with all CD and hard drives unplugged, does not work.
 Tried the 32-bit CDs, these do boot though I have not tested them extensively.
 No RAID is in use on this system - RAID disabled in BIOS.
 Returning BIOS to default settings, does not help. No overclocking or overvoltage in use.
 Tried the Alternative CDs, they hang in the same spot.
 Tried the available options in F4 and F6, removing "splash", etc, does not help.

WORKAROUND: 8gb Ram, so mem=8589934592

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in casper.

affects: ubuntu → casper (Ubuntu)

hanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

Verifying that is does not work using another distribution may help in resolving this issue.

Thanks for taking the time to make Ubuntu better!

Changed in casper (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tags: added: lucid
doctordruidphd (doctordruidphd) wrote :

The same problem exists with the current 64-bit Sidux-Moros, Debian-Live-Lenny-5.0.3, and all ubuntu/kubuntu/xubuntu karmic and lucid versions. It also exists with the ubuntu-karmic-mini.iso. The problem DOES NOT exist on the current OpenSUSE-11.2 live cd. All of these have been tested both on CD and on USB sticks created with usb-creator-kde.
This system was designed for 64-bit, and came from the vendor with 64-bit vista on it.
When the system hangs, it does not respond to CTRL-ALT-DEL or any other key presses; it requires a power down with the power switch.
I am running the current 64-bit 2.6.31-20-generic kernel in karmic, and I am testing a karmic system upgraded to the current lucid 2.6.32 kernel, as well as an up-to-date Sidux 2.6.32 system, and all run without crashes or other problems.
I do not know if this problem is related, but I am unable to do a full upgrade of the karmic system to lucid. Attempting to boot after the upgrade results in a system hang after the udev warnings; the system is apparently unable to mount the file system. In the case of this attempted upgrade, after the system hangs it does respond to CTRL-ALT-DEL. So this is probably a different issue.

Grïzlürk (grizlurk) wrote :

I have the same issue with the Ubuntu/Kubuntu 64bit Alternative CD and 64bit DVD. After the black screen with the cursor, if you are patient enough, after 3 minutes you will have an error saying it can find the CDROM device. As for USB mouse and keyboard, If you wait 2 minutes it will start to work. When I finally managed to access the console, there was no device for the CDROM. With ot without NOLAPIC as boot parameter.

I was running OpenSuse 11.2 64bit and the only way to install with USB mouse/keyboard, was to set NOLAPIC in the boot parameter to get the mouse/keyboard to function. After the siystem was installed it was no required. When I updated the kernel to 2.6.32 USB devices started to acting up and this wait time of 2-3 minutes appeared. Tons of USB error messages started to appear.

Since when I launch Kubuntu or any other distros I have this wait time (NOLAPIC or not). I am starting to thing the 2.6.32 kernel might have brick my DVD/USB/Motherborad partialy.

I was able to install Windows XP (needed to being able to acces the net). Something who look somewhat related is within WinXP I need to go in the Device manager and redetect hardware to get the DVD drive to appear. Might be realted to the Netbook version of XP tho.

For now I am stuck in XP/IE. Next step is to flash the bios.

Computer specs:

ADM Athlon 64 X2 3600+
2GB of DDR2 667 RAM (128MB shared with video card)
1 TB Seagate SATA HDD (1 partition only Ext4 used as storage for soft, music etc)
300 GB Western Digital ATA 133 HDD (1 partition only /home Ext4)
80 GB Seagate SATA HDD : Patrition 1: 45 GB C:\ NTFS WinXp, Patrition 2: 20 GB Linux partition (blank for now), Partition 3: 4 GB Linux swap
Mouse/Keyboard: Microsoft Wireless Optical Desktop Receiver 2.1 + Microsoft Wireless Multimedia keyboard 1.1 and Microsoft Standard Wireless Optical mouse
Motherboard is EVGA nForce 730a (nVidia 730 chipset + latest BIOS)
Audio on board (Intel codec)
Lan on board (Realtek 8139 modules)
Video on board (nVidia GeForce 8200)

Nohing is overclocked.

Os Tested on it:
- Windows 7 RC2 (Stable for months)
- Windows XP Home HP mini 110 version (Stable)
- OpenSuse 11.2 (stable for months but USB/DVD Acting up since new kernel and/or some security updates)
- Ubuntu/Kubuntu 64bit CD Alternative and Ubuntu/Kubuntu 64bit DVD

I hope it can help.

doctordruidphd (doctordruidphd) wrote :

I have left the karmic and lucid disks in for 30 minutes, and they remain in the hang state. Only way out is a hard power down.

Grïzlürk (grizlurk) wrote :

Ok I am not sending this from Karmic 64bit after a successful install from the DVD. I was trying to boot from a USB key install. I went to the BIOS to make sure I can boot on the USB and ensure the boot order of the drives are were set to Removable, CDROM then Hard disks. In my reality USB sticks are Removable drive but it seems in some BIOS (mainly AWARD) their reality is different and they consider USB stick as Hard Drive. So while trying to boot on the "Hard Drive" it failed. I went back to the BIOS and changed the following:

- Set the boot order back to CDROM, Hard Disk (as if there is no USB key or floppy you need to press F1 and it is annoying)
- I went in the section where you can enable the USB legacy support, for computer without PS/2 mouse/keyboard.
- Offered me 3 USB device type choices of configuration: USB Mouse, USB Keyboard and USB Mass Storage
- In the USB mass storage it offer 3 ways to use USB mass storage: Floppy disk (FDD), Hard Drive (HDD) and Auto
- It was set up as AUTO then it was choosing HDD mode by default. So Is changed it to FDD mode.
- Saved the new config, Reboot and got the install to load whitout whining for a CDROM device etc.

I got a succesful install (via text mode as I am too impatient to deal with the resources hog of the graphical install). I am not sure if to change the mode of the USB storage you need to have a USB key in the USB port or not. This feature been added to the new BIOS I flashed some weeks ago then my USB/CDROM issues started to happen. This stupid error made me discover Ubuntu so at least this is positive.

It also solved the problem of the USB mouse/keyboard who took 2 minutes after the boot to being detected/enabled by whatever Linux distros including Ubuntu. No errors messages regarding USB in dmesg and successful install.

My BIOS is an AWARD 6.0PG (A730aZ13 version from EVGA)

I hope this help

Paddy

Grïzlürk (grizlurk) wrote :

Please read the first sentence as: OK I am NOW sending this from....

doctordruidphd (doctordruidphd) wrote :

Thanks for your comments, but the problem on my system is not with the CD drives nor with the USB or bios, as I can boot other systems with both cds and USBs. The problem is in the software, apparently casper, as older versions of k/ubuntu (8.10 for example) boot as they should. The newer live-cd, cd and USB installer versions of debian based systems (sidux, x/l/k/ubuntu, and even the newest lenny) are what do not boot; opensuse-11.2 does boot, from either cd or USB.

Have you tried booting the cd in safe mode? Hit F4 at the menu, select safe graphics, hit enter. Then I think you have to hit ESC and hit enter again, but I don't remember for certain. That allows it to bypass the video card. If you have all those distributions not working for you, it is probably a hardware incompatibility issue.

"Have you tried booting the cd in safe mode?"

Yes, I have tried that, and the alternative cd, and pretty much every kernel option I have been able to find. There certainly is an incompatibility issue, that we need to get resolved, since several distributions share the same problem.

mirix (miromoman) wrote :

This also affects my laptop. The bug also happens installing from a USB pen-drive.

The workaround is removing the "splash --" boot option and maybe adding the vga mode "vga=xxx" which corresponds to your monitor (see Linux video mode numbers in http://en.wikipedia.org/wiki/VESA_BIOS_Extensions). After doing this, you are still welcome by a black screen but after a while (a pretty long while if you are using the live CD), the KDE splash screen finally appears.

For Alpha 3: The LiveCD is perfectly usable and the installation proceeds without further complications. The system has been pretty stable this far, with the exception of a few minor KDE bugs.

"The workaround is removing the "splash --" boot option and maybe adding the vga mode "vga=xxx" which corresponds to your monitor"

Thank You for your suggestion, but as stated in the original post, I have tried removing splash -- and all the other options, and also tried all of the valid vga= options for my system, ones that do work with normal booting.

The live cd hangs no matter what, and I have left it for 30 minutes or longer. So the workaround is not effective on this system.

mirix (miromoman) wrote :

I tried Kubuntu 10.04 Alpha 3 and it works for me replacing "splash --" with "vga=789". I have a black screen for some minutes but finally the KDE splash screen shows up. I am sorry that this does not work for you, but it can be useful for others.

Your problem appears to be more serious because you reported it happens with virtually any Debian derivative, which is not the case for me.

jnm (jens-nolte) wrote :

I got the sameproblem here on my Fujitsu Siemens Scaleo T, AMD X2 5000+,4 G RAM.

I experienced this problem first after upgrading from 9.04 to 9.10, when the kernel version 2.6.31 showed these symptoms. The old kernel of 9.04 did boot, however.
I then installed the vanilla kernels 2.6.31 (which failed to boot like the karmic kernel), and then 2.6.32, which booted perfectly without any issues. Assuming some incompatibilities between my machine and kernel 2.6.31, I decided to stick to 2.6.32 and wait for Lucid to go back for the ubuntu kernel.

After downloading Lucid Alpha (1 and 2) in 64 bit, I experienced the same problem with the live CD. However, when installung the vanilla 2.6.32-9 (which -to my knowledge- is the base forthe Lucifkernel), I can perfectly well boot my Karmic without any issues. My machine boots fine with the Lucid alpha Live CD in i386 version, as well as OpenSuse 11.2 Live CD.

So generally there seems to be an issue with the ubuntu modifications of the kernel. Since I only get a black screen and no error message at all, I am having a hard time trying to submit some useful data for bugtracking. Any hints ?

Additional information:

I have tried several debian-based distributions, including l/x/k/ubuntu, sidx, and debian squeeze beta. None of them will boot from live CD or live USB.

OpenSUSE 11.2 and 11.3 "milestone" 3 boots and runs from the live cd. The kernel version is 2.6.33.

So basically the issue here is that no debian-based live-cds starting with kernel 2.6.31 are bootable. The systems themselves, once installed and upgraded from 2.6.<31 to higher, boot just fine from hard disk.

KyleSLinux (kspitz) wrote :

I have the same problem unfortunately. I downloaded and tried the amd64 iso for Ubuntu 10.04 Beta 2, and I was unable to boot my computer. I have also tried every "optional" boot option available and have been unsuccessful. I know when I installed Ubuntu 9.10, I could only have 64 bit if I installed 9.04 64 first and upgraded.

I have the same error as everyone else where I get a blinking cursor, then the computer becomes completely unresponsive.

Currently I'm running 9.10 x86 as it is the latest version I can successfully boot.

Any insight into this would be greatly appreciated.

Alan (evolutionspeak) wrote :

This problem occurs with all the Dell 630i computers in my office using the Live CD for 9.10 64-bit as well as 10.04 64-bit. 9.04 64-bit works fine, and upgrading after installing 9.04 also seems to work fine. If there is an option to turn on more verbose logging I would be happy to use it and post my logs.

jakeman66 (james-l-jacobs-cox) wrote :

I have exact same problem. 64 bit live cd's or USB installs will not load or install after menu selections. Also have a Dell XPS 630i.

jakeman66 (james-l-jacobs-cox) wrote :

Don't think so Alan. My system (Dell XPS 630i) has duel ATI cards. I did get Ubuntu 9.04 64 bit to install and am now in the process of upgrading via the update manager. Will advise if the update works.

jakeman66 (james-l-jacobs-cox) wrote :

Work around appears to be install from Ubuntu 9.04 AMD64 Live CD (or USB). After install of 9.04, use "Update Manager" to upgrade to Ubuntu 9.10, and then use "Update Manager" again to upgrade to 10.04. A lengthy process, but it works. Appears to be a hardware compatibility issue between kernels.

KyleSLinux (kspitz) wrote :

Jakeman66, Just to clarify if it's the same issue that I have. Are you able to boot the i386 10.04 and 9.10 cds? I have been successfully able to boot both 9.10 and 10.04 i386 Live installers, however I have been unable to boot x86_64. I also have a Dell XPS 630i, although I have an nvidia 280 gtx card.

jakeman66 (james-l-jacobs-cox) wrote :

KyleSLinux - yes, I could boot and install any 32 bit but not 64 bit.

Update on the work around: Install Ubuntu 8.04 LTS 64 bit version first. 8.04 can be upgraded to 10.04 directly from a network connection as identified on this page:
https://help.ubuntu.com/community/LucidUpgrades

Much quicker this way than from version 9.10.

jakeman66 (james-l-jacobs-cox) wrote :

Directions from my previous link:

Upgrade from 8.04 LTS to 10.04 LTS
Network Upgrade for Ubuntu Desktops (Recommended)
You can easily upgrade over the network with the following procedure.
   1. Press Alt-F2 and type update-manager --devel-release
   2. Click the Check button to check for new updates.
   3. If there are any updates to install, use the Install Updates button to install them, and press Check again after that is complete.
   4. A message will appear informing you of the availability of the new release.
   5. Click Upgrade.
   6. Follow the on-screen instructions.

jakeman66 (james-l-jacobs-cox) wrote :

Found a better work around which worked for me and other Dell owners.

Boot from CD or DVD
Highlight your preferred install option (I prefer compatibility mode)
Hit the tab key to add boot options
Add to end of existing string "mem=xxx" (without quotes and replace xxx with your memory
Hit return to start boot process

Formula to determine your memory is:
X*1024*1024*1024=mem
replace X with number of GB ram you have.
Example:
4GB Ram = 4*1024*1024*1024=4294967296

So for Dell 64 bit systems with 4GB ram, add "mem=4294967296" to the end of the boot options string.
For 6GB ram systems, add "mem=6442450944.

I've used for Ubuntu and Arch Linux and has worked both times, but without the string, my system appears to freeze but is actually performing a kernel panic.

P.S. Stumbled across this work around on the Fedora forums.

This workaround works on my system.
8gb Ram, so mem=8589934592

Can now boot live cd/usb for kubuntu 10.04.

So what does this mean? The kernel is not correctly detecting the amount of memory? If so, it sounds more like a kernel bug than casper.

jakeman66 (james-l-jacobs-cox) wrote :

But only affecting Dell 64 bit systems.. Dunno, weird.

Thomas Hood (jdthood) on 2012-06-20
summary: - Cannot boot 64-bit Karmic Live CDs
+ Cannot boot 64-bit live CDs
Stéphane Graber (stgraber) wrote :

Can't find any evidence of casper's fault there, sounds like a kernel issue, moving the bug.

affects: casper (Ubuntu) → linux (Ubuntu)

doctordruidphd, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please provide the information following https://wiki.ubuntu.com/DebuggingCasper ?

As well, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Please let us know your results. Thank you for your understanding.

tags: added: amd64 karmic
tags: added: regression-release
description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Just downloaded the latest kubuntu 12.04.1 amd-64 cd, and it boots as expected, without errors.
So I will mark this as resolved.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers