[Lucid] No longer boots with new 2.6.32-16 generic kernel

Bug #518452 reported by Dmitry Tantsur on 2010-02-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

After an update I was unable to boot my laptop. Boot process hangs after "Ubuntu" logo disappears.
I reinstalled Lucid from alpha2 CD and everything worked nicely.
After I updated the system again, laptop didn't boot.
I succeeded in booting previous 2.6.32-10 generic kernel, that's why I consider this a regression.

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: divius 1681 F.... pulseaudio
CRDA: Error: [Errno 2] Нет такого файла или каталога
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe4500000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,1025022b,00100004'
   Controls : 17
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xe4410000 irq 17'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [off]
Date: Sun Feb 7 19:57:47 2010
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=6e6c0d2e-69b9-40c8-aea7-4ec6170231f5
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100113)
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100113)
MachineType: Acer Aspire 5810T
Package: linux-image-2.6.32-12-generic 2.6.32-12.17
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-10-generic root=UUID=b5de0c34-5c56-414c-8544-abedc2785ac4 ro quiet splash
ProcEnviron:
 LANG=ru_RU.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.29
Reproducible: Yes
SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-10-generic x86_64
UserAsoundrc:
 # ALSA library configuration file

 # Include settings that are under the control of asoundconf(1).
 # (To disable these settings, comment out this line.)
 </home/divius/.asoundrc.asoundconf>
dmi.bios.date: 05/27/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: V1.15
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire 5810T
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrV1.15:bd05/27/2009:svnAcer:pnAspire5810T:pvrV1.15:rvnAcer:rnAspire5810T:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: Aspire 5810T
dmi.product.version: V1.15
dmi.sys.vendor: Acer

Dmitry Tantsur (divius) wrote :
Harry (harry33) wrote :

This is perhaps a dublicate to the bug 510524:
https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/510524

Try removing the package plymouth completely.
But note that the package libplymouth2 must remain untouched.
You may be able to boot into recovery mode.
Then drop into shell and run command:
sudo apt-get purge plymouth

Dmitry Tantsur (divius) wrote :

I'm not sure:

>During the boot I have a first freeze on ubuntu logo. To pass it I switch to Ctrl+Alt+F1 and come back to Alt-F7
>I access gdm, enter login+ pass and got a new freeze. Make another switch to Ctrl+Alt+F1 and come back to Alt-F7 and freeze disapear and gnome is ready.

Ctrl+Alt+F1 doesn't work for me. And if Plymouth is to blame, why booting with old kernel helps?

Dmitry Tantsur (divius) wrote :

Well, deleting Plymouth fixed the issue.

Jeremy Foshee (jeremyfoshee) wrote :

setting Triaged and Medium importance. Will inquire as to direction this should go today.

-JFo

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Chase Douglas (chasedouglas) wrote :

@Дмитрий "Divius" Танцур

I'm marking this as a duplicate bug of 510524 since removing plymouth fixed things for you.

Changed in linux (Ubuntu):
status: Triaged → Invalid
Steve Langasek (vorlon) wrote :

I don't think there's enough evidence here to conclude that this is a plymouth bug, or that it's the same as bug #510524. Plymouth doesn't do anything extraordinary that should break VT switching; if the system is hanging to the point where Ctrl+Alt+F1, Ctrl+Alt+F2, etc. have no effect, this is more likely to be a kernel problem.

Changed in linux (Ubuntu):
status: Invalid → New
Chase Douglas (chasedouglas) wrote :

@Дмитрий "Divius" Танцур:

There have been two major updates that may solve your issue. First, the 2.6.32-16 and later kernels have updated graphics drivers. Second, the plymouth package was just updated today to version 0.8.0~-13. Please upgrade to these versions of the packages and retest.

Thanks

Changed in linux (Ubuntu):
status: New → Incomplete
Dmitry Tantsur (divius) wrote :

Oh, I hope I'll be able to recover if something goes wrong... I'll try to tomorrow.

Dmitry Tantsur (divius) wrote :

It's ok now, thanks!

Dmitry Tantsur (divius) wrote :

Oh, no, it doesn't. Again I had the same problems and deleted this plymouth crap.

Changed in linux (Ubuntu):
status: Incomplete → New
Brian Murray (brian-murray) wrote :

How exactly did you go about deleting plymouth and does that allow you to boot consistently?

Changed in linux (Ubuntu):
status: New → Incomplete
summary: - [Lucid] No longer boots with new 2.6.32-12 generic kernel
+ [Lucid] No longer boots with new 2.6.32-16 generic kernel
Dmitry Tantsur (divius) wrote :

I'll try to once more. This story with Plymouth is strange.

Foffa (fredrik-and) wrote :

I can confirm a similar problem on my Intel 855GM. System boot OK with 2.6.31.X but I haven't been able too boot any of the 2.6.32-X kernels normaly.

When I disabled ACPI with a boot option in grub, the kernel 2.6.32-15 booted, but the system where unstable and crashed after 1 minute.

#> lspci
00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
02:01.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
02:09.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
02:09.2 FireWire (IEEE 1394): Texas Instruments PCI7x20 1394a-2000 OHCI Two-Port PHY/Link-Layer Controller
02:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

Download full text (5.6 KiB)

Wow! It does boot!

2010/3/23 Foffa <email address hidden>

> I can confirm a similar problem on my Intel 855GM. System boot OK with
> 2.6.31.X but I haven't been able too boot any of the 2.6.32-X kernels
> normaly.
>
> When I disabled ACPI with a boot option in grub, the kernel 2.6.32-15
> booted, but the system where unstable and crashed after 1 minute.
>
> #> lspci
> 00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
> to I/O Controller (rev 02)
> 00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV
> Processor to I/O Controller (rev 02)
> 00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV
> Processor to I/O Controller (rev 02)
> 00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
> Graphics Device (rev 02)
> 00:02.1 Display controller: Intel Corporation 82852/855GM Integrated
> Graphics Device (rev 02)
> 00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM
> (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
> 00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM
> (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
> 00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM
> (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
> 00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2
> EHCI Controller (rev 03)
> 00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
> 00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface
> Bridge (rev 03)
> 00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller
> (rev 03)
> 00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
> Controller (rev 03)
> 00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
> (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
> 00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
> Modem Controller (rev 03)
> 02:01.0 Network controller: Intel Corporation PRO/Wireless 2200BG
> [Calexico2] Network Connection (rev 05)
> 02:09.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
> 02:09.2 FireWire (IEEE 1394): Texas Instruments PCI7x20 1394a-2000 OHCI
> Two-Port PHY/Link-Layer Controller
> 02:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
> RTL-8139/8139C/8139C+ (rev 10)
>
>
> ** Attachment added: "dmesg"
> http://launchpadlibrarian.net/41649964/dmesg
>
> --
> [Lucid] No longer boots with new 2.6.32-16 generic kernel
> https://bugs.launchpad.net/bugs/518452
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Incomplete
>
> Bug description:
> After an update I was unable to boot my laptop. Boot process hangs after
> "Ubuntu" logo disappears.
> I reinstalled Lucid from alpha2 CD and everything worked nicely.
> After I updated the system again, laptop didn't boot.
> I succeeded in booting previous 2.6.32-10 generic kernel, that's why I
> consider this a regression.
>
> ProblemType: Bug
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel...

Read more...

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers