[lucid] Plymouth hangs at boot

Bug #518034 reported by Ruben Verweij on 2010-02-06
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: plymouth

I'm using the nouveau drivers from ppa:~xorg-edgers/nouveau. When selecting kernel 2.6.32.12.12 plymouth briefly shows up and then the system hangs, displaying the following messages every two minutes:
kernel: [ 240.216053] INFO: task plymouthd:229 blocked for more than 120 seconds.
kernel: [ 240.216095] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

If I select the 2.6.31-18 kernel it boots without plymouth to low graphics mode, stating drm can't find the device. {edit: that's because it's only installed in 2.6.32.12.12 of course}
If any more info is required, I will happily provide it.

ProblemType: Bug
Architecture: i386
CheckboxSubmission: d1356733fecbd9f61efca73482ee5328
CheckboxSystem: 3a099e6025b6966c7dc0b35e6bf85b5f
Date: Sat Feb 6 14:06:12 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: plymouth 0.8.0~-9
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-18.55-generic
SourcePackage: plymouth
Uname: Linux 2.6.31-18-generic i686

Ruben Verweij (ruben-verweij) wrote :
Ruben Verweij (ruben-verweij) wrote :

I forgot to mention I have two displays attached. I will attach my xorg.conf and Xorg.0.log.

Ruben Verweij (ruben-verweij) wrote :
Ruben Verweij (ruben-verweij) wrote :

I think the duplicate status is wrong, because in that bug the kernel doesn't lock up. I'm not able to switch to another tty because my whole kernel freezes and no key presses are registered any more.
Also, I don't have the freeze *when* plymouth is displaying the ubuntu logo but *after* it has vanished.
Therefore, I don't think this is a duplicate of 510524. Correct me if I'm wrong.

description: updated
Steve Langasek (vorlon) wrote :

If it's not a duplicate of the main plymouth tty handling bug, then I guess it must be a kernel bug instead; reassigning to the kernel.

affects: plymouth (Ubuntu) → linux (Ubuntu)
Jeremy Foshee (jeremyfoshee) wrote :

Ruben,
      Would it be possible for me to get the command: apport-collect -p linux 518034
run on this machine? That should send a few logs to this bug. I'd like to collect all of the environment and logging.

Thanks in advance,

-JFo

Changed in linux (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
tags: added: apport-collected
Ruben Verweij (ruben-verweij) wrote :

I'd love to, but I'm experiencing bug 516381. Also, I can only run the command in 2.6.31-18 because 2.6.32.12.12 won't boot if plymouth is installed. Removing plymouth solves the issue. So, if bug 516381 is resolved, should I run it in the older kernel or in the newer kernel without plymouth? Or is there another way?

Michael Evans (mjevans1983) wrote :

Daily build 20100222 fixes my framebuffer issues and this bug no longer effects me. However depending on a framebuffer as a core system component somehow seems like the wrong route to take.

noorbeast (noorbeast) wrote :

I am experiencing the same problem. I'm using the nouveau drivers from ppa:~xorg-edgers/nouveau and kernel 2.6.32-14. Result: kernel: [ 240.216053] INFO: task plymouthd:229 blocked for more than 120 seconds.
kernel: [ 240.216095] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

Ichthyostega (ichthyo) wrote :

Getting the same behaviour.

Just did a pristine install of Ubuntu 9.10 and then immediately did a dist-upgrade to Ubuntu Lucid Alpha.
System hangs on first boot into the newly installation; symptoms as described by the original report.

Using the failsafe boot entry, I was able to get a login and from there startx got me to gnome desktop.
This Computer is equipped with a nvidia card and dual head display; the upgrade had picked the nouveau
driver automatically

Ichthyostega (ichthyo) wrote :

stacktrace from /var/log/messages on each hang
Mar 1 23:04:40 ws3933 kernel: [ 1319.735024] plymouthd D 00004b46 0 301 1 0x00000000
Mar 1 23:04:40 ws3933 kernel: [ 1319.735029] f64f3e1c 00000086 00000001 00004b46 00000000 c087a6e0 f6a202ac c087a6e0
Mar 1 23:04:40 ws3933 kernel: [ 1319.735036] c6a02301 00000003 c087a6e0 c087a6e0 f6a202ac c087a6e0 c087a6e0 f643c8c0
Mar 1 23:04:40 ws3933 kernel: [ 1319.735042] c689de23 00000003 f6a20000 f698f414 f698f418 ffffffff f64f3e48 c05a40b6
Mar 1 23:04:40 ws3933 kernel: [ 1319.735048] Call Trace:
Mar 1 23:04:40 ws3933 kernel: [ 1319.735057] [<c05a40b6>] __mutex_lock_slowpath+0xc6/0x130
Mar 1 23:04:40 ws3933 kernel: [ 1319.735061] [<c05a3fd5>] mutex_lock+0x25/0x40
Mar 1 23:04:40 ws3933 kernel: [ 1319.735070] [<f8201b54>] nouveau_gem_ioctl_cpu_fini+0x54/0xb0 [lbm_nouveau]
Mar 1 23:04:40 ws3933 kernel: [ 1319.735072] [<c05a513f>] ? _spin_lock_irqsave+0x2f/0x50
Mar 1 23:04:40 ws3933 kernel: [ 1319.735080] [<f807e8cd>] lbm_drm_ioctl+0x25d/0x3e0 [lbm_drm]
Mar 1 23:04:40 ws3933 kernel: [ 1319.735089] [<f8201b00>] ? nouveau_gem_ioctl_cpu_fini+0x0/0xb0 [lbm_nouveau]
Mar 1 23:04:40 ws3933 kernel: [ 1319.735092] [<c01ff5c5>] ? mem_cgroup_update_mapped_file_stat+0x35/0x90
Mar 1 23:04:40 ws3933 kernel: [ 1319.735095] [<c01c7926>] ? unlock_page+0x46/0x50
Mar 1 23:04:40 ws3933 kernel: [ 1319.735097] [<c01e2200>] ? __do_fault+0x3a0/0x490
Mar 1 23:04:40 ws3933 kernel: [ 1319.735100] [<c03b8ac0>] ? vt_ioctl+0x0/0x16a0
Mar 1 23:04:40 ws3933 kernel: [ 1319.735103] [<c03af52c>] ? tty_ioctl+0x7c/0x630
Mar 1 23:04:40 ws3933 kernel: [ 1319.735110] [<f807e670>] ? lbm_drm_ioctl+0x0/0x3e0 [lbm_drm]
Mar 1 23:04:40 ws3933 kernel: [ 1319.735113] [<c02139a1>] vfs_ioctl+0x21/0x90
Mar 1 23:04:40 ws3933 kernel: [ 1319.735116] [<c0213c89>] do_vfs_ioctl+0x79/0x310
Mar 1 23:04:40 ws3933 kernel: [ 1319.735118] [<c05a7662>] ? do_page_fault+0x152/0x380
Mar 1 23:04:40 ws3933 kernel: [ 1319.735121] [<c0213f87>] sys_ioctl+0x67/0x80
Mar 1 23:04:40 ws3933 kernel: [ 1319.735123] [<c01033ec>] syscall_call+0x7/0xb

Ichthyostega (ichthyo) wrote :

just for the record: resolved the problem by apt-get purge plymouth

teh603 (darth-giles) wrote :

I had the same problem or a similar one with the AMD64 version, on an off-the-shelf Dell Inspiron 1564, i3 based version with Arrandale graphics. The system would hang on boot, and would sit there for a while before actually doing anything, if it did anything at all. Removing Plymouth with Synaptic worked, cut my boot time to a fraction of what it is with it installed, and gives me a few annoying command prompt errors on boot and shutdown.

Let me know if I need to attach an lspci and lshw.

KJ4OHH (kj4ohh) wrote :

I'm experiencing the same problem on my Core i7 Desktop system with nvidia graphics card.

I installed 10.04 Alpha 3, upon rebooting I ran the upgrade manager and it downloaded and installed over 500 new packages.

I did not do any other configuration changes other than doing the upgrade.

I'm getting a similar error message to the ones previously posted but I'm getting a different number after "...task plymothd:" in my message:

[ 241.528626] INFO: task plymouthd:427 blocked for more than 120 seconds.
[ 241.528639] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

Umbriel (umbriel3-yahoo) wrote :

On Lucid final, after upgrade from Karmic, I have the same problem of plymouth hanging the system after boot. But if I hit ESC key when booting so plymouth is exited, system boots fine.

I'm using nvidia-current (195.36.15) instead of nouveau.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers