Ubuntu

Asus Eee Function Keys (Hotkeys) are not working with Lucid 10.04

Reported by Usama Akkad on 2010-02-06
160
This bug affects 34 people
Affects Status Importance Assigned to Milestone
linux (Fedora)
Unknown
Unknown
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Usama Akkad

Bug Description

Binary package hint: udev

Most of function keys are not working with Ubuntu Lucid 10.04
Tested on Asus Eee 1005HA

F1 sleep Yes
F2 Wifi No
F3 disables touch-pad No
F4 control Screen No
F5 decrease screen brightness Yes
F6 increase screen brightness Yes
F7 disables screen No
F8 switches display No
F9 shows Task Managers No
F10 mutes sound No
F11 decreases sound No
F12 increases sound No
Space switch Hybird Engine modes No
Insert Works as NumLk Yes
Delete Works as ScrLK Unknown
Arrows Works as Home\End\Page(up,Down) Yes

Most of those keys are working with Karmic 9.10

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 1246e2167e60db88087b6d934b8ef8b0
CheckboxSystem: 9c26adf6eed2f681ba41f94dd24c07e4
Date: Sat Feb 6 13:32:12 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100113)
MachineType: ASUSTeK Computer INC. 1005HA
Package: udev 149-5
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-12-generic root=UUID=a3b4007e-3bfb-44e3-a494-eeaa2e0a3574 ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.16-generic
SourcePackage: udev
Uname: Linux 2.6.32-12-generic i686
dmi.bios.date: 12/21/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1203
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1005HA
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1203:bd12/21/2009:svnASUSTeKComputerINC.:pn1005HA:pvrx.x:rvnASUSTeKComputerINC.:rn1005HA:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1005HA
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Usama Akkad (damascene) wrote :
description: updated
Usama Akkad (damascene) on 2010-02-06
summary: - Asus Eee Function Keys are not working with Lucid 10.04
+ Asus Eee Function Keys (Hotkeys) are not working with Lucid 10.04
Usama Akkad (damascene) wrote :

https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch

I tired the above methods but only the method 2 worked. and only recorded the working keys. like brightness and darkness keys and the turn screen off key which have worked after a recent update and wasn't working the time I posted the first post.

I believe that the key-code 28 in the attached file is for the Fn key
and the 224 for brightness and 225 for darkness

Usama Akkad (damascene) wrote :

sorry,
the 224 is for darkness and 225 for brightness. and the turn off button didn't record and when I tried method 3 there was no /var/log/acpid

Daniel T Chen (crimsun) on 2010-02-09
affects: udev (Ubuntu) → linux (Ubuntu)
Abhishek Dasgupta (abhidg) wrote :

Related to bug 505452 (eeepc_laptop module which provides the hotkeys no longer loads). That bug also contains a workaround, which however is not perfect (some people had problems with ethernet after that)

Sitsofe Wheeler (sitsofe) wrote :

Just for the record, this isn't related to Bug 232170 . See the aforementioned bug 505452 for details about a potential upstream patch.

I'm testing Lucid Alpha 3 and the problem still persists exactly as described in the bug report.

tags: added: iso-testing
Sitsofe Wheeler (sitsofe) wrote :

This issue does not appear to be affecting an EeePC 900 (Lucid Alpha 3) so I suspect it is newer models.

PataSenko (patasenko) wrote :

I can confirm this bug affecting EeePC 1000H.

I have an Eee PC S101 and I'm experiencing the symptoms described in this bug report.

Usama Akkad (damascene) wrote :

adding acpi_osi=Linux to grub fixed most of the keys but the f7 no longer turns off display and the wifi light isn't working too thought it's controlling the connection

seems like this is duplicate for bug #505452 but the "eeepc_laptop module not loading" will only drive experts to that bug. and there is no "function keys" or even "function" inside the report.

note: Linux should be with capital L to work in the workaround

Rola (pabswiss) wrote :

Adding acpi_osi=Linux worked for me on 1005ha, but now fn+F7 does nothing, I get no notification for brightness hotkeys (though they work) and touchpad disable hotkeys do send a signal but they don't disable it (just get the "touchpad enabled" message.

Luca Aluffi (aluffilu) wrote :

_Same here with asus 1201nl. Later, I'll try acpi_osi.

Luca Aluffi (aluffilu) wrote :

Hi!
acpi_osi trick works for some keys (volume control and wi-fi) but other are still missing. The switch between lcd and external monitor, for example.

Albertononi (albertononi) wrote :

Hi, the acpi_osi trick seems to have broken my DropBox: everytime I boot, it asks me to install the daemon, and when I accept it downloads it but does nothing more... and Dropbox doesn't work anymore.

Danne MCA (danne-mca) wrote :

This bug affect to me too, I'll try the acpi_osi in live mode.

Danne MCA (danne-mca) wrote :

Fixed the fn keys with the acpi_osi=Linux added in grub entry.

WeatherGod (ben-v-root) wrote :

I am concerned about side-effects of adding that line to the grub configurations. In particular with battery monitoring and other hardware-related things. This might fix our problem, but does it break other things?

What is it that changing the acpi_osi line fixes that allows the module to load? Would it be better to fix the module directly?

Please note that I am just asking these questions just as a sanity check because I would hate to see Lucid plagued with hardware troubles at release and have it traced back to this fix.

Axess_Denied (jim-bauckman) wrote :

Has anyone verified that adding the acpi_osi addition fixes this problem with ALL fn keys?

Erik Wegner (e-wegner) wrote :

On my ASUS 1000 HE with Ubuntu Netbook Edition 10.04 these keys work/do not work:

F1/suspend: works
F2/WLAN: works
F3/Touchpad: no reaction/does not work
F4/scale screen: not tested
F5/Brightness -: works
F6/Brightness +: works
F7/Screen off: no reaction/does not work
F8/External screen: not tested
F9/Task manager: no reaction/does not work
F10/Mute: works
F11/Volume -: works
F12/Volume +: works

kaanatakan (kaanatakan) wrote :

sourceI can confirm the same problem with the eeePC 1005HA bought in Germany (German Keyboard Layout).

fn-f1: sleep works
fn-f2: wireless on/off broken
fn-f3: mousepad on/off broken
fn-f4: adjust screen? broken
fn-f5: brightness down works
fn-f6: brightness up works
fn-f7: screen on/off works
fn-f8: change video out broken
fn-f9: system monitor broken
fn-f10: mute broken
fn-f11: volume down broken
fn-f12: volume up broken

other fn-combinations

fn-space: clockspeed/power broken
fn-insert: numlock works
fn-del: scrolllock works
fn-ö: - works
fn-p: * works
fn--: + works
fn-right: home works
fn-left: end works
fn-up: page-up works
fn-down: page-down works

BTW broken means produces no keystroke. I believe fn-space wasn't implemented in 9.10 either.

I would like to check if eeepc-laptop is loading
but i don't know how.

lores@day-v:~$ sudo modprobe eeepc-laptop
FATAL: Error inserting eeepc_laptop (/lib/modules/2.6.32-21-generic/kernel/drivers/platform/x86/eeepc-laptop.ko): No such device

But couldn't this be because I'm trying to load it after the system has booted up?
I'm going to try from a rootshell but can someone tell me what file i need to tail to see if it is loading?

WeatherGod (ben-v-root) wrote :

You can grep the results of lsmod like so:

lsmod | grep eeepc

If you get no output, then the module was not loaded.

Changed in linux (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.