HP Touchsmart tm2 requires newer wacom driver

Bug #516777 reported by Brian Murray
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
erpampa@gmail.com

Bug Description

To get my touchscreen working in Lucid with USB ID: 056a:00e3 I needed to download and compile a new version of the kernel driver from http://linuxwacom.sourceforge.net/index.php/dl. I downloaded package version 0.8.5-9 as this adds support for my specific tablet.

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bdmurray 2102 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd4500000 irq 22'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:111d7605,103c3662,00100402 HDA:80862802,80860101,00100000'
   Controls : 18
   Simple ctrls : 10
CheckboxSubmission: aa17cf12317e2f016b28e1ab7ae0112a
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Wed Feb 3 14:07:14 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=f13ec592-c6b2-4884-9238-62426a3ee29b
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100128)
MachineType: Hewlett-Packard HP TouchSmart tm2 Notebook PC
Package: linux-image-2.6.32-12-generic 2.6.32-12.16
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-12-generic root=UUID=0be32406-6c36-49ca-9b4b-883155e15c24 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.16-generic
Regression: No
RelatedPackageVersions: linux-firmware 1.28
Reproducible: Yes
SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-12-generic x86_64
dmi.bios.date: 12/21/2009
dmi.bios.vendor: Insyde
dmi.bios.version: F.02
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3662
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 47.16
dmi.chassis.asset.tag: CNU0035Q1Y
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnInsyde:bvrF.02:bd12/21/2009:svnHewlett-Packard:pnHPTouchSmarttm2NotebookPC:pvr049E100000200800000120000:rvnHewlett-Packard:rn3662:rvrKBCVersion47.16:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP TouchSmart tm2 Notebook PC
dmi.product.version: 049E100000200800000120000
dmi.sys.vendor: Hewlett-Packard

Revision history for this message
Brian Murray (brian-murray) wrote :
Andy Whitcroft (apw)
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Revision history for this message
Thiago Bellini (bellini666) wrote :

That happens on HP Touchsmart Tx2 too!

The only way to get it working is that: http://ubuntuforums.org/showthread.php?t=1252492
but, multi-touch is not working!

Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Thiago,
     Please open a separate bug for this new hardware.

Thanks!

-JFo

Revision history for this message
Chase Douglas (chasedouglas) wrote :

Generally speaking, Ubuntu includes sources directly from upstream with individual fixes only where necessary for bugs that cause severe issues (such as kernel crashes). Exceptions are made from time to time, but this is the preferred flow of sources into Ubuntu for many reasons.

As such, the preferred route for the fix for your issue is to have the changes percolate up from the beta sources of the linux wacom project to the stable sources of the project to the mainline linux kernel. Once it reaches the mainline linux kernel we prefer to have the fixes come through the -stable series that are separately maintained for back versions of the kernel, which is usually what the Ubuntu development distribution is based on. Our Lucid kernels are based directly off of the -stable series, so changes there likely will be incorporated into our kernels automatically.

Unfortunately, that means a bit of waiting for end users of new hardware that does not work out of the box. There are a few options that can ease the situation though:

1. Build the updated modules personally
2. Create a dkms package to build the modules for you each time the kernel is updated (and potentially host the packages in a launchpad personal package archive for others to use)
3. Work to incorporate the newer modules into the Ubuntu linux-backports-modules package
4. Inclusion as an "ubuntu" driver in linux-image

Note that option 3 is fairly heavyweight and would necessitate extra work not only to develop the new modules within linux-backports-modules, but also to ensure all the process requirements are met. Option 4 is probably similar in amount of work.

Both options 3 and 4 would still likely require the source to at least become stable in the linux wacom project, and also be an issue for a large amount of end users to be considered.

As such, I am marking this bug as 'Won't Fix'. If the upstream sources become stable and you believe there are a reasonable amount of affected users to pursue options 3 or 4 you may reopen the bug.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Setting back to Triaged.

Changed in linux (Ubuntu):
status: Won't Fix → Triaged
Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Brian,
      When you built from the source, did it create one driver or many? If many, which one did you load? We'd like to compare versus what is available in the kernel.

Thanks!

-JFo

Revision history for this message
Brian Murray (brian-murray) wrote :

The only driver I built and loaded was wacom.ko.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

I've built a test module of wacom.ko. It's based on the latest lucid kernel sources tip + two git commits from 2.6.33 [1] [2]. Please download and test this module in lucid to see if it works (Note: this is very frankensteined and may be unstable!):

http://people.canonical.com/~cndougla/516777/wacom.ko

[1] http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=ee54500d7b960984df125bdd0cd2105d6150e8f1
[2] http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=ec67bbedcf290ef182a897017f65a2707106c7f8

Changed in linux (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
status: Triaged → In Progress
Revision history for this message
Chase Douglas (chasedouglas) wrote :
Revision history for this message
Brian Murray (brian-murray) wrote :

When I try to insert the module I receive the following error message:

insmod: error inserting 'wacom.ko': -1 Invalid module format

I checked to see if perhaps there was a new version of linux wacom and there is, 0.8.5-10. However, I downloaded that and compiled the kernel driver myself and was able to load it without any problems.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@Brian Murray:

When you see insmod errors, the best thing to do is to check dmesg. Usually more info is available in the dmesg than is given by insmod. Can you post any relevant information from your dmesg? Relevant info should be near the end.

The problem is that the driver from the linuxwacom website is a stand alone package. It is not integrated into the linux kernel tree. The module I built is taken from upstream commits to the 2.6.33 kernel tree. We can't integrate the linuxwacom package into the Ubuntu kernel. The best we can do is create a dkms package for it or put it into lbm if the test module I built won't work.

Revision history for this message
Brian Murray (brian-murray) wrote :

wacom: no symbol version for module_layout

Revision history for this message
Chase Douglas (chasedouglas) wrote :

When I first built the modules I didn't build the entire kernel, just the drivers/input/tablet directory. This didn't allow for the proper modpost run which fixes things up in the module so it can load properly. I've since rebuilt the modules and reuploaded them. The previous urls now have the corrected modules to test with.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Tried it with an Intuos4L to see if anything would break, and nothing did. Tried suspend/resume too with it attached.

Revision history for this message
Stefan Bader (smb) wrote :

Tested i386 module on my Netbook with a Wacom Bamboo MTE-450 (0x056a:0x0065). xev seems to produce events for all its buttons and the pen area and the jog dial (touchpad) work. Same after suspend/resume with the tablet attached.

Revision history for this message
Brian Murray (brian-murray) wrote :

The corrected modules loaded properly and worked great on my system. Both the pen and the touchscreen work including after suspend and resume.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

I have sent an email to the maintainer of the driver, Ping Cheng <email address hidden>, asking for his support in trying to get this into -stable for .32. We will make a decision as to how these changes can be brought into lucid based on the timeframe and nature of his response.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

The patches have been committed to the lucid kernel tree. Please make sure to test the next kernel that comes out to ensure that everything is working properly, both with new hardware and old. We need to be sure it works. If we find any issues, we can still pull out the patch before general release.

Also, I've sent the patches upstream to -stable. I doubt they will be accepted, but it's worth a shot. I've been communicating with the maintainer of the driver, and he is supporting the effort.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (7.8 KiB)

This bug was fixed in the package linux - 2.6.32-15.21

---------------
linux (2.6.32-15.21) lucid; urgency=low

  [ Andy Whitcroft ]

  * Revert "(pre-stable) drm/i915: Increase fb alignment to 64k"
  * Revert "[Config] lenovo-sl-laptop -- enable"
  * Revert "ubuntu: lenovo-sl-laptop -- git tip (b19a08f81f)"
  * armel -- cramfs module will no longer be built
  * d-i -- make all modules optional
  * rename the debug packages to match archive standard
    - LP: #527837
  * lenovo-sl-laptop is no longer built

  [ Colin Ian King ]

  * Disable 4MB page tables for Atom, work around errata AAE44
    - LP: #523112

  [ Colin Watson ]

  * ubuntu: dm-raid4-5: Depend on XOR_BLOCKS
  * ubuntu: fsam7400: Depend on CHECK_SIGNATURE

  [ Jesse Barnes ]

  * SAUCE: drm/i915: don't change DRM configuration when releasing load
    detect pipe
    - LP: #488328

  [ Loïc Minier ]

  * [Config] armel Update versatile initrd configs
    - LP: #524893
  * SAUCE: [um] Don't use nx_enabled under UML
    - LP: #524849

  [ Manoj Iyer ]

  * [Config] added new config option CONFIG_SR_REPORT_TIME_LIMIT

  [ Mario Limonciello ]

  * SAUCE: v3 - Add Dell Business Class Netbook LED driver

  [ Rafael J. Wysocki ]

  * SAUCE: PM report driver and device suspend/resume times.

  [ Surbhi Palande ]

  * Revert "[Upstream] e1000e: enhance frame fragment detection"
    - CVE-2009-4538
  * Revert "[Upstream] e1000: enhance frame fragment detection"
    - CVE-2009-4536

  [ Tim Gardner ]

  * [Config] Enabled CONFIG_LEDS_DELL_NETBOOKS=m
  * SAUCE: (pre-stable) netfilter: xt_recent: fix buffer overflow
  * SAUCE: (pre-stable) netfilter: xt_recent: fix false match

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) eCryptfs: Add getattr function"
  * Fix potential crash with sys_move_pages
  * futex_lock_pi() key refcnt fix
  * futex: Handle user space corruption gracefully
  * futex: Handle futex value corruption gracefully
  * Fix race in tty_fasync() properly
  * hwmon: (w83781d) Request I/O ports individually for probing
  * hwmon: (lm78) Request I/O ports individually for probing
  * hwmon: (adt7462) Wrong ADT7462_VOLT_COUNT
  * ALSA: ctxfi - fix PTP address initialization
  * drm/i915: disable hotplug detect before Ironlake CRT detect
  * drm/i915: enable self-refresh on 965
  * drm/i915: Disable SR when more than one pipe is enabled
  * drm/i915: Fix DDC on some systems by clearing BIOS GMBUS setup.
  * drm/i915: Add HP nx9020/SamsungSX20S to ACPI LID quirk list
  * drm/i915: Fix the incorrect DMI string for Samsung SX20S laptop
  * drm/i915: Add MALATA PC-81005 to ACPI LID quirk list
  * usb: r8a66597-hcd: Flush the D-cache for the pipe-in transfer buffers.
  * i2c-tiny-usb: Fix on big-endian systems
  * drm/i915: handle FBC and self-refresh better
  * drm/i915: Increase fb alignment to 64k
  * drm/i915: Update write_domains on active list after flush.
  * regulator: Fix display of null constraints for regulators
  * ALSA: hda-intel: Avoid divide by zero crash
  * CPUFREQ: Fix use after free of struct powernow_k8_data
  * freeze_bdev: don't deactivate successfully frozen MS_RDONLY sb
  * cciss: Make cciss_seq_show handle holes in the h->drv[] array
  * ioat: fix in...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
assignee: Chase Douglas (chasedouglas) → erpampa@gmail.com (erpampa)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers