missing cmd64x driver in kernel-tree for PPC arch.

Bug #513131 reported by grof on 2010-01-27
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara

Bug Description

Missing cmd64x driver in kernel-tree for PPC arch.

Without this kernel modul you can not start up hard discs on blue&white G3 Mac PowerPC.
I made workaround and describe problem in this post:
http://www.uluga.ubuntuforums.org/showpost.php?p=8731226&postcount=27

Please, can you include cmd64x driver in kernel-tree of next ubuntu release (10.04) (it exist in kernel source code but it isn't compiled)

As a digression, in kernel source exist pata_cmd64x driver too, which works well, but problem is that pata_cmd64x is in naming drives as SCSI devices (/dev/sdx) and this naming nomenclature confusing yaboot and PPC can not be booted after install Ubuntu.

From other side, cmd64x driver naming devices as standard IDE (/dev/hdx) what do not confuse yaboot!

grof (grof) wrote :

This is workaround

Jeremy Foshee (jeremyfoshee) wrote :

Hi grof,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 513131

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
grof (grof) wrote :

I will, but please note that your link with latest ISO images contains only i386 and x86 arch images, but my problem persist on to G3 Mac PPC (PowerPC) architecture!

Matthew Swank (akopa) wrote :

Certainly I can confirm that the 10.04 Ubuntu power-pc mac live cd (uname: Linux ubuntu 2.6.32-21-powerpc #32-Ubuntu Fri Apr 16 08:10:47 UTC 2010 ppc GNU/Linux) does not load a driver for:
 01:01.0 IDE interface: Silicon Image, Inc. PCI0646 (rev 07), and I am unable to see any of the drives on that controller.
The /lib/modules/2.6.32-21-powerpc/kernel/drivers/ide directory does not exist, and there is no pata variant of the cmd64x driver in /lib/modules/2.6.32-21-powerpc/kernel/ata.

Here is lsmod:
Module Size Used by
nls_cp437 5223 1
smbfs 73154 0
cifs 270546 2
binfmt_misc 8530 1
radeon 802403 0
ttm 62566 1 radeon
drm_kms_helper 31219 1 radeon
drm 192389 3 radeon,ttm,drm_kms_helper
agpgart 39895 2 ttm,drm
ipv6 299918 10
ppdev 7877 0
lp 9304 0
parport 39110 2 ppdev,lp
snd_powermac 68187 2
dm_crypt 14921 0
snd_pcm_oss 47872 0
snd_mixer_oss 19382 1 snd_pcm_oss
snd_pcm 87095 2 snd_powermac,snd_pcm_oss
snd_seq_dummy 1766 0
snd_seq_oss 36232 0
snd_seq_midi 6161 0
snd_rawmidi 24746 1 snd_seq_midi
snd_seq_midi_event 7367 2 snd_seq_oss,snd_seq_midi
snd_seq 61897 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 24515 2 snd_pcm,snd_seq
snd_seq_device 7524 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 70628 13 snd_powermac,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
pcilynx 17049 0
soundcore 7534 1 snd
ieee1394 97330 1 pcilynx
pmac_zilog 18110 0
snd_page_alloc 7660 1 snd_pcm
serial_core 23813 1 pmac_zilog
rtc_generic 1391 0
evdev 10257 4
squashfs 26239 1
loop 16948 2
aufs 191198 1
isofs 35744 1
windfarm_core 10420 0
dm_mirror 15615 0
dm_region_hash 11772 1 dm_mirror
dm_log 11095 2 dm_mirror,dm_region_hash
dm_mod 82087 3 dm_crypt,dm_mirror,dm_log
usbhid 44238 0
aic7xxx 134490 0
hid 78460 1 usbhid
bmac 13992 0
mesh 21149 0
scsi_transport_spi 26921 1 aic7xxx
ata_generic 3247 0

Matthew Swank (akopa) wrote :

Just to be perfectly clear, I am using the iso image available at the following url: http://cdimage.ubuntu.com/ports/releases/lucid/release/ubuntu-10.04-desktop-powerpc.iso

Matthew Swank (akopa) wrote :

There's no .deb, but here is the version of the cmd64x driver for the current 10.04 mac power-pc live cd

Timothy Geiser (slimshady007) wrote :

I can confirm that the ubuntu-10.04-desktop-powerpc.iso is missing this module. Note that this bug affects first-generation G4 machines as well (those use the same motherboard as the B&W G3s). Is grof's workaround (reply #1) the "correct" way to fix this? How would I go about using the cmd64x.ko that Matthew provided in reply #6?

codewarrior (lvr) on 2010-07-02
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
codewarrior (lvr) wrote :

C'mon, this is a no-brainer to fix. For the latest Maverick kernel source (linux_2.6.35-6.9) edit:
 arch/powerpc/configs/pmac32_defconfig line 741

-# CONFIG_BLK_DEV_CMD64X is not set
+CONFIG_BLK_DEV_CMD64X=y

Here's a patch

tags: added: patch
Diederen (jjhdiederen) wrote :

It's still an issue, it's incredible that this has not been fixed. It's clear that people at Ubuntu don't care about PPC users.
http://ubuntuforums.org/showthread.php?t=1701831

The reason this likely has not been enabled is because it's dependent on a configuration option which is noted to be deprecated, ie see drivers/ide/Kconfig:

menuconfig IDE
        tristate "ATA/ATAPI/MFM/RLL support (DEPRECATED)"
        depends on HAVE_IDE
        depends on BLOCK
        ---help---
          If you say Y here, your kernel will be able to manage ATA/(E)IDE and
          ATAPI units. The most common cases are IDE hard drives and ATAPI
          CD-ROM drives.

          This subsystem is currently in maintenance mode with only bug fix
          changes applied. Users of ATA hardware are encouraged to migrate to
          the newer ATA subsystem ("Serial ATA (prod) and Parallel ATA
          (experimental) drivers") which is more actively maintained.

          To compile this driver as a module, choose M here: the
          module will be called ide-core.

          For further information, please read <file:Documentation/ide/ide.txt>.

          If unsure, say N.

if IDE

...

config BLK_DEV_CMD64X
        tristate "CMD64{3|6|8|9} chipset support"
        select IDE_TIMINGS
        select BLK_DEV_IDEDMA_PCI
        help
          Say Y here if you have an IDE controller which uses any of these
          chipsets: CMD643, CMD646, or CMD648.

That being said, it does appear that the current Oneiric kernel config still enables CONFIG_IDE=y for powerpc. Thus, for the time being I'd be willing to enable the BLK_DEV_CMD64X option for Oneiric (assuming it builds) per this bug request. However, please note that there is no guarantee going forward this option will remain enabled and could potentially disappear due to the deprecated nature. Give me a bit and I'll try to post some test kernels for you as well. Thanks.

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: Confirmed → In Progress

I've built a powerpc test kernel with CONFIG_BLK_DEV_CMD64x=m and placed it at the following location. Please test and let me know your results:

http://people.canonical.com/~ogasawara/lp513131/

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.0.0-7.9

---------------
linux (3.0.0-7.9) oneiric; urgency=low

  [ Andy Whitcroft ]

  * Revert "[Upstream] add local prefix to oss local change_bits"
  * Revert "SAUCE: add tracing for user initiated readahead requests"
  * Revert "SAUCE: vfs: Add a trace point in the mark_inode_dirty function"
  * Revert "SAUCE: Input: ALPS - Enable Intellimouse mode for Lenovo
    Zhaoyang E47"
  * Revert "SAUCE: fix documentation strings for struct input_keymap_entry"
  * Revert "SAUCE: vt -- fix handoff numbering to 1..n and add range checks
    (grub)"
  * Revert "SAUCE: vt -- fix handoff numbering to 1..n and add range
    checks"
  * Revert "SAUCE: vt -- allow grub to request automatic vt_handoff"
  * Revert "SAUCE: vt -- maintain bootloader screen mode and content until
    vt switch"
  * [Config] enable CONFIG_MTRR_SANITIZER_ENABLE_DEFAULT=1
    - LP: #816035
  * ubuntu: Yama: if an underlying filesystem provides a permissions op use
    it
  * SAUCE: (no-up) add tracing for user initiated readahead requests
  * SAUCE: vt -- maintain bootloader screen mode and content until vt
    switch
  * SAUCE: vt -- allow grub to request automatic vt_handoff

  [ Arjan van de Ven ]

  * SAUCE: (no-up) vfs: Add a trace point in the mark_inode_dirty function

  [ Kees Cook ]

  * Revert "SAUCE: (no-up) Disable building the ACPI debugfs source"
  * [Config] enforce ACPI_CUSTOM_METHOD disabled

  [ Keng-Yu Lin ]

  * SAUCE: (no-up) Input: ALPS - Enable Intellimouse mode for Lenovo
    Zhaoyang E47
    - LP: #632884, #803005

  [ Leann Ogasawara ]

  * [Config] Enable CONFIG_BLK_DEV_CMD64X=m on powerpc
    - LP: #513131
  * [Config] Enable CONFIG_RT2800PCI_RT53XX=y
    - LP: #815064

  [ Rezwanul Kabir ]

  * SAUCE: (no-up) Add support for Intellimouse Mode in ALPS touchpad on
    Dell E2 series Laptops
    - LP: #632884

  [ Upstream Kernel Changes ]

  * Revert "yama: if an underlying filesystem provides a permissions op use
    it"
  * Revert "Add support for Intellimouse Mode in ALPS touchpad on Dell E2
    series Laptops"
  * Revert "tty: include linux/slab.h for kfree"
  * Revert "gpio/ml_ioh_gpio: include linux/slab.h for kfree"
  * Revert "pch_dma: add include/slab.h for kfree"
  * mmc: Added quirks for Ricoh 1180:e823 lower base clock frequency
    - LP: #773524
  * oss: rename local change_bits to avoid powerpc bitsops.h definition
 -- Leann Ogasawara <email address hidden> Mon, 25 Jul 2011 09:08:01 -0700

Changed in linux (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers