Ubuntu

No ethernet and no Wifi in Kubuntu 9.10 (on Toshiba P300 with Marvell Yukon ethernet and Intel Wifi)

Reported by Olivier V on 2010-01-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I've bought a toshiba P300-27Z wich have :
- a Marvell Yukon 88E8040T PCI-E ethernet card
- a Intel Wifi Link 5100 AGN.

I've neither internet nor LAN connexion after installation from Kubuntu 9.10 32 bits or 64 bits.

On the french forum I've found this http://forum.ubuntu-fr.org/viewtopic.php?pid=3196309 :
  'Add pci=use_crs to grub2 options, for example in GRUB_CMDLINE_LINUX="pci=use_crs"'.
With this, the connexion works but is very very slow, particulary in the acces to server.

Other users of toshiba with Marvell Yukon cards have the same problem. I have seen this on the internet.

I think it is a bug of the 9.10 version because the two connexion (LAN and wifi) works fine on Kubuntu 9.04 !

Olivier V

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in linux.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 505102

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report. Thanks in advance!

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: meloli 1760 F.... kmix
 /dev/snd/controlC0: meloli 1731 F.... knotify4
                      meloli 1760 F.... kmix
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8400000 irq 22'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,1179ff57,00100000'
   Controls : 14
   Simple ctrls : 7
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xcfeec000 irq 17'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined
   Playback channels: Mono
   Mono: Playback [off]
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=bc78a701-7444-4702-8b0e-5355f031b32a
MachineType: TOSHIBA Satellite P300
Package: linux (not installed)
ProcCmdLine: root=UUID=d9479a33-e531-4063-91a5-2c6483d3143a ro quiet splash pci=use_crs
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_FR.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-14-generic N/A
 linux-firmware 1.24
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: yes
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 04/07/2009
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V3.40
dmi.board.name: Satellite P300
dmi.board.vendor: TOSHIBA
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV3.40:bd04/07/2009:svnTOSHIBA:pnSatelliteP300:pvrPSPCCE-0KF03PFR:rvnTOSHIBA:rnSatelliteP300:rvrNotApplicable:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: Satellite P300
dmi.product.version: PSPCCE-0KF03PFR
dmi.sys.vendor: TOSHIBA

Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
Andy Whitcroft (apw) on 2010-01-13
tags: added: karmic
Thalecress (raviclones) wrote :

I also have a Toshiba Satellite P300 with the same configuration as Oliver V and am facing the same networking problems.
I got tired trying to find a solution and had to uninstall Karmic and run it in a virtualbox with Vista host.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Olivier,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 505102

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Olivier V (forum-viennet) wrote :

On the 10.04 kubuntu the problem is solved.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers