Ubuntu

Toshiba M505-S4972 The Fan does not work unless i suspend and bring it back up

Reported by ghepeath on 2009-12-27
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
High
linux (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by ghepeath

Bug Description

Binary package hint: gnome-power-manager

My fan does not right out the box on boot
i have to suspend my laptop and then bring back up for it to work
also it did not detect my wireless driver (rtl819xSE) i had to compile it from a tar.....
My laptop also seem to show the tempeture hight under lm-sensors
under temp1, (i dont realy know what is that)
Multimedia touch controls does not work well, it seem that every time
i press it onece it keep pressing on it's own
Looks like is somethign to the acpi, i install toshacpi, acpitools and did not help me.
Also the fan seem to keep spining at one speed, when the tempeture goes up
the fan does not lsping faster to keep it cooler

the track pack seem to work good, but the multfeature it bring does not
example when im trying tu use 2 fingerand stuf,
the main problem it's the fan .... i hope someone can find a fix to this issue

$ cat /proc/acpi/thermal_zone/*/trip_points
critical (S5): 108 C
passive: 101 C: tc1=30 tc2=30 tsp=50 devices=CPU0 CPU1
active[0]: 98 C: devices=FAN0
active[1]: 82 C: devices=FAN1
active[2]: 72 C: devices=FAN2
active[3]: 62 C: devices=FAN3
active[4]: 57 C: devices=FAN4
active[5]: 37 C: devices=FAN5

Thanks for you time
 any more info requierd please contact me to
<email address hidden>

ProblemType: Bug
Architecture: amd64
Date: Sat Dec 26 19:37:22 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: gnome-power-manager 2.28.1-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: gnome-power-manager
Uname: Linux 2.6.31-16-generic x86_64

ghepeath (ghepeath) wrote :
summary: - Toshiba M505-S4972 The Faand does not work unless i suspend and bring it
+ Toshiba M505-S4972 The Fan does not work unless i suspend and bring it
back up
ghepeath (ghepeath) on 2009-12-27
description: updated
description: updated
ghepeath (ghepeath) on 2009-12-27
description: updated
Dave Gilbert (ubuntu-treblig) wrote :

On my Tosh laptop, sometimes I found a problem where the fan wouldn't start (or stop) unless I had something
that checked the temperature.

It might be worth just doing an acpi -t and see if the fan suddenly changes speed.

Dave

Paul Dufresne (paulduf) wrote :

I note from http://ubuntuforums.org/showthread.php?t=1282161:
"I purchased new Toshiba Satellite M505-S4945 laptop and installed 64-bit Jaunty. Everything works great except that the fan cannot be turned on due to broken ACPI tables from Phoenix BIOS. The fan makes a big difference (40C vs 70+C).

I found an omnibook module from sourceforge that is supposed to fix some issues with Satellite laptops, but I was unsuccessful compiling it, probably because the types of supported laptops do not include Satellite M505. I am not a developer nor a programmer, so I cannot fix the source code of omnibook module myself to add my specific model nor can I find it from terminal."

They seems to get to the conclusion that:
"$ cat /proc/acpi/thermal_zone/*/trip_points
critical (S5): 108 C
passive: 101 C: tc1=30 tc2=30 tsp=50 devices=CPU0 CPU1
active[0]: 94 C: devices=FAN0
active[1]: 82 C: devices=FAN1
active[2]: 72 C: devices=FAN2
active[3]: 52 C: devices=FAN3
active[4]: 42 C: devices=FAN4 " is wrong.

What is the result of: "cat /proc/acpi/thermal_zone/*/trip_points" for you in a terminal window?

I believe this is more a kernel bug. So I'll update the package.

affects: gnome-power-manager (Ubuntu) → linux (Ubuntu)
Paul Dufresne (paulduf) wrote :

As I have changed the package of this bug to the kernel (from gnome-power-manager), please type:
apport-collect -p linux 500666
to attach newly needed information to this bug.

Changed in linux (Ubuntu):
status: New → Incomplete
ghepeath (ghepeath) on 2010-01-15
description: updated
Changed in linux (Ubuntu):
status: Incomplete → New
description: updated
description: updated

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: almikul 2164 F.... pulseaudio
 /dev/snd/pcmC0D0p: almikul 2164 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfddf8000 irq 22'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:10ec0269,1179ffc6,00100004 HDA:11c11040,11790001,00100200 HDA:80862802,80860101,00100000'
   Controls : 26
   Simple ctrls : 14
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=5db4de4a-ab50-43e6-b221-79d0737b132d
MachineType: TOSHIBA Satellite M505
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-17-generic root=UUID=34cc7724-0ddb-4e6d-a791-3e9970efb920 ro quiet splash acpi=force
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-17-generic N/A
 linux-firmware 1.26
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Uname: Linux 2.6.31-17-generic i686
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
dmi.bios.date: 09/15/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.90
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: To be filled by O.E.M.
dmi.board.vendor: TOSHIBA
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.90:bd09/15/2009:svnTOSHIBA:pnSatelliteM505:pvrPSMG2U-01401F:rvnTOSHIBA:rnTobefilledbyO.E.M.:rvrTobefilledbyO.E.M.:cvnTOSHIBA:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: Satellite M505
dmi.product.version: PSMG2U-01401F
dmi.sys.vendor: TOSHIBA

tags: added: apport-collected
Paul Dufresne (paulduf) wrote :

I note the following from BootDMesg.txt:
[ 0.262168] ACPI: Power Resource [PF0] (on)
[ 0.262211] ACPI: Power Resource [PF1] (on)
[ 0.262252] ACPI: Power Resource [PF2] (on)
[ 0.262293] ACPI: Power Resource [PF3] (on)
[ 0.262334] ACPI: Power Resource [PF4] (on)
[ 0.262377] ACPI: Power Resource [PF5] (on)
[ 0.262482] ACPI Warning: Incorrect checksum in table [OEMB] - D5, should be 92 20090521 tbutils-246
[ 0.263168] ACPI Warning: Incorrect checksum in table [GSCI] - C0, should be 22 20090521 tbutils-246
...
[ 0.560317] fan PNP0C0B:00: registered as cooling_device0
[ 0.560323] ACPI: Fan [FAN0] (on)
[ 0.560456] fan PNP0C0B:01: registered as cooling_device1
[ 0.560461] ACPI: Fan [FAN1] (on)
[ 0.560591] fan PNP0C0B:02: registered as cooling_device2
[ 0.560598] ACPI: Fan [FAN2] (on)
[ 0.560726] fan PNP0C0B:03: registered as cooling_device3
[ 0.560732] ACPI: Fan [FAN3] (on)
[ 0.560860] fan PNP0C0B:04: registered as cooling_device4
[ 0.560865] ACPI: Fan [FAN4] (on)
[ 0.560995] fan PNP0C0B:05: registered as cooling_device5
[ 0.561000] ACPI: Fan [FAN5] (on)

Changed in linux (Ubuntu):
status: New → Confirmed
Klaus Doblmann (moviemaniac) wrote :

Added remote bug tracker link to the kernel bugzilla. However the fix/workaround posted there doesn't work on this chap's M900: http://ubuntuforums.org/showthread.php?t=1456703&page=4

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: will 1651 F.... pulseaudio
 /dev/snd/pcmC0D0p: will 1651 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x94600000 irq 22'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,1179ff66,00100003'
   Controls : 12
   Simple ctrls : 7
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=27711c67-cd85-4aeb-a2f5-6c9fdecd3479
MachineType: TOSHIBA Satellite L305
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=3b173524-4109-410c-8d14-c4c1086170d3 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Regression: No
RelatedPackageVersions: linux-firmware 1.34
Reproducible: Yes
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: lucid suspend resume needs-upstream-testing
Uname: Linux 2.6.32-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/23/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: 2.10
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr2.10:bd09/23/2009:svnTOSHIBA:pnSatelliteL305:pvrPSLB8U-13T038B:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Satellite L305
dmi.product.version: PSLB8U-13T038B
dmi.sys.vendor: TOSHIBA

apport information

apport information

apport information

apport information

apport information

apport information

Will Taff (wrtaff) wrote : Lspci.txt

apport information

Will Taff (wrtaff) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Will Taff (wrtaff) wrote :

Also having this problem on a Toshiba Laptop Satellite L305-S5955. I believe this problem is the same as bug# 463611. ACPI doesn't seem to work correctly until the suspend. The FN keys (LCD adjust, etc) do not work either until the suspend. Suspending by closing laptop lid doesn't work either. BUT - once you do a single suspend, it all works perfectly, so I think that things are mostly working perfectly, just the one odd behavior of ACPI not seeming to want to work until after that initial suspend. Have had this problem first on Jaunty, now on Lucid.

tags: added: kernel-therm
peterwil (peter-william) wrote :

Wow! I have GREAT NEWS regarding my Toshiba Laptop L305-S5881.
I struggled with this issue since I bought the laptop in '08 October.
Reported it a number of issues. Tried
i) Hardy - Ubuntu 8 (temps > 75C ) , then
ii) Jaunty - Ubuntu 9.0.4( temps <65 but definitely still hot )
iii) compiled the 2.6.30 kernel and installed the image all to no avail
then gave up the idea of running Ubuntu solely on this laptop, being aware
that the laptop could fry over.
Last week dual booted Vista crashed - had to recover my email from thunderbird and
then decided to look into Ubuntu again based on Jeremy's email a couple of months ago.
After looking through the acpi module source code -noticed a patch was introduced in sleep.c
referencing "Toshiba Satellite L300" to set the EIN bit ,
changed this string to "Toshiba Satellite L305" and recompiled
Kernel.. Still no difference.

Then did an upgrade to 9.10 . After the upgrade and a reboot VOILA !
i) My Fn keys are working. Suspend actuallly WORKS! .. It never did. always had to power down the switch
to make it recover from either Suspend to RAM or Hibernate. -dmesg always showed errors in ACPI .
ii) And then the magic .. acpi -t shows 45 C... !!! This laptop has never showed this reading after 10 mins.
of usage before this.

So fellow Ubuntu aficianados! using Toshiba Laptops L305D or similar models.

Please try out the generic kernel 2.6.31-22 ( 9.10 upgrade ). The overheating and the Suspend issues
are definitely fixed for this model in this release.

My salutations to the developer/s who fixed this most annoying bug/bugs which almost rendered the
Laptop unusable on Ubuntu.. It would have perhaps taken my weeks of ploughing through the
ACPI modules ( sleep.c, fan.c etc ) to try and fix this monster.! Not to mention the 1 hour kernel compile
on each change!.. Glad I can get back to the application space!.

Cheers and best regards
Peter William

Changed in linux:
status: Unknown → Invalid
Changed in linux:
importance: Unknown → High

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.